/[gentoo-x86]/app-crypt/gnupg/ChangeLog
Gentoo

Diff of /app-crypt/gnupg/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.389 Revision 1.424
1# ChangeLog for app-crypt/gnupg 1# ChangeLog for app-crypt/gnupg
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.389 2010/09/10 12:16:23 klausman Exp $ 3# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.424 2012/03/05 04:31:00 radhermit Exp $
4
5 05 Mar 2012; Tim Harder <radhermit@gentoo.org> gnupg-2.0.18.ebuild:
6 Add more dependencies required for static build (fixes bugs #395669 and
7 #406331).
8
9 18 Feb 2012; Ulrich Müller <ulm@gentoo.org> metadata.xml:
10 Update description of idea USE flag, bug 404353.
11
12 11 Feb 2012; Robin H. Johnson <robbat2@gentoo.org> gnupg-2.0.17-r2.ebuild,
13 gnupg-2.0.17-r3.ebuild, gnupg-2.0.17.ebuild, gnupg-2.0.18.ebuild:
14 Bug #380755: missing sys-libs/zlib dependency.
15
16*gnupg-1.4.12 (31 Jan 2012)
17
18 31 Jan 2012; Robin H. Johnson <robbat2@gentoo.org> +gnupg-1.4.12.ebuild:
19 Version bump.
20
21 11 Jan 2012; Robin H. Johnson <robbat2@gentoo.org> gnupg-1.4.11.ebuild:
22 Bug #398441: IDEA patents have expired, remove bindist impact on USE=idea.
23
24 30 Nov 2011; Mike Frysinger <vapier@gentoo.org> gnupg-2.0.18.ebuild:
25 Control readline dep with USE=readline.
26
27 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> gnupg-2.0.18.ebuild:
28 Simplify dependencies. Patch by Arfrever.
29
30*gnupg-2.0.18 (04 Aug 2011)
31
32 04 Aug 2011; Robin H. Johnson <robbat2@gentoo.org> +gnupg-2.0.18.ebuild:
33 Version bump.
34
35*gnupg-2.0.17-r3 (03 Jul 2011)
36
37 03 Jul 2011; Robin H. Johnson <robbat2@gentoo.org> +gnupg-2.0.17-r3.ebuild,
38 +files/gnupg-2.0.17-libgrcrypt150-bugfix.patch:
39 Bug #373959: critical patch to enable signing w/ libgcrypt-1.5.0.
40
41*gnupg-2.0.17-r2 (09 Jun 2011)
42
43 09 Jun 2011; Dane Smith <c1pher@gentoo.org> -gnupg-2.0.17-r1.ebuild,
44 +gnupg-2.0.17-r2.ebuild:
45 Revision bump. Remove caps USE flag since capabilities are no longer
46 used anywhere wrt bug 360421.
47 Remove no longer needed || die.
48 Drop old revision. No keyword changes necessary.
49
50 14 May 2011; Raúl Porcel <armin76@gentoo.org> gnupg-2.0.17.ebuild:
51 ia64/s390/sh/sparc stable wrt #355265
52
53 09 May 2011; Markus Meier <maekke@gentoo.org> gnupg-2.0.17.ebuild:
54 arm stable, bug #355265
55
56*gnupg-2.0.17-r1 (16 Apr 2011)
57
58 16 Apr 2011; Diego E. Pettenò <flameeyes@gentoo.org>
59 +gnupg-2.0.17-r1.ebuild, +files/gnupg-2.0.17-gpgsm-gencert.patch,
60 metadata.xml:
61 Revision bump: patch gpgsm-gencert.sh to actually work; remove openct and
62 pcsc-lite USE flags: smartcard USE flag now enables scdaemon, and usb enables
63 the internal CCID driver; don't depend on a particular implementation since
64 there are multiple options; use EAPI=4 and REQUIRED_USE to block static
65 support with smartcard.
66
67 23 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> gnupg-2.0.17.ebuild:
68 ppc/ppc64 stable wrt #355265
69
70 18 Mar 2011; Dane Smith <c1pher@gentoo.org> gnupg-2.0.17.ebuild:
71 Remove the use of ecompressdir wrt bug 356501. Other small QA fixes. No
72 revbump as installed files don't change (Save for the removal of a couple
73 examples files that were once doc.)
74
75 12 Mar 2011; Tobias Klausmann <klausman@gentoo.org> gnupg-2.0.17.ebuild:
76 Stable on alpha, bug #355265
77
78 11 Mar 2011; Thomas Kahle <tomka@gentoo.org> gnupg-2.0.17.ebuild:
79 x86 stable per bug 355265
80
81 08 Mar 2011; Jeroen Roovers <jer@gentoo.org> gnupg-2.0.17.ebuild:
82 Stable for HPPA (bug #355265).
83
84 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> gnupg-2.0.17.ebuild:
85 Stable on amd64 wrt bug #355265
86
87 16 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
88 gnupg-2.0.17.ebuild:
89 Fix dependencies.
90
91 16 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
92 gnupg-2.0.17.ebuild:
93 Fix installation (bug #351831).
94
95*gnupg-2.0.17 (14 Jan 2011)
96
97 14 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
98 -gnupg-1.4.10.ebuild, -gnupg-1.4.10-r1.ebuild,
99 -files/gnupg-2.0.12-adns.patch, -gnupg-2.0.16.ebuild, +gnupg-2.0.17.ebuild:
100 Version bump.
101
102 06 Jan 2011; Raúl Porcel <armin76@gentoo.org> gnupg-1.4.11.ebuild:
103 alpha/ia64/s390/sh/sparc stable wrt #348093
104
105 28 Dec 2010; Brent Baude <ranger@gentoo.org> gnupg-1.4.11.ebuild:
106 stable ppc64, bug 348093
107
108 15 Dec 2010; Markus Meier <maekke@gentoo.org> gnupg-1.4.11.ebuild:
109 arm stable, bug #348093
110
111 10 Dec 2010; Markos Chandras <hwoarang@gentoo.org> gnupg-1.4.11.ebuild:
112 Stable on amd64 wrt bug #348093
113
114 10 Dec 2010; Jeroen Roovers <jer@gentoo.org> gnupg-1.4.11.ebuild:
115 Stable for HPPA (bug #348093).
116
117 10 Dec 2010; Jeroen Roovers <jer@gentoo.org> gnupg-1.4.11.ebuild:
118 Stable for PPC (bug #348093).
119
120 09 Dec 2010; Dane Smith <c1pher@gentoo.org> gnupg-1.4.11.ebuild:
121 Stable x86 wrt bug 348093.
122
123 09 Dec 2010; Dane Smith <c1pher@gentoo.org> gnupg-1.4.11.ebuild:
124 *Removed $(use_enable) static. No longer used upstream wrt bug 348200.
125 *Changed --disable-capabilities to --without-capabilities wrt bug 348200.
126 *Added some missing || die.
127 Not revbumping. --with-capabilites defaults to without so all current
128 installs
129 will be without. $(use_enable static) is gone completely so it also
130 won't change any current install.
131
132 19 Oct 2010; Robin H. Johnson <robbat2@gentoo.org> -gnupg-2.0.11.ebuild,
133 -gnupg-2.0.12.ebuild, -gnupg-2.0.13.ebuild, -gnupg-2.0.14.ebuild,
134 -gnupg-2.0.15.ebuild:
135 Trim redundant versions.
136
137*gnupg-2.0.16-r2 (19 Oct 2010)
138
139 19 Oct 2010; Robin H. Johnson <robbat2@gentoo.org>
140 +gnupg-2.0.16-r2.ebuild, +files/gnupg-2.0.16-opengpgv2-sha2.patch:
141 Bug #339005: SHA2 support. Bug #285289: CONFIG_PROTECT for
142 /usr/share/gnupg/qualified.txt. Bug #301941: USE=openct/pcsc-lite without
143 USE=smartcard is useless. Bug #219423: USE=smartcard/openct/pcsc-lite and
144 USE=static are not permitted together.
145
146*gnupg-1.4.11 (19 Oct 2010)
147
148 19 Oct 2010; Robin H. Johnson <robbat2@gentoo.org> +gnupg-1.4.11.ebuild:
149 Version bump.
150
151 30 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> gnupg-2.0.11.ebuild,
152 gnupg-2.0.12.ebuild, gnupg-2.0.13.ebuild, gnupg-2.0.14.ebuild,
153 gnupg-2.0.15.ebuild, gnupg-2.0.16.ebuild, gnupg-2.0.16-r1.ebuild:
154 Fix dependencies to accept app-crypt/pinentry-qt.
155
156 11 Sep 2010; Raúl Porcel <armin76@gentoo.org> gnupg-2.0.16-r1.ebuild:
157 ia64/s390/sh/sparc stable wrt #329583
4 158
5 10 Sep 2010; Tobias Klausmann <klausman@gentoo.org> 159 10 Sep 2010; Tobias Klausmann <klausman@gentoo.org>
6 gnupg-2.0.16-r1.ebuild: 160 gnupg-2.0.16-r1.ebuild:
7 Stable on alpha, bug #329583 161 Stable on alpha, bug #329583
8 162

Legend:
Removed from v.1.389  
changed lines
  Added in v.1.424

  ViewVC Help
Powered by ViewVC 1.1.20