/[gentoo-x86]/app-crypt/gnupg/ChangeLog
Gentoo

Diff of /app-crypt/gnupg/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.389 Revision 1.426
1# ChangeLog for app-crypt/gnupg 1# ChangeLog for app-crypt/gnupg
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.389 2010/09/10 12:16:23 klausman Exp $ 3# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.426 2012/03/28 03:46:42 radhermit Exp $
4
5*gnupg-2.0.19 (28 Mar 2012)
6
7 28 Mar 2012; Tim Harder <radhermit@gentoo.org> +gnupg-2.0.19.ebuild:
8 Version bump.
9
10 05 Mar 2012; Tim Harder <radhermit@gentoo.org> gnupg-2.0.18.ebuild:
11 Allow older zlib versions without the static-libs use flag to statisfy the
12 dependency as well.
13
14 05 Mar 2012; Tim Harder <radhermit@gentoo.org> gnupg-2.0.18.ebuild:
15 Add more dependencies required for static build (fixes bugs #395669 and
16 #406331).
17
18 18 Feb 2012; Ulrich Müller <ulm@gentoo.org> metadata.xml:
19 Update description of idea USE flag, bug 404353.
20
21 11 Feb 2012; Robin H. Johnson <robbat2@gentoo.org> gnupg-2.0.17-r2.ebuild,
22 gnupg-2.0.17-r3.ebuild, gnupg-2.0.17.ebuild, gnupg-2.0.18.ebuild:
23 Bug #380755: missing sys-libs/zlib dependency.
24
25*gnupg-1.4.12 (31 Jan 2012)
26
27 31 Jan 2012; Robin H. Johnson <robbat2@gentoo.org> +gnupg-1.4.12.ebuild:
28 Version bump.
29
30 11 Jan 2012; Robin H. Johnson <robbat2@gentoo.org> gnupg-1.4.11.ebuild:
31 Bug #398441: IDEA patents have expired, remove bindist impact on USE=idea.
32
33 30 Nov 2011; Mike Frysinger <vapier@gentoo.org> gnupg-2.0.18.ebuild:
34 Control readline dep with USE=readline.
35
36 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> gnupg-2.0.18.ebuild:
37 Simplify dependencies. Patch by Arfrever.
38
39*gnupg-2.0.18 (04 Aug 2011)
40
41 04 Aug 2011; Robin H. Johnson <robbat2@gentoo.org> +gnupg-2.0.18.ebuild:
42 Version bump.
43
44*gnupg-2.0.17-r3 (03 Jul 2011)
45
46 03 Jul 2011; Robin H. Johnson <robbat2@gentoo.org> +gnupg-2.0.17-r3.ebuild,
47 +files/gnupg-2.0.17-libgrcrypt150-bugfix.patch:
48 Bug #373959: critical patch to enable signing w/ libgcrypt-1.5.0.
49
50*gnupg-2.0.17-r2 (09 Jun 2011)
51
52 09 Jun 2011; Dane Smith <c1pher@gentoo.org> -gnupg-2.0.17-r1.ebuild,
53 +gnupg-2.0.17-r2.ebuild:
54 Revision bump. Remove caps USE flag since capabilities are no longer
55 used anywhere wrt bug 360421.
56 Remove no longer needed || die.
57 Drop old revision. No keyword changes necessary.
58
59 14 May 2011; Raúl Porcel <armin76@gentoo.org> gnupg-2.0.17.ebuild:
60 ia64/s390/sh/sparc stable wrt #355265
61
62 09 May 2011; Markus Meier <maekke@gentoo.org> gnupg-2.0.17.ebuild:
63 arm stable, bug #355265
64
65*gnupg-2.0.17-r1 (16 Apr 2011)
66
67 16 Apr 2011; Diego E. Pettenò <flameeyes@gentoo.org>
68 +gnupg-2.0.17-r1.ebuild, +files/gnupg-2.0.17-gpgsm-gencert.patch,
69 metadata.xml:
70 Revision bump: patch gpgsm-gencert.sh to actually work; remove openct and
71 pcsc-lite USE flags: smartcard USE flag now enables scdaemon, and usb enables
72 the internal CCID driver; don't depend on a particular implementation since
73 there are multiple options; use EAPI=4 and REQUIRED_USE to block static
74 support with smartcard.
75
76 23 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> gnupg-2.0.17.ebuild:
77 ppc/ppc64 stable wrt #355265
78
79 18 Mar 2011; Dane Smith <c1pher@gentoo.org> gnupg-2.0.17.ebuild:
80 Remove the use of ecompressdir wrt bug 356501. Other small QA fixes. No
81 revbump as installed files don't change (Save for the removal of a couple
82 examples files that were once doc.)
83
84 12 Mar 2011; Tobias Klausmann <klausman@gentoo.org> gnupg-2.0.17.ebuild:
85 Stable on alpha, bug #355265
86
87 11 Mar 2011; Thomas Kahle <tomka@gentoo.org> gnupg-2.0.17.ebuild:
88 x86 stable per bug 355265
89
90 08 Mar 2011; Jeroen Roovers <jer@gentoo.org> gnupg-2.0.17.ebuild:
91 Stable for HPPA (bug #355265).
92
93 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> gnupg-2.0.17.ebuild:
94 Stable on amd64 wrt bug #355265
95
96 16 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
97 gnupg-2.0.17.ebuild:
98 Fix dependencies.
99
100 16 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
101 gnupg-2.0.17.ebuild:
102 Fix installation (bug #351831).
103
104*gnupg-2.0.17 (14 Jan 2011)
105
106 14 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
107 -gnupg-1.4.10.ebuild, -gnupg-1.4.10-r1.ebuild,
108 -files/gnupg-2.0.12-adns.patch, -gnupg-2.0.16.ebuild, +gnupg-2.0.17.ebuild:
109 Version bump.
110
111 06 Jan 2011; Raúl Porcel <armin76@gentoo.org> gnupg-1.4.11.ebuild:
112 alpha/ia64/s390/sh/sparc stable wrt #348093
113
114 28 Dec 2010; Brent Baude <ranger@gentoo.org> gnupg-1.4.11.ebuild:
115 stable ppc64, bug 348093
116
117 15 Dec 2010; Markus Meier <maekke@gentoo.org> gnupg-1.4.11.ebuild:
118 arm stable, bug #348093
119
120 10 Dec 2010; Markos Chandras <hwoarang@gentoo.org> gnupg-1.4.11.ebuild:
121 Stable on amd64 wrt bug #348093
122
123 10 Dec 2010; Jeroen Roovers <jer@gentoo.org> gnupg-1.4.11.ebuild:
124 Stable for HPPA (bug #348093).
125
126 10 Dec 2010; Jeroen Roovers <jer@gentoo.org> gnupg-1.4.11.ebuild:
127 Stable for PPC (bug #348093).
128
129 09 Dec 2010; Dane Smith <c1pher@gentoo.org> gnupg-1.4.11.ebuild:
130 Stable x86 wrt bug 348093.
131
132 09 Dec 2010; Dane Smith <c1pher@gentoo.org> gnupg-1.4.11.ebuild:
133 *Removed $(use_enable) static. No longer used upstream wrt bug 348200.
134 *Changed --disable-capabilities to --without-capabilities wrt bug 348200.
135 *Added some missing || die.
136 Not revbumping. --with-capabilites defaults to without so all current
137 installs
138 will be without. $(use_enable static) is gone completely so it also
139 won't change any current install.
140
141 19 Oct 2010; Robin H. Johnson <robbat2@gentoo.org> -gnupg-2.0.11.ebuild,
142 -gnupg-2.0.12.ebuild, -gnupg-2.0.13.ebuild, -gnupg-2.0.14.ebuild,
143 -gnupg-2.0.15.ebuild:
144 Trim redundant versions.
145
146*gnupg-2.0.16-r2 (19 Oct 2010)
147
148 19 Oct 2010; Robin H. Johnson <robbat2@gentoo.org>
149 +gnupg-2.0.16-r2.ebuild, +files/gnupg-2.0.16-opengpgv2-sha2.patch:
150 Bug #339005: SHA2 support. Bug #285289: CONFIG_PROTECT for
151 /usr/share/gnupg/qualified.txt. Bug #301941: USE=openct/pcsc-lite without
152 USE=smartcard is useless. Bug #219423: USE=smartcard/openct/pcsc-lite and
153 USE=static are not permitted together.
154
155*gnupg-1.4.11 (19 Oct 2010)
156
157 19 Oct 2010; Robin H. Johnson <robbat2@gentoo.org> +gnupg-1.4.11.ebuild:
158 Version bump.
159
160 30 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> gnupg-2.0.11.ebuild,
161 gnupg-2.0.12.ebuild, gnupg-2.0.13.ebuild, gnupg-2.0.14.ebuild,
162 gnupg-2.0.15.ebuild, gnupg-2.0.16.ebuild, gnupg-2.0.16-r1.ebuild:
163 Fix dependencies to accept app-crypt/pinentry-qt.
164
165 11 Sep 2010; Raúl Porcel <armin76@gentoo.org> gnupg-2.0.16-r1.ebuild:
166 ia64/s390/sh/sparc stable wrt #329583
4 167
5 10 Sep 2010; Tobias Klausmann <klausman@gentoo.org> 168 10 Sep 2010; Tobias Klausmann <klausman@gentoo.org>
6 gnupg-2.0.16-r1.ebuild: 169 gnupg-2.0.16-r1.ebuild:
7 Stable on alpha, bug #329583 170 Stable on alpha, bug #329583
8 171

Legend:
Removed from v.1.389  
changed lines
  Added in v.1.426

  ViewVC Help
Powered by ViewVC 1.1.20