/[gentoo-x86]/app-crypt/gnupg/ChangeLog
Gentoo

Diff of /app-crypt/gnupg/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.390 Revision 1.422
1# ChangeLog for app-crypt/gnupg 1# ChangeLog for app-crypt/gnupg
2# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.390 2010/09/11 15:18:01 armin76 Exp $ 3# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.422 2012/02/11 19:16:34 robbat2 Exp $
4
5 11 Feb 2012; Robin H. Johnson <robbat2@gentoo.org> gnupg-2.0.17-r2.ebuild,
6 gnupg-2.0.17-r3.ebuild, gnupg-2.0.17.ebuild, gnupg-2.0.18.ebuild:
7 Bug #380755: missing sys-libs/zlib dependency.
8
9*gnupg-1.4.12 (31 Jan 2012)
10
11 31 Jan 2012; Robin H. Johnson <robbat2@gentoo.org> +gnupg-1.4.12.ebuild:
12 Version bump.
13
14 11 Jan 2012; Robin H. Johnson <robbat2@gentoo.org> gnupg-1.4.11.ebuild:
15 Bug #398441: IDEA patents have expired, remove bindist impact on USE=idea.
16
17 30 Nov 2011; Mike Frysinger <vapier@gentoo.org> gnupg-2.0.18.ebuild:
18 Control readline dep with USE=readline.
19
20 19 Aug 2011; Markos Chandras <hwoarang@gentoo.org> gnupg-2.0.18.ebuild:
21 Simplify dependencies. Patch by Arfrever.
22
23*gnupg-2.0.18 (04 Aug 2011)
24
25 04 Aug 2011; Robin H. Johnson <robbat2@gentoo.org> +gnupg-2.0.18.ebuild:
26 Version bump.
27
28*gnupg-2.0.17-r3 (03 Jul 2011)
29
30 03 Jul 2011; Robin H. Johnson <robbat2@gentoo.org> +gnupg-2.0.17-r3.ebuild,
31 +files/gnupg-2.0.17-libgrcrypt150-bugfix.patch:
32 Bug #373959: critical patch to enable signing w/ libgcrypt-1.5.0.
33
34*gnupg-2.0.17-r2 (09 Jun 2011)
35
36 09 Jun 2011; Dane Smith <c1pher@gentoo.org> -gnupg-2.0.17-r1.ebuild,
37 +gnupg-2.0.17-r2.ebuild:
38 Revision bump. Remove caps USE flag since capabilities are no longer
39 used anywhere wrt bug 360421.
40 Remove no longer needed || die.
41 Drop old revision. No keyword changes necessary.
42
43 14 May 2011; Raúl Porcel <armin76@gentoo.org> gnupg-2.0.17.ebuild:
44 ia64/s390/sh/sparc stable wrt #355265
45
46 09 May 2011; Markus Meier <maekke@gentoo.org> gnupg-2.0.17.ebuild:
47 arm stable, bug #355265
48
49*gnupg-2.0.17-r1 (16 Apr 2011)
50
51 16 Apr 2011; Diego E. Pettenò <flameeyes@gentoo.org>
52 +gnupg-2.0.17-r1.ebuild, +files/gnupg-2.0.17-gpgsm-gencert.patch,
53 metadata.xml:
54 Revision bump: patch gpgsm-gencert.sh to actually work; remove openct and
55 pcsc-lite USE flags: smartcard USE flag now enables scdaemon, and usb enables
56 the internal CCID driver; don't depend on a particular implementation since
57 there are multiple options; use EAPI=4 and REQUIRED_USE to block static
58 support with smartcard.
59
60 23 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> gnupg-2.0.17.ebuild:
61 ppc/ppc64 stable wrt #355265
62
63 18 Mar 2011; Dane Smith <c1pher@gentoo.org> gnupg-2.0.17.ebuild:
64 Remove the use of ecompressdir wrt bug 356501. Other small QA fixes. No
65 revbump as installed files don't change (Save for the removal of a couple
66 examples files that were once doc.)
67
68 12 Mar 2011; Tobias Klausmann <klausman@gentoo.org> gnupg-2.0.17.ebuild:
69 Stable on alpha, bug #355265
70
71 11 Mar 2011; Thomas Kahle <tomka@gentoo.org> gnupg-2.0.17.ebuild:
72 x86 stable per bug 355265
73
74 08 Mar 2011; Jeroen Roovers <jer@gentoo.org> gnupg-2.0.17.ebuild:
75 Stable for HPPA (bug #355265).
76
77 19 Feb 2011; Markos Chandras <hwoarang@gentoo.org> gnupg-2.0.17.ebuild:
78 Stable on amd64 wrt bug #355265
79
80 16 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
81 gnupg-2.0.17.ebuild:
82 Fix dependencies.
83
84 16 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
85 gnupg-2.0.17.ebuild:
86 Fix installation (bug #351831).
87
88*gnupg-2.0.17 (14 Jan 2011)
89
90 14 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
91 -gnupg-1.4.10.ebuild, -gnupg-1.4.10-r1.ebuild,
92 -files/gnupg-2.0.12-adns.patch, -gnupg-2.0.16.ebuild, +gnupg-2.0.17.ebuild:
93 Version bump.
94
95 06 Jan 2011; Raúl Porcel <armin76@gentoo.org> gnupg-1.4.11.ebuild:
96 alpha/ia64/s390/sh/sparc stable wrt #348093
97
98 28 Dec 2010; Brent Baude <ranger@gentoo.org> gnupg-1.4.11.ebuild:
99 stable ppc64, bug 348093
100
101 15 Dec 2010; Markus Meier <maekke@gentoo.org> gnupg-1.4.11.ebuild:
102 arm stable, bug #348093
103
104 10 Dec 2010; Markos Chandras <hwoarang@gentoo.org> gnupg-1.4.11.ebuild:
105 Stable on amd64 wrt bug #348093
106
107 10 Dec 2010; Jeroen Roovers <jer@gentoo.org> gnupg-1.4.11.ebuild:
108 Stable for HPPA (bug #348093).
109
110 10 Dec 2010; Jeroen Roovers <jer@gentoo.org> gnupg-1.4.11.ebuild:
111 Stable for PPC (bug #348093).
112
113 09 Dec 2010; Dane Smith <c1pher@gentoo.org> gnupg-1.4.11.ebuild:
114 Stable x86 wrt bug 348093.
115
116 09 Dec 2010; Dane Smith <c1pher@gentoo.org> gnupg-1.4.11.ebuild:
117 *Removed $(use_enable) static. No longer used upstream wrt bug 348200.
118 *Changed --disable-capabilities to --without-capabilities wrt bug 348200.
119 *Added some missing || die.
120 Not revbumping. --with-capabilites defaults to without so all current
121 installs
122 will be without. $(use_enable static) is gone completely so it also
123 won't change any current install.
124
125 19 Oct 2010; Robin H. Johnson <robbat2@gentoo.org> -gnupg-2.0.11.ebuild,
126 -gnupg-2.0.12.ebuild, -gnupg-2.0.13.ebuild, -gnupg-2.0.14.ebuild,
127 -gnupg-2.0.15.ebuild:
128 Trim redundant versions.
129
130*gnupg-2.0.16-r2 (19 Oct 2010)
131
132 19 Oct 2010; Robin H. Johnson <robbat2@gentoo.org>
133 +gnupg-2.0.16-r2.ebuild, +files/gnupg-2.0.16-opengpgv2-sha2.patch:
134 Bug #339005: SHA2 support. Bug #285289: CONFIG_PROTECT for
135 /usr/share/gnupg/qualified.txt. Bug #301941: USE=openct/pcsc-lite without
136 USE=smartcard is useless. Bug #219423: USE=smartcard/openct/pcsc-lite and
137 USE=static are not permitted together.
138
139*gnupg-1.4.11 (19 Oct 2010)
140
141 19 Oct 2010; Robin H. Johnson <robbat2@gentoo.org> +gnupg-1.4.11.ebuild:
142 Version bump.
143
144 30 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> gnupg-2.0.11.ebuild,
145 gnupg-2.0.12.ebuild, gnupg-2.0.13.ebuild, gnupg-2.0.14.ebuild,
146 gnupg-2.0.15.ebuild, gnupg-2.0.16.ebuild, gnupg-2.0.16-r1.ebuild:
147 Fix dependencies to accept app-crypt/pinentry-qt.
4 148
5 11 Sep 2010; Raúl Porcel <armin76@gentoo.org> gnupg-2.0.16-r1.ebuild: 149 11 Sep 2010; Raúl Porcel <armin76@gentoo.org> gnupg-2.0.16-r1.ebuild:
6 ia64/s390/sh/sparc stable wrt #329583 150 ia64/s390/sh/sparc stable wrt #329583
7 151
8 10 Sep 2010; Tobias Klausmann <klausman@gentoo.org> 152 10 Sep 2010; Tobias Klausmann <klausman@gentoo.org>

Legend:
Removed from v.1.390  
changed lines
  Added in v.1.422

  ViewVC Help
Powered by ViewVC 1.1.20