/[gentoo-x86]/app-misc/alexandria/alexandria-0.6.9.ebuild
Gentoo

Contents of /app-misc/alexandria/alexandria-0.6.9.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.5 - (hide annotations) (download)
Sat Apr 19 02:57:49 2014 UTC (8 months ago) by mrueg
Branch: MAIN
CVS Tags: HEAD
Changes since 1.4: +1 -1 lines
FILE REMOVED
app-misc/alexandria removal. Supports ruby-1.8 only See bug #434064.

1 ago 1.2 # Copyright 1999-2013 Gentoo Foundation
2 fauli 1.1 # Distributed under the terms of the GNU General Public License v2
3 mrueg 1.5 # $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/alexandria-0.6.9.ebuild,v 1.4 2013/09/14 06:51:12 graaff Exp $
4 fauli 1.1
5     EAPI=4
6     USE_RUBY="ruby18"
7    
8     inherit gnome2 ruby-ng
9    
10     DESCRIPTION="A GNOME application to help you manage your book collection"
11     HOMEPAGE="http://alexandria.rubyforge.org/"
12     SRC_URI="mirror://rubyforge/${PN}/${PN}-${PV}.tar.gz"
13    
14     LICENSE="GPL-2"
15     SLOT="0"
16 ago 1.3 KEYWORDS="amd64 x86"
17 fauli 1.1 IUSE="evo"
18    
19     DOCS="ChangeLog README TODO doc/BUGS doc/cuecat_support.rdoc doc/FAQ doc/HACKING doc/NEWS"
20    
21     ruby_add_rdepend "
22     >=dev-ruby/ruby-gettext-0.6.1
23     >=dev-ruby/ruby-gtk2-0.90
24     >=dev-ruby/ruby-goocanvas-0.90
25     >=dev-ruby/ruby-gstreamer-0.90
26     >=dev-ruby/ruby-pango-0.90
27     >=dev-ruby/imagesize-0.1.1
28     dev-ruby/hpricot
29     evo? ( >=dev-ruby/revolution-0.5 )"
30    
31     ruby_add_bdepend "dev-ruby/rake"
32    
33     DEPEND="${DEPEND}
34     gnome-base/gconf:2
35     app-text/scrollkeeper"
36    
37     RUBY_PATCHES=(
38     "${FILESDIR}/${PN}-0.6.6-Rakefile.patch"
39     )
40    
41     each_ruby_compile() {
42     ${RUBY} -S rake || die
43     }
44    
45     each_ruby_install() {
46     export DESTDIR="${D}" PREFIX=/usr RUBYLIBDIR="$(ruby_rbconfig_value 'sitelibdir')"
47     ${RUBY} -S rake install_package_staging || die
48     }
49    
50     all_ruby_install() {
51     [ -n "${DOCS}" ] && dodoc ${DOCS} || die "Failed to install documentation"
52     }
53    
54     pkg_postinst() {
55     unset PREFIX
56    
57     gnome2_gconf_install
58    
59     # For the next line see bug #76726
60     "${ROOT}/usr/bin/gconftool-2" --shutdown
61    
62     echo
63     elog "To enable some book providers you will need to emerge"
64     elog "additional packages:"
65     echo
66     elog " For the Deastore book provider:"
67     elog " dev-ruby/htmlentities"
68     }

  ViewVC Help
Powered by ViewVC 1.1.20