/[gentoo-x86]/app-office/libreoffice-bin/libreoffice-bin-4.0.4.2.ebuild
Gentoo

Contents of /app-office/libreoffice-bin/libreoffice-bin-4.0.4.2.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.6 - (hide annotations) (download)
Mon Sep 16 11:32:37 2013 UTC (15 months, 1 week ago) by dilfridge
Branch: MAIN
Changes since 1.5: +2 -1 lines
Fix boost version, otherwise we get in trouble

(Portage version: 2.2.3/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)

1 dilfridge 1.1 # Copyright 1999-2013 Gentoo Foundation
2     # Distributed under the terms of the GNU General Public License v2
3 dilfridge 1.6 # $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice-bin/libreoffice-bin-4.0.4.2.ebuild,v 1.5 2013/08/05 07:31:30 dilfridge Exp $
4 dilfridge 1.1
5     EAPI=5
6    
7     KDE_REQUIRED="optional"
8     CMAKE_REQUIRED="never"
9    
10     BASE_AMD64_URI="mirror://gentoo/amd64-bin-"
11     BASE_X86_URI="mirror://gentoo/x86-bin-"
12    
13     PYTHON_COMPAT=( python2_7 python3_3 )
14     PYTHON_REQ_USE="threads,xml"
15    
16     inherit kde4-base java-pkg-opt-2 python-single-r1 pax-utils prefix versionator
17    
18     DESCRIPTION="LibreOffice, a full office productivity suite. Binary package."
19     HOMEPAGE="http://www.libreoffice.org"
20     SRC_URI_AMD64="
21     kde? (
22     !java? ( ${BASE_AMD64_URI}${PN/-bin}-kde-${PVR}.tar.xz )
23     java? ( ${BASE_AMD64_URI}${PN/-bin}-kde-java-${PVR}.tar.xz )
24     )
25     gnome? (
26     !java? ( ${BASE_AMD64_URI}${PN/-bin}-gnome-${PVR}.tar.xz )
27     java? ( ${BASE_AMD64_URI}${PN/-bin}-gnome-java-${PVR}.tar.xz )
28     )
29     !kde? ( !gnome? (
30     !java? ( ${BASE_AMD64_URI}${PN/-bin}-base-${PVR}.tar.xz )
31     java? ( ${BASE_AMD64_URI}${PN/-bin}-base-java-${PVR}.tar.xz )
32     ) )
33     "
34     SRC_URI_X86="
35     kde? (
36     !java? ( ${BASE_X86_URI}${PN/-bin}-kde-${PVR}.tar.xz )
37     java? ( ${BASE_X86_URI}${PN/-bin}-kde-java-${PVR}.tar.xz )
38     )
39     gnome? (
40     !java? ( ${BASE_X86_URI}${PN/-bin}-gnome-${PVR}.tar.xz )
41     java? ( ${BASE_X86_URI}${PN/-bin}-gnome-java-${PVR}.tar.xz )
42     )
43     !kde? ( !gnome? (
44     !java? ( ${BASE_X86_URI}${PN/-bin}-base-${PVR}.tar.xz )
45     java? ( ${BASE_X86_URI}${PN/-bin}-base-java-${PVR}.tar.xz )
46     ) )
47     "
48    
49     SRC_URI="
50     amd64? ( ${SRC_URI_AMD64} )
51     x86? ( ${SRC_URI_X86} )
52     "
53    
54 dilfridge 1.2 IUSE="debug gnome java kde"
55 dilfridge 1.1 LICENSE="LGPL-3"
56     SLOT="0"
57 ago 1.4 KEYWORDS="-* amd64 x86"
58 dilfridge 1.1
59     BIN_COMMON_DEPEND="
60     =app-text/libexttextcat-3.4*
61     app-text/poppler:0/35
62 dilfridge 1.6 =dev-libs/boost-1.49*
63 dilfridge 1.1 dev-libs/icu:0/51.1
64     =media-gfx/graphite2-1.2*
65     =media-libs/libpng-1.5*
66     >=sys-libs/glibc-2.15-r3
67     kde? ( >=kde-base/kdelibs-4.10.4:4 >=dev-qt/qtcore-4.8.4-r5:4 )
68 dilfridge 1.5 || ( <media-libs/libjpeg-turbo-1.3.0-r2 =media-libs/jpeg-8* )
69 dilfridge 1.1 "
70    
71     # PLEASE place any restrictions that are specific to the binary builds
72     # into the BIN_COMMON_DEPEND block above.
73     # All dependencies below this point should remain identical to those in
74     # the source ebuilds.
75    
76     COMMON_DEPEND="
77     ${BIN_COMMON_DEPEND}
78     ${PYTHON_DEPS}
79     app-arch/zip
80     app-arch/unzip
81     >=app-text/hunspell-1.3.2-r3
82     app-text/mythes
83     >=app-text/libexttextcat-3.2
84     app-text/liblangtag
85     app-text/libmspub
86     app-text/libwpd:0.9[tools]
87     app-text/libwpg:0.2
88     >=app-text/libwps-0.2.2
89     >=app-text/poppler-0.16:=[xpdf-headers(+),cxx]
90     >=dev-cpp/clucene-2.3.3.4-r2
91     >=dev-cpp/libcmis-0.3.1:0.3
92     dev-db/unixODBC
93     dev-libs/expat
94     >=dev-libs/hyphen-2.7.1
95     >=dev-libs/icu-4.8.1.1:=
96     =dev-libs/liborcus-0.3*
97     >=dev-libs/nspr-4.8.8
98     >=dev-libs/nss-3.12.9
99     >=dev-lang/perl-5.0
100     >=dev-libs/openssl-1.0.0d
101     >=dev-libs/redland-1.0.14[ssl]
102     media-gfx/graphite2
103     >=media-libs/fontconfig-2.8.0
104     media-libs/freetype:2
105     media-libs/lcms:2
106     >=media-libs/libpng-1.4
107     >=media-libs/libcdr-0.0.5
108     media-libs/libvisio
109     >=net-misc/curl-7.21.4
110     net-nds/openldap
111     sci-mathematics/lpsolve
112     virtual/jpeg
113     >=x11-libs/cairo-1.10.0[X]
114     x11-libs/libXinerama
115     x11-libs/libXrandr
116     x11-libs/libXrender
117 dilfridge 1.2 net-print/cups
118 dilfridge 1.1 >=dev-libs/dbus-glib-0.92
119     gnome? ( gnome-extra/evolution-data-server )
120     gnome? ( gnome-base/gconf:2 )
121     x11-libs/gdk-pixbuf[X]
122     >=x11-libs/gtk+-2.24:2
123     media-libs/gstreamer:1.0
124     media-libs/gst-plugins-base:1.0
125     virtual/glu
126     virtual/opengl
127     net-libs/neon
128     "
129    
130     RDEPEND="${COMMON_DEPEND}
131     !app-office/libreoffice
132     !<app-office/openoffice-bin-3.4.0-r1
133     !app-office/openoffice
134     media-fonts/libertine-ttf
135     media-fonts/liberation-fonts
136     media-fonts/urw-fonts
137     java? ( >=virtual/jre-1.6 )
138     "
139    
140     PDEPEND="
141     =app-office/libreoffice-l10n-4.0*
142     "
143    
144     DEPEND=""
145    
146     # only one flavor at a time
147     REQUIRED_USE="kde? ( !gnome ) gnome? ( !kde )"
148    
149     RESTRICT="test strip"
150    
151     S="${WORKDIR}"
152    
153     PYTHON_UPDATER_IGNORE="1"
154    
155     pkg_pretend() {
156     [[ $(gcc-major-version) -lt 4 ]] || \
157     ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -le 4 ]] ) \
158     && die "Sorry, but gcc-4.4 and earlier won't work for libreoffice-bin package (see bug #387515)."
159     }
160    
161     pkg_setup() {
162     kde4-base_pkg_setup
163     }
164    
165     src_unpack() {
166     default
167     }
168    
169     src_prepare() {
170     cp "${FILESDIR}"/50-${PN} "${T}"
171     eprefixify "${T}"/50-${PN}
172     }
173    
174     src_configure() { :; }
175    
176     src_compile() { :; }
177    
178     src_install() {
179     dodir /usr
180     cp -aR "${S}"/usr/* "${ED}"/usr/
181    
182     # prevent revdep-rebuild from attempting to rebuild all the time
183     insinto /etc/revdep-rebuild && doins "${T}/50-${PN}"
184     }
185    
186     pkg_preinst() {
187     # Cache updates - all handled by kde eclass for all environments
188     kde4-base_pkg_preinst
189     }
190    
191     pkg_postinst() {
192     kde4-base_pkg_postinst
193    
194     pax-mark -m "${EPREFIX}"/usr/$(get_libdir)/libreoffice/program/soffice.bin
195     pax-mark -m "${EPREFIX}"/usr/$(get_libdir)/libreoffice/program/unopkg.bin
196    
197     use java || \
198     ewarn 'If you plan to use lbase application you should enable java or you will get various crashes.'
199     }
200    
201     pkg_postrm() {
202     kde4-base_pkg_postrm
203     }

  ViewVC Help
Powered by ViewVC 1.1.20