/[gentoo-x86]/app-office/libreoffice/libreoffice-9999-r2.ebuild
Gentoo

Contents of /app-office/libreoffice/libreoffice-9999-r2.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.153 - (show annotations) (download)
Tue Jan 15 15:45:50 2013 UTC (23 months ago) by scarabeus
Branch: MAIN
Changes since 1.152: +2 -2 lines
Fix nsplugins calls. Fixes bug#452368.

(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)

1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r2.ebuild,v 1.152 2013/01/14 13:24:37 scarabeus Exp $
4
5 EAPI=5
6
7 KDE_REQUIRED="optional"
8 QT_MINIMAL="4.7.4"
9 KDE_SCM="git"
10 CMAKE_REQUIRED="never"
11
12 PYTHON_COMPAT=( python2_7 python3_3 )
13 PYTHON_REQ_USE="threads,xml"
14
15 # experimental ; release ; old
16 # Usually the tarballs are moved a lot so this should make
17 # everyone happy.
18 DEV_URI="
19 http://dev-builds.libreoffice.org/pre-releases/src
20 http://download.documentfoundation.org/libreoffice/src/${PV:0:5}/
21 http://download.documentfoundation.org/libreoffice/old/${PV}/
22 "
23 EXT_URI="http://ooo.itc.hu/oxygenoffice/download/libreoffice"
24 ADDONS_URI="http://dev-www.libreoffice.org/src/"
25
26 BRANDING="${PN}-branding-gentoo-0.7.tar.xz"
27 # PATCHSET="${P}-patchset-01.tar.xz"
28
29 [[ ${PV} == *9999* ]] && SCM_ECLASS="git-2"
30 inherit base autotools bash-completion-r1 check-reqs eutils java-pkg-opt-2 kde4-base pax-utils python-single-r1 multilib toolchain-funcs flag-o-matic nsplugins ${SCM_ECLASS}
31 unset SCM_ECLASS
32
33 DESCRIPTION="LibreOffice, a full office productivity suite."
34 HOMEPAGE="http://www.libreoffice.org"
35 SRC_URI="branding? ( http://dev.gentoo.org/~dilfridge/distfiles/${BRANDING} )"
36 [[ -n ${PATCHSET} ]] && SRC_URI+=" http://dev.gentooexperimental.org/~scarabeus/${PATCHSET}"
37
38 # Split modules following git/tarballs
39 # Core MUST be first!
40 # Help is used for the image generator
41 MODULES="core help"
42 # Only release has the tarballs
43 if [[ ${PV} != *9999* ]]; then
44 for i in ${DEV_URI}; do
45 for mod in ${MODULES}; do
46 if [[ ${mod} == core ]]; then
47 SRC_URI+=" ${i}/${P}.tar.xz"
48 else
49 SRC_URI+=" ${i}/${PN}-${mod}-${PV}.tar.xz"
50 fi
51 done
52 unset mod
53 done
54 unset i
55 fi
56 unset DEV_URI
57
58 # Really required addons
59 # These are bundles that can't be removed for now due to huge patchsets.
60 # If you want them gone, patches are welcome.
61 ADDONS_SRC+=" ${ADDONS_URI}/ea91f2fb4212a21d708aced277e6e85a-vigra1.4.0.tar.gz"
62 ADDONS_SRC+=" ${ADDONS_URI}/1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz" # modifies source code
63 ADDONS_SRC+=" java? ( ${ADDONS_URI}/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip )"
64 ADDONS_SRC+=" libreoffice_extensions_wiki-publisher? ( ${ADDONS_URI}/a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip )" # no release for 8 years, should we package it?
65 ADDONS_SRC+=" libreoffice_extensions_scripting-javascript? ( ${ADDONS_URI}/798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip )" # Does not build with 1.6 rhino at all
66 ADDONS_SRC+=" libreoffice_extensions_scripting-javascript? ( ${ADDONS_URI}/35c94d2df8893241173de1d16b6034c0-swingExSrc.zip )" # requirement of rhino
67 ADDONS_SRC+=" odk? ( http://download.go-oo.org/extern/185d60944ea767075d27247c3162b3bc-unowinreg.dll )" # not packageable
68 SRC_URI+=" ${ADDONS_SRC}"
69
70 unset ADDONS_URI
71 unset EXT_URI
72 unset ADDONS_SRC
73
74 IUSE="bluetooth +branding +cups dbus debug eds gnome gstreamer +gtk
75 gtk3 jemalloc kde mysql odk opengl postgres telepathy test +vba +webdav"
76
77 LO_EXTS="nlpsolver presenter-minimizer scripting-beanshell scripting-javascript wiki-publisher"
78 # Unpackaged separate extensions:
79 # diagram: lo has 0.9.5 upstream is weirdly patched 0.9.4 -> wtf?
80 # hunart: only on ooo extensions -> fubared download path somewhere on sf
81 # numbertext, typo, validator, watch-window: ^^
82 # oooblogger: no homepage or anything
83 # Extensions that need extra work:
84 # report-builder: missing java packages
85 for lo_xt in ${LO_EXTS}; do
86 IUSE+=" libreoffice_extensions_${lo_xt}"
87 done
88 unset lo_xt
89
90 LICENSE="|| ( LGPL-3 MPL-1.1 )"
91 SLOT="0"
92 [[ ${PV} == *9999* ]] || KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
93
94 COMMON_DEPEND="
95 ${PYTHON_DEPS}
96 app-arch/zip
97 app-arch/unzip
98 >=app-text/hunspell-1.3.2-r3
99 app-text/mythes
100 >=app-text/libexttextcat-3.2
101 app-text/liblangtag
102 app-text/libmspub
103 app-text/libwpd:0.9[tools]
104 app-text/libwpg:0.2
105 >=app-text/libwps-0.2.2
106 >=app-text/poppler-0.16[xpdf-headers(+),cxx]
107 >=dev-cpp/clucene-2.3.3.4-r2
108 dev-cpp/libcmis:0.3
109 dev-db/unixODBC
110 dev-libs/expat
111 >=dev-libs/hyphen-2.7.1
112 >=dev-libs/icu-4.8.1.1
113 >=dev-libs/liborcus-0.3
114 >=dev-libs/nspr-4.8.8
115 >=dev-libs/nss-3.12.9
116 >=dev-lang/perl-5.0
117 >=dev-libs/openssl-1.0.0d
118 >=dev-libs/redland-1.0.14[ssl]
119 media-gfx/graphite2
120 >=media-libs/fontconfig-2.8.0
121 media-libs/freetype:2
122 media-libs/lcms:2
123 >=media-libs/libpng-1.4
124 >=media-libs/libcdr-0.0.5
125 media-libs/libvisio
126 >=net-misc/curl-7.21.4
127 net-nds/openldap
128 sci-mathematics/lpsolve
129 virtual/jpeg
130 >=x11-libs/cairo-1.10.0[X]
131 x11-libs/libXinerama
132 x11-libs/libXrandr
133 x11-libs/libXrender
134 bluetooth? ( net-wireless/bluez )
135 cups? ( net-print/cups )
136 dbus? ( >=dev-libs/dbus-glib-0.92 )
137 eds? ( gnome-extra/evolution-data-server )
138 gnome? ( gnome-base/gconf:2 )
139 gtk? (
140 x11-libs/gdk-pixbuf[X]
141 >=x11-libs/gtk+-2.24:2
142 )
143 gtk3? ( >=x11-libs/gtk+-3.2:3 )
144 gstreamer? (
145 media-libs/gstreamer:1.0
146 media-libs/gst-plugins-base:1.0
147 )
148 jemalloc? ( dev-libs/jemalloc )
149 libreoffice_extensions_scripting-beanshell? ( >=dev-java/bsh-2.0_beta4 )
150 libreoffice_extensions_scripting-javascript? ( dev-java/rhino:1.6 )
151 libreoffice_extensions_wiki-publisher? (
152 dev-java/commons-codec:0
153 dev-java/commons-httpclient:3
154 dev-java/commons-lang:2.1
155 dev-java/commons-logging:0
156 dev-java/tomcat-servlet-api:3.0
157 )
158 mysql? ( >=dev-db/mysql-connector-c++-1.1.0 )
159 opengl? (
160 virtual/glu
161 virtual/opengl
162 )
163 postgres? ( >=dev-db/postgresql-base-9.0[kerberos] )
164 telepathy? (
165 dev-libs/glib:2
166 >=net-libs/telepathy-glib-0.18.0
167 )
168 webdav? ( net-libs/neon )
169 "
170
171 RDEPEND="${COMMON_DEPEND}
172 !app-office/libreoffice-bin
173 !app-office/libreoffice-bin-debug
174 !<app-office/openoffice-bin-3.4.0-r1
175 !app-office/openoffice
176 media-fonts/libertine-ttf
177 media-fonts/liberation-fonts
178 media-fonts/urw-fonts
179 java? ( >=virtual/jre-1.6 )
180 "
181
182 PDEPEND="
183 =app-office/libreoffice-l10n-3.6*
184 "
185
186 # FIXME: cppunit should be moved to test conditional
187 # after everything upstream is under gbuild
188 # as dmake execute tests right away
189 DEPEND="${COMMON_DEPEND}
190 >=dev-libs/boost-1.46
191 >=dev-libs/libxml2-2.7.8
192 dev-libs/libxslt
193 dev-perl/Archive-Zip
194 dev-util/cppunit
195 >=dev-util/gperf-3
196 dev-util/intltool
197 dev-util/mdds
198 virtual/pkgconfig
199 net-misc/npapi-sdk
200 >=sys-apps/findutils-4.4.2
201 sys-devel/bison
202 sys-apps/coreutils
203 sys-devel/flex
204 sys-devel/gettext
205 >=sys-devel/make-3.82
206 sys-devel/ucpp
207 sys-libs/zlib
208 x11-libs/libXt
209 x11-libs/libXtst
210 x11-proto/randrproto
211 x11-proto/xextproto
212 x11-proto/xineramaproto
213 x11-proto/xproto
214 java? (
215 >=virtual/jdk-1.6
216 >=dev-java/ant-core-1.7
217 )
218 odk? ( app-doc/doxygen )
219 test? ( dev-util/cppunit )
220 "
221
222 PATCHES=(
223 # not upstreamable stuff
224 "${FILESDIR}/${PN}-3.7-system-pyuno.patch"
225 "${FILESDIR}/${PN}-3.7-separate-checks.patch"
226 )
227
228 REQUIRED_USE="
229 bluetooth? ( dbus )
230 gnome? ( gtk )
231 eds? ( gnome )
232 libreoffice_extensions_nlpsolver? ( java )
233 libreoffice_extensions_scripting-beanshell? ( java )
234 libreoffice_extensions_scripting-javascript? ( java )
235 libreoffice_extensions_wiki-publisher? ( java )
236 "
237
238 CHECKREQS_MEMORY="512M"
239 CHECKREQS_DISK_BUILD="6G"
240
241 pkg_pretend() {
242 local pgslot
243
244 if [[ ${MERGE_TYPE} != binary ]]; then
245 check-reqs_pkg_pretend
246
247 if [[ $(gcc-major-version) -lt 4 ]] || \
248 ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) \
249 ; then
250 eerror "Compilation with gcc older than 4.6 is not supported"
251 die "Too old gcc found."
252 fi
253 fi
254
255 # ensure pg version
256 if use postgres; then
257 pgslot=$(postgresql-config show)
258 if [[ ${pgslot//.} < 90 ]] ; then
259 eerror "PostgreSQL slot must be set to 9.0 or higher."
260 eerror " postgresql-config set 9.0"
261 die "PostgreSQL slot is not set to 9.0 or higher."
262 fi
263 fi
264 }
265
266 pkg_setup() {
267 java-pkg-opt-2_pkg_setup
268 kde4-base_pkg_setup
269 python-single-r1_pkg_setup
270
271 [[ ${MERGE_TYPE} != binary ]] && check-reqs_pkg_setup
272 }
273
274 src_unpack() {
275 local mod mod2 dest tmplfile tmplname mypv
276
277 [[ -n ${PATCHSET} ]] && unpack ${PATCHSET}
278 use branding && unpack "${BRANDING}"
279
280 if [[ ${PV} != *9999* ]]; then
281 unpack "${P}.tar.xz"
282 for mod in ${MODULES}; do
283 [[ ${mod} == core ]] && continue
284 unpack "${PN}-${mod}-${PV}.tar.xz"
285 done
286 else
287 for mod in ${MODULES}; do
288 mypv=${PV/.9999}
289 [[ ${mypv} != ${PV} ]] && EGIT_BRANCH="${PN}-${mypv/./-}"
290 EGIT_PROJECT="${PN}/${mod}"
291 EGIT_SOURCEDIR="${WORKDIR}/${P}"
292 [[ ${mod} != core ]] && EGIT_SOURCEDIR="${WORKDIR}/${PN}-${mod}-${PV}"
293 EGIT_REPO_URI="git://anongit.freedesktop.org/${PN}/${mod}"
294 EGIT_NOUNPACK="true"
295 git-2_src_unpack
296 if [[ ${mod} != core ]]; then
297 mod2=${mod}
298 # mapping does not match on help
299 [[ ${mod} == help ]] && mod2="helpcontent2"
300 mkdir -p "${S}/${mod2}/" || die
301 mv -n "${WORKDIR}/${PN}-${mod}-${PV}"/* "${S}/${mod2}" || die
302 rm -rf "${WORKDIR}/${PN}-${mod}-${PV}"
303 fi
304 done
305 unset EGIT_PROJECT EGIT_SOURCEDIR EGIT_REPO_URI EGIT_BRANCH
306 fi
307 }
308
309 src_prepare() {
310 # optimization flags
311 export ARCH_FLAGS="${CXXFLAGS}"
312 export LINKFLAGSOPTIMIZE="${LDFLAGS}"
313 export GMAKE_OPTIONS="${MAKEOPTS}"
314
315 # patchset
316 if [[ -n ${PATCHSET} ]]; then
317 EPATCH_FORCE="yes" \
318 EPATCH_SOURCE="${WORKDIR}/${PATCHSET/.tar.xz/}" \
319 EPATCH_SUFFIX="patch" \
320 epatch
321 fi
322
323 base_src_prepare
324
325 AT_M4DIR="m4"
326 eautoreconf
327 # hack in the autogen.sh
328 touch autogen.lastrun
329
330 # system pyuno mess
331 sed \
332 -e "s:%eprefix%:${EPREFIX}:g" \
333 -e "s:%libdir%:$(get_libdir):g" \
334 -i pyuno/source/module/uno.py \
335 -i scripting/source/pyprov/officehelper.py || die
336 }
337
338 src_configure() {
339 local java_opts
340 local internal_libs
341 local lo_ext
342 local ext_opts
343 local jbs=$(sed -ne 's/.*\(-j[[:space:]]*\|--jobs=\)\([[:digit:]]\+\).*/\2/;T;p' <<< "${MAKEOPTS}")
344
345 # recheck that there is some value in jobs
346 [[ -z ${jbs} ]] && jbs="1"
347
348 # sane: just sane.h header that is used for scan in writer, not
349 # linked or anything else, worthless to depend on
350 # vigra: just uses templates from there
351 # it is serious pain in the ass for packaging
352 # should be replaced by boost::gil if someone interested
353 internal_libs+="
354 --without-system-sane
355 --without-system-vigra
356 "
357
358 # libreoffice extensions handling
359 for lo_xt in ${LO_EXTS}; do
360 if [[ "${lo_xt}" == "scripting-beanshell" || "${lo_xt}" == "scripting-javascript" ]]; then
361 ext_opts+=" $(use_enable libreoffice_extensions_${lo_xt} ${lo_xt})"
362 else
363 ext_opts+=" $(use_enable libreoffice_extensions_${lo_xt} ext-${lo_xt})"
364 fi
365 done
366
367 if use java; then
368 # hsqldb: system one is too new
369 java_opts="
370 --without-junit
371 --without-system-hsqldb
372 --with-ant-home="${ANT_HOME}"
373 --with-jdk-home=$(java-config --jdk-home 2>/dev/null)
374 --with-java-target-version=$(java-pkg_get-target)
375 --with-jvm-path="${EPREFIX}/usr/$(get_libdir)/"
376 "
377
378 use libreoffice_extensions_scripting-beanshell && \
379 java_opts+=" --with-beanshell-jar=$(java-pkg_getjar bsh bsh.jar)"
380
381 use libreoffice_extensions_scripting-javascript && \
382 java_opts+=" --with-rhino-jar=$(java-pkg_getjar rhino-1.6 js.jar)"
383
384 if use libreoffice_extensions_wiki-publisher; then
385 java_opts+="
386 --with-commons-codec-jar=$(java-pkg_getjar commons-codec commons-codec.jar)
387 --with-commons-httpclient-jar=$(java-pkg_getjar commons-httpclient-3 commons-httpclient.jar)
388 --with-commons-lang-jar=$(java-pkg_getjar commons-lang-2.1 commons-lang.jar)
389 --with-commons-logging-jar=$(java-pkg_getjar commons-logging commons-logging.jar)
390 --with-servlet-api-jar=$(java-pkg_getjar tomcat-servlet-api-3.0 servlet-api.jar)
391 "
392 fi
393 fi
394
395 if use branding; then
396 # hack...
397 mv -v "${WORKDIR}/branding-intro.png" "${S}/icon-themes/galaxy/brand/intro.png" || die
398 fi
399
400 # System python 2.7 enablement:
401 export PYTHON="${PYTHON}"
402 export PYTHON_CFLAGS=`pkg-config --cflags ${EPYTHON}`
403 export PYTHON_LIBS=`pkg-config --libs ${EPYTHON}`
404
405 # system headers/libs/...: enforce using system packages
406 # --enable-unix-qstart-libpng: use libpng splashscreen that is faster
407 # --enable-cairo: ensure that cairo is always required
408 # --enable-graphite: disabling causes build breakages
409 # --enable-*-link: link to the library rather than just dlopen on runtime
410 # --enable-release-build: build the libreoffice as release
411 # --disable-fetch-external: prevent dowloading during compile phase
412 # --disable-gnome-vfs: old gnome virtual fs support
413 # --disable-kdeab: kde3 adressbook
414 # --disable-kde: kde3 support
415 # --disable-rpath: relative runtime path is not desired
416 # --disable-systray: quickstarter does not actually work at all so do not
417 # promote it
418 # --disable-zenity: disable build icon
419 # --enable-extension-integration: enable any extension integration support
420 # --without-{afms,fonts,myspell-dicts,ppsd}: prevent install of sys pkgs
421 # --disable-ext-report-builder: too much java packages pulled in
422 econf \
423 --docdir="${EPREFIX}/usr/share/doc/${PF}/" \
424 --with-system-headers \
425 --with-system-libs \
426 --with-system-jars \
427 --with-system-dicts \
428 --enable-cairo-canvas \
429 --enable-graphite \
430 --enable-largefile \
431 --enable-mergelibs \
432 --enable-python=system \
433 --enable-randr \
434 --enable-randr-link \
435 --enable-release-build \
436 --enable-unix-qstart-libpng \
437 --enable-hardlink-deliver \
438 --disable-ccache \
439 --disable-crashdump \
440 --disable-dependency-tracking \
441 --disable-epm \
442 --disable-fetch-external \
443 --disable-gnome-vfs \
444 --disable-gstreamer-0-10 \
445 --disable-ext-report-builder \
446 --disable-kdeab \
447 --disable-kde \
448 --disable-online-update \
449 --disable-rpath \
450 --disable-systray \
451 --disable-zenity \
452 --with-alloc=$(use jemalloc && echo "jemalloc" || echo "system") \
453 --with-build-version="Gentoo official package" \
454 --enable-extension-integration \
455 --with-external-dict-dir="${EPREFIX}/usr/share/myspell" \
456 --with-external-hyph-dir="${EPREFIX}/usr/share/myspell" \
457 --with-external-thes-dir="${EPREFIX}/usr/share/myspell" \
458 --with-external-tar="${DISTDIR}" \
459 --with-lang="" \
460 --with-parallelism=${jbs} \
461 --with-system-ucpp \
462 --with-unix-wrapper=libreoffice \
463 --with-vendor="Gentoo Foundation" \
464 --with-x \
465 --without-afms \
466 --without-fonts \
467 --without-myspell-dicts \
468 --without-help \
469 --with-helppack-integration \
470 --without-sun-templates \
471 $(use_enable bluetooth sdremote-bluetooth) \
472 $(use_enable cups) \
473 $(use_enable debug) \
474 $(use_enable dbus) \
475 $(use_enable eds evolution2) \
476 $(use_enable gnome gconf) \
477 $(use_enable gnome gio) \
478 $(use_enable gnome lockdown) \
479 $(use_enable gtk) \
480 $(use_enable gtk3) \
481 $(use_enable kde kde4) \
482 $(use_enable mysql ext-mysql-connector) \
483 $(use_enable odk) \
484 $(use_enable opengl) \
485 $(use_enable postgres postgresql-sdbc) \
486 $(use_enable telepathy) \
487 $(use_enable test linkoo) \
488 $(use_enable vba) \
489 $(use_enable webdav neon) \
490 $(use_with java) \
491 $(use_with mysql system-mysql-cppconn) \
492 $(use_with odk doxygen) \
493 ${internal_libs} \
494 ${java_opts} \
495 ${ext_opts}
496 }
497
498 src_compile() {
499 # hack for offlinehelp, this needs fixing upstream at some point
500 # it is broken because we send --without-help
501 # https://bugs.freedesktop.org/show_bug.cgi?id=46506
502 (
503 grep "^export" "${S}/config_host.mk" > "${T}/config_host.mk"
504 source "${T}/config_host.mk" 2&> /dev/null
505
506 local path="${SOLARVER}/${INPATH}/res/img"
507 mkdir -p "${path}" || die
508
509 echo "perl \"${S}/helpcontent2/helpers/create_ilst.pl\" -dir=icon-themes/galaxy/res/helpimg > \"${path}/helpimg.ilst\""
510 perl "${S}/helpcontent2/helpers/create_ilst.pl" \
511 -dir=icon-themes/galaxy/res/helpimg \
512 > "${path}/helpimg.ilst"
513 [[ -s "${path}/helpimg.ilst" ]] || ewarn "The help images list is empty, something is fishy, report a bug."
514 )
515
516 # this is not a proper make script
517 make build || die
518 }
519
520 src_test() {
521 make unitcheck || die
522 make slowcheck || die
523 }
524
525 src_install() {
526 # This is not Makefile so no buildserver
527 make DESTDIR="${D}" distro-pack-install -o build -o check || die
528
529 # Fix bash completion placement
530 newbashcomp "${ED}"/etc/bash_completion.d/libreoffice.sh ${PN}
531 rm -rf "${ED}"/etc/
532
533 if use branding; then
534 insinto /usr/$(get_libdir)/${PN}/program
535 newins "${WORKDIR}/branding-sofficerc" sofficerc
536 fi
537
538 # symlink the nsplugin to proper location
539 use gtk && inst_plugin /usr/$(get_libdir)/libreoffice/program/libnpsoplugin.so
540
541 # Hack for offlinehelp, this needs fixing upstream at some point.
542 # It is broken because we send --without-help
543 # https://bugs.freedesktop.org/show_bug.cgi?id=46506
544 insinto /usr/$(get_libdir)/libreoffice/help
545 doins xmlhelp/util/*.xsl
546
547 # Remove desktop files for support to old installs that can't parse mime
548 rm -rf "${ED}"/usr/share/mimelnk/
549 }
550
551 pkg_preinst() {
552 # Cache updates - all handled by kde eclass for all environments
553 kde4-base_pkg_preinst
554 }
555
556 pkg_postinst() {
557 kde4-base_pkg_postinst
558
559 pax-mark -m "${EPREFIX}"/usr/$(get_libdir)/libreoffice/program/soffice.bin
560 pax-mark -m "${EPREFIX}"/usr/$(get_libdir)/libreoffice/program/unopkg.bin
561
562 use java || \
563 ewarn 'If you plan to use lbase application you should enable java or you will get various crashes.'
564 }
565
566 pkg_postrm() {
567 kde4-base_pkg_postrm
568 }

  ViewVC Help
Powered by ViewVC 1.1.20