/[gentoo-x86]/dev-ruby/coderay/coderay-0.9.7.ebuild
Gentoo

Contents of /dev-ruby/coderay/coderay-0.9.7.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.4 - (show annotations) (download)
Thu Dec 8 19:50:44 2011 UTC (3 years ago) by flameeyes
Branch: MAIN
CVS Tags: HEAD
Changes since 1.3: +1 -1 lines
FILE REMOVED
Version bump, remove JRuby support due to the known-broken tests; drop ruby 1.9 support from coderay 0.9.8 so that we can ask stable. Replace the old syntax for ruby_add_bdepend.

(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)

1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/coderay-0.9.7.ebuild,v 1.3 2011/09/21 19:08:48 graaff Exp $
4
5 EAPI=2
6
7 USE_RUBY="ruby18 ree18 ruby19 jruby"
8
9 RUBY_FAKEGEM_TASK_DOC="doc"
10 RUBY_FAKEGEM_DOCDIR="doc"
11
12 RUBY_FAKEGEM_EXTRADOC="lib/README"
13
14 inherit ruby-fakegem
15
16 DESCRIPTION="A Ruby library for syntax highlighting."
17 HOMEPAGE="http://coderay.rubychan.de/"
18
19 LICENSE="LGPL-2.1"
20 SLOT="0"
21 KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
22 IUSE=""
23
24 # Redcloth is optional but automagically tested, so we add this
25 # dependency to ensure that we get at least a version that works: bug
26 # 330621. We use this convoluted way because redcloth isn't available
27 # yet for jruby.
28 USE_RUBY=ruby18 ruby_add_bdepend "ruby_targets_ruby18 test" ">=dev-ruby/redcloth-4.2.2"
29 USE_RUBY=ruby19 ruby_add_bdepend "ruby_targets_ruby19 test" ">=dev-ruby/redcloth-4.2.2"
30 USE_RUBY=ree18 ruby_add_bdepend "ruby_targets_ree18 test" ">=dev-ruby/redcloth-4.2.2"

  ViewVC Help
Powered by ViewVC 1.1.20