/[gentoo-x86]/dev-ruby/markaby/markaby-0.6.9-r1.ebuild
Gentoo

Contents of /dev-ruby/markaby/markaby-0.6.9-r1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.1 - (hide annotations) (download)
Sun Sep 19 06:52:31 2010 UTC (3 years, 11 months ago) by graaff
Branch: MAIN
Also install the VERSION file because markaby depends on it to know its own version.
(Portage version: 2.1.8.3/cvs/Linux x86_64)

1 graaff 1.1 # Copyright 1999-2010 Gentoo Foundation
2     # Distributed under the terms of the GNU General Public License v2
3     # $Header: /var/cvsroot/gentoo-x86/dev-ruby/markaby/markaby-0.6.9.ebuild,v 1.1 2010/08/05 05:55:58 graaff Exp $
4    
5     EAPI=2
6     USE_RUBY="ruby18"
7    
8     RUBY_FAKEGEM_TASK_DOC=""
9     RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
10    
11     RUBY_FAKEGEM_TASK_TEST="spec"
12    
13     RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
14    
15     inherit ruby-fakegem
16    
17     DESCRIPTION="A templating language for Ruby to write HTML templates in pre Ruby"
18     HOMEPAGE="http://rubyforge.org/projects/markaby/"
19    
20     LICENSE="MIT"
21     SLOT="0"
22     KEYWORDS="~amd64 ~ia64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
23     IUSE=""
24    
25     ruby_add_bdepend "test? ( virtual/ruby-test-unit dev-ruby/rspec )"
26     ruby_add_rdepend ">=dev-ruby/builder-2.0.0"
27    
28     all_ruby_prepare() {
29     # Remove specs for dependencies that we do not yet support
30     rm -rf spec/markaby/tilt* || die "Unable to remove specs for unsupported dependencies."
31     }

  ViewVC Help
Powered by ViewVC 1.1.20