/[gentoo-x86]/dev-ruby/rails/ChangeLog
Gentoo

Contents of /dev-ruby/rails/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.174 - (hide annotations) (download)
Sun May 23 11:03:14 2010 UTC (4 years, 4 months ago) by a3li
Branch: MAIN
Changes since 1.173: +6 -1 lines
Add REE18 support
(Portage version: 2.2_rc67/cvs/Linux x86_64)

1 pythonhead 1.1 # ChangeLog for dev-ruby/rails
2 flameeyes 1.166 # Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
3 a3li 1.174 # $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.173 2010/05/22 14:36:13 flameeyes Exp $
4    
5     *rails-2.3.5-r3 (23 May 2010)
6    
7     23 May 2010; Alex Legler <a3li@gentoo.org> +rails-2.3.5-r3.ebuild:
8     Add REE18 support
9 flameeyes 1.173
10     22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org> rails-2.3.5.ebuild,
11     -rails-2.3.5-r1.ebuild, rails-2.3.5-r2.ebuild:
12     Cleanup old versions, use new syntax.
13 abcd 1.172
14     21 Feb 2010; Jonathan Callen <abcd@gentoo.org> rails-2.3.5-r2.ebuild:
15     Transfer prefix keywords (no other changes)
16 graaff 1.171
17     *rails-2.3.5-r2 (17 Feb 2010)
18    
19     17 Feb 2010; Hans de Graaff <graaff@gentoo.org> +rails-2.3.5-r2.ebuild:
20     Install more files so that creating a new project works again, fixing
21     #303581.
22 armin76 1.170
23     13 Feb 2010; Raúl Porcel <armin76@gentoo.org> rails-2.3.5-r1.ebuild:
24     Add ~ia64/~sparc
25 maekke 1.169
26     01 Feb 2010; Markus Meier <maekke@gentoo.org> rails-2.3.5-r1.ebuild:
27     add ~x86, bug #301007
28 ranger 1.168
29     18 Jan 2010; Brent Baude <ranger@gentoo.org> rails-2.3.5-r1.ebuild:
30     Marking rails-2.3.5-r1 ~ppc64 for bug 301007
31 ranger 1.167
32     18 Jan 2010; Brent Baude <ranger@gentoo.org> rails-2.3.5-r1.ebuild:
33     Marking rails-2.3.5-r1 ~ppc for bug 301007
34 flameeyes 1.166
35     *rails-2.3.5-r1 (14 Jan 2010)
36    
37     14 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
38     +rails-2.3.5-r1.ebuild:
39     Bump to ruby-fakegem. Tests cannot be executed because upstream does not
40     package them.
41 a3li 1.165
42     20 Dec 2009; Alex Legler <a3li@gentoo.org> -rails-2.2.3.ebuild,
43     -rails-2.3.4.ebuild:
44     Removing vulnerable versions
45 jer 1.164
46     19 Dec 2009; Jeroen Roovers <jer@gentoo.org> rails-2.2.3-r1.ebuild,
47     rails-2.3.5.ebuild:
48     Stable for PPC (bug #294797).
49 armin76 1.163
50     30 Nov 2009; Raúl Porcel <armin76@gentoo.org> rails-2.2.3-r1.ebuild,
51     rails-2.3.5.ebuild:
52     ia64/sparc stable wrt #294797
53 ranger 1.162
54     30 Nov 2009; Brent Baude <ranger@gentoo.org> rails-2.2.3-r1.ebuild,
55     rails-2.3.5.ebuild:
56     Marking rails-2.3.5 ppc64 stable for bug 294797
57 maekke 1.161
58     30 Nov 2009; Markus Meier <maekke@gentoo.org> rails-2.3.5.ebuild:
59     amd64/x86 stable, bug #294797
60 maekke 1.160
61     30 Nov 2009; Markus Meier <maekke@gentoo.org> rails-2.2.3-r1.ebuild:
62     amd64/x86 stable, bug #294797
63 a3li 1.159
64     *rails-2.2.3-r1 (28 Nov 2009)
65    
66     28 Nov 2009; Alex Legler <a3li@gentoo.org> +rails-2.2.3-r1.ebuild:
67     Revision bump, security bug 294797.
68 a3li 1.158
69     *rails-2.3.5 (28 Nov 2009)
70    
71     28 Nov 2009; Alex Legler <a3li@gentoo.org> +rails-2.3.5.ebuild:
72     Version bump, security bug 294797
73 a3li 1.157
74     22 Oct 2009; Alex Legler <a3li@gentoo.org> -rails-1.2.6-r1.ebuild,
75     -rails-2.0.5-r1.ebuild, -rails-2.1.2-r1.ebuild:
76     Removing three old versions
77 a3li 1.156
78     18 Oct 2009; Alex Legler <a3li@gentoo.org> -rails-2.2.2-r1.ebuild:
79     removing vulnerable ebuild, bug 283396
80 nixnut 1.155
81     18 Oct 2009; nixnut <nixnut@gentoo.org> rails-2.2.3.ebuild:
82     ppc stable #283396
83 ranger 1.154
84     18 Oct 2009; Brent Baude <ranger@gentoo.org> rails-2.2.3.ebuild:
85     Marking rails-2.2.3 ppc64 stable for bug 283396
86 armin76 1.153
87     08 Oct 2009; Raúl Porcel <armin76@gentoo.org> rails-2.2.3.ebuild:
88     ia64/sparc stable wrt #283396
89 maekke 1.152
90     07 Oct 2009; Markus Meier <maekke@gentoo.org> rails-2.2.3.ebuild:
91     amd64 stable, bug #283396
92 fauli 1.151
93     04 Oct 2009; Christian Faulhammer <fauli@gentoo.org> rails-2.2.3.ebuild:
94     stable x86, bug 283396
95 a3li 1.150
96     *rails-2.2.3 (03 Oct 2009)
97    
98     03 Oct 2009; Alex Legler <a3li@gentoo.org> +rails-2.2.3.ebuild:
99     Version bump, security bug 283396
100 graaff 1.149
101     26 Sep 2009; Hans de Graaff <graaff@gentoo.org> -rails-2.3.2.ebuild,
102     -rails-2.3.3.ebuild:
103     Remove insecure versions, bug 283396.
104    
105     26 Sep 2009; Hans de Graaff <graaff@gentoo.org> ChangeLog:
106     Remove insecure versions, bug 283396.
107 ranger 1.148
108     25 Sep 2009; Brent Baude <ranger@gentoo.org> rails-2.3.4.ebuild:
109     Marking rails-2.3.4 ppc64 stable for bug 283396
110 nixnut 1.147
111     20 Sep 2009; nixnut <nixnut@gentoo.org> rails-2.3.4.ebuild:
112     ppc stable #283396
113 armin76 1.146
114     19 Sep 2009; Raúl Porcel <armin76@gentoo.org> rails-2.3.4.ebuild:
115     ia64/sparc stable wrt #283396
116 maekke 1.145
117     14 Sep 2009; Markus Meier <maekke@gentoo.org> rails-2.3.4.ebuild:
118     amd64/x86 stable, bug #283396
119 flameeyes 1.144
120     14 Sep 2009; Diego E. Pettenò <flameeyes@gentoo.org> rails-2.3.4.ebuild:
121     Bump rubygems requirement to 1.3.2.
122 graaff 1.143
123     *rails-2.3.4 (04 Sep 2009)
124    
125     04 Sep 2009; Hans de Graaff <graaff@gentoo.org> +rails-2.3.4.ebuild:
126     Version bump: fix security issues reported in #283396.
127 armin76 1.142
128     16 Aug 2009; Raúl Porcel <armin76@gentoo.org> rails-2.3.3.ebuild:
129     Add ~ia64 wrt #279123
130 graaff 1.141
131     26 Jul 2009; Hans de Graaff <graaff@gentoo.org> rails-2.3.3.ebuild:
132     Drop ia64 keyword #279123.
133 graaff 1.140
134     *rails-2.3.3 (22 Jul 2009)
135    
136     22 Jul 2009; Hans de Graaff <graaff@gentoo.org> +rails-2.3.3.ebuild:
137     Version bump for Rails 2.3.3.
138 armin76 1.139
139     28 May 2009; Raúl Porcel <armin76@gentoo.org> rails-2.3.2.ebuild:
140     ia64 stable wrt #270331
141 maekke 1.137
142     24 May 2009; Markus Meier <maekke@gentoo.org> rails-2.3.2.ebuild:
143     x86 stable, bug #270331
144 gentoofan23 1.136
145     23 May 2009; Thomas Anderson <gentoofan23@gentoo.org> rails-2.3.2.ebuild:
146     stable amd64, bug 270331
147 ranger 1.135
148     23 May 2009; Brent Baude <ranger@gentoo.org> rails-2.3.2.ebuild:
149     Marking rails-2.3.2 ppc64 stable for bug 270331
150 ranger 1.134
151     23 May 2009; Brent Baude <ranger@gentoo.org> rails-2.3.2.ebuild:
152     Marking rails-2.3.2 ppc stable for bug 270331
153 fmccor 1.133
154     18 May 2009; Ferris McCormick <fmccor@gentoo.org> rails-2.3.2.ebuild:
155     Sparc stable, Bug #270331.
156 a3li 1.132
157 graaff 1.138 18 May 2009; Hans de Graaff <graaff@gentoo.org> -rails-1.2.6.ebuild,
158     -rails-2.0.5.ebuild, -rails-2.1.2.ebuild, -rails-2.2.2.ebuild:
159     Remove old and vulnerable versions.
160    
161 a3li 1.132 *rails-2.3.2 (17 Mar 2009)
162    
163     17 Mar 2009; Alex Legler <a3li@gentoo.org> +rails-2.3.2.ebuild:
164     Version bump
165 armin76 1.131
166     10 Jan 2009; Raúl Porcel <armin76@gentoo.org> rails-1.2.6-r1.ebuild,
167     rails-2.1.2-r1.ebuild, rails-2.2.2-r1.ebuild:
168     ia64 stable wrt #253425
169 ranger 1.130
170     09 Jan 2009; Brent Baude <ranger@gentoo.org> rails-1.2.6-r1.ebuild,
171     rails-2.0.5-r1.ebuild, rails-2.1.2-r1.ebuild, rails-2.2.2-r1.ebuild:
172     rails-1.2.6-r1 rails-2.0.5-r1 rails-2.1.2-r1 rails-2.2.2-r1 ppc stable for
173     bug 253425
174 fmccor 1.129
175     07 Jan 2009; Ferris McCormick <fmccor@gentoo.org> rails-2.2.2-r1.ebuild:
176     Sparc stable, Bug #253425.
177 fmccor 1.128
178     07 Jan 2009; Ferris McCormick <fmccor@gentoo.org> rails-1.2.6-r1.ebuild,
179     rails-2.0.5-r1.ebuild, rails-2.1.2-r1.ebuild:
180     Sparc stable, part of Bug #253425.
181 ranger 1.127
182     07 Jan 2009; Brent Baude <ranger@gentoo.org> rails-1.2.6-r1.ebuild,
183     rails-2.0.5-r1.ebuild, rails-2.1.2-r1.ebuild, rails-2.2.2-r1.ebuild:
184     rails-1.2.6-r1 rails-2.0.5-r1 rails-2.1.2-r1 rails-2.2.2-r1 ppc64 stable
185 maekke 1.126
186     04 Jan 2009; Markus Meier <maekke@gentoo.org> rails-1.2.6-r1.ebuild,
187     rails-2.0.5-r1.ebuild, rails-2.1.2-r1.ebuild, rails-2.2.2-r1.ebuild:
188     amd64/x86 stable, bug #253425
189 graaff 1.125
190     08 Dec 2008; Hans de Graaff <graaff@gentoo.org> rails-2.2.2-r1.ebuild:
191     Add missing RDEPEND on >=rubygems-1.3.1 as per #250245.
192 graaff 1.124
193     03 Dec 2008; Hans de Graaff <graaff@gentoo.org> rails-1.2.6-r1.ebuild:
194     Fix quoting.
195 graaff 1.123
196     *rails-2.2.2-r1 (03 Dec 2008)
197     *rails-2.1.2-r1 (03 Dec 2008)
198     *rails-2.0.5-r1 (03 Dec 2008)
199     *rails-1.2.6-r1 (03 Dec 2008)
200    
201     03 Dec 2008; Hans de Graaff <graaff@gentoo.org> +rails-1.2.6-r1.ebuild,
202     +rails-2.0.5-r1.ebuild, +rails-2.1.2-r1.ebuild, +rails-2.2.2-r1.ebuild:
203     Make sure /usr/bin/rails loads the correct version of rails. Depend on and use
204     select-rails-0.14 to simplify the rails update process. Fixes #221899. Thanks
205     to Mark Somerville for initial patches and Alex Legler for getting it ready
206     for the tree and testing.
207 graaff 1.122
208     *rails-2.2.2 (27 Nov 2008)
209    
210     27 Nov 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.2.2.ebuild:
211     Version bump for Rails 2.2.2
212 graaff 1.121
213     17 Nov 2008; Hans de Graaff <graaff@gentoo.org> -rails-2.0.2.ebuild,
214     -rails-2.0.4.ebuild, -rails-2.1.0.ebuild, -rails-2.1.1.ebuild:
215     Remove old, insecure, versions
216 dertobi123 1.120
217     15 Nov 2008; Tobias Scherbaum <dertobi123@gentoo.org> rails-2.0.5.ebuild,
218     rails-2.1.2.ebuild:
219     ppc stable, bug #237385
220 armin76 1.119
221     06 Nov 2008; Raúl Porcel <armin76@gentoo.org> rails-2.1.2.ebuild:
222     ia64 stable wrt #237385
223 maekke 1.118
224     05 Nov 2008; Markus Meier <maekke@gentoo.org> rails-2.0.5.ebuild:
225     amd64/x86 stable, bug #237385
226 ranger 1.117
227     04 Nov 2008; Brent Baude <ranger@gentoo.org> rails-2.0.5.ebuild,
228     rails-2.1.2.ebuild:
229     Marking rails-2.0.5|2.1.2 ppc64 for bug 237385
230 maekke 1.116
231     03 Nov 2008; Markus Meier <maekke@gentoo.org> rails-2.1.2.ebuild:
232     amd64/x86 stable, bug #237385
233 fmccor 1.115
234     03 Nov 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.5.ebuild,
235     rails-2.1.2.ebuild:
236     Sparc stable, Security Bug #237385.
237 graaff 1.114
238     *rails-2.1.2 (24 Oct 2008)
239    
240     24 Oct 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.2.ebuild:
241     Version bump. Fixes security issue #242914 (header-injection) and #237285.
242     Also features minor fixes.
243 graaff 1.113
244     *rails-2.0.5 (20 Oct 2008)
245    
246     20 Oct 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.0.5.ebuild:
247     Version bump for Rails 2.0.5
248 graaff 1.112
249     *rails-2.1.1 (13 Sep 2008)
250    
251     13 Sep 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.1.ebuild:
252     Version bump for Rails 2.1.1, bug #237392
253 graaff 1.111
254     *rails-2.0.4 (12 Sep 2008)
255    
256     12 Sep 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.0.4.ebuild:
257     Version bump for Rails 2.0.4, bug #237385
258 graaff 1.110
259     13 Jul 2008; Hans de Graaff <graaff@gentoo.org>
260     -files/1.1.6-deprecate-old-lighttpd.patch, -rails-1.1.6.ebuild,
261     -rails-1.1.6-r2.ebuild:
262     Belated removal for GLSA 200711-17
263 graaff 1.109
264     04 Jul 2008; Hans de Graaff <graaff@gentoo.org> rails-2.1.0.ebuild:
265     Rails now depends on rake 0.8.1 or better.
266 graaff 1.108
267     17 Jun 2008; Hans de Graaff <graaff@gentoo.org> -rails-1.2.5.ebuild:
268     Remove old version
269 graaff 1.107
270     *rails-2.1.0 (17 Jun 2008)
271    
272     17 Jun 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.0.ebuild:
273     Version bump for Rails 2.1.0
274 nixnut 1.106
275     16 May 2008; nixnut <nixnut@gentoo.org> rails-2.0.2.ebuild:
276     Stable on ppc wrt bug 221309
277 armin76 1.105
278     13 May 2008; Raúl Porcel <armin76@gentoo.org> rails-2.0.2.ebuild:
279     ia64 stable wrt #221309
280 fmccor 1.104
281     13 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
282     Sparc stable (again), following Hans de Graff's comment 7 in Bug #221309.
283     RMD160 for rails-2.0.2.gem should now be correct.
284 corsair 1.103
285     12 May 2008; Markus Rothe <corsair@gentoo.org> rails-2.0.2.ebuild:
286     Stable on ppc64; bug #221309
287 fmccor 1.102
288     11 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
289     Back to ~sparc because of Friedrich Oslage's comments in Bug #221309.
290 fmccor 1.101
291     11 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
292     Sparc stable --- part of Bug #221309 --- Good for about 5 months.
293 maekke 1.100
294     11 May 2008; Markus Meier <maekke@gentoo.org> rails-2.0.2.ebuild:
295     x86 stable, bug #221309
296 graaff 1.99
297     11 May 2008; Hans de Graaff <graaff@gentoo.org> rails-2.0.2.ebuild:
298     Stable on amd64, bug #221309
299 graaff 1.98
300     19 Mar 2008; Hans de Graaff <graaff@gentoo.org> Manifest:
301     Redigest due to upstream repackaging
302 nichoj 1.97
303     04 Jan 2008; <nichoj@gentoo.org> ChangeLog:
304     Updated dependencies not to relay on specific version, and allowing for
305     later revisions (ie change =dev-ruby/activerecord-2.0.2 to
306     ~dev-ruby/activerecord-2.0.2.
307 graaff 1.96
308     18 Dec 2007; Hans de Graaff <graaff@gentoo.org> rails-2.0.2.ebuild:
309     Fix quoting; database USE flags have moved to dev-ruby/activerecord, make this
310     a warn instead of an info message.
311 graaff 1.95
312     *rails-2.0.2 (18 Dec 2007)
313    
314     18 Dec 2007; Hans de Graaff <graaff@gentoo.org> +rails-2.0.2.ebuild:
315     Version bump for Rails 2.0.2
316 angelos 1.94
317     01 Dec 2007; Christoph Mende <angelos@gentoo.org> rails-1.2.6.ebuild:
318     Stable on amd64 wrt bug #200159
319 graaff 1.93
320     01 Dec 2007; Hans de Graaff <graaff@gentoo.org> -rails-1.2.3.ebuild,
321     -rails-1.2.3-r1.ebuild, -rails-1.2.4.ebuild:
322     Remove old vulnerable versions
323 corsair 1.92
324     27 Nov 2007; Markus Rothe <corsair@gentoo.org> rails-1.2.6.ebuild:
325     Added ~ppc64; bug #200159
326 armin76 1.91
327     27 Nov 2007; Raúl Porcel <armin76@gentoo.org> rails-1.2.6.ebuild:
328     ia64/sparc stable wrt security #200159
329 ranger 1.90
330     26 Nov 2007; Brent Baude <ranger@gentoo.org> rails-1.2.6.ebuild:
331     Marking rails-1.2.6 ppc for bug 200159
332 opfer 1.89
333     26 Nov 2007; Christian Faulhammer <opfer@gentoo.org> rails-1.2.6.ebuild:
334     stable x86, security bug 200159
335 graaff 1.88
336     *rails-1.2.6 (25 Nov 2007)
337    
338     25 Nov 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.6.ebuild:
339     Version bump for Rails 1.2.6, security bug #200159
340 beandog 1.87
341     21 Oct 2007; Steve Dibb <beandog@gentoo.org> rails-1.2.5.ebuild:
342     amd64 stable, security bug 195315
343 dertobi123 1.86
344     18 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org> rails-1.2.5.ebuild:
345     ppc stable, bug #195315
346 armin76 1.85
347     16 Oct 2007; Raúl Porcel <armin76@gentoo.org> rails-1.2.5.ebuild:
348     ia64/sparc stable wrt security #195315
349 graaff 1.84
350     16 Oct 2007; Hans de Graaff <graaff@gentoo.org> rails-1.2.5.ebuild:
351     Add back the dependency on eselect-rails that got dropped somehow after
352     rails-1.2.3-r1
353 opfer 1.83
354     16 Oct 2007; Christian Faulhammer <opfer@gentoo.org> rails-1.2.5.ebuild:
355     stable x86, security bug 195315
356 graaff 1.82
357     *rails-1.2.5 (13 Oct 2007)
358    
359     13 Oct 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.5.ebuild:
360     Version bump with security fixes, bug 195315
361 graaff 1.81
362     07 Oct 2007; Hans de Graaff <graaff@gentoo.org> rails-1.2.4.ebuild:
363     Add back the code that handles eselect, I must have used the wrong file to
364     start from :-(
365 opfer 1.80
366     06 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
367     rails-1.2.3-r1.ebuild:
368     stable x86, bug 177209
369 graaff 1.79
370     *rails-1.2.4 (06 Oct 2007)
371    
372     06 Oct 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.4.ebuild:
373     Version bump for rails 1.2.4
374 graaff 1.78
375     06 Oct 2007; Hans de Graaff <graaff@gentoo.org>
376     -files/rails-1.0.0-rdoc-rake-0.7.patch, -rails-1.1.6-r1.ebuild,
377     -rails-1.2.0.ebuild, -rails-1.2.1.ebuild, -rails-1.2.2.ebuild:
378     Remove versions that are old or won't become stable
379 dertobi123 1.77
380     06 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
381     rails-1.2.3-r1.ebuild:
382     ppc stable, bug #177209
383 fmccor 1.76
384     05 Oct 2007; Ferris McCormick <fmccor@gentoo.org> rails-1.2.3-r1.ebuild:
385     Sparc stable --- Bug #177209
386 nichoj 1.75
387     03 Sep 2007; Joshua Nichols <nichoj@gentoo.org> rails-1.1.6.ebuild,
388     rails-1.1.6-r1.ebuild, rails-1.1.6-r2.ebuild, rails-1.2.0.ebuild,
389     rails-1.2.1.ebuild, rails-1.2.2.ebuild, rails-1.2.3.ebuild,
390     rails-1.2.3-r1.ebuild:
391     Changed eselect-rails from PDEPEND to DEPEND. Moved blockers from
392     eselect-rails to here. Should address bug #172812.
393 nichoj 1.74
394     *rails-1.2.3-r1 (01 Sep 2007)
395     *rails-1.1.6-r2 (01 Sep 2007)
396    
397     01 Sep 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.1.6-r2.ebuild,
398     +rails-1.2.3-r1.ebuild:
399     Revision bumps for both slots. No longer installs /usr/bin/rails. Instead,
400     uses app-admin/eselect-rails to manage the symlink.
401 rbrown 1.73
402     14 Mar 2007; Richard Brown <rbrown@gentoo.org> rails-1.2.3.ebuild:
403     Fix rails-1.2.3 rake dependency
404 nichoj 1.72
405     *rails-1.2.3 (14 Mar 2007)
406    
407     14 Mar 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.2.3.ebuild:
408     Version bump for rails 1.2.3.
409 nichoj 1.71
410     *rails-1.2.2 (11 Feb 2007)
411    
412     11 Feb 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.2.2.ebuild:
413     Version bump.
414 pclouds 1.70
415     10 Feb 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
416     rails-1.1.6.ebuild, rails-1.1.6-r1.ebuild, rails-1.2.0.ebuild,
417     rails-1.2.1.ebuild:
418     Updated rails license to MIT, #165876
419 pclouds 1.69
420     *rails-1.2.1 (21 Jan 2007)
421    
422     21 Jan 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
423     -rails-1.2.0_rc1.ebuild, +rails-1.2.1.ebuild:
424     1.2.1 in, 1.2.0_rc1 out
425 caleb 1.68
426     *rails-1.2.0 (19 Jan 2007)
427    
428     19 Jan 2007; Caleb Tennis <caleb@gentoo.org> +rails-1.2.0.ebuild:
429     rails 1.2.0
430 caleb 1.67
431     *rails-1.2.0_rc1 (24 Nov 2006)
432    
433     24 Nov 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.2.0_rc1.ebuild:
434     1.2.0_rc1
435 pclouds 1.66
436     *rails-1.1.6-r1 (03 Oct 2006)
437    
438     03 Oct 2006; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
439     +files/1.1.6-deprecate-old-lighttpd.patch, -rails-1.1.2.ebuild,
440     -rails-1.1.3.ebuild, -rails-1.1.4.ebuild, -rails-1.1.5.ebuild,
441     +rails-1.1.6-r1.ebuild:
442     Removed old ebuilds. Added 1.1.6-r1 to ignore lighttpd older than 1.4.10
443     (bug #133500)
444 kloeri 1.65
445     02 Sep 2006; Bryan Østergaard <kloeri@gentoo.org> rails-1.1.6.ebuild:
446     Stable on ia64.
447 caleb 1.64
448     *rails-1.1.6 (10 Aug 2006)
449    
450     10 Aug 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.6.ebuild:
451     version bump
452 fmccor 1.63
453     10 Aug 2006; Ferris McCormick <fmccor@gentoo.org> rails-1.1.5.ebuild:
454     Stable on sparc --- Bug #143369 (mandatory security upgrade) --- installs and
455     works.
456 tsunam 1.62
457     10 Aug 2006; Joshua Jackson <tsunam@gentoo.org> rails-1.1.5.ebuild:
458     Stable x86; bug # 143369
459 tcort 1.61
460     09 Aug 2006; Thomas Cort <tcort@gentoo.org> rails-1.1.5.ebuild:
461     Stable on amd64 wrt security Bug #143369.
462 dertobi123 1.60
463     09 Aug 2006; Tobias Scherbaum <dertobi123@gentoo.org> rails-1.1.5.ebuild:
464     ppc stable, bug #143369
465 caleb 1.59
466     *rails-1.1.5 (09 Aug 2006)
467    
468     09 Aug 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.5.ebuild:
469     version bump
470 blubb 1.58
471     31 Jul 2006; Simon Stelling <blubb@gentoo.org> rails-1.1.4.ebuild:
472     stable on amd64 wrt bug 138323
473 agriffis 1.57
474     13 Jul 2006; Aron Griffis <agriffis@gentoo.org> rails-1.1.4.ebuild:
475     Mark 1.1.4 stable on ia64. #138323
476 weeve 1.56
477     06 Jul 2006; Jason Wever <weeve@gentoo.org> rails-1.1.4.ebuild:
478     Stable on SPARC wrt security bug #138323.
479 tsunam 1.55
480     05 Jul 2006; Joshua Jackson <tsunam@gentoo.org> rails-1.1.4.ebuild:
481     Stable x86; bug #138323
482 pylon 1.54
483     03 Jul 2006; Lars Weiler <pylon@gentoo.org> rails-1.1.4.ebuild:
484     Stable on ppc; security bug #138323.
485 caleb 1.53
486     *rails-1.1.4 (03 Jul 2006)
487    
488     03 Jul 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.4.ebuild:
489     Version bump
490 caleb 1.52
491     *rails-1.1.3 (28 Jun 2006)
492    
493     28 Jun 2006; Caleb Tennis <caleb@gentoo.org> -rails-1.0.0.ebuild,
494     -rails-1.1.0.ebuild, -rails-1.1.1.ebuild, +rails-1.1.3.ebuild:
495     version bump, remove old versions
496 dertobi123 1.51
497     25 Jun 2006; Tobias Scherbaum <dertobi123@gentoo.org> rails-1.1.2.ebuild:
498     ppc stable, bug #133003
499 robbat2 1.50
500     14 Jun 2006; Robin H. Johnson <robbat2@gentoo.org> rails-1.1.2.ebuild:
501     Somebody left out ppc. It works fine here.
502 blubb 1.49
503     06 Jun 2006; Simon Stelling <blubb@gentoo.org> rails-1.1.2.ebuild:
504     stable on amd64
505 flameeyes 1.48
506     02 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
507     +files/rails-1.0.0-rdoc-rake-0.7.patch, rails-1.0.0.ebuild:
508     Add patch to fix rdoc call with rake 0.7. Thanks to Stephen Tallowitz in bug
509     #132692.
510 tsunam 1.47
511     16 May 2006; Joshua Jackson <tsunam@gentoo.org> rails-1.1.2.ebuild:
512     x86 stable; bug #133003
513 fmccor 1.46
514     11 May 2006; Ferris McCormick <fmccor@gentoo.org> rails-1.1.2.ebuild:
515     Stable on sparc (Bug #133003).
516 seemant 1.45
517     08 May 2006; Seemant Kulleen <seemant@gentoo.org> rails-1.1.2.ebuild:
518     keyworded for ~amd64
519 marienz 1.44
520     27 Apr 2006; Marien Zwart <marienz@gentoo.org> files/digest-rails-1.0.0,
521     files/digest-rails-1.1.0, files/digest-rails-1.1.1, Manifest:
522     Fixing SHA256 digest, pass four
523 flameeyes 1.43
524     17 Apr 2006; Diego Pettenò <flameeyes@gentoo.org> rails-1.1.2.ebuild:
525     Add ~x86-fbsd keyword.
526 caleb 1.42
527     *rails-1.1.2 (14 Apr 2006)
528    
529     14 Apr 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.2.ebuild:
530     Version bump
531 caleb 1.41
532     08 Apr 2006; Caleb Tennis <caleb@gentoo.org> rails-1.1.1.ebuild:
533     make it dep on rake 0.7.1
534 caleb 1.40
535     *rails-1.1.1 (06 Apr 2006)
536    
537     06 Apr 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.1.ebuild:
538     version bump
539 caleb 1.39
540     31 Mar 2006; Caleb Tennis <caleb@gentoo.org> rails-1.0.0.ebuild:
541     Fix deps to lock rails 1.0 components together
542 agriffis 1.38
543     30 Mar 2006; Aron Griffis <agriffis@gentoo.org> rails-1.1.0.ebuild:
544     Mark 1.1.0 ~ia64
545 caleb 1.37
546     *rails-1.1.0 (28 Mar 2006)
547    
548     28 Mar 2006; Caleb Tennis <caleb@gentoo.org> -rails-1.0.0.4008.ebuild,
549     +rails-1.1.0.ebuild:
550     Rails 1.1
551 caleb 1.36
552     *rails-1.0.0.4008 (22 Mar 2006)
553    
554     22 Mar 2006; Caleb Tennis <caleb@gentoo.org> -rails-0.13.1.ebuild,
555     +rails-1.0.0.4008.ebuild:
556     New 1.1 release candidate, slotted to install alongside existing rails
557 hansmi 1.35
558     27 Jan 2006; Michael Hanselmann <hansmi@gentoo.org> rails-1.0.0.ebuild:
559     Stable on ppc.
560 fmccor 1.34
561     10 Jan 2006; Ferris McCormick <fmccor@gentoo.org> rails-1.0.0.ebuild:
562     Stable on sparc (at gustavoz's request); works as it should for me.
563 caleb 1.33
564     02 Jan 2006; Caleb Tennis <caleb@gentoo.org> rails-1.0.0.ebuild:
565     x86 stable
566 dang 1.32
567     20 Dec 2005; <dang@gentoo.org> rails-1.0.0.ebuild:
568     Marked ~amd64 Per bug#115774
569 caleb 1.31
570     *rails-1.0.0 (13 Dec 2005)
571    
572     13 Dec 2005; Caleb Tennis <caleb@gentoo.org> -rails-0.14.4.ebuild,
573     +rails-1.0.0.ebuild:
574     Version bump
575 caleb 1.30
576     *rails-0.14.4 (08 Dec 2005)
577    
578     08 Dec 2005; Caleb Tennis <caleb@gentoo.org> -rails-0.14.3.ebuild,
579     +rails-0.14.4.ebuild:
580     Version bump
581 weeve 1.29
582     13 Nov 2005; Jason Wever <weeve@gentoo.org> rails-0.13.1.ebuild:
583     Stable on SPARC.
584 caleb 1.28
585     *rails-0.14.3 (08 Nov 2005)
586    
587     08 Nov 2005; Caleb Tennis <caleb@gentoo.org> -rails-0.14.2.ebuild,
588     +rails-0.14.3.ebuild:
589     version bump
590 caleb 1.27
591     *rails-0.14.2 (04 Nov 2005)
592    
593     04 Nov 2005; Caleb Tennis <caleb@gentoo.org> -rails-0.14.1.ebuild,
594     +rails-0.14.2.ebuild:
595     bump and remove previous version
596 caleb 1.26
597     01 Nov 2005; Caleb Tennis <caleb@gentoo.org> rails-0.14.1.ebuild:
598     Requires rake-0.6.2
599 lu_zero 1.25
600     19 Oct 2005; Luca Barbato <lu_zero@gentoo.org> rails-0.13.1.ebuild:
601     Marked ppc
602 caleb 1.24
603     *rails-0.14.1 (19 Oct 2005)
604    
605     19 Oct 2005; Caleb Tennis <caleb@gentoo.org> +rails-0.14.1.ebuild:
606     Version bump
607 caleb 1.23
608     23 Sep 2005; Caleb Tennis <caleb@gentoo.org> -rails-0.9.5.ebuild,
609     -rails-0.10.0-r1.ebuild, -rails-0.10.1.ebuild, -rails-0.11.0-r1.ebuild,
610     -rails-0.11.1-r1.ebuild, -rails-0.12.1.ebuild:
611     Remove old versions
612 fmccor 1.22
613     01 Aug 2005; Ferris McCormick <fmccor@gentoo.org> rails-0.13.1.ebuild:
614     Add ~sparc keyword. Builds and appears to run without problems.
615 caleb 1.21
616     27 Jul 2005; Caleb Tennis <caleb@gentoo.org> rails-0.13.1.ebuild:
617     x86 stable
618 caleb 1.20
619     *rails-0.13.1 (12 Jul 2005)
620    
621     12 Jul 2005; Caleb Tennis <caleb@gentoo.org> +rails-0.13.1.ebuild:
622     Version bump
623 dholm 1.19
624     12 Jul 2005; David Holm <dholm@gentoo.org> rails-0.12.1.ebuild:
625     Added to ~ppc.
626 pythonhead 1.18
627     *rails-0.12.1 (20 Apr 2005)
628    
629     20 Apr 2005; Rob Cakebread <pythonhead@gentoo.org> -rails-0.12.0.ebuild,
630     +rails-0.12.1.ebuild:
631     Version bump removed bad version.
632 caleb 1.17
633     19 Apr 2005; Caleb Tennis <caleb@gentoo.org> rails-0.12.0.ebuild:
634     This version of rails seems to require rake 0.5.3
635 pythonhead 1.16
636     19 Apr 2005; Rob Cakebread <pythonhead@gentoo.org> rails-0.12.0.ebuild:
637     Removed obsolete postinst_info
638 pythonhead 1.15
639     *rails-0.12.0 (19 Apr 2005)
640    
641     19 Apr 2005; Rob Cakebread <pythonhead@gentoo.org> +rails-0.12.0.ebuild:
642     Version bump.
643 caleb 1.14
644     01 Apr 2005; Caleb Tennis <caleb@gentoo.org> rails-0.11.1-r1.ebuild:
645     x86 stable
646 caleb 1.13
647     30 Mar 2005; Caleb Tennis <caleb@gentoo.org> rails-0.11.1-r1.ebuild:
648     This version of rails requires rake 0.5.0
649 pythonhead 1.12
650     *rails-0.11.1-r1 (29 Mar 2005)
651    
652     29 Mar 2005; Rob Cakebread <pythonhead@gentoo.org> -rails-0.11.1.ebuild,
653     +rails-0.11.1-r1.ebuild:
654     Fixed rubyforge gem url.
655 pythonhead 1.11
656     *rails-0.11.1 (28 Mar 2005)
657    
658     28 Mar 2005; Rob Cakebread <pythonhead@gentoo.org> +rails-0.11.1.ebuild:
659     Version bump.
660 pythonhead 1.10
661     26 Mar 2005; Rob Cakebread <pythonhead@gentoo.org> rails-0.11.0-r1.ebuild:
662     Added fastcgi support/USE flag
663 pythonhead 1.8
664     25 Mar 2005; Rob Cakebread <pythonhead@gentoo.org>
665 pythonhead 1.9 +files/rails-0.11.0-dispatch.fcgi.diff, +rails-0.11.0-r1.ebuild:
666 pythonhead 1.8 Patched borken dispatch.fcgi, added some helpful einfo about upgrading from
667 pythonhead 1.9 0.10. Removed 0.11.0
668 caleb 1.7
669     *rails-0.11.0 (22 Mar 2005)
670    
671     22 Mar 2005; Caleb Tennis <caleb@gentoo.org> +rails-0.11.0.ebuild:
672     version bump
673 pythonhead 1.6
674     *rails-0.10.1 (10 Mar 2005)
675    
676     10 Mar 2005; Rob Cakebread <pythonhead@gentoo.org> +rails-0.10.1.ebuild:
677     Version bump.
678 caleb 1.5
679     08 Mar 2005; Caleb Tennis <caleb@gentoo.org> rails-0.10.0-r1.ebuild:
680     x86 stable
681 pythonhead 1.4
682     01 Mar 2005; Rob Cakebread <pythonhead@gentoo.org> rails-0.10.0-r1.ebuild:
683     Added upgrade postinst info
684 caleb 1.3
685     *rails-0.10.0-r1 (01 Mar 2005)
686    
687     01 Mar 2005; Caleb Tennis <caleb@gentoo.org> +rails-0.10.0-r1.ebuild,
688     -rails-0.10.0.ebuild:
689     Bump because my SRC_URI was wrong
690 caleb 1.2
691     *rails-0.10.0 (28 Feb 2005)
692    
693     28 Feb 2005; Caleb Tennis <caleb@gentoo.org> +rails-0.10.0.ebuild:
694     Version bump - bug #83446
695 pythonhead 1.1
696     *rails-0.9.5 (15 Feb 2005)
697    
698     15 Feb 2005; Rob Cakebread <pythonhead@gentoo.org> +metadata.xml,
699     +rails-0.9.5.ebuild:
700     Initial commit. bug# 80828

  ViewVC Help
Powered by ViewVC 1.1.20