/[gentoo-x86]/dev-ruby/rails/ChangeLog
Gentoo

Contents of /dev-ruby/rails/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.186 - (hide annotations) (download)
Mon Feb 21 20:12:22 2011 UTC (3 years, 6 months ago) by graaff
Branch: MAIN
Changes since 1.185: +6 -1 lines
Version bump for Rails 2.3.11.

(Portage version: 2.1.9.25/cvs/Linux x86_64)

1 pythonhead 1.1 # ChangeLog for dev-ruby/rails
2 graaff 1.182 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
3 graaff 1.186 # $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.185 2011/02/13 21:11:07 tomka Exp $
4    
5     *rails-2.3.11 (21 Feb 2011)
6    
7     21 Feb 2011; Hans de Graaff <graaff@gentoo.org> +rails-2.3.11.ebuild:
8     Version bump for Rails 2.3.11.
9 tomka 1.185
10     13 Feb 2011; Thomas Kahle <tomka@gentoo.org> rails-3.0.3.ebuild:
11     keyworded ~x86 per bug 351835
12 graaff 1.184
13     22 Jan 2011; Hans de Graaff <graaff@gentoo.org> -rails-2.3.5-r2.ebuild,
14     -rails-2.3.5-r3.ebuild, -rails-2.3.8.ebuild:
15     Remove old versions.
16 graaff 1.183
17     12 Jan 2011; Hans de Graaff <graaff@gentoo.org> rails-3.0.3.ebuild:
18     Update dependency on eselect-rails to a version that understands Rails
19     3.x. Thanks to Elias Probst in bug 351434.
20 graaff 1.182
21     07 Jan 2011; Hans de Graaff <graaff@gentoo.org> rails-2.3.10.ebuild:
22     Move forward ppc and ppc64 keywords that got missed on a version bump.
23 graaff 1.181
24     *rails-3.0.3 (28 Dec 2010)
25    
26     28 Dec 2010; Hans de Graaff <graaff@gentoo.org> +rails-3.0.3.ebuild:
27     Version bump for Rails 3.0.3.
28 graaff 1.180
29     15 Oct 2010; Hans de Graaff <graaff@gentoo.org> -rails-2.3.9.ebuild:
30     Remove vulnerable version.
31 graaff 1.179
32     *rails-2.3.10 (15 Oct 2010)
33    
34     15 Oct 2010; Hans de Graaff <graaff@gentoo.org> +rails-2.3.10.ebuild:
35     Version bump for rails 2.3.10.
36 ranger 1.178
37     29 Sep 2010; Brent Baude <ranger@gentoo.org> rails-2.3.8.ebuild:
38     Marking rails-2.3.8 ~ppc64 for bug 322175
39 ranger 1.177
40     28 Sep 2010; Brent Baude <ranger@gentoo.org> rails-2.3.8.ebuild:
41     Marking rails-2.3.8 ~ppc for bug 322175
42 graaff 1.176
43     *rails-2.3.9 (05 Sep 2010)
44    
45     05 Sep 2010; Hans de Graaff <graaff@gentoo.org> +rails-2.3.9.ebuild:
46     Version bump for Rails 2.3.9
47 graaff 1.175
48     *rails-2.3.8 (31 May 2010)
49    
50     31 May 2010; Hans de Graaff <graaff@gentoo.org> +rails-2.3.8.ebuild:
51     Bump for Rails 2.3.8. Drop ppc/ppc64 keywords due to new unkeyworded
52     dependency.
53 a3li 1.174
54     *rails-2.3.5-r3 (23 May 2010)
55    
56     23 May 2010; Alex Legler <a3li@gentoo.org> +rails-2.3.5-r3.ebuild:
57     Add REE18 support
58 flameeyes 1.173
59     22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org> rails-2.3.5.ebuild,
60     -rails-2.3.5-r1.ebuild, rails-2.3.5-r2.ebuild:
61     Cleanup old versions, use new syntax.
62 abcd 1.172
63     21 Feb 2010; Jonathan Callen <abcd@gentoo.org> rails-2.3.5-r2.ebuild:
64     Transfer prefix keywords (no other changes)
65 graaff 1.171
66     *rails-2.3.5-r2 (17 Feb 2010)
67    
68     17 Feb 2010; Hans de Graaff <graaff@gentoo.org> +rails-2.3.5-r2.ebuild:
69     Install more files so that creating a new project works again, fixing
70     #303581.
71 armin76 1.170
72     13 Feb 2010; Raúl Porcel <armin76@gentoo.org> rails-2.3.5-r1.ebuild:
73     Add ~ia64/~sparc
74 maekke 1.169
75     01 Feb 2010; Markus Meier <maekke@gentoo.org> rails-2.3.5-r1.ebuild:
76     add ~x86, bug #301007
77 ranger 1.168
78     18 Jan 2010; Brent Baude <ranger@gentoo.org> rails-2.3.5-r1.ebuild:
79     Marking rails-2.3.5-r1 ~ppc64 for bug 301007
80 ranger 1.167
81     18 Jan 2010; Brent Baude <ranger@gentoo.org> rails-2.3.5-r1.ebuild:
82     Marking rails-2.3.5-r1 ~ppc for bug 301007
83 flameeyes 1.166
84     *rails-2.3.5-r1 (14 Jan 2010)
85    
86     14 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
87     +rails-2.3.5-r1.ebuild:
88     Bump to ruby-fakegem. Tests cannot be executed because upstream does not
89     package them.
90 a3li 1.165
91     20 Dec 2009; Alex Legler <a3li@gentoo.org> -rails-2.2.3.ebuild,
92     -rails-2.3.4.ebuild:
93     Removing vulnerable versions
94 jer 1.164
95     19 Dec 2009; Jeroen Roovers <jer@gentoo.org> rails-2.2.3-r1.ebuild,
96     rails-2.3.5.ebuild:
97     Stable for PPC (bug #294797).
98 armin76 1.163
99     30 Nov 2009; Raúl Porcel <armin76@gentoo.org> rails-2.2.3-r1.ebuild,
100     rails-2.3.5.ebuild:
101     ia64/sparc stable wrt #294797
102 ranger 1.162
103     30 Nov 2009; Brent Baude <ranger@gentoo.org> rails-2.2.3-r1.ebuild,
104     rails-2.3.5.ebuild:
105     Marking rails-2.3.5 ppc64 stable for bug 294797
106 maekke 1.161
107     30 Nov 2009; Markus Meier <maekke@gentoo.org> rails-2.3.5.ebuild:
108     amd64/x86 stable, bug #294797
109 maekke 1.160
110     30 Nov 2009; Markus Meier <maekke@gentoo.org> rails-2.2.3-r1.ebuild:
111     amd64/x86 stable, bug #294797
112 a3li 1.159
113     *rails-2.2.3-r1 (28 Nov 2009)
114    
115     28 Nov 2009; Alex Legler <a3li@gentoo.org> +rails-2.2.3-r1.ebuild:
116     Revision bump, security bug 294797.
117 a3li 1.158
118     *rails-2.3.5 (28 Nov 2009)
119    
120     28 Nov 2009; Alex Legler <a3li@gentoo.org> +rails-2.3.5.ebuild:
121     Version bump, security bug 294797
122 a3li 1.157
123     22 Oct 2009; Alex Legler <a3li@gentoo.org> -rails-1.2.6-r1.ebuild,
124     -rails-2.0.5-r1.ebuild, -rails-2.1.2-r1.ebuild:
125     Removing three old versions
126 a3li 1.156
127     18 Oct 2009; Alex Legler <a3li@gentoo.org> -rails-2.2.2-r1.ebuild:
128     removing vulnerable ebuild, bug 283396
129 nixnut 1.155
130     18 Oct 2009; nixnut <nixnut@gentoo.org> rails-2.2.3.ebuild:
131     ppc stable #283396
132 ranger 1.154
133     18 Oct 2009; Brent Baude <ranger@gentoo.org> rails-2.2.3.ebuild:
134     Marking rails-2.2.3 ppc64 stable for bug 283396
135 armin76 1.153
136     08 Oct 2009; Raúl Porcel <armin76@gentoo.org> rails-2.2.3.ebuild:
137     ia64/sparc stable wrt #283396
138 maekke 1.152
139     07 Oct 2009; Markus Meier <maekke@gentoo.org> rails-2.2.3.ebuild:
140     amd64 stable, bug #283396
141 fauli 1.151
142     04 Oct 2009; Christian Faulhammer <fauli@gentoo.org> rails-2.2.3.ebuild:
143     stable x86, bug 283396
144 a3li 1.150
145     *rails-2.2.3 (03 Oct 2009)
146    
147     03 Oct 2009; Alex Legler <a3li@gentoo.org> +rails-2.2.3.ebuild:
148     Version bump, security bug 283396
149 graaff 1.149
150     26 Sep 2009; Hans de Graaff <graaff@gentoo.org> -rails-2.3.2.ebuild,
151     -rails-2.3.3.ebuild:
152     Remove insecure versions, bug 283396.
153    
154     26 Sep 2009; Hans de Graaff <graaff@gentoo.org> ChangeLog:
155     Remove insecure versions, bug 283396.
156 ranger 1.148
157     25 Sep 2009; Brent Baude <ranger@gentoo.org> rails-2.3.4.ebuild:
158     Marking rails-2.3.4 ppc64 stable for bug 283396
159 nixnut 1.147
160     20 Sep 2009; nixnut <nixnut@gentoo.org> rails-2.3.4.ebuild:
161     ppc stable #283396
162 armin76 1.146
163     19 Sep 2009; Raúl Porcel <armin76@gentoo.org> rails-2.3.4.ebuild:
164     ia64/sparc stable wrt #283396
165 maekke 1.145
166     14 Sep 2009; Markus Meier <maekke@gentoo.org> rails-2.3.4.ebuild:
167     amd64/x86 stable, bug #283396
168 flameeyes 1.144
169     14 Sep 2009; Diego E. Pettenò <flameeyes@gentoo.org> rails-2.3.4.ebuild:
170     Bump rubygems requirement to 1.3.2.
171 graaff 1.143
172     *rails-2.3.4 (04 Sep 2009)
173    
174     04 Sep 2009; Hans de Graaff <graaff@gentoo.org> +rails-2.3.4.ebuild:
175     Version bump: fix security issues reported in #283396.
176 armin76 1.142
177     16 Aug 2009; Raúl Porcel <armin76@gentoo.org> rails-2.3.3.ebuild:
178     Add ~ia64 wrt #279123
179 graaff 1.141
180     26 Jul 2009; Hans de Graaff <graaff@gentoo.org> rails-2.3.3.ebuild:
181     Drop ia64 keyword #279123.
182 graaff 1.140
183     *rails-2.3.3 (22 Jul 2009)
184    
185     22 Jul 2009; Hans de Graaff <graaff@gentoo.org> +rails-2.3.3.ebuild:
186     Version bump for Rails 2.3.3.
187 armin76 1.139
188     28 May 2009; Raúl Porcel <armin76@gentoo.org> rails-2.3.2.ebuild:
189     ia64 stable wrt #270331
190 maekke 1.137
191     24 May 2009; Markus Meier <maekke@gentoo.org> rails-2.3.2.ebuild:
192     x86 stable, bug #270331
193 gentoofan23 1.136
194     23 May 2009; Thomas Anderson <gentoofan23@gentoo.org> rails-2.3.2.ebuild:
195     stable amd64, bug 270331
196 ranger 1.135
197     23 May 2009; Brent Baude <ranger@gentoo.org> rails-2.3.2.ebuild:
198     Marking rails-2.3.2 ppc64 stable for bug 270331
199 ranger 1.134
200     23 May 2009; Brent Baude <ranger@gentoo.org> rails-2.3.2.ebuild:
201     Marking rails-2.3.2 ppc stable for bug 270331
202 fmccor 1.133
203     18 May 2009; Ferris McCormick <fmccor@gentoo.org> rails-2.3.2.ebuild:
204     Sparc stable, Bug #270331.
205 a3li 1.132
206 graaff 1.138 18 May 2009; Hans de Graaff <graaff@gentoo.org> -rails-1.2.6.ebuild,
207     -rails-2.0.5.ebuild, -rails-2.1.2.ebuild, -rails-2.2.2.ebuild:
208     Remove old and vulnerable versions.
209    
210 a3li 1.132 *rails-2.3.2 (17 Mar 2009)
211    
212     17 Mar 2009; Alex Legler <a3li@gentoo.org> +rails-2.3.2.ebuild:
213     Version bump
214 armin76 1.131
215     10 Jan 2009; Raúl Porcel <armin76@gentoo.org> rails-1.2.6-r1.ebuild,
216     rails-2.1.2-r1.ebuild, rails-2.2.2-r1.ebuild:
217     ia64 stable wrt #253425
218 ranger 1.130
219     09 Jan 2009; Brent Baude <ranger@gentoo.org> rails-1.2.6-r1.ebuild,
220     rails-2.0.5-r1.ebuild, rails-2.1.2-r1.ebuild, rails-2.2.2-r1.ebuild:
221     rails-1.2.6-r1 rails-2.0.5-r1 rails-2.1.2-r1 rails-2.2.2-r1 ppc stable for
222     bug 253425
223 fmccor 1.129
224     07 Jan 2009; Ferris McCormick <fmccor@gentoo.org> rails-2.2.2-r1.ebuild:
225     Sparc stable, Bug #253425.
226 fmccor 1.128
227     07 Jan 2009; Ferris McCormick <fmccor@gentoo.org> rails-1.2.6-r1.ebuild,
228     rails-2.0.5-r1.ebuild, rails-2.1.2-r1.ebuild:
229     Sparc stable, part of Bug #253425.
230 ranger 1.127
231     07 Jan 2009; Brent Baude <ranger@gentoo.org> rails-1.2.6-r1.ebuild,
232     rails-2.0.5-r1.ebuild, rails-2.1.2-r1.ebuild, rails-2.2.2-r1.ebuild:
233     rails-1.2.6-r1 rails-2.0.5-r1 rails-2.1.2-r1 rails-2.2.2-r1 ppc64 stable
234 maekke 1.126
235     04 Jan 2009; Markus Meier <maekke@gentoo.org> rails-1.2.6-r1.ebuild,
236     rails-2.0.5-r1.ebuild, rails-2.1.2-r1.ebuild, rails-2.2.2-r1.ebuild:
237     amd64/x86 stable, bug #253425
238 graaff 1.125
239     08 Dec 2008; Hans de Graaff <graaff@gentoo.org> rails-2.2.2-r1.ebuild:
240     Add missing RDEPEND on >=rubygems-1.3.1 as per #250245.
241 graaff 1.124
242     03 Dec 2008; Hans de Graaff <graaff@gentoo.org> rails-1.2.6-r1.ebuild:
243     Fix quoting.
244 graaff 1.123
245     *rails-2.2.2-r1 (03 Dec 2008)
246     *rails-2.1.2-r1 (03 Dec 2008)
247     *rails-2.0.5-r1 (03 Dec 2008)
248     *rails-1.2.6-r1 (03 Dec 2008)
249    
250     03 Dec 2008; Hans de Graaff <graaff@gentoo.org> +rails-1.2.6-r1.ebuild,
251     +rails-2.0.5-r1.ebuild, +rails-2.1.2-r1.ebuild, +rails-2.2.2-r1.ebuild:
252     Make sure /usr/bin/rails loads the correct version of rails. Depend on and use
253     select-rails-0.14 to simplify the rails update process. Fixes #221899. Thanks
254     to Mark Somerville for initial patches and Alex Legler for getting it ready
255     for the tree and testing.
256 graaff 1.122
257     *rails-2.2.2 (27 Nov 2008)
258    
259     27 Nov 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.2.2.ebuild:
260     Version bump for Rails 2.2.2
261 graaff 1.121
262     17 Nov 2008; Hans de Graaff <graaff@gentoo.org> -rails-2.0.2.ebuild,
263     -rails-2.0.4.ebuild, -rails-2.1.0.ebuild, -rails-2.1.1.ebuild:
264     Remove old, insecure, versions
265 dertobi123 1.120
266     15 Nov 2008; Tobias Scherbaum <dertobi123@gentoo.org> rails-2.0.5.ebuild,
267     rails-2.1.2.ebuild:
268     ppc stable, bug #237385
269 armin76 1.119
270     06 Nov 2008; Raúl Porcel <armin76@gentoo.org> rails-2.1.2.ebuild:
271     ia64 stable wrt #237385
272 maekke 1.118
273     05 Nov 2008; Markus Meier <maekke@gentoo.org> rails-2.0.5.ebuild:
274     amd64/x86 stable, bug #237385
275 ranger 1.117
276     04 Nov 2008; Brent Baude <ranger@gentoo.org> rails-2.0.5.ebuild,
277     rails-2.1.2.ebuild:
278     Marking rails-2.0.5|2.1.2 ppc64 for bug 237385
279 maekke 1.116
280     03 Nov 2008; Markus Meier <maekke@gentoo.org> rails-2.1.2.ebuild:
281     amd64/x86 stable, bug #237385
282 fmccor 1.115
283     03 Nov 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.5.ebuild,
284     rails-2.1.2.ebuild:
285     Sparc stable, Security Bug #237385.
286 graaff 1.114
287     *rails-2.1.2 (24 Oct 2008)
288    
289     24 Oct 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.2.ebuild:
290     Version bump. Fixes security issue #242914 (header-injection) and #237285.
291     Also features minor fixes.
292 graaff 1.113
293     *rails-2.0.5 (20 Oct 2008)
294    
295     20 Oct 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.0.5.ebuild:
296     Version bump for Rails 2.0.5
297 graaff 1.112
298     *rails-2.1.1 (13 Sep 2008)
299    
300     13 Sep 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.1.ebuild:
301     Version bump for Rails 2.1.1, bug #237392
302 graaff 1.111
303     *rails-2.0.4 (12 Sep 2008)
304    
305     12 Sep 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.0.4.ebuild:
306     Version bump for Rails 2.0.4, bug #237385
307 graaff 1.110
308     13 Jul 2008; Hans de Graaff <graaff@gentoo.org>
309     -files/1.1.6-deprecate-old-lighttpd.patch, -rails-1.1.6.ebuild,
310     -rails-1.1.6-r2.ebuild:
311     Belated removal for GLSA 200711-17
312 graaff 1.109
313     04 Jul 2008; Hans de Graaff <graaff@gentoo.org> rails-2.1.0.ebuild:
314     Rails now depends on rake 0.8.1 or better.
315 graaff 1.108
316     17 Jun 2008; Hans de Graaff <graaff@gentoo.org> -rails-1.2.5.ebuild:
317     Remove old version
318 graaff 1.107
319     *rails-2.1.0 (17 Jun 2008)
320    
321     17 Jun 2008; Hans de Graaff <graaff@gentoo.org> +rails-2.1.0.ebuild:
322     Version bump for Rails 2.1.0
323 nixnut 1.106
324     16 May 2008; nixnut <nixnut@gentoo.org> rails-2.0.2.ebuild:
325     Stable on ppc wrt bug 221309
326 armin76 1.105
327     13 May 2008; Raúl Porcel <armin76@gentoo.org> rails-2.0.2.ebuild:
328     ia64 stable wrt #221309
329 fmccor 1.104
330     13 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
331     Sparc stable (again), following Hans de Graff's comment 7 in Bug #221309.
332     RMD160 for rails-2.0.2.gem should now be correct.
333 corsair 1.103
334     12 May 2008; Markus Rothe <corsair@gentoo.org> rails-2.0.2.ebuild:
335     Stable on ppc64; bug #221309
336 fmccor 1.102
337     11 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
338     Back to ~sparc because of Friedrich Oslage's comments in Bug #221309.
339 fmccor 1.101
340     11 May 2008; Ferris McCormick <fmccor@gentoo.org> rails-2.0.2.ebuild:
341     Sparc stable --- part of Bug #221309 --- Good for about 5 months.
342 maekke 1.100
343     11 May 2008; Markus Meier <maekke@gentoo.org> rails-2.0.2.ebuild:
344     x86 stable, bug #221309
345 graaff 1.99
346     11 May 2008; Hans de Graaff <graaff@gentoo.org> rails-2.0.2.ebuild:
347     Stable on amd64, bug #221309
348 graaff 1.98
349     19 Mar 2008; Hans de Graaff <graaff@gentoo.org> Manifest:
350     Redigest due to upstream repackaging
351 nichoj 1.97
352     04 Jan 2008; <nichoj@gentoo.org> ChangeLog:
353     Updated dependencies not to relay on specific version, and allowing for
354     later revisions (ie change =dev-ruby/activerecord-2.0.2 to
355     ~dev-ruby/activerecord-2.0.2.
356 graaff 1.96
357     18 Dec 2007; Hans de Graaff <graaff@gentoo.org> rails-2.0.2.ebuild:
358     Fix quoting; database USE flags have moved to dev-ruby/activerecord, make this
359     a warn instead of an info message.
360 graaff 1.95
361     *rails-2.0.2 (18 Dec 2007)
362    
363     18 Dec 2007; Hans de Graaff <graaff@gentoo.org> +rails-2.0.2.ebuild:
364     Version bump for Rails 2.0.2
365 angelos 1.94
366     01 Dec 2007; Christoph Mende <angelos@gentoo.org> rails-1.2.6.ebuild:
367     Stable on amd64 wrt bug #200159
368 graaff 1.93
369     01 Dec 2007; Hans de Graaff <graaff@gentoo.org> -rails-1.2.3.ebuild,
370     -rails-1.2.3-r1.ebuild, -rails-1.2.4.ebuild:
371     Remove old vulnerable versions
372 corsair 1.92
373     27 Nov 2007; Markus Rothe <corsair@gentoo.org> rails-1.2.6.ebuild:
374     Added ~ppc64; bug #200159
375 armin76 1.91
376     27 Nov 2007; Raúl Porcel <armin76@gentoo.org> rails-1.2.6.ebuild:
377     ia64/sparc stable wrt security #200159
378 ranger 1.90
379     26 Nov 2007; Brent Baude <ranger@gentoo.org> rails-1.2.6.ebuild:
380     Marking rails-1.2.6 ppc for bug 200159
381 opfer 1.89
382     26 Nov 2007; Christian Faulhammer <opfer@gentoo.org> rails-1.2.6.ebuild:
383     stable x86, security bug 200159
384 graaff 1.88
385     *rails-1.2.6 (25 Nov 2007)
386    
387     25 Nov 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.6.ebuild:
388     Version bump for Rails 1.2.6, security bug #200159
389 beandog 1.87
390     21 Oct 2007; Steve Dibb <beandog@gentoo.org> rails-1.2.5.ebuild:
391     amd64 stable, security bug 195315
392 dertobi123 1.86
393     18 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org> rails-1.2.5.ebuild:
394     ppc stable, bug #195315
395 armin76 1.85
396     16 Oct 2007; Raúl Porcel <armin76@gentoo.org> rails-1.2.5.ebuild:
397     ia64/sparc stable wrt security #195315
398 graaff 1.84
399     16 Oct 2007; Hans de Graaff <graaff@gentoo.org> rails-1.2.5.ebuild:
400     Add back the dependency on eselect-rails that got dropped somehow after
401     rails-1.2.3-r1
402 opfer 1.83
403     16 Oct 2007; Christian Faulhammer <opfer@gentoo.org> rails-1.2.5.ebuild:
404     stable x86, security bug 195315
405 graaff 1.82
406     *rails-1.2.5 (13 Oct 2007)
407    
408     13 Oct 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.5.ebuild:
409     Version bump with security fixes, bug 195315
410 graaff 1.81
411     07 Oct 2007; Hans de Graaff <graaff@gentoo.org> rails-1.2.4.ebuild:
412     Add back the code that handles eselect, I must have used the wrong file to
413     start from :-(
414 opfer 1.80
415     06 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
416     rails-1.2.3-r1.ebuild:
417     stable x86, bug 177209
418 graaff 1.79
419     *rails-1.2.4 (06 Oct 2007)
420    
421     06 Oct 2007; Hans de Graaff <graaff@gentoo.org> +rails-1.2.4.ebuild:
422     Version bump for rails 1.2.4
423 graaff 1.78
424     06 Oct 2007; Hans de Graaff <graaff@gentoo.org>
425     -files/rails-1.0.0-rdoc-rake-0.7.patch, -rails-1.1.6-r1.ebuild,
426     -rails-1.2.0.ebuild, -rails-1.2.1.ebuild, -rails-1.2.2.ebuild:
427     Remove versions that are old or won't become stable
428 dertobi123 1.77
429     06 Oct 2007; Tobias Scherbaum <dertobi123@gentoo.org>
430     rails-1.2.3-r1.ebuild:
431     ppc stable, bug #177209
432 fmccor 1.76
433     05 Oct 2007; Ferris McCormick <fmccor@gentoo.org> rails-1.2.3-r1.ebuild:
434     Sparc stable --- Bug #177209
435 nichoj 1.75
436     03 Sep 2007; Joshua Nichols <nichoj@gentoo.org> rails-1.1.6.ebuild,
437     rails-1.1.6-r1.ebuild, rails-1.1.6-r2.ebuild, rails-1.2.0.ebuild,
438     rails-1.2.1.ebuild, rails-1.2.2.ebuild, rails-1.2.3.ebuild,
439     rails-1.2.3-r1.ebuild:
440     Changed eselect-rails from PDEPEND to DEPEND. Moved blockers from
441     eselect-rails to here. Should address bug #172812.
442 nichoj 1.74
443     *rails-1.2.3-r1 (01 Sep 2007)
444     *rails-1.1.6-r2 (01 Sep 2007)
445    
446     01 Sep 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.1.6-r2.ebuild,
447     +rails-1.2.3-r1.ebuild:
448     Revision bumps for both slots. No longer installs /usr/bin/rails. Instead,
449     uses app-admin/eselect-rails to manage the symlink.
450 rbrown 1.73
451     14 Mar 2007; Richard Brown <rbrown@gentoo.org> rails-1.2.3.ebuild:
452     Fix rails-1.2.3 rake dependency
453 nichoj 1.72
454     *rails-1.2.3 (14 Mar 2007)
455    
456     14 Mar 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.2.3.ebuild:
457     Version bump for rails 1.2.3.
458 nichoj 1.71
459     *rails-1.2.2 (11 Feb 2007)
460    
461     11 Feb 2007; Joshua Nichols <nichoj@gentoo.org> +rails-1.2.2.ebuild:
462     Version bump.
463 pclouds 1.70
464     10 Feb 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
465     rails-1.1.6.ebuild, rails-1.1.6-r1.ebuild, rails-1.2.0.ebuild,
466     rails-1.2.1.ebuild:
467     Updated rails license to MIT, #165876
468 pclouds 1.69
469     *rails-1.2.1 (21 Jan 2007)
470    
471     21 Jan 2007; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
472     -rails-1.2.0_rc1.ebuild, +rails-1.2.1.ebuild:
473     1.2.1 in, 1.2.0_rc1 out
474 caleb 1.68
475     *rails-1.2.0 (19 Jan 2007)
476    
477     19 Jan 2007; Caleb Tennis <caleb@gentoo.org> +rails-1.2.0.ebuild:
478     rails 1.2.0
479 caleb 1.67
480     *rails-1.2.0_rc1 (24 Nov 2006)
481    
482     24 Nov 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.2.0_rc1.ebuild:
483     1.2.0_rc1
484 pclouds 1.66
485     *rails-1.1.6-r1 (03 Oct 2006)
486    
487     03 Oct 2006; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
488     +files/1.1.6-deprecate-old-lighttpd.patch, -rails-1.1.2.ebuild,
489     -rails-1.1.3.ebuild, -rails-1.1.4.ebuild, -rails-1.1.5.ebuild,
490     +rails-1.1.6-r1.ebuild:
491     Removed old ebuilds. Added 1.1.6-r1 to ignore lighttpd older than 1.4.10
492     (bug #133500)
493 kloeri 1.65
494     02 Sep 2006; Bryan Østergaard <kloeri@gentoo.org> rails-1.1.6.ebuild:
495     Stable on ia64.
496 caleb 1.64
497     *rails-1.1.6 (10 Aug 2006)
498    
499     10 Aug 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.6.ebuild:
500     version bump
501 fmccor 1.63
502     10 Aug 2006; Ferris McCormick <fmccor@gentoo.org> rails-1.1.5.ebuild:
503     Stable on sparc --- Bug #143369 (mandatory security upgrade) --- installs and
504     works.
505 tsunam 1.62
506     10 Aug 2006; Joshua Jackson <tsunam@gentoo.org> rails-1.1.5.ebuild:
507     Stable x86; bug # 143369
508 tcort 1.61
509     09 Aug 2006; Thomas Cort <tcort@gentoo.org> rails-1.1.5.ebuild:
510     Stable on amd64 wrt security Bug #143369.
511 dertobi123 1.60
512     09 Aug 2006; Tobias Scherbaum <dertobi123@gentoo.org> rails-1.1.5.ebuild:
513     ppc stable, bug #143369
514 caleb 1.59
515     *rails-1.1.5 (09 Aug 2006)
516    
517     09 Aug 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.5.ebuild:
518     version bump
519 blubb 1.58
520     31 Jul 2006; Simon Stelling <blubb@gentoo.org> rails-1.1.4.ebuild:
521     stable on amd64 wrt bug 138323
522 agriffis 1.57
523     13 Jul 2006; Aron Griffis <agriffis@gentoo.org> rails-1.1.4.ebuild:
524     Mark 1.1.4 stable on ia64. #138323
525 weeve 1.56
526     06 Jul 2006; Jason Wever <weeve@gentoo.org> rails-1.1.4.ebuild:
527     Stable on SPARC wrt security bug #138323.
528 tsunam 1.55
529     05 Jul 2006; Joshua Jackson <tsunam@gentoo.org> rails-1.1.4.ebuild:
530     Stable x86; bug #138323
531 pylon 1.54
532     03 Jul 2006; Lars Weiler <pylon@gentoo.org> rails-1.1.4.ebuild:
533     Stable on ppc; security bug #138323.
534 caleb 1.53
535     *rails-1.1.4 (03 Jul 2006)
536    
537     03 Jul 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.4.ebuild:
538     Version bump
539 caleb 1.52
540     *rails-1.1.3 (28 Jun 2006)
541    
542     28 Jun 2006; Caleb Tennis <caleb@gentoo.org> -rails-1.0.0.ebuild,
543     -rails-1.1.0.ebuild, -rails-1.1.1.ebuild, +rails-1.1.3.ebuild:
544     version bump, remove old versions
545 dertobi123 1.51
546     25 Jun 2006; Tobias Scherbaum <dertobi123@gentoo.org> rails-1.1.2.ebuild:
547     ppc stable, bug #133003
548 robbat2 1.50
549     14 Jun 2006; Robin H. Johnson <robbat2@gentoo.org> rails-1.1.2.ebuild:
550     Somebody left out ppc. It works fine here.
551 blubb 1.49
552     06 Jun 2006; Simon Stelling <blubb@gentoo.org> rails-1.1.2.ebuild:
553     stable on amd64
554 flameeyes 1.48
555     02 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
556     +files/rails-1.0.0-rdoc-rake-0.7.patch, rails-1.0.0.ebuild:
557     Add patch to fix rdoc call with rake 0.7. Thanks to Stephen Tallowitz in bug
558     #132692.
559 tsunam 1.47
560     16 May 2006; Joshua Jackson <tsunam@gentoo.org> rails-1.1.2.ebuild:
561     x86 stable; bug #133003
562 fmccor 1.46
563     11 May 2006; Ferris McCormick <fmccor@gentoo.org> rails-1.1.2.ebuild:
564     Stable on sparc (Bug #133003).
565 seemant 1.45
566     08 May 2006; Seemant Kulleen <seemant@gentoo.org> rails-1.1.2.ebuild:
567     keyworded for ~amd64
568 marienz 1.44
569     27 Apr 2006; Marien Zwart <marienz@gentoo.org> files/digest-rails-1.0.0,
570     files/digest-rails-1.1.0, files/digest-rails-1.1.1, Manifest:
571     Fixing SHA256 digest, pass four
572 flameeyes 1.43
573     17 Apr 2006; Diego Pettenò <flameeyes@gentoo.org> rails-1.1.2.ebuild:
574     Add ~x86-fbsd keyword.
575 caleb 1.42
576     *rails-1.1.2 (14 Apr 2006)
577    
578     14 Apr 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.2.ebuild:
579     Version bump
580 caleb 1.41
581     08 Apr 2006; Caleb Tennis <caleb@gentoo.org> rails-1.1.1.ebuild:
582     make it dep on rake 0.7.1
583 caleb 1.40
584     *rails-1.1.1 (06 Apr 2006)
585    
586     06 Apr 2006; Caleb Tennis <caleb@gentoo.org> +rails-1.1.1.ebuild:
587     version bump
588 caleb 1.39
589     31 Mar 2006; Caleb Tennis <caleb@gentoo.org> rails-1.0.0.ebuild:
590     Fix deps to lock rails 1.0 components together
591 agriffis 1.38
592     30 Mar 2006; Aron Griffis <agriffis@gentoo.org> rails-1.1.0.ebuild:
593     Mark 1.1.0 ~ia64
594 caleb 1.37
595     *rails-1.1.0 (28 Mar 2006)
596    
597     28 Mar 2006; Caleb Tennis <caleb@gentoo.org> -rails-1.0.0.4008.ebuild,
598     +rails-1.1.0.ebuild:
599     Rails 1.1
600 caleb 1.36
601     *rails-1.0.0.4008 (22 Mar 2006)
602    
603     22 Mar 2006; Caleb Tennis <caleb@gentoo.org> -rails-0.13.1.ebuild,
604     +rails-1.0.0.4008.ebuild:
605     New 1.1 release candidate, slotted to install alongside existing rails
606 hansmi 1.35
607     27 Jan 2006; Michael Hanselmann <hansmi@gentoo.org> rails-1.0.0.ebuild:
608     Stable on ppc.
609 fmccor 1.34
610     10 Jan 2006; Ferris McCormick <fmccor@gentoo.org> rails-1.0.0.ebuild:
611     Stable on sparc (at gustavoz's request); works as it should for me.
612 caleb 1.33
613     02 Jan 2006; Caleb Tennis <caleb@gentoo.org> rails-1.0.0.ebuild:
614     x86 stable
615 dang 1.32
616     20 Dec 2005; <dang@gentoo.org> rails-1.0.0.ebuild:
617     Marked ~amd64 Per bug#115774
618 caleb 1.31
619     *rails-1.0.0 (13 Dec 2005)
620    
621     13 Dec 2005; Caleb Tennis <caleb@gentoo.org> -rails-0.14.4.ebuild,
622     +rails-1.0.0.ebuild:
623     Version bump
624 caleb 1.30
625     *rails-0.14.4 (08 Dec 2005)
626    
627     08 Dec 2005; Caleb Tennis <caleb@gentoo.org> -rails-0.14.3.ebuild,
628     +rails-0.14.4.ebuild:
629     Version bump
630 weeve 1.29
631     13 Nov 2005; Jason Wever <weeve@gentoo.org> rails-0.13.1.ebuild:
632     Stable on SPARC.
633 caleb 1.28
634     *rails-0.14.3 (08 Nov 2005)
635    
636     08 Nov 2005; Caleb Tennis <caleb@gentoo.org> -rails-0.14.2.ebuild,
637     +rails-0.14.3.ebuild:
638     version bump
639 caleb 1.27
640     *rails-0.14.2 (04 Nov 2005)
641    
642     04 Nov 2005; Caleb Tennis <caleb@gentoo.org> -rails-0.14.1.ebuild,
643     +rails-0.14.2.ebuild:
644     bump and remove previous version
645 caleb 1.26
646     01 Nov 2005; Caleb Tennis <caleb@gentoo.org> rails-0.14.1.ebuild:
647     Requires rake-0.6.2
648 lu_zero 1.25
649     19 Oct 2005; Luca Barbato <lu_zero@gentoo.org> rails-0.13.1.ebuild:
650     Marked ppc
651 caleb 1.24
652     *rails-0.14.1 (19 Oct 2005)
653    
654     19 Oct 2005; Caleb Tennis <caleb@gentoo.org> +rails-0.14.1.ebuild:
655     Version bump
656 caleb 1.23
657     23 Sep 2005; Caleb Tennis <caleb@gentoo.org> -rails-0.9.5.ebuild,
658     -rails-0.10.0-r1.ebuild, -rails-0.10.1.ebuild, -rails-0.11.0-r1.ebuild,
659     -rails-0.11.1-r1.ebuild, -rails-0.12.1.ebuild:
660     Remove old versions
661 fmccor 1.22
662     01 Aug 2005; Ferris McCormick <fmccor@gentoo.org> rails-0.13.1.ebuild:
663     Add ~sparc keyword. Builds and appears to run without problems.
664 caleb 1.21
665     27 Jul 2005; Caleb Tennis <caleb@gentoo.org> rails-0.13.1.ebuild:
666     x86 stable
667 caleb 1.20
668     *rails-0.13.1 (12 Jul 2005)
669    
670     12 Jul 2005; Caleb Tennis <caleb@gentoo.org> +rails-0.13.1.ebuild:
671     Version bump
672 dholm 1.19
673     12 Jul 2005; David Holm <dholm@gentoo.org> rails-0.12.1.ebuild:
674     Added to ~ppc.
675 pythonhead 1.18
676     *rails-0.12.1 (20 Apr 2005)
677    
678     20 Apr 2005; Rob Cakebread <pythonhead@gentoo.org> -rails-0.12.0.ebuild,
679     +rails-0.12.1.ebuild:
680     Version bump removed bad version.
681 caleb 1.17
682     19 Apr 2005; Caleb Tennis <caleb@gentoo.org> rails-0.12.0.ebuild:
683     This version of rails seems to require rake 0.5.3
684 pythonhead 1.16
685     19 Apr 2005; Rob Cakebread <pythonhead@gentoo.org> rails-0.12.0.ebuild:
686     Removed obsolete postinst_info
687 pythonhead 1.15
688     *rails-0.12.0 (19 Apr 2005)
689    
690     19 Apr 2005; Rob Cakebread <pythonhead@gentoo.org> +rails-0.12.0.ebuild:
691     Version bump.
692 caleb 1.14
693     01 Apr 2005; Caleb Tennis <caleb@gentoo.org> rails-0.11.1-r1.ebuild:
694     x86 stable
695 caleb 1.13
696     30 Mar 2005; Caleb Tennis <caleb@gentoo.org> rails-0.11.1-r1.ebuild:
697     This version of rails requires rake 0.5.0
698 pythonhead 1.12
699     *rails-0.11.1-r1 (29 Mar 2005)
700    
701     29 Mar 2005; Rob Cakebread <pythonhead@gentoo.org> -rails-0.11.1.ebuild,
702     +rails-0.11.1-r1.ebuild:
703     Fixed rubyforge gem url.
704 pythonhead 1.11
705     *rails-0.11.1 (28 Mar 2005)
706    
707     28 Mar 2005; Rob Cakebread <pythonhead@gentoo.org> +rails-0.11.1.ebuild:
708     Version bump.
709 pythonhead 1.10
710     26 Mar 2005; Rob Cakebread <pythonhead@gentoo.org> rails-0.11.0-r1.ebuild:
711     Added fastcgi support/USE flag
712 pythonhead 1.8
713     25 Mar 2005; Rob Cakebread <pythonhead@gentoo.org>
714 pythonhead 1.9 +files/rails-0.11.0-dispatch.fcgi.diff, +rails-0.11.0-r1.ebuild:
715 pythonhead 1.8 Patched borken dispatch.fcgi, added some helpful einfo about upgrading from
716 pythonhead 1.9 0.10. Removed 0.11.0
717 caleb 1.7
718     *rails-0.11.0 (22 Mar 2005)
719    
720     22 Mar 2005; Caleb Tennis <caleb@gentoo.org> +rails-0.11.0.ebuild:
721     version bump
722 pythonhead 1.6
723     *rails-0.10.1 (10 Mar 2005)
724    
725     10 Mar 2005; Rob Cakebread <pythonhead@gentoo.org> +rails-0.10.1.ebuild:
726     Version bump.
727 caleb 1.5
728     08 Mar 2005; Caleb Tennis <caleb@gentoo.org> rails-0.10.0-r1.ebuild:
729     x86 stable
730 pythonhead 1.4
731     01 Mar 2005; Rob Cakebread <pythonhead@gentoo.org> rails-0.10.0-r1.ebuild:
732     Added upgrade postinst info
733 caleb 1.3
734     *rails-0.10.0-r1 (01 Mar 2005)
735    
736     01 Mar 2005; Caleb Tennis <caleb@gentoo.org> +rails-0.10.0-r1.ebuild,
737     -rails-0.10.0.ebuild:
738     Bump because my SRC_URI was wrong
739 caleb 1.2
740     *rails-0.10.0 (28 Feb 2005)
741    
742     28 Feb 2005; Caleb Tennis <caleb@gentoo.org> +rails-0.10.0.ebuild:
743     Version bump - bug #83446
744 pythonhead 1.1
745     *rails-0.9.5 (15 Feb 2005)
746    
747     15 Feb 2005; Rob Cakebread <pythonhead@gentoo.org> +metadata.xml,
748     +rails-0.9.5.ebuild:
749     Initial commit. bug# 80828

  ViewVC Help
Powered by ViewVC 1.1.20