/[gentoo-x86]/dev-util/valgrind/files/valgrind-3.6.1-glibc-2.14.patch
Gentoo

Contents of /dev-util/valgrind/files/valgrind-3.6.1-glibc-2.14.patch

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.1 - (show annotations) (download)
Tue Aug 9 13:30:14 2011 UTC (3 years, 1 month ago) by blueness
Branch: MAIN
Patch to allow valgrind to build against glibc-2.14, bug #378157

(Portage version: 2.1.10.3/cvs/Linux x86_64)

1 diff -Naur valgrind-3.6.1.orig/configure.in valgrind-3.6.1/configure.in
2 --- valgrind-3.6.1.orig/configure.in 2011-08-09 09:06:50.000000000 -0400
3 +++ valgrind-3.6.1/configure.in 2011-08-09 09:21:42.000000000 -0400
4 @@ -756,6 +756,13 @@
5 DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
6 DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
7 ;;
8 + 2.14)
9 + AC_MSG_RESULT(2.14 family)
10 + AC_DEFINE([GLIBC_2_14], 1, [Define to 1 if you're using glibc 2.14.x])
11 + DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
12 + DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
13 + DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
14 + ;;
15 aix5)
16 AC_MSG_RESULT(AIX 5.1 or 5.2 or 5.3)
17 AC_DEFINE([AIX5_LIBC], 1, [Define to 1 if you're using AIX 5.1 or 5.2 or 5.3])
18 @@ -769,7 +776,7 @@
19
20 *)
21 AC_MSG_RESULT([unsupported version ${GLIBC_VERSION}])
22 - AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.13])
23 + AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.14])
24 AC_MSG_ERROR([or AIX 5.1 or 5.2 or 5.3 GLIBC_VERSION])
25 AC_MSG_ERROR([or Darwin libc])
26 ;;

  ViewVC Help
Powered by ViewVC 1.1.20