/[gentoo-x86]/dev-util/valgrind/files/valgrind-3.8.1-glibc-2.17.patch
Gentoo

Contents of /dev-util/valgrind/files/valgrind-3.8.1-glibc-2.17.patch

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.1 - (show annotations) (download)
Tue Feb 19 18:06:53 2013 UTC (18 months, 1 week ago) by blueness
Branch: MAIN
CVS Tags: HEAD
Build against glibc-2.17, bug #458326

(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)

1 diff -Nuar valgrind-3.8.1.orig/configure.in valgrind-3.8.1/configure.in
2 --- valgrind-3.8.1.orig/configure.in 2012-09-18 15:17:32.000000000 -0400
3 +++ valgrind-3.8.1/configure.in 2013-02-19 13:00:26.000000000 -0500
4 @@ -906,6 +906,13 @@
5 DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
6 DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
7 ;;
8 + 2.17)
9 + AC_MSG_RESULT(2.17 family)
10 + AC_DEFINE([GLIBC_2_17], 1, [Define to 1 if you're using glibc 2.17.x])
11 + DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
12 + DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
13 + DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
14 + ;;
15 darwin)
16 AC_MSG_RESULT(Darwin)
17 AC_DEFINE([DARWIN_LIBC], 1, [Define to 1 if you're using Darwin])
18 @@ -919,7 +926,7 @@
19
20 *)
21 AC_MSG_RESULT([unsupported version ${GLIBC_VERSION}])
22 - AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.16])
23 + AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.17])
24 AC_MSG_ERROR([or Darwin libc])
25 ;;
26 esac

  ViewVC Help
Powered by ViewVC 1.1.20