/[gentoo-x86]/dev-vcs/git/git-1.7.2.4-r1.ebuild
Gentoo

Contents of /dev-vcs/git/git-1.7.2.4-r1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.3 - (show annotations) (download)
Sat Feb 12 23:26:10 2011 UTC (3 years, 8 months ago) by robbat2
Branch: MAIN
CVS Tags: HEAD
Changes since 1.2: +1 -1 lines
FILE REMOVED
Cleanup old files.

(Portage version: 2.2.0_alpha21/cvs/Linux x86_64)

1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.2.4-r1.ebuild,v 1.2 2010/12/20 07:49:25 robbat2 Exp $
4
5 EAPI=3
6
7 GENTOO_DEPEND_ON_PERL=no
8 inherit toolchain-funcs eutils elisp-common perl-module bash-completion
9 [ "$PV" == "9999" ] && inherit git
10
11 MY_PV="${PV/_rc/.rc}"
12 MY_P="${PN}-${MY_PV}"
13
14 DOC_VER=${MY_PV}
15
16 DESCRIPTION="GIT - the stupid content tracker, the revision control system heavily used by the Linux kernel team"
17 HOMEPAGE="http://www.git-scm.com/"
18 if [ "$PV" != "9999" ]; then
19 SRC_URI="mirror://kernel/software/scm/git/${MY_P}.tar.bz2
20 mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
21 doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
22 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
23 else
24 SRC_URI=""
25 EGIT_BRANCH="master"
26 EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
27 # EGIT_REPO_URI="http://www.kernel.org/pub/scm/git/git.git"
28 KEYWORDS=""
29 fi
30
31 LICENSE="GPL-2"
32 SLOT="0"
33 IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl ppcsha1 tk +threads +webdav xinetd cvs subversion"
34
35 # Common to both DEPEND and RDEPEND
36 CDEPEND="
37 !blksha1? ( dev-libs/openssl )
38 sys-libs/zlib
39 perl? ( dev-lang/perl[-build] )
40 tk? ( dev-lang/tk )
41 curl? (
42 net-misc/curl
43 webdav? ( dev-libs/expat )
44 )
45 emacs? ( virtual/emacs )"
46
47 RDEPEND="${CDEPEND}
48 perl? ( dev-perl/Error
49 dev-perl/Net-SMTP-SSL
50 dev-perl/Authen-SASL
51 cgi? ( virtual/perl-CGI )
52 cvs? ( >=dev-vcs/cvsps-2.1 dev-perl/DBI dev-perl/DBD-SQLite )
53 subversion? ( dev-vcs/subversion[-dso,perl] dev-perl/libwww-perl dev-perl/TermReadKey )
54 )
55 gtk?
56 (
57 >=dev-python/pygtk-2.8
58 || ( dev-python/pygtksourceview:2 dev-python/gtksourceview-python )
59 )"
60
61 # This is how info docs are created with Git:
62 # .txt/asciidoc --(asciidoc)---------> .xml/docbook
63 # .xml/docbook --(docbook2texi.pl)--> .texi
64 # .texi --(makeinfo)---------> .info
65 DEPEND="${CDEPEND}
66 app-arch/cpio
67 doc? (
68 app-text/asciidoc
69 app-text/docbook2X
70 sys-apps/texinfo
71 )"
72
73 # Live ebuild builds HTML docs, additionally
74 if [ "$PV" == "9999" ]; then
75 DEPEND="${DEPEND}
76 doc? (
77 app-text/xmlto
78 )"
79 fi
80
81 SITEFILE=50${PN}-gentoo.el
82 S="${WORKDIR}/${MY_P}"
83
84 pkg_setup() {
85 if ! use perl ; then
86 use cgi && ewarn "gitweb needs USE=perl, ignoring USE=cgi"
87 use cvs && ewarn "CVS integration needs USE=perl, ignoring USE=cvs"
88 use subversion && ewarn "git-svn needs USE=perl, it won't work"
89 fi
90 if use webdav && ! use curl ; then
91 ewarn "USE=webdav needs USE=curl. Ignoring"
92 fi
93 if use subversion && has_version dev-vcs/subversion && built_with_use --missing false dev-vcs/subversion dso ; then
94 ewarn "Per Gentoo bugs #223747, #238586, when subversion is built"
95 ewarn "with USE=dso, there may be weird crashes in git-svn. You"
96 ewarn "have been warned."
97 fi
98 }
99
100 # This is needed because for some obscure reasons future calls to make don't
101 # pick up these exports if we export them in src_unpack()
102 exportmakeopts() {
103 local myopts
104
105 if use blksha1 ; then
106 myopts="${myopts} BLK_SHA1=YesPlease"
107 elif use ppcsha1 ; then
108 myopts="${myopts} PPC_SHA1=YesPlease"
109 fi
110
111 if use curl ; then
112 use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
113 else
114 myopts="${myopts} NO_CURL=YesPlease"
115 fi
116
117 # broken assumptions, because of broken build system ...
118 myopts="${myopts} NO_FINK=YesPlease NO_DARWIN_PORTS=YesPlease"
119 myopts="${myopts} INSTALL=install TAR=tar"
120 myopts="${myopts} SHELL_PATH=${EPREFIX}/bin/sh"
121 myopts="${myopts} SANE_TOOL_PATH="
122 myopts="${myopts} OLD_ICONV="
123 myopts="${myopts} NO_EXTERNAL_GREP="
124
125 # can't define this to null, since the entire makefile depends on it
126 sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
127
128 use iconv \
129 || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
130 # || myopts="${myopts} NO_ICONV=YesPlease"
131 # because, above, we need to do this unconditionally (no "&& use iconv")
132 use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
133
134 use tk \
135 || myopts="${myopts} NO_TCLTK=YesPlease"
136 use perl \
137 && myopts="${myopts} INSTALLDIRS=vendor" \
138 || myopts="${myopts} NO_PERL=YesPlease"
139 use threads \
140 && myopts="${myopts} THREADED_DELTA_SEARCH=YesPlease"
141 use subversion \
142 || myopts="${myopts} NO_SVN_TESTS=YesPlease"
143 # Disabled until ~m68k-mint can be keyworded again
144 # if [[ ${CHOST} == *-mint* ]] ; then
145 # myopts="${myopts} NO_MMAP=YesPlease"
146 # myopts="${myopts} NO_IPV6=YesPlease"
147 # myopts="${myopts} NO_STRLCPY=YesPlease"
148 # myopts="${myopts} NO_MEMMEM=YesPlease"
149 # myopts="${myopts} NO_MKDTEMP=YesPlease"
150 # myopts="${myopts} NO_MKSTEMPS=YesPlease"
151 # fi
152 if [[ ${CHOST} == *-interix* ]] ; then
153 myopts="${myopts} NO_IPV6=YesPlease"
154 myopts="${myopts} NO_MEMMEM=YesPlease"
155 myopts="${myopts} NO_MKDTEMP=YesPlease"
156 myopts="${myopts} NO_STRTOUMAX=YesPlease"
157 myopts="${myopts} NO_STRTOULL=YesPlease"
158 myopts="${myopts} NO_INET_NTOP=YesPlease"
159 myopts="${myopts} NO_INET_PTON=YesPlease"
160 myopts="${myopts} NO_NSEC=YesPlease"
161 myopts="${myopts} NO_MKSTEMPS=YesPlease"
162 fi
163 if [[ ${CHOST} == ia64-*-hpux* ]]; then
164 myopts="${myopts} NO_NSEC=YesPlease"
165 fi
166
167 has_version '>=app-text/asciidoc-8.0' \
168 && myopts="${myopts} ASCIIDOC8=YesPlease"
169 myopts="${myopts} ASCIIDOC_NO_ROFF=YesPlease"
170
171 # Bug 290465:
172 # builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
173 [[ "${CHOST}" == *-uclibc* ]] && \
174 myopts="${myopts} NO_NSEC=YesPlease"
175
176 export MY_MAKEOPTS="${myopts}"
177 }
178
179 src_unpack() {
180 if [ "${PV}" != "9999" ]; then
181 unpack ${MY_P}.tar.bz2
182 cd "${S}"
183 unpack ${PN}-manpages-${DOC_VER}.tar.bz2
184 use doc && \
185 cd "${S}"/Documentation && \
186 unpack ${PN}-htmldocs-${DOC_VER}.tar.bz2
187 cd "${S}"
188 else
189 git_src_unpack
190 cd "${S}"
191 #cp "${FILESDIR}"/GIT-VERSION-GEN .
192 fi
193
194 }
195
196 src_prepare() {
197 # Noperl is being merged to upstream as of 2009/04/05
198 #epatch "${FILESDIR}"/20090305-git-1.6.2-noperl.patch
199
200 # GetOpt-Long v2.38 is strict
201 # Merged in 1.6.3 final 2009/05/07
202 #epatch "${FILESDIR}"/20090505-git-1.6.2.5-getopt-fixes.patch
203
204 # JS install fixup
205 epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
206
207 # USE=-iconv causes segfaults, fixed post 1.7.1
208 # Gentoo bug #321895
209 #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
210
211 # CVE-2010-3906: XSS in gitweb
212 epatch "${FILESDIR}"/git-1.6.4.5-gitweb-cve-2010-3906.patch
213
214 sed -i \
215 -e 's:^\(CFLAGS =\).*$:\1 $(OPTCFLAGS) -Wall:' \
216 -e 's:^\(LDFLAGS =\).*$:\1 $(OPTLDFLAGS):' \
217 -e 's:^\(CC = \).*$:\1$(OPTCC):' \
218 -e 's:^\(AR = \).*$:\1$(OPTAR):' \
219 -e "s:\(PYTHON_PATH = \)\(.*\)$:\1${EPREFIX}\2:" \
220 -e "s:\(PERL_PATH = \)\(.*\)$:\1${EPREFIX}\2:" \
221 Makefile || die "sed failed"
222
223 # Never install the private copy of Error.pm (bug #296310)
224 sed -i \
225 -e '/private-Error.pm/s,^,#,' \
226 perl/Makefile.PL
227
228 # Fix docbook2texi command
229 sed -i 's/DOCBOOK2X_TEXI=docbook2x-texi/DOCBOOK2X_TEXI=docbook2texi.pl/' \
230 Documentation/Makefile || die "sed failed"
231
232 # bug #318289
233 epatch "${FILESDIR}"/git-1.7.1-interix.patch
234 epatch "${FILESDIR}"/git-1.6.6.1-interix6.patch
235 }
236
237 git_emake() {
238 emake ${MY_MAKEOPTS} \
239 DESTDIR="${D}" \
240 OPTCFLAGS="${CFLAGS}" \
241 OPTLDFLAGS="${LDFLAGS}" \
242 OPTCC="$(tc-getCC)" \
243 OPTAR="$(tc-getAR)" \
244 prefix="${EPREFIX}"/usr \
245 htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
246 sysconfdir="${EPREFIX}"/etc \
247 "$@"
248 }
249
250 src_configure() {
251 exportmakeopts
252 }
253
254 src_compile() {
255 git_emake || die "emake failed"
256
257 if use emacs ; then
258 elisp-compile contrib/emacs/git{,-blame}.el \
259 || die "emacs modules failed"
260 fi
261
262 if use perl && use cgi ; then
263 git_emake \
264 gitweb/gitweb.cgi \
265 || die "emake gitweb/gitweb.cgi failed"
266 fi
267
268 cd "${S}"/Documentation
269 if [[ "$PV" == "9999" ]] ; then
270 git_emake man \
271 || die "emake man failed"
272 if use doc ; then
273 git_emake info html \
274 || die "emake info html failed"
275 fi
276 else
277 if use doc ; then
278 git_emake info \
279 || die "emake info html failed"
280 fi
281 fi
282 }
283
284 src_install() {
285 git_emake \
286 install || \
287 die "make install failed"
288
289 # Depending on the tarball and manual rebuild of the documentation, the
290 # manpages may exist in either OR both of these directories.
291 find man?/*.[157] >/dev/null 2>&1 && doman man?/*.[157]
292 find Documentation/*.[157] >/dev/null 2>&1 && doman Documentation/*.[157]
293
294 dodoc README Documentation/{SubmittingPatches,CodingGuidelines}
295 use doc && dodir /usr/share/doc/${PF}/html
296 for d in / /howto/ /technical/ ; do
297 docinto ${d}
298 dodoc Documentation${d}*.txt
299 use doc && dohtml -p ${d} Documentation${d}*.html
300 done
301 docinto /
302 # Upstream does not ship this pre-built :-(
303 use doc && doinfo Documentation/{git,gitman}.info
304
305 dobashcompletion contrib/completion/git-completion.bash ${PN}
306
307 if use emacs ; then
308 elisp-install ${PN} contrib/emacs/git.{el,elc} || die
309 elisp-install ${PN} contrib/emacs/git-blame.{el,elc} || die
310 #elisp-install ${PN}/compat contrib/emacs/vc-git.{el,elc} || die
311 # don't add automatically to the load-path, so the sitefile
312 # can do a conditional loading
313 touch "${ED}${SITELISP}/${PN}/compat/.nosearch"
314 elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
315 fi
316
317 if use gtk ; then
318 dobin "${S}"/contrib/gitview/gitview
319 dodoc "${S}"/contrib/gitview/gitview.txt
320 fi
321
322 dobin contrib/fast-import/git-p4
323 dodoc contrib/fast-import/git-p4.txt
324 newbin contrib/fast-import/import-tars.perl import-tars
325
326 dodir /usr/share/${PN}/contrib
327 # The following are excluded:
328 # svnimport - use git-svn
329 # p4import - excluded because fast-import has a better one
330 # examples - these are stuff that is not used in Git anymore actually
331 # patches - stuff the Git guys made to go upstream to other places
332 for i in continuous fast-import hg-to-git \
333 hooks remotes2config.sh stats \
334 workdir convert-objects blameview ; do
335 cp -rf \
336 "${S}"/contrib/${i} \
337 "${ED}"/usr/share/${PN}/contrib \
338 || die "Failed contrib ${i}"
339 done
340
341 if use perl && use cgi ; then
342 exeinto /usr/share/${PN}/gitweb
343 doexe "${S}"/gitweb/gitweb.cgi
344 insinto /usr/share/${PN}/gitweb/static
345 doins "${S}"/gitweb/static/gitweb.css
346 js=gitweb.js
347 [ -f "${S}"/gitweb/static/gitweb.min.js ] && js=gitweb.min.js
348 doins "${S}"/gitweb/static/${js}
349 doins "${S}"/gitweb/static/git-{favicon,logo}.png
350
351 # INSTALL discusses configuration issues, not just installation
352 docinto /
353 newdoc "${S}"/gitweb/INSTALL INSTALL.gitweb
354 newdoc "${S}"/gitweb/README README.gitweb
355
356 find "${ED}"/usr/lib64/perl5/ \
357 -name .packlist \
358 -exec rm \{\} \;
359 fi
360 if ! use subversion ; then
361 rm -f "${ED}"/usr/libexec/git-core/git-svn \
362 "${ED}"/usr/share/man/man1/git-svn.1*
363 fi
364
365 if use xinetd ; then
366 insinto /etc/xinetd.d
367 newins "${FILESDIR}"/git-daemon.xinetd git-daemon
368 fi
369
370 newinitd "${FILESDIR}"/git-daemon.initd git-daemon
371 newconfd "${FILESDIR}"/git-daemon.confd git-daemon
372
373 fixlocalpod
374 }
375
376 src_test() {
377 local disabled=""
378 local tests_cvs="t9200-git-cvsexportcommit.sh \
379 t9400-git-cvsserver-server.sh \
380 t9401-git-cvsserver-crlf.sh \
381 t9600-cvsimport.sh \
382 t9601-cvsimport-vendor-branch.sh \
383 t9602-cvsimport-branches-tags.sh \
384 t9603-cvsimport-patchsets.sh"
385 local tests_perl="t5502-quickfetch.sh \
386 t5512-ls-remote.sh \
387 t5520-pull.sh"
388 # Bug #225601 - t0004 is not suitable for root perm
389 # Bug #219839 - t1004 is not suitable for root perm
390 # t0001-init.sh - check for init notices EPERM* fails
391 local tests_nonroot="t0001-init.sh \
392 t0004-unwritable.sh \
393 t1004-read-tree-m-u-wf.sh \
394 t3700-add.sh \
395 t7300-clean.sh"
396
397 # Unzip is used only for the testcase code, not by any normal parts of Git.
398 if ! has_version app-arch/unzip ; then
399 einfo "Disabling tar-tree tests"
400 disabled="${disabled} t5000-tar-tree.sh"
401 fi
402
403 cvs=0
404 use cvs && let cvs=$cvs+1
405 if [[ ${EUID} -eq 0 ]]; then
406 if [[ $cvs -eq 1 ]]; then
407 ewarn "Skipping CVS tests because CVS does not work as root!"
408 ewarn "You should retest with FEATURES=userpriv!"
409 disabled="${disabled} ${tests_cvs}"
410 fi
411 einfo "Skipping other tests that require being non-root"
412 disabled="${disabled} ${tests_nonroot}"
413 else
414 [[ $cvs -gt 0 ]] && \
415 has_version dev-vcs/cvs && \
416 let cvs=$cvs+1
417 [[ $cvs -gt 1 ]] && \
418 built_with_use dev-vcs/cvs server && \
419 let cvs=$cvs+1
420 if [[ $cvs -lt 3 ]]; then
421 einfo "Disabling CVS tests (needs dev-vcs/cvs[USE=server])"
422 disabled="${disabled} ${tests_cvs}"
423 fi
424 fi
425
426 if ! use perl ; then
427 einfo "Disabling tests that need Perl"
428 disabled="${disabled} ${tests_perl}"
429 fi
430
431 # Reset all previously disabled tests
432 cd "${S}/t"
433 for i in *.sh.DISABLED ; do
434 [[ -f "${i}" ]] && mv -f "${i}" "${i%.DISABLED}"
435 done
436 einfo "Disabled tests:"
437 for i in ${disabled} ; do
438 [[ -f "${i}" ]] && mv -f "${i}" "${i}.DISABLED" && einfo "Disabled $i"
439 done
440 cd "${S}"
441 # Now run the tests
442 einfo "Start test run"
443 git_emake \
444 test || die "tests failed"
445 }
446
447 showpkgdeps() {
448 local pkg=$1
449 shift
450 elog " $(printf "%-17s:" ${pkg}) ${@}"
451 }
452
453 pkg_postinst() {
454 use emacs && elisp-site-regen
455 if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
456 ewarn "You must build dev-vcs/subversion with USE=perl"
457 ewarn "to get the full functionality of git-svn!"
458 fi
459 elog "These additional scripts need some dependencies:"
460 echo
461 showpkgdeps git-quiltimport "dev-util/quilt"
462 showpkgdeps git-instaweb \
463 "|| ( www-servers/lighttpd www-servers/apache )"
464 echo
465 }
466
467 pkg_postrm() {
468 use emacs && elisp-site-regen
469 }

  ViewVC Help
Powered by ViewVC 1.1.20