/[gentoo-x86]/dev-vcs/git/git-1.7.3.4-r1.ebuild
Gentoo

Diff of /dev-vcs/git/git-1.7.3.4-r1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.16 Revision 1.17
1# Copyright 1999-2011 Gentoo Foundation 1# Copyright 1999-2011 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/Attic/git-1.7.3.4-r1.ebuild,v 1.16 2011/04/04 08:58:41 pacho Exp $ 3# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/Attic/git-1.7.3.4-r1.ebuild,v 1.17 2011/08/19 18:43:47 darkside Exp $
4 4
5EAPI=3 5EAPI=3
6 6
7GENTOO_DEPEND_ON_PERL=no 7GENTOO_DEPEND_ON_PERL=no
8inherit toolchain-funcs eutils elisp-common perl-module bash-completion 8inherit toolchain-funcs eutils elisp-common perl-module bash-completion
475 elog " $(printf "%-17s:" ${pkg}) ${@}" 475 elog " $(printf "%-17s:" ${pkg}) ${@}"
476} 476}
477 477
478pkg_postinst() { 478pkg_postinst() {
479 use emacs && elisp-site-regen 479 use emacs && elisp-site-regen
480 if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
481 ewarn "You must build dev-vcs/subversion with USE=perl"
482 ewarn "to get the full functionality of git-svn!"
483 fi
484 elog "These additional scripts need some dependencies:" 480 elog "These additional scripts need some dependencies:"
485 echo 481 echo
486 showpkgdeps git-quiltimport "dev-util/quilt" 482 showpkgdeps git-quiltimport "dev-util/quilt"
487 showpkgdeps git-instaweb \ 483 showpkgdeps git-instaweb \
488 "|| ( www-servers/lighttpd www-servers/apache )" 484 "|| ( www-servers/lighttpd www-servers/apache )"

Legend:
Removed from v.1.16  
changed lines
  Added in v.1.17

  ViewVC Help
Powered by ViewVC 1.1.20