/[gentoo-x86]/dev-vcs/git/git-1.7.3.4-r1.ebuild
Gentoo

Contents of /dev-vcs/git/git-1.7.3.4-r1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.5 - (show annotations) (download)
Sat Dec 25 18:49:32 2010 UTC (3 years, 8 months ago) by robbat2
Branch: MAIN
Changes since 1.4: +6 -3 lines
Improve output phase of src_test block for new stables.

(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)

1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.3.4-r1.ebuild,v 1.4 2010/12/23 22:46:09 jer Exp $
4
5 EAPI=3
6
7 GENTOO_DEPEND_ON_PERL=no
8 inherit toolchain-funcs eutils elisp-common perl-module bash-completion
9 [ "$PV" == "9999" ] && inherit git
10
11 MY_PV="${PV/_rc/.rc}"
12 MY_P="${PN}-${MY_PV}"
13
14 DOC_VER=${MY_PV}
15
16 DESCRIPTION="GIT - the stupid content tracker, the revision control system heavily used by the Linux kernel team"
17 HOMEPAGE="http://www.git-scm.com/"
18 if [ "$PV" != "9999" ]; then
19 SRC_URI="mirror://kernel/software/scm/git/${MY_P}.tar.bz2
20 mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
21 doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
22 KEYWORDS="alpha ~amd64 ~arm hppa ~ia64 ~mips ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
23 else
24 SRC_URI=""
25 EGIT_BRANCH="master"
26 EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
27 # EGIT_REPO_URI="http://www.kernel.org/pub/scm/git/git.git"
28 KEYWORDS=""
29 fi
30
31 LICENSE="GPL-2"
32 SLOT="0"
33 IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl ppcsha1 tk +threads +webdav xinetd cvs subversion"
34
35 # Common to both DEPEND and RDEPEND
36 CDEPEND="
37 !blksha1? ( dev-libs/openssl )
38 sys-libs/zlib
39 perl? ( dev-lang/perl[-build] )
40 tk? ( dev-lang/tk )
41 curl? (
42 net-misc/curl
43 webdav? ( dev-libs/expat )
44 )
45 emacs? ( virtual/emacs )"
46
47 RDEPEND="${CDEPEND}
48 perl? ( dev-perl/Error
49 dev-perl/Net-SMTP-SSL
50 dev-perl/Authen-SASL
51 cgi? ( virtual/perl-CGI )
52 cvs? ( >=dev-vcs/cvsps-2.1 dev-perl/DBI dev-perl/DBD-SQLite )
53 subversion? ( dev-vcs/subversion[-dso,perl] dev-perl/libwww-perl dev-perl/TermReadKey )
54 )
55 gtk?
56 (
57 >=dev-python/pygtk-2.8
58 || ( dev-python/pygtksourceview:2 dev-python/gtksourceview-python )
59 )"
60
61 # This is how info docs are created with Git:
62 # .txt/asciidoc --(asciidoc)---------> .xml/docbook
63 # .xml/docbook --(docbook2texi.pl)--> .texi
64 # .texi --(makeinfo)---------> .info
65 DEPEND="${CDEPEND}
66 app-arch/cpio
67 doc? (
68 app-text/asciidoc
69 app-text/docbook2X
70 sys-apps/texinfo
71 )"
72
73 # Live ebuild builds man pages and HTML docs, additionally
74 if [ "$PV" == "9999" ]; then
75 DEPEND="${DEPEND}
76 app-text/asciidoc
77 app-text/xmlto"
78 fi
79
80 SITEFILE=50${PN}-gentoo.el
81 S="${WORKDIR}/${MY_P}"
82
83 pkg_setup() {
84 if ! use perl ; then
85 use cgi && ewarn "gitweb needs USE=perl, ignoring USE=cgi"
86 use cvs && ewarn "CVS integration needs USE=perl, ignoring USE=cvs"
87 use subversion && ewarn "git-svn needs USE=perl, it won't work"
88 fi
89 if use webdav && ! use curl ; then
90 ewarn "USE=webdav needs USE=curl. Ignoring"
91 fi
92 if use subversion && has_version dev-vcs/subversion && built_with_use --missing false dev-vcs/subversion dso ; then
93 ewarn "Per Gentoo bugs #223747, #238586, when subversion is built"
94 ewarn "with USE=dso, there may be weird crashes in git-svn. You"
95 ewarn "have been warned."
96 fi
97 }
98
99 # This is needed because for some obscure reasons future calls to make don't
100 # pick up these exports if we export them in src_unpack()
101 exportmakeopts() {
102 local myopts
103
104 if use blksha1 ; then
105 myopts="${myopts} BLK_SHA1=YesPlease"
106 elif use ppcsha1 ; then
107 myopts="${myopts} PPC_SHA1=YesPlease"
108 fi
109
110 if use curl ; then
111 use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
112 else
113 myopts="${myopts} NO_CURL=YesPlease"
114 fi
115
116 # broken assumptions, because of broken build system ...
117 myopts="${myopts} NO_FINK=YesPlease NO_DARWIN_PORTS=YesPlease"
118 myopts="${myopts} INSTALL=install TAR=tar"
119 myopts="${myopts} SHELL_PATH=${EPREFIX}/bin/sh"
120 myopts="${myopts} SANE_TOOL_PATH="
121 myopts="${myopts} OLD_ICONV="
122 myopts="${myopts} NO_EXTERNAL_GREP="
123
124 # can't define this to null, since the entire makefile depends on it
125 sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
126
127 use iconv \
128 || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
129 # || myopts="${myopts} NO_ICONV=YesPlease"
130 # because, above, we need to do this unconditionally (no "&& use iconv")
131 use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
132
133 use tk \
134 || myopts="${myopts} NO_TCLTK=YesPlease"
135 use perl \
136 && myopts="${myopts} INSTALLDIRS=vendor" \
137 || myopts="${myopts} NO_PERL=YesPlease"
138 use threads \
139 && myopts="${myopts} THREADED_DELTA_SEARCH=YesPlease"
140 use subversion \
141 || myopts="${myopts} NO_SVN_TESTS=YesPlease"
142 # Disabled until ~m68k-mint can be keyworded again
143 # if [[ ${CHOST} == *-mint* ]] ; then
144 # myopts="${myopts} NO_MMAP=YesPlease"
145 # myopts="${myopts} NO_IPV6=YesPlease"
146 # myopts="${myopts} NO_STRLCPY=YesPlease"
147 # myopts="${myopts} NO_MEMMEM=YesPlease"
148 # myopts="${myopts} NO_MKDTEMP=YesPlease"
149 # myopts="${myopts} NO_MKSTEMPS=YesPlease"
150 # fi
151 if [[ ${CHOST} == ia64-*-hpux* ]]; then
152 myopts="${myopts} NO_NSEC=YesPlease"
153 fi
154
155 has_version '>=app-text/asciidoc-8.0' \
156 && myopts="${myopts} ASCIIDOC8=YesPlease"
157 myopts="${myopts} ASCIIDOC_NO_ROFF=YesPlease"
158
159 # Bug 290465:
160 # builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
161 [[ "${CHOST}" == *-uclibc* ]] && \
162 myopts="${myopts} NO_NSEC=YesPlease"
163
164 export MY_MAKEOPTS="${myopts}"
165 }
166
167 src_unpack() {
168 if [ "${PV}" != "9999" ]; then
169 unpack ${MY_P}.tar.bz2
170 cd "${S}"
171 unpack ${PN}-manpages-${DOC_VER}.tar.bz2
172 use doc && \
173 cd "${S}"/Documentation && \
174 unpack ${PN}-htmldocs-${DOC_VER}.tar.bz2
175 cd "${S}"
176 else
177 git_src_unpack
178 cd "${S}"
179 #cp "${FILESDIR}"/GIT-VERSION-GEN .
180 fi
181
182 }
183
184 src_prepare() {
185 # Noperl is being merged to upstream as of 2009/04/05
186 #epatch "${FILESDIR}"/20090305-git-1.6.2-noperl.patch
187
188 # GetOpt-Long v2.38 is strict
189 # Merged in 1.6.3 final 2009/05/07
190 #epatch "${FILESDIR}"/20090505-git-1.6.2.5-getopt-fixes.patch
191
192 # JS install fixup
193 epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
194
195 # USE=-iconv causes segfaults, fixed post 1.7.1
196 # Gentoo bug #321895
197 #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
198
199 sed -i \
200 -e 's:^\(CFLAGS =\).*$:\1 $(OPTCFLAGS) -Wall:' \
201 -e 's:^\(LDFLAGS =\).*$:\1 $(OPTLDFLAGS):' \
202 -e 's:^\(CC = \).*$:\1$(OPTCC):' \
203 -e 's:^\(AR = \).*$:\1$(OPTAR):' \
204 -e "s:\(PYTHON_PATH = \)\(.*\)$:\1${EPREFIX}\2:" \
205 -e "s:\(PERL_PATH = \)\(.*\)$:\1${EPREFIX}\2:" \
206 Makefile || die "sed failed"
207
208 # Never install the private copy of Error.pm (bug #296310)
209 sed -i \
210 -e '/private-Error.pm/s,^,#,' \
211 perl/Makefile.PL
212
213 # Fix docbook2texi command
214 sed -i 's/DOCBOOK2X_TEXI=docbook2x-texi/DOCBOOK2X_TEXI=docbook2texi.pl/' \
215 Documentation/Makefile || die "sed failed"
216
217 # bug #318289
218 epatch "${FILESDIR}"/git-1.7.3.2-interix.patch
219 }
220
221 git_emake() {
222 # bug #326625: PERL_PATH, PERL_MM_OPT
223 # bug #320647: PYTHON_PATH
224 emake ${MY_MAKEOPTS} \
225 DESTDIR="${D}" \
226 OPTCFLAGS="${CFLAGS}" \
227 OPTLDFLAGS="${LDFLAGS}" \
228 OPTCC="$(tc-getCC)" \
229 OPTAR="$(tc-getAR)" \
230 prefix="${EPREFIX}"/usr \
231 htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
232 sysconfdir="${EPREFIX}"/etc \
233 PYTHON_PATH="${EPREFIX}/usr/bin/python" \
234 PERL_PATH="${EPREFIX}/usr/bin/env perl" \
235 PERL_MM_OPT="" \
236 GIT_TEST_OPTS="--no-color" \
237 "$@"
238 }
239
240 src_configure() {
241 exportmakeopts
242 }
243
244 src_compile() {
245 git_emake || die "emake failed"
246
247 if use emacs ; then
248 elisp-compile contrib/emacs/git{,-blame}.el \
249 || die "emacs modules failed"
250 fi
251
252 if use perl && use cgi ; then
253 git_emake \
254 gitweb/gitweb.cgi \
255 || die "emake gitweb/gitweb.cgi failed"
256 fi
257
258 cd "${S}"/Documentation
259 if [[ "$PV" == "9999" ]] ; then
260 git_emake man \
261 || die "emake man failed"
262 if use doc ; then
263 git_emake info html \
264 || die "emake info html failed"
265 fi
266 else
267 if use doc ; then
268 git_emake info \
269 || die "emake info html failed"
270 fi
271 fi
272 }
273
274 src_install() {
275 git_emake \
276 install || \
277 die "make install failed"
278
279 # Depending on the tarball and manual rebuild of the documentation, the
280 # manpages may exist in either OR both of these directories.
281 find man?/*.[157] >/dev/null 2>&1 && doman man?/*.[157]
282 find Documentation/*.[157] >/dev/null 2>&1 && doman Documentation/*.[157]
283
284 dodoc README Documentation/{SubmittingPatches,CodingGuidelines}
285 use doc && dodir /usr/share/doc/${PF}/html
286 for d in / /howto/ /technical/ ; do
287 docinto ${d}
288 dodoc Documentation${d}*.txt
289 use doc && dohtml -p ${d} Documentation${d}*.html
290 done
291 docinto /
292 # Upstream does not ship this pre-built :-(
293 use doc && doinfo Documentation/{git,gitman}.info
294
295 dobashcompletion contrib/completion/git-completion.bash ${PN}
296
297 if use emacs ; then
298 elisp-install ${PN} contrib/emacs/git.{el,elc} || die
299 elisp-install ${PN} contrib/emacs/git-blame.{el,elc} || die
300 #elisp-install ${PN}/compat contrib/emacs/vc-git.{el,elc} || die
301 # don't add automatically to the load-path, so the sitefile
302 # can do a conditional loading
303 touch "${ED}${SITELISP}/${PN}/compat/.nosearch"
304 elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
305 fi
306
307 if use gtk ; then
308 dobin "${S}"/contrib/gitview/gitview
309 dodoc "${S}"/contrib/gitview/gitview.txt
310 fi
311
312 dobin contrib/fast-import/git-p4
313 dodoc contrib/fast-import/git-p4.txt
314 newbin contrib/fast-import/import-tars.perl import-tars
315 newbin contrib/git-resurrect.sh git-resurrect
316
317 dodir /usr/share/${PN}/contrib
318 # The following are excluded:
319 # completion - installed above
320 # emacs - installed above
321 # examples - these are stuff that is not used in Git anymore actually
322 # gitview - installed above
323 # p4import - excluded because fast-import has a better one
324 # patches - stuff the Git guys made to go upstream to other places
325 # svnimport - use git-svn
326 # thunderbird-patch-inline - fixes thunderbird
327 for i in \
328 blameview buildsystems ciabot continuous convert-objects fast-import \
329 hg-to-git hooks remotes2config.sh remotes2config.sh rerere-train.sh \
330 stats svn-fe vim workdir \
331 ; do
332 cp -rf \
333 "${S}"/contrib/${i} \
334 "${ED}"/usr/share/${PN}/contrib \
335 || die "Failed contrib ${i}"
336 done
337
338 if use perl && use cgi ; then
339 # We used to install in /usr/share/${PN}/gitweb
340 # but upstream installs in /usr/share/gitweb
341 # so we will install a symlink and use their location for compat with other
342 # distros
343 dosym /usr/share/gitweb /usr/share/${PN}/gitweb
344
345 # INSTALL discusses configuration issues, not just installation
346 docinto /
347 newdoc "${S}"/gitweb/INSTALL INSTALL.gitweb
348 newdoc "${S}"/gitweb/README README.gitweb
349
350 find "${ED}"/usr/lib64/perl5/ \
351 -name .packlist \
352 -exec rm \{\} \;
353 else
354 rm -rf "${D}"/usr/share/gitweb
355 fi
356
357 if ! use subversion ; then
358 rm -f "${ED}"/usr/libexec/git-core/git-svn \
359 "${ED}"/usr/share/man/man1/git-svn.1*
360 fi
361
362 if use xinetd ; then
363 insinto /etc/xinetd.d
364 newins "${FILESDIR}"/git-daemon.xinetd git-daemon
365 fi
366
367 newinitd "${FILESDIR}"/git-daemon.initd git-daemon
368 newconfd "${FILESDIR}"/git-daemon.confd git-daemon
369
370 fixlocalpod
371 }
372
373 src_test() {
374 local disabled=""
375 local tests_cvs="t9200-git-cvsexportcommit.sh \
376 t9400-git-cvsserver-server.sh \
377 t9401-git-cvsserver-crlf.sh \
378 t9600-cvsimport.sh \
379 t9601-cvsimport-vendor-branch.sh \
380 t9602-cvsimport-branches-tags.sh \
381 t9603-cvsimport-patchsets.sh"
382 local tests_perl="t5502-quickfetch.sh \
383 t5512-ls-remote.sh \
384 t5520-pull.sh"
385 # Bug #225601 - t0004 is not suitable for root perm
386 # Bug #219839 - t1004 is not suitable for root perm
387 # t0001-init.sh - check for init notices EPERM* fails
388 local tests_nonroot="t0001-init.sh \
389 t0004-unwritable.sh \
390 t1004-read-tree-m-u-wf.sh \
391 t3700-add.sh \
392 t7300-clean.sh"
393
394 # Unzip is used only for the testcase code, not by any normal parts of Git.
395 if ! has_version app-arch/unzip ; then
396 einfo "Disabling tar-tree tests"
397 disabled="${disabled} t5000-tar-tree.sh"
398 fi
399
400 cvs=0
401 use cvs && let cvs=$cvs+1
402 if [[ ${EUID} -eq 0 ]]; then
403 if [[ $cvs -eq 1 ]]; then
404 ewarn "Skipping CVS tests because CVS does not work as root!"
405 ewarn "You should retest with FEATURES=userpriv!"
406 disabled="${disabled} ${tests_cvs}"
407 fi
408 einfo "Skipping other tests that require being non-root"
409 disabled="${disabled} ${tests_nonroot}"
410 else
411 [[ $cvs -gt 0 ]] && \
412 has_version dev-vcs/cvs && \
413 let cvs=$cvs+1
414 [[ $cvs -gt 1 ]] && \
415 built_with_use dev-vcs/cvs server && \
416 let cvs=$cvs+1
417 if [[ $cvs -lt 3 ]]; then
418 einfo "Disabling CVS tests (needs dev-vcs/cvs[USE=server])"
419 disabled="${disabled} ${tests_cvs}"
420 fi
421 fi
422
423 if ! use perl ; then
424 einfo "Disabling tests that need Perl"
425 disabled="${disabled} ${tests_perl}"
426 fi
427
428 # Reset all previously disabled tests
429 cd "${S}/t"
430 for i in *.sh.DISABLED ; do
431 [[ -f "${i}" ]] && mv -f "${i}" "${i%.DISABLED}"
432 done
433 einfo "Disabled tests:"
434 for i in ${disabled} ; do
435 [[ -f "${i}" ]] && mv -f "${i}" "${i}.DISABLED" && einfo "Disabled $i"
436 done
437 cd "${S}"
438 # Now run the tests
439 einfo "Start test run"
440 git_emake test
441 rc=$?
442 # Display nice results
443 git_emake aggregate-results
444 [ $rc -eq 0 ] || die "tests failed. Please file a bug with ${S}/t/ attached."
445 }
446
447 showpkgdeps() {
448 local pkg=$1
449 shift
450 elog " $(printf "%-17s:" ${pkg}) ${@}"
451 }
452
453 pkg_postinst() {
454 use emacs && elisp-site-regen
455 if use subversion && has_version dev-vcs/subversion && ! built_with_use --missing false dev-vcs/subversion perl ; then
456 ewarn "You must build dev-vcs/subversion with USE=perl"
457 ewarn "to get the full functionality of git-svn!"
458 fi
459 elog "These additional scripts need some dependencies:"
460 echo
461 showpkgdeps git-quiltimport "dev-util/quilt"
462 showpkgdeps git-instaweb \
463 "|| ( www-servers/lighttpd www-servers/apache )"
464 echo
465 }
466
467 pkg_postrm() {
468 use emacs && elisp-site-regen
469 }

  ViewVC Help
Powered by ViewVC 1.1.20