/[gentoo-x86]/dev-vcs/git/git-1.7.4.5.ebuild
Gentoo

Contents of /dev-vcs/git/git-1.7.4.5.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.3 - (show annotations) (download)
Tue Jun 26 16:24:30 2012 UTC (2 years, 5 months ago) by darkside
Branch: MAIN
CVS Tags: HEAD
Changes since 1.2: +1 -1 lines
FILE REMOVED
Cleanup some unstable ebuilds

(Portage version: 2.1.10.65/cvs/Linux i686)

1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.4.5.ebuild,v 1.2 2011/08/19 18:43:47 darkside Exp $
4
5 EAPI=3
6
7 GENTOO_DEPEND_ON_PERL=no
8
9 # bug #329479: git-remote-testgit is not multiple-version aware
10 PYTHON_DEPEND="python? 2"
11 [[ ${PV} == *9999 ]] && SCM="git-2"
12 EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
13
14 inherit toolchain-funcs eutils elisp-common perl-module bash-completion python ${SCM}
15
16 MY_PV="${PV/_rc/.rc}"
17 MY_P="${PN}-${MY_PV}"
18
19 DOC_VER=${MY_PV}
20
21 DESCRIPTION="GIT - the stupid content tracker, the revision control system heavily used by the Linux kernel team"
22 HOMEPAGE="http://www.git-scm.com/"
23 if [[ ${PV} != *9999 ]]; then
24 SRC_URI="mirror://kernel/software/scm/git/${MY_P}.tar.bz2
25 mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
26 doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
27 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
28 else
29 SRC_URI=""
30 KEYWORDS=""
31 fi
32
33 LICENSE="GPL-2"
34 SLOT="0"
35 IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion"
36
37 # Common to both DEPEND and RDEPEND
38 CDEPEND="
39 !blksha1? ( dev-libs/openssl )
40 sys-libs/zlib
41 perl? ( dev-lang/perl[-build] )
42 tk? ( dev-lang/tk )
43 curl? (
44 net-misc/curl
45 webdav? ( dev-libs/expat )
46 )
47 emacs? ( virtual/emacs )"
48
49 RDEPEND="${CDEPEND}
50 perl? ( dev-perl/Error
51 dev-perl/Net-SMTP-SSL
52 dev-perl/Authen-SASL
53 cgi? ( virtual/perl-CGI )
54 cvs? ( >=dev-vcs/cvsps-2.1 dev-perl/DBI dev-perl/DBD-SQLite )
55 subversion? ( dev-vcs/subversion[-dso,perl] dev-perl/libwww-perl dev-perl/TermReadKey )
56 )
57 python? ( gtk?
58 (
59 >=dev-python/pygtk-2.8
60 dev-python/pygtksourceview:2
61 ) )"
62
63 # This is how info docs are created with Git:
64 # .txt/asciidoc --(asciidoc)---------> .xml/docbook
65 # .xml/docbook --(docbook2texi.pl)--> .texi
66 # .texi --(makeinfo)---------> .info
67 DEPEND="${CDEPEND}
68 app-arch/cpio
69 doc? (
70 app-text/asciidoc
71 app-text/docbook2X
72 sys-apps/texinfo
73 )"
74
75 # Live ebuild builds man pages and HTML docs, additionally
76 if [[ ${PV} == *9999 ]]; then
77 DEPEND="${DEPEND}
78 app-text/asciidoc
79 app-text/xmlto"
80 fi
81
82 SITEFILE=50${PN}-gentoo.el
83 S="${WORKDIR}/${MY_P}"
84
85 pkg_setup() {
86 if ! use perl ; then
87 use cgi && ewarn "gitweb needs USE=perl, ignoring USE=cgi"
88 use cvs && ewarn "CVS integration needs USE=perl, ignoring USE=cvs"
89 use subversion && ewarn "git-svn needs USE=perl, it won't work"
90 fi
91 if use webdav && ! use curl ; then
92 ewarn "USE=webdav needs USE=curl. Ignoring"
93 fi
94 if use subversion && has_version dev-vcs/subversion && built_with_use --missing false dev-vcs/subversion dso ; then
95 ewarn "Per Gentoo bugs #223747, #238586, when subversion is built"
96 ewarn "with USE=dso, there may be weird crashes in git-svn. You"
97 ewarn "have been warned."
98 fi
99 if use python ; then
100 python_set_active_version 2
101 python_pkg_setup
102 fi
103 }
104
105 # This is needed because for some obscure reasons future calls to make don't
106 # pick up these exports if we export them in src_unpack()
107 exportmakeopts() {
108 local myopts
109
110 if use blksha1 ; then
111 myopts="${myopts} BLK_SHA1=YesPlease"
112 elif use ppcsha1 ; then
113 myopts="${myopts} PPC_SHA1=YesPlease"
114 fi
115
116 if use curl ; then
117 use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
118 else
119 myopts="${myopts} NO_CURL=YesPlease"
120 fi
121
122 # broken assumptions, because of broken build system ...
123 myopts="${myopts} NO_FINK=YesPlease NO_DARWIN_PORTS=YesPlease"
124 myopts="${myopts} INSTALL=install TAR=tar"
125 myopts="${myopts} SHELL_PATH=${EPREFIX}/bin/sh"
126 myopts="${myopts} SANE_TOOL_PATH="
127 myopts="${myopts} OLD_ICONV="
128 myopts="${myopts} NO_EXTERNAL_GREP="
129
130 # can't define this to null, since the entire makefile depends on it
131 sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
132
133 use iconv \
134 || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
135 # || myopts="${myopts} NO_ICONV=YesPlease"
136 # because, above, we need to do this unconditionally (no "&& use iconv")
137 use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
138
139 use tk \
140 || myopts="${myopts} NO_TCLTK=YesPlease"
141 use perl \
142 && myopts="${myopts} INSTALLDIRS=vendor" \
143 || myopts="${myopts} NO_PERL=YesPlease"
144 use python \
145 || myopts="${myopts} NO_PYTHON=YesPlease"
146 use subversion \
147 || myopts="${myopts} NO_SVN_TESTS=YesPlease"
148 use threads \
149 && myopts="${myopts} THREADED_DELTA_SEARCH=YesPlease"
150 use cvs \
151 || myopts="${myopts} NO_CVS=YesPlease"
152 # Disabled until ~m68k-mint can be keyworded again
153 # if [[ ${CHOST} == *-mint* ]] ; then
154 # myopts="${myopts} NO_MMAP=YesPlease"
155 # myopts="${myopts} NO_IPV6=YesPlease"
156 # myopts="${myopts} NO_STRLCPY=YesPlease"
157 # myopts="${myopts} NO_MEMMEM=YesPlease"
158 # myopts="${myopts} NO_MKDTEMP=YesPlease"
159 # myopts="${myopts} NO_MKSTEMPS=YesPlease"
160 # fi
161 if [[ ${CHOST} == ia64-*-hpux* ]]; then
162 myopts="${myopts} NO_NSEC=YesPlease"
163 fi
164 if [[ ${CHOST} == *-*-aix* ]]; then
165 myopts="${myopts} NO_FNMATCH_CASEFOLD=YesPlease"
166 fi
167
168 has_version '>=app-text/asciidoc-8.0' \
169 && myopts="${myopts} ASCIIDOC8=YesPlease"
170 myopts="${myopts} ASCIIDOC_NO_ROFF=YesPlease"
171
172 # Bug 290465:
173 # builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
174 [[ "${CHOST}" == *-uclibc* ]] && \
175 myopts="${myopts} NO_NSEC=YesPlease"
176
177 export MY_MAKEOPTS="${myopts}"
178 }
179
180 src_unpack() {
181 if [[ ${PV} != *9999 ]]; then
182 unpack ${MY_P}.tar.bz2
183 cd "${S}"
184 unpack ${PN}-manpages-${DOC_VER}.tar.bz2
185 use doc && \
186 cd "${S}"/Documentation && \
187 unpack ${PN}-htmldocs-${DOC_VER}.tar.bz2
188 cd "${S}"
189 else
190 git-2_src_unpack
191 cd "${S}"
192 #cp "${FILESDIR}"/GIT-VERSION-GEN .
193 fi
194
195 }
196
197 src_prepare() {
198 # Noperl is being merged to upstream as of 2009/04/05
199 #epatch "${FILESDIR}"/20090305-git-1.6.2-noperl.patch
200
201 # GetOpt-Long v2.38 is strict
202 # Merged in 1.6.3 final 2009/05/07
203 #epatch "${FILESDIR}"/20090505-git-1.6.2.5-getopt-fixes.patch
204
205 # JS install fixup
206 epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
207
208 # USE=-iconv causes segfaults, fixed post 1.7.1
209 # Gentoo bug #321895
210 #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
211
212 # Fix false positives with t3404 due to SHELL=/bin/false for the portage
213 # user.
214 # Merged upstream
215 #epatch "${FILESDIR}"/git-1.7.3.4-avoid-shell-issues.patch
216
217 # bug #350075: t9001: fix missing prereq on some tests
218 # Merged upstream
219 #epatch "${FILESDIR}"/git-1.7.3.4-fix-perl-test-prereq.patch
220
221 # bug #350330 - automagic CVS when we don't want it is bad.
222 epatch "${FILESDIR}"/git-1.7.3.5-optional-cvs.patch
223
224 sed -i \
225 -e 's:^\(CFLAGS =\).*$:\1 $(OPTCFLAGS) -Wall:' \
226 -e 's:^\(LDFLAGS =\).*$:\1 $(OPTLDFLAGS):' \
227 -e 's:^\(CC = \).*$:\1$(OPTCC):' \
228 -e 's:^\(AR = \).*$:\1$(OPTAR):' \
229 -e "s:\(PYTHON_PATH = \)\(.*\)$:\1${EPREFIX}\2:" \
230 -e "s:\(PERL_PATH = \)\(.*\)$:\1${EPREFIX}\2:" \
231 Makefile || die "sed failed"
232
233 # Never install the private copy of Error.pm (bug #296310)
234 sed -i \
235 -e '/private-Error.pm/s,^,#,' \
236 perl/Makefile.PL
237
238 # Fix docbook2texi command
239 sed -i 's/DOCBOOK2X_TEXI=docbook2x-texi/DOCBOOK2X_TEXI=docbook2texi.pl/' \
240 Documentation/Makefile || die "sed failed"
241
242 # bug #318289
243 # Merged upstream
244 #epatch "${FILESDIR}"/git-1.7.3.2-interix.patch
245 }
246
247 git_emake() {
248 # bug #326625: PERL_PATH, PERL_MM_OPT
249 # bug #320647: PYTHON_PATH
250 PYTHON_PATH=""
251 use python && PYTHON_PATH="$(PYTHON -a)"
252 emake ${MY_MAKEOPTS} \
253 DESTDIR="${D}" \
254 OPTCFLAGS="${CFLAGS}" \
255 OPTLDFLAGS="${LDFLAGS}" \
256 OPTCC="$(tc-getCC)" \
257 OPTAR="$(tc-getAR)" \
258 prefix="${EPREFIX}"/usr \
259 htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
260 sysconfdir="${EPREFIX}"/etc \
261 PYTHON_PATH="${PYTHON_PATH}" \
262 PERL_PATH="${EPREFIX}/usr/bin/env perl" \
263 PERL_MM_OPT="" \
264 GIT_TEST_OPTS="--no-color" \
265 "$@"
266 }
267
268 src_configure() {
269 exportmakeopts
270 }
271
272 src_compile() {
273 git_emake || die "emake failed"
274
275 if use emacs ; then
276 elisp-compile contrib/emacs/git{,-blame}.el \
277 || die "emacs modules failed"
278 fi
279
280 if use perl && use cgi ; then
281 git_emake \
282 gitweb/gitweb.cgi \
283 || die "emake gitweb/gitweb.cgi failed"
284 fi
285
286 cd "${S}"/Documentation
287 if [[ ${PV} == *9999 ]] ; then
288 git_emake man \
289 || die "emake man failed"
290 if use doc ; then
291 git_emake info html \
292 || die "emake info html failed"
293 fi
294 else
295 if use doc ; then
296 git_emake info \
297 || die "emake info html failed"
298 fi
299 fi
300 }
301
302 src_install() {
303 git_emake \
304 install || \
305 die "make install failed"
306
307 # Depending on the tarball and manual rebuild of the documentation, the
308 # manpages may exist in either OR both of these directories.
309 find man?/*.[157] >/dev/null 2>&1 && doman man?/*.[157]
310 find Documentation/*.[157] >/dev/null 2>&1 && doman Documentation/*.[157]
311
312 dodoc README Documentation/{SubmittingPatches,CodingGuidelines}
313 use doc && dodir /usr/share/doc/${PF}/html
314 for d in / /howto/ /technical/ ; do
315 docinto ${d}
316 dodoc Documentation${d}*.txt
317 use doc && dohtml -p ${d} Documentation${d}*.html
318 done
319 docinto /
320 # Upstream does not ship this pre-built :-(
321 use doc && doinfo Documentation/{git,gitman}.info
322
323 dobashcompletion contrib/completion/git-completion.bash ${PN}
324
325 if use emacs ; then
326 elisp-install ${PN} contrib/emacs/git.{el,elc} || die
327 elisp-install ${PN} contrib/emacs/git-blame.{el,elc} || die
328 #elisp-install ${PN}/compat contrib/emacs/vc-git.{el,elc} || die
329 # don't add automatically to the load-path, so the sitefile
330 # can do a conditional loading
331 touch "${ED}${SITELISP}/${PN}/compat/.nosearch"
332 elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
333 fi
334
335 if use python && use gtk ; then
336 dobin "${S}"/contrib/gitview/gitview
337 python_convert_shebangs ${PYTHON_ABI} "${ED}"/usr/bin/gitview
338 dodoc "${S}"/contrib/gitview/gitview.txt
339 fi
340
341 dobin contrib/fast-import/git-p4
342 dodoc contrib/fast-import/git-p4.txt
343 newbin contrib/fast-import/import-tars.perl import-tars
344 newbin contrib/git-resurrect.sh git-resurrect
345
346 dodir /usr/share/${PN}/contrib
347 # The following are excluded:
348 # completion - installed above
349 # emacs - installed above
350 # examples - these are stuff that is not used in Git anymore actually
351 # gitview - installed above
352 # p4import - excluded because fast-import has a better one
353 # patches - stuff the Git guys made to go upstream to other places
354 # svnimport - use git-svn
355 # thunderbird-patch-inline - fixes thunderbird
356 for i in \
357 blameview buildsystems ciabot continuous convert-objects fast-import \
358 hg-to-git hooks remotes2config.sh remotes2config.sh rerere-train.sh \
359 stats svn-fe vim workdir \
360 ; do
361 cp -rf \
362 "${S}"/contrib/${i} \
363 "${ED}"/usr/share/${PN}/contrib \
364 || die "Failed contrib ${i}"
365 done
366
367 if use perl && use cgi ; then
368 # We used to install in /usr/share/${PN}/gitweb
369 # but upstream installs in /usr/share/gitweb
370 # so we will install a symlink and use their location for compat with other
371 # distros
372 dosym /usr/share/gitweb /usr/share/${PN}/gitweb
373
374 # INSTALL discusses configuration issues, not just installation
375 docinto /
376 newdoc "${S}"/gitweb/INSTALL INSTALL.gitweb
377 newdoc "${S}"/gitweb/README README.gitweb
378
379 find "${ED}"/usr/lib64/perl5/ \
380 -name .packlist \
381 -exec rm \{\} \;
382 else
383 rm -rf "${ED}"/usr/share/gitweb
384 fi
385
386 if ! use subversion ; then
387 rm -f "${ED}"/usr/libexec/git-core/git-svn \
388 "${ED}"/usr/share/man/man1/git-svn.1*
389 fi
390
391 if use xinetd ; then
392 insinto /etc/xinetd.d
393 newins "${FILESDIR}"/git-daemon.xinetd git-daemon
394 fi
395
396 newinitd "${FILESDIR}"/git-daemon.initd git-daemon
397 newconfd "${FILESDIR}"/git-daemon.confd git-daemon
398
399 fixlocalpod
400 }
401
402 src_test() {
403 local disabled=""
404 local tests_cvs="t9200-git-cvsexportcommit.sh \
405 t9400-git-cvsserver-server.sh \
406 t9401-git-cvsserver-crlf.sh \
407 t9600-cvsimport.sh \
408 t9601-cvsimport-vendor-branch.sh \
409 t9602-cvsimport-branches-tags.sh \
410 t9603-cvsimport-patchsets.sh"
411 local tests_perl="t5502-quickfetch.sh \
412 t5512-ls-remote.sh \
413 t5520-pull.sh"
414 # Bug #225601 - t0004 is not suitable for root perm
415 # Bug #219839 - t1004 is not suitable for root perm
416 # t0001-init.sh - check for init notices EPERM* fails
417 local tests_nonroot="t0001-init.sh \
418 t0004-unwritable.sh \
419 t1004-read-tree-m-u-wf.sh \
420 t3700-add.sh \
421 t7300-clean.sh"
422
423 # Unzip is used only for the testcase code, not by any normal parts of Git.
424 if ! has_version app-arch/unzip ; then
425 einfo "Disabling tar-tree tests"
426 disabled="${disabled} t5000-tar-tree.sh"
427 fi
428
429 cvs=0
430 use cvs && let cvs=$cvs+1
431 if [[ ${EUID} -eq 0 ]]; then
432 if [[ $cvs -eq 1 ]]; then
433 ewarn "Skipping CVS tests because CVS does not work as root!"
434 ewarn "You should retest with FEATURES=userpriv!"
435 disabled="${disabled} ${tests_cvs}"
436 fi
437 einfo "Skipping other tests that require being non-root"
438 disabled="${disabled} ${tests_nonroot}"
439 else
440 [[ $cvs -gt 0 ]] && \
441 has_version dev-vcs/cvs && \
442 let cvs=$cvs+1
443 [[ $cvs -gt 1 ]] && \
444 built_with_use dev-vcs/cvs server && \
445 let cvs=$cvs+1
446 if [[ $cvs -lt 3 ]]; then
447 einfo "Disabling CVS tests (needs dev-vcs/cvs[USE=server])"
448 disabled="${disabled} ${tests_cvs}"
449 fi
450 fi
451
452 if ! use perl ; then
453 einfo "Disabling tests that need Perl"
454 disabled="${disabled} ${tests_perl}"
455 fi
456
457 # Reset all previously disabled tests
458 cd "${S}/t"
459 for i in *.sh.DISABLED ; do
460 [[ -f "${i}" ]] && mv -f "${i}" "${i%.DISABLED}"
461 done
462 einfo "Disabled tests:"
463 for i in ${disabled} ; do
464 [[ -f "${i}" ]] && mv -f "${i}" "${i}.DISABLED" && einfo "Disabled $i"
465 done
466
467 # Avoid the test system removing the results because we want them ourselves
468 sed -e '/^[[:space:]]*$(MAKE) clean/s,^,#,g' \
469 -i "${S}"/t/Makefile
470
471 # Clean old results first
472 cd "${S}/t"
473 git_emake clean
474
475 # Now run the tests
476 cd "${S}"
477 einfo "Start test run"
478 git_emake test
479 rc=$?
480
481 # Display nice results
482 cd "${S}/t"
483 git_emake aggregate-results
484
485 # And exit
486 [ $rc -eq 0 ] || die "tests failed. Please file a bug."
487 }
488
489 showpkgdeps() {
490 local pkg=$1
491 shift
492 elog " $(printf "%-17s:" ${pkg}) ${@}"
493 }
494
495 pkg_postinst() {
496 use emacs && elisp-site-regen
497 use python && python_mod_optimize git_remote_helpers
498 elog "These additional scripts need some dependencies:"
499 echo
500 showpkgdeps git-quiltimport "dev-util/quilt"
501 showpkgdeps git-instaweb \
502 "|| ( www-servers/lighttpd www-servers/apache )"
503 echo
504 }
505
506 pkg_postrm() {
507 use emacs && elisp-site-regen
508 use python && python_mod_cleanup git_remote_helpers
509 }

  ViewVC Help
Powered by ViewVC 1.1.20