/[gentoo-x86]/dev-vcs/git/git-1.7.6.1.ebuild
Gentoo

Contents of /dev-vcs/git/git-1.7.6.1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.2 - (show annotations) (download)
Fri Jan 20 08:38:27 2012 UTC (2 years, 7 months ago) by robbat2
Branch: MAIN
CVS Tags: HEAD
Changes since 1.1: +1 -1 lines
FILE REMOVED
Clean up some unstable ebuilds.

(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)

1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.6.1.ebuild,v 1.1 2011/08/25 01:45:36 robbat2 Exp $
4
5 EAPI=3
6
7 GENTOO_DEPEND_ON_PERL=no
8
9 # bug #329479: git-remote-testgit is not multiple-version aware
10 PYTHON_DEPEND="python? 2"
11 [[ ${PV} == *9999 ]] && SCM="git-2"
12 EGIT_REPO_URI="git://git.kernel.org/pub/scm/git/git.git"
13
14 inherit toolchain-funcs eutils elisp-common perl-module bash-completion python ${SCM}
15
16 MY_PV="${PV/_rc/.rc}"
17 MY_P="${PN}-${MY_PV}"
18
19 DOC_VER=${MY_PV}
20
21 DESCRIPTION="GIT - the stupid content tracker, the revision control system heavily used by the Linux kernel team"
22 HOMEPAGE="http://www.git-scm.com/"
23 if [[ ${PV} != *9999 ]]; then
24 SRC_URI="mirror://kernel/software/scm/git/${MY_P}.tar.bz2
25 mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
26 doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
27 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
28 else
29 SRC_URI=""
30 KEYWORDS=""
31 fi
32
33 LICENSE="GPL-2"
34 SLOT="0"
35 IUSE="+blksha1 +curl cgi doc emacs gtk iconv +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion"
36
37 # Common to both DEPEND and RDEPEND
38 CDEPEND="
39 !blksha1? ( dev-libs/openssl )
40 sys-libs/zlib
41 perl? ( dev-lang/perl[-build] )
42 tk? ( dev-lang/tk )
43 curl? (
44 net-misc/curl
45 webdav? ( dev-libs/expat )
46 )
47 emacs? ( virtual/emacs )"
48
49 RDEPEND="${CDEPEND}
50 perl? ( dev-perl/Error
51 dev-perl/Net-SMTP-SSL
52 dev-perl/Authen-SASL
53 cgi? ( virtual/perl-CGI )
54 cvs? ( >=dev-vcs/cvsps-2.1 dev-perl/DBI dev-perl/DBD-SQLite )
55 subversion? ( dev-vcs/subversion[-dso,perl] dev-perl/libwww-perl dev-perl/TermReadKey )
56 )
57 python? ( gtk?
58 (
59 >=dev-python/pygtk-2.8
60 dev-python/pygtksourceview:2
61 ) )"
62
63 # This is how info docs are created with Git:
64 # .txt/asciidoc --(asciidoc)---------> .xml/docbook
65 # .xml/docbook --(docbook2texi.pl)--> .texi
66 # .texi --(makeinfo)---------> .info
67 DEPEND="${CDEPEND}
68 app-arch/cpio
69 doc? (
70 app-text/asciidoc
71 app-text/docbook2X
72 sys-apps/texinfo
73 )"
74
75 # Live ebuild builds man pages and HTML docs, additionally
76 if [[ ${PV} == *9999 ]]; then
77 DEPEND="${DEPEND}
78 app-text/asciidoc
79 app-text/xmlto"
80 fi
81
82 SITEFILE=50${PN}-gentoo.el
83 S="${WORKDIR}/${MY_P}"
84
85 pkg_setup() {
86 if ! use perl ; then
87 use cgi && ewarn "gitweb needs USE=perl, ignoring USE=cgi"
88 use cvs && ewarn "CVS integration needs USE=perl, ignoring USE=cvs"
89 use subversion && ewarn "git-svn needs USE=perl, it won't work"
90 fi
91 if use webdav && ! use curl ; then
92 ewarn "USE=webdav needs USE=curl. Ignoring"
93 fi
94 if use subversion && has_version dev-vcs/subversion && built_with_use --missing false dev-vcs/subversion dso ; then
95 ewarn "Per Gentoo bugs #223747, #238586, when subversion is built"
96 ewarn "with USE=dso, there may be weird crashes in git-svn. You"
97 ewarn "have been warned."
98 fi
99 if use python ; then
100 python_set_active_version 2
101 python_pkg_setup
102 fi
103 }
104
105 # This is needed because for some obscure reasons future calls to make don't
106 # pick up these exports if we export them in src_unpack()
107 exportmakeopts() {
108 local myopts
109
110 if use blksha1 ; then
111 myopts="${myopts} BLK_SHA1=YesPlease"
112 elif use ppcsha1 ; then
113 myopts="${myopts} PPC_SHA1=YesPlease"
114 fi
115
116 if use curl ; then
117 use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
118 else
119 myopts="${myopts} NO_CURL=YesPlease"
120 fi
121
122 # broken assumptions, because of broken build system ...
123 myopts="${myopts} NO_FINK=YesPlease NO_DARWIN_PORTS=YesPlease"
124 myopts="${myopts} INSTALL=install TAR=tar"
125 myopts="${myopts} SHELL_PATH=${EPREFIX}/bin/sh"
126 myopts="${myopts} SANE_TOOL_PATH="
127 myopts="${myopts} OLD_ICONV="
128 myopts="${myopts} NO_EXTERNAL_GREP="
129
130 # can't define this to null, since the entire makefile depends on it
131 sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile
132
133 use iconv \
134 || einfo "Forcing iconv for ${PVR} due to bugs #321895, #322205."
135 # || myopts="${myopts} NO_ICONV=YesPlease"
136 # because, above, we need to do this unconditionally (no "&& use iconv")
137 use !elibc_glibc && myopts="${myopts} NEEDS_LIBICONV=YesPlease"
138
139 use tk \
140 || myopts="${myopts} NO_TCLTK=YesPlease"
141 use perl \
142 && myopts="${myopts} INSTALLDIRS=vendor" \
143 || myopts="${myopts} NO_PERL=YesPlease"
144 use python \
145 || myopts="${myopts} NO_PYTHON=YesPlease"
146 use subversion \
147 || myopts="${myopts} NO_SVN_TESTS=YesPlease"
148 use threads \
149 && myopts="${myopts} THREADED_DELTA_SEARCH=YesPlease"
150 use cvs \
151 || myopts="${myopts} NO_CVS=YesPlease"
152 # Disabled until ~m68k-mint can be keyworded again
153 # if [[ ${CHOST} == *-mint* ]] ; then
154 # myopts="${myopts} NO_MMAP=YesPlease"
155 # myopts="${myopts} NO_IPV6=YesPlease"
156 # myopts="${myopts} NO_STRLCPY=YesPlease"
157 # myopts="${myopts} NO_MEMMEM=YesPlease"
158 # myopts="${myopts} NO_MKDTEMP=YesPlease"
159 # myopts="${myopts} NO_MKSTEMPS=YesPlease"
160 # fi
161 if [[ ${CHOST} == ia64-*-hpux* ]]; then
162 myopts="${myopts} NO_NSEC=YesPlease"
163 fi
164 if [[ ${CHOST} == *-*-aix* ]]; then
165 myopts="${myopts} NO_FNMATCH_CASEFOLD=YesPlease"
166 fi
167
168 has_version '>=app-text/asciidoc-8.0' \
169 && myopts="${myopts} ASCIIDOC8=YesPlease"
170 myopts="${myopts} ASCIIDOC_NO_ROFF=YesPlease"
171
172 # Bug 290465:
173 # builtin-fetch-pack.c:816: error: 'struct stat' has no member named 'st_mtim'
174 [[ "${CHOST}" == *-uclibc* ]] && \
175 myopts="${myopts} NO_NSEC=YesPlease"
176
177 export MY_MAKEOPTS="${myopts}"
178 }
179
180 src_unpack() {
181 if [[ ${PV} != *9999 ]]; then
182 unpack ${MY_P}.tar.bz2
183 cd "${S}"
184 unpack ${PN}-manpages-${DOC_VER}.tar.bz2
185 use doc && \
186 cd "${S}"/Documentation && \
187 unpack ${PN}-htmldocs-${DOC_VER}.tar.bz2
188 cd "${S}"
189 else
190 git-2_src_unpack
191 cd "${S}"
192 #cp "${FILESDIR}"/GIT-VERSION-GEN .
193 fi
194
195 }
196
197 src_prepare() {
198 # Noperl is being merged to upstream as of 2009/04/05
199 #epatch "${FILESDIR}"/20090305-git-1.6.2-noperl.patch
200
201 # GetOpt-Long v2.38 is strict
202 # Merged in 1.6.3 final 2009/05/07
203 #epatch "${FILESDIR}"/20090505-git-1.6.2.5-getopt-fixes.patch
204
205 # JS install fixup
206 # Merged in 1.7.5.x
207 #epatch "${FILESDIR}"/git-1.7.2-always-install-js.patch
208
209 # USE=-iconv causes segfaults, fixed post 1.7.1
210 # Gentoo bug #321895
211 #epatch "${FILESDIR}"/git-1.7.1-noiconv-segfault-fix.patch
212
213 # Fix false positives with t3404 due to SHELL=/bin/false for the portage
214 # user.
215 # Merged upstream
216 #epatch "${FILESDIR}"/git-1.7.3.4-avoid-shell-issues.patch
217
218 # bug #350075: t9001: fix missing prereq on some tests
219 # Merged upstream
220 #epatch "${FILESDIR}"/git-1.7.3.4-fix-perl-test-prereq.patch
221
222 # bug #350330 - automagic CVS when we don't want it is bad.
223 epatch "${FILESDIR}"/git-1.7.3.5-optional-cvs.patch
224
225 sed -i \
226 -e 's:^\(CFLAGS =\).*$:\1 $(OPTCFLAGS) -Wall:' \
227 -e 's:^\(LDFLAGS =\).*$:\1 $(OPTLDFLAGS):' \
228 -e 's:^\(CC = \).*$:\1$(OPTCC):' \
229 -e 's:^\(AR = \).*$:\1$(OPTAR):' \
230 -e "s:\(PYTHON_PATH = \)\(.*\)$:\1${EPREFIX}\2:" \
231 -e "s:\(PERL_PATH = \)\(.*\)$:\1${EPREFIX}\2:" \
232 Makefile || die "sed failed"
233
234 # Never install the private copy of Error.pm (bug #296310)
235 sed -i \
236 -e '/private-Error.pm/s,^,#,' \
237 perl/Makefile.PL
238
239 # Fix docbook2texi command
240 sed -i 's/DOCBOOK2X_TEXI=docbook2x-texi/DOCBOOK2X_TEXI=docbook2texi.pl/' \
241 Documentation/Makefile || die "sed failed"
242
243 # bug #318289
244 # Merged upstream
245 #epatch "${FILESDIR}"/git-1.7.3.2-interix.patch
246
247 # merged upstream
248 #epatch "${FILESDIR}"/git-1.7.5-interix.patch
249 # but only one of two hunks made it into the release ... :(
250 epatch "${FILESDIR}"/git-1.7.6-interix.patch
251 }
252
253 git_emake() {
254 # bug #326625: PERL_PATH, PERL_MM_OPT
255 # bug #320647: PYTHON_PATH
256 PYTHON_PATH=""
257 use python && PYTHON_PATH="$(PYTHON -a)"
258 emake ${MY_MAKEOPTS} \
259 DESTDIR="${D}" \
260 OPTCFLAGS="${CFLAGS}" \
261 OPTLDFLAGS="${LDFLAGS}" \
262 OPTCC="$(tc-getCC)" \
263 OPTAR="$(tc-getAR)" \
264 prefix="${EPREFIX}"/usr \
265 htmldir="${EPREFIX}"/usr/share/doc/${PF}/html \
266 sysconfdir="${EPREFIX}"/etc \
267 PYTHON_PATH="${PYTHON_PATH}" \
268 PERL_MM_OPT="" \
269 GIT_TEST_OPTS="--no-color" \
270 "$@"
271 # This is the fix for bug #326625, but it also causes breakage, see bug
272 # #352693.
273 # PERL_PATH="${EPREFIX}/usr/bin/env perl" \
274 }
275
276 src_configure() {
277 exportmakeopts
278 }
279
280 src_compile() {
281 git_emake || die "emake failed"
282
283 if use emacs ; then
284 elisp-compile contrib/emacs/git{,-blame}.el \
285 || die "emacs modules failed"
286 fi
287
288 if use perl && use cgi ; then
289 git_emake \
290 gitweb/gitweb.cgi \
291 || die "emake gitweb/gitweb.cgi failed"
292 fi
293
294 cd "${S}"/Documentation
295 if [[ ${PV} == *9999 ]] ; then
296 git_emake man \
297 || die "emake man failed"
298 if use doc ; then
299 git_emake info html \
300 || die "emake info html failed"
301 fi
302 else
303 if use doc ; then
304 git_emake info \
305 || die "emake info html failed"
306 fi
307 fi
308 }
309
310 src_install() {
311 git_emake \
312 install || \
313 die "make install failed"
314
315 # Depending on the tarball and manual rebuild of the documentation, the
316 # manpages may exist in either OR both of these directories.
317 find man?/*.[157] >/dev/null 2>&1 && doman man?/*.[157]
318 find Documentation/*.[157] >/dev/null 2>&1 && doman Documentation/*.[157]
319
320 dodoc README Documentation/{SubmittingPatches,CodingGuidelines}
321 use doc && dodir /usr/share/doc/${PF}/html
322 for d in / /howto/ /technical/ ; do
323 docinto ${d}
324 dodoc Documentation${d}*.txt
325 use doc && dohtml -p ${d} Documentation${d}*.html
326 done
327 docinto /
328 # Upstream does not ship this pre-built :-(
329 use doc && doinfo Documentation/{git,gitman}.info
330
331 dobashcompletion contrib/completion/git-completion.bash ${PN}
332
333 if use emacs ; then
334 elisp-install ${PN} contrib/emacs/git.{el,elc} || die
335 elisp-install ${PN} contrib/emacs/git-blame.{el,elc} || die
336 #elisp-install ${PN}/compat contrib/emacs/vc-git.{el,elc} || die
337 # don't add automatically to the load-path, so the sitefile
338 # can do a conditional loading
339 touch "${ED}${SITELISP}/${PN}/compat/.nosearch"
340 elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
341 fi
342
343 if use python && use gtk ; then
344 dobin "${S}"/contrib/gitview/gitview
345 python_convert_shebangs ${PYTHON_ABI} "${ED}"/usr/bin/gitview
346 dodoc "${S}"/contrib/gitview/gitview.txt
347 fi
348
349 dobin contrib/fast-import/git-p4
350 dodoc contrib/fast-import/git-p4.txt
351 newbin contrib/fast-import/import-tars.perl import-tars
352 newbin contrib/git-resurrect.sh git-resurrect
353
354 dodir /usr/share/${PN}/contrib
355 # The following are excluded:
356 # completion - installed above
357 # emacs - installed above
358 # examples - these are stuff that is not used in Git anymore actually
359 # gitview - installed above
360 # p4import - excluded because fast-import has a better one
361 # patches - stuff the Git guys made to go upstream to other places
362 # svnimport - use git-svn
363 # thunderbird-patch-inline - fixes thunderbird
364 for i in \
365 blameview buildsystems ciabot continuous convert-objects fast-import \
366 hg-to-git hooks remotes2config.sh remotes2config.sh rerere-train.sh \
367 stats svn-fe vim workdir \
368 ; do
369 cp -rf \
370 "${S}"/contrib/${i} \
371 "${ED}"/usr/share/${PN}/contrib \
372 || die "Failed contrib ${i}"
373 done
374
375 if use perl && use cgi ; then
376 # We used to install in /usr/share/${PN}/gitweb
377 # but upstream installs in /usr/share/gitweb
378 # so we will install a symlink and use their location for compat with other
379 # distros
380 dosym /usr/share/gitweb /usr/share/${PN}/gitweb
381
382 # INSTALL discusses configuration issues, not just installation
383 docinto /
384 newdoc "${S}"/gitweb/INSTALL INSTALL.gitweb
385 newdoc "${S}"/gitweb/README README.gitweb
386
387 find "${ED}"/usr/lib64/perl5/ \
388 -name .packlist \
389 -exec rm \{\} \;
390 else
391 rm -rf "${ED}"/usr/share/gitweb
392 fi
393
394 if ! use subversion ; then
395 rm -f "${ED}"/usr/libexec/git-core/git-svn \
396 "${ED}"/usr/share/man/man1/git-svn.1*
397 fi
398
399 if use xinetd ; then
400 insinto /etc/xinetd.d
401 newins "${FILESDIR}"/git-daemon.xinetd git-daemon
402 fi
403
404 newinitd "${FILESDIR}"/git-daemon.initd git-daemon
405 newconfd "${FILESDIR}"/git-daemon.confd git-daemon
406
407 fixlocalpod
408 }
409
410 src_test() {
411 local disabled=""
412 local tests_cvs="t9200-git-cvsexportcommit.sh \
413 t9400-git-cvsserver-server.sh \
414 t9401-git-cvsserver-crlf.sh \
415 t9600-cvsimport.sh \
416 t9601-cvsimport-vendor-branch.sh \
417 t9602-cvsimport-branches-tags.sh \
418 t9603-cvsimport-patchsets.sh"
419 local tests_perl="t5502-quickfetch.sh \
420 t5512-ls-remote.sh \
421 t5520-pull.sh"
422 # Bug #225601 - t0004 is not suitable for root perm
423 # Bug #219839 - t1004 is not suitable for root perm
424 # t0001-init.sh - check for init notices EPERM* fails
425 local tests_nonroot="t0001-init.sh \
426 t0004-unwritable.sh \
427 t0070-fundamental.sh \
428 t1004-read-tree-m-u-wf.sh \
429 t3700-add.sh \
430 t7300-clean.sh"
431
432 # Unzip is used only for the testcase code, not by any normal parts of Git.
433 if ! has_version app-arch/unzip ; then
434 einfo "Disabling tar-tree tests"
435 disabled="${disabled} t5000-tar-tree.sh"
436 fi
437
438 cvs=0
439 use cvs && let cvs=$cvs+1
440 if [[ ${EUID} -eq 0 ]]; then
441 if [[ $cvs -eq 1 ]]; then
442 ewarn "Skipping CVS tests because CVS does not work as root!"
443 ewarn "You should retest with FEATURES=userpriv!"
444 disabled="${disabled} ${tests_cvs}"
445 fi
446 einfo "Skipping other tests that require being non-root"
447 disabled="${disabled} ${tests_nonroot}"
448 else
449 [[ $cvs -gt 0 ]] && \
450 has_version dev-vcs/cvs && \
451 let cvs=$cvs+1
452 [[ $cvs -gt 1 ]] && \
453 built_with_use dev-vcs/cvs server && \
454 let cvs=$cvs+1
455 if [[ $cvs -lt 3 ]]; then
456 einfo "Disabling CVS tests (needs dev-vcs/cvs[USE=server])"
457 disabled="${disabled} ${tests_cvs}"
458 fi
459 fi
460
461 if ! use perl ; then
462 einfo "Disabling tests that need Perl"
463 disabled="${disabled} ${tests_perl}"
464 fi
465
466 # Reset all previously disabled tests
467 cd "${S}/t"
468 for i in *.sh.DISABLED ; do
469 [[ -f "${i}" ]] && mv -f "${i}" "${i%.DISABLED}"
470 done
471 einfo "Disabled tests:"
472 for i in ${disabled} ; do
473 [[ -f "${i}" ]] && mv -f "${i}" "${i}.DISABLED" && einfo "Disabled $i"
474 done
475
476 # Avoid the test system removing the results because we want them ourselves
477 sed -e '/^[[:space:]]*$(MAKE) clean/s,^,#,g' \
478 -i "${S}"/t/Makefile
479
480 # Clean old results first
481 cd "${S}/t"
482 git_emake clean
483
484 # Now run the tests
485 cd "${S}"
486 einfo "Start test run"
487 git_emake test
488 rc=$?
489
490 # Display nice results
491 cd "${S}/t"
492 git_emake aggregate-results
493
494 # And exit
495 [ $rc -eq 0 ] || die "tests failed. Please file a bug."
496 }
497
498 showpkgdeps() {
499 local pkg=$1
500 shift
501 elog " $(printf "%-17s:" ${pkg}) ${@}"
502 }
503
504 pkg_postinst() {
505 use emacs && elisp-site-regen
506 use python && python_mod_optimize git_remote_helpers
507 use bash-completion && \
508 einfo "Please read /usr/share/bash-completion/git for Git bash completion"
509 elog "These additional scripts need some dependencies:"
510 echo
511 showpkgdeps git-quiltimport "dev-util/quilt"
512 showpkgdeps git-instaweb \
513 "|| ( www-servers/lighttpd www-servers/apache )"
514 echo
515 }
516
517 pkg_postrm() {
518 use emacs && elisp-site-regen
519 use python && python_mod_cleanup git_remote_helpers
520 }

  ViewVC Help
Powered by ViewVC 1.1.20