/[gentoo-x86]/eclass/autotools-multilib.eclass
Gentoo

Diff of /eclass/autotools-multilib.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.1 Revision 1.11
1# Copyright 1999-2012 Gentoo Foundation 1# Copyright 1999-2013 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/autotools-multilib.eclass,v 1.1 2012/10/08 18:44:30 mgorny Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/autotools-multilib.eclass,v 1.11 2013/02/27 21:46:31 mgorny Exp $
4 4
5# @ECLASS: autotools-multilib.eclass 5# @ECLASS: autotools-multilib.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# Michał Górny <mgorny@gentoo.org> 7# Michał Górny <mgorny@gentoo.org>
8# @BLURB: autotools-utils wrapper for multilib builds 8# @BLURB: autotools-utils wrapper for multilib builds
9# @DESCRIPTION: 9# @DESCRIPTION:
10# The autotools-multilib.eclass is an autotools-utils.eclass(5) wrapper 10# The autotools-multilib.eclass is an autotools-utils.eclass(5) wrapper
11# introducing support for building for more than one ABI (multilib). 11# introducing support for building for more than one ABI (multilib).
12# 12#
13# Inheriting this eclass sets IUSE=multilib and exports autotools-utils 13# Inheriting this eclass sets the USE flags and exports autotools-utils
14# phase function wrappers which build the package for each supported ABI 14# phase function wrappers which build the package for each supported ABI
15# if the flag is enabled. Otherwise, it works like regular 15# when the relevant flag is enabled. Other than that, it works like
16# autotools-utils. 16# regular autotools-utils.
17# 17#
18# Note that the multilib support requires out-of-source builds to be 18# Note that the multilib support requires out-of-source builds to be
19# enabled. Thus, it is impossible to use AUTOTOOLS_IN_SOURCE_BUILD with 19# enabled. Thus, it is impossible to use AUTOTOOLS_IN_SOURCE_BUILD with
20# it. 20# it.
21 21
22# EAPI=5 is required for meaningful MULTILIB_USEDEP.
22case ${EAPI:-0} in 23case ${EAPI:-0} in
23 2|3|4) ;; 24 5) ;;
24 *) die "EAPI=${EAPI} is not supported" ;; 25 *) die "EAPI=${EAPI} is not supported" ;;
25esac 26esac
26 27
27if [[ ${AUTOTOOLS_IN_SOURCE_BUILD} ]]; then 28if [[ ${AUTOTOOLS_IN_SOURCE_BUILD} ]]; then
28 die "${ECLASS}: multilib support requires out-of-source builds." 29 die "${ECLASS}: multilib support requires out-of-source builds."
29fi 30fi
30 31
31inherit autotools-utils multilib 32inherit autotools-utils multilib-build
32 33
33EXPORT_FUNCTIONS src_configure src_compile src_test src_install 34EXPORT_FUNCTIONS src_configure src_compile src_test src_install
34 35
35IUSE=multilib
36
37# @FUNCTION: autotools-multilib_foreach_abi
38# @USAGE: argv...
39# @DESCRIPTION:
40# If multilib support is enabled, sets the toolchain up for each
41# supported ABI along with the ABI variable and correct
42# AUTOTOOLS_BUILD_DIR, and runs the given commands with them.
43#
44# If multilib support is disabled, it just runs the commands. No setup
45# is done.
46autotools-multilib_foreach_abi() {
47 if use multilib; then
48 local ABI
49 for ABI in $(get_all_abis); do
50 multilib_toolchain_setup "${ABI}"
51 AUTOTOOLS_BUILD_DIR=${S%%/}-${ABI} "${@}"
52 done
53 else
54 "${@}"
55 fi
56}
57
58autotools-multilib_src_configure() { 36autotools-multilib_src_configure() {
59 autotools-multilib_foreach_abi autotools-utils_src_configure 37 multilib_parallel_foreach_abi autotools-utils_src_configure "${@}"
60} 38}
61 39
62autotools-multilib_src_compile() { 40autotools-multilib_src_compile() {
63 autotools-multilib_foreach_abi autotools-utils_src_compile 41 multilib_foreach_abi autotools-utils_src_compile "${@}"
64} 42}
65 43
66autotools-multilib_src_test() { 44autotools-multilib_src_test() {
67 autotools-multilib_foreach_abi autotools-utils_src_test 45 multilib_foreach_abi autotools-utils_src_test "${@}"
68} 46}
69 47
70autotools-multilib_src_install() { 48autotools-multilib_src_install() {
49 autotools-multilib_secure_install() {
50 autotools-utils_src_install "${@}"
51
52 # Make sure all headers are the same for each ABI.
53 multilib_check_headers
54 }
55
71 autotools-multilib_foreach_abi autotools-utils_src_install 56 multilib_foreach_abi autotools-multilib_secure_install "${@}"
72} 57}

Legend:
Removed from v.1.1  
changed lines
  Added in v.1.11

  ViewVC Help
Powered by ViewVC 1.1.20