/[gentoo-x86]/eclass/autotools.eclass
Gentoo

Contents of /eclass/autotools.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.138 - (hide annotations) (download)
Sun May 20 13:01:22 2012 UTC (2 years, 1 month ago) by vapier
Branch: MAIN
Changes since 1.137: +2 -6 lines
change eautomake over to autotools_check_macro now that we cache the results and it should be quick

1 robbat2 1.119 # Copyright 1999-2012 Gentoo Foundation
2 vapier 1.6 # Distributed under the terms of the GNU General Public License v2
3 vapier 1.138 # $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.137 2012/05/20 12:58:23 vapier Exp $
4 vapier 1.76
5     # @ECLASS: autotools.eclass
6     # @MAINTAINER:
7     # base-system@gentoo.org
8     # @BLURB: Regenerates auto* build scripts
9     # @DESCRIPTION:
10     # This eclass is for safely handling autotooled software packages that need to
11     # regenerate their build scripts. All functions will abort in case of errors.
12 azarah 1.1
13 vapier 1.114 # Note: We require GNU m4, as does autoconf. So feel free to use any features
14     # from the GNU version of m4 without worrying about other variants (i.e. BSD).
15    
16 vapier 1.111 if [[ ${___ECLASS_ONCE_AUTOTOOLS} != "recur -_+^+_- spank" ]] ; then
17     ___ECLASS_ONCE_AUTOTOOLS="recur -_+^+_- spank"
18    
19 vapier 1.134 inherit libtool
20 azarah 1.11
21 vapier 1.76 # @ECLASS-VARIABLE: WANT_AUTOCONF
22     # @DESCRIPTION:
23     # The major version of autoconf your package needs
24 vapier 1.94 : ${WANT_AUTOCONF:=latest}
25 vapier 1.76
26     # @ECLASS-VARIABLE: WANT_AUTOMAKE
27     # @DESCRIPTION:
28     # The major version of automake your package needs
29 vapier 1.94 : ${WANT_AUTOMAKE:=latest}
30 flameeyes 1.63
31 vapier 1.105 # @ECLASS-VARIABLE: WANT_LIBTOOL
32     # @DESCRIPTION:
33     # Do you want libtool? Valid values here are "latest" and "none".
34     : ${WANT_LIBTOOL:=latest}
35    
36 robbat2 1.95 # @ECLASS-VARIABLE: _LATEST_AUTOMAKE
37 vapier 1.100 # @INTERNAL
38 robbat2 1.95 # @DESCRIPTION:
39     # CONSTANT!
40 vapier 1.128 # The latest major version/slot of automake available on each arch. #312315
41 flameeyes 1.127 # If a newer slot is stable on any arch, and is NOT reflected in this list,
42 robbat2 1.95 # then circular dependencies may arise during emerge @system bootstraps.
43     # Do NOT change this variable in your ebuilds!
44 vapier 1.128 # If you want to force a newer minor version, you can specify the correct
45     # WANT value by using a colon: <PV>[:<WANT_AUTOMAKE>]
46     _LATEST_AUTOMAKE=( 1.11.1:1.11 )
47 robbat2 1.95
48 vapier 1.40 _automake_atom="sys-devel/automake"
49     _autoconf_atom="sys-devel/autoconf"
50 peper 1.55 if [[ -n ${WANT_AUTOMAKE} ]]; then
51 flameeyes 1.49 case ${WANT_AUTOMAKE} in
52 vapier 1.133 # Even if the package doesn't use automake, we still need to depend
53     # on it because we run aclocal to process m4 macros. This matches
54     # the autoreconf tool, so this requirement is correct. #401605
55     none) ;;
56 flameeyes 1.127 latest)
57 vapier 1.128 # Use SLOT deps if we can. For EAPI=0, we get pretty close.
58     if [[ ${EAPI:-0} != 0 ]] ; then
59     _automake_atom="|| ( `printf '>=sys-devel/automake-%s:%s ' ${_LATEST_AUTOMAKE[@]/:/ }` )"
60 flameeyes 1.127 else
61 vapier 1.128 _automake_atom="|| ( `printf '>=sys-devel/automake-%s ' ${_LATEST_AUTOMAKE[@]/%:*}` )"
62 flameeyes 1.127 fi
63     ;;
64 vapier 1.128 *) _automake_atom="=sys-devel/automake-${WANT_AUTOMAKE}*" ;;
65 flameeyes 1.49 esac
66 vapier 1.64 export WANT_AUTOMAKE
67 flameeyes 1.48 fi
68    
69 vapier 1.45 if [[ -n ${WANT_AUTOCONF} ]] ; then
70 flameeyes 1.41 case ${WANT_AUTOCONF} in
71 vapier 1.67 none) _autoconf_atom="" ;; # some packages don't require autoconf at all
72     2.1) _autoconf_atom="=sys-devel/autoconf-${WANT_AUTOCONF}*" ;;
73 vapier 1.120 # if you change the "latest" version here, change also autotools_env_setup
74 vapier 1.121 latest|2.5) _autoconf_atom=">=sys-devel/autoconf-2.68" ;;
75 vapier 1.106 *) die "Invalid WANT_AUTOCONF value '${WANT_AUTOCONF}'" ;;
76 flameeyes 1.41 esac
77 vapier 1.64 export WANT_AUTOCONF
78 flameeyes 1.41 fi
79 vapier 1.93
80 vapier 1.105 _libtool_atom="sys-devel/libtool"
81     if [[ -n ${WANT_LIBTOOL} ]] ; then
82     case ${WANT_LIBTOOL} in
83     none) _libtool_atom="" ;;
84     latest) ;;
85 vapier 1.106 *) die "Invalid WANT_LIBTOOL value '${WANT_LIBTOOL}'" ;;
86 vapier 1.105 esac
87     export WANT_LIBTOOL
88     fi
89    
90     AUTOTOOLS_DEPEND="${_automake_atom} ${_autoconf_atom} ${_libtool_atom}"
91 flameeyes 1.46 RDEPEND=""
92 vapier 1.93
93     # @ECLASS-VARIABLE: AUTOTOOLS_AUTO_DEPEND
94     # @DESCRIPTION:
95     # Set to 'no' to disable automatically adding to DEPEND. This lets
96     # ebuilds former conditional depends by using ${AUTOTOOLS_DEPEND} in
97     # their own DEPEND string.
98 vapier 1.94 : ${AUTOTOOLS_AUTO_DEPEND:=yes}
99 vapier 1.93 if [[ ${AUTOTOOLS_AUTO_DEPEND} != "no" ]] ; then
100     DEPEND=${AUTOTOOLS_DEPEND}
101     fi
102    
103 vapier 1.40 unset _automake_atom _autoconf_atom
104 azarah 1.11
105 vapier 1.76 # @ECLASS-VARIABLE: AM_OPTS
106 vapier 1.100 # @DEFAULT_UNSET
107 vapier 1.76 # @DESCRIPTION:
108     # Additional options to pass to automake during
109     # eautoreconf call.
110    
111 robbat2 1.122 # @ECLASS-VARIABLE: AT_NOEAUTOMAKE
112     # @DEFAULT_UNSET
113     # @DESCRIPTION:
114 vapier 1.130 # Don't run eautomake command if set to 'yes'; only used to workaround
115     # broken packages. Generally you should, instead, fix the package to
116     # not call AM_INIT_AUTOMAKE if it doesn't actually use automake.
117 robbat2 1.122
118 vapier 1.76 # @ECLASS-VARIABLE: AT_NOELIBTOOLIZE
119 vapier 1.100 # @DEFAULT_UNSET
120 vapier 1.76 # @DESCRIPTION:
121     # Don't run elibtoolize command if set to 'yes',
122     # useful when elibtoolize needs to be ran with
123     # particular options
124 azarah 1.16
125 vapier 1.76 # @ECLASS-VARIABLE: AT_M4DIR
126     # @DESCRIPTION:
127     # Additional director(y|ies) aclocal should search
128 vapier 1.114 : ${AT_M4DIR:=}
129 azarah 1.11
130 vapier 1.113 # @ECLASS-VARIABLE: AT_SYS_M4DIR
131     # @INTERNAL
132     # @DESCRIPTION:
133     # For system integrators, a list of additional aclocal search paths.
134     # This variable gets eval-ed, so you can use variables in the definition
135     # that may not be valid until eautoreconf & friends are run.
136     : ${AT_SYS_M4DIR:=}
137    
138 vapier 1.76 # @FUNCTION: eautoreconf
139     # @DESCRIPTION:
140 azarah 1.17 # This function mimes the behavior of autoreconf, but uses the different
141     # eauto* functions to run the tools. It doesn't accept parameters, but
142     # the directory with include files can be specified with AT_M4DIR variable.
143 jmbsvicetto 1.81 #
144 vapier 1.76 # Should do a full autoreconf - normally what most people will be interested in.
145     # Also should handle additional directories specified by AC_CONFIG_SUBDIRS.
146 azarah 1.17 eautoreconf() {
147 vapier 1.131 local x g
148 jmbsvicetto 1.81
149 flameeyes 1.39 if [[ -z ${AT_NO_RECURSIVE} ]]; then
150     # Take care of subdirs
151 vapier 1.137 for x in $(autotools_check_macro_val AC_CONFIG_SUBDIRS) ; do
152 flameeyes 1.39 if [[ -d ${x} ]] ; then
153 vapier 1.91 pushd "${x}" >/dev/null
154 flameeyes 1.39 AT_NOELIBTOOLIZE="yes" eautoreconf
155 vapier 1.91 popd >/dev/null
156 flameeyes 1.39 fi
157     done
158     fi
159 azarah 1.11
160 vapier 1.137 einfo "Running eautoreconf in '${PWD}' ..."
161    
162     local m4dirs=$(autotools_check_macro_val AC_CONFIG_{AUX,MACRO}_DIR)
163     [[ -n ${m4dirs} ]] && mkdir -p ${m4dirs}
164 flameeyes 1.38
165 vapier 1.130 eaclocal
166 vapier 1.132 if grep -q '^AM_GNU_GETTEXT_VERSION' configure.?? ; then
167     eautopoint --force
168     fi
169 vapier 1.135 _elibtoolize --install --copy --force
170 vapier 1.130 eautoconf
171     eautoheader
172 robbat2 1.122 [[ ${AT_NOEAUTOMAKE} != "yes" ]] && FROM_EAUTORECONF="yes" eautomake ${AM_OPTS}
173 azarah 1.1
174 flameeyes 1.32 [[ ${AT_NOELIBTOOLIZE} == "yes" ]] && return 0
175    
176 flameeyes 1.30 # Call it here to prevent failures due to elibtoolize called _before_
177 vapier 1.84 # eautoreconf. We set $S because elibtoolize runs on that #265319
178 vapier 1.110 S=${PWD} elibtoolize --force
179 flameeyes 1.30
180 flameeyes 1.21 return 0
181 azarah 1.12 }
182    
183 vapier 1.107 # @FUNCTION: eaclocal_amflags
184 vapier 1.76 # @DESCRIPTION:
185 vapier 1.107 # Extract the ACLOCAL_AMFLAGS value from the Makefile.am and try to handle
186     # (most) of the crazy crap that people throw at us.
187     eaclocal_amflags() {
188     local aclocal_opts amflags_file
189 azarah 1.12
190 vapier 1.74 for amflags_file in GNUmakefile.am Makefile.am GNUmakefile.in Makefile.in ; do
191     [[ -e ${amflags_file} ]] || continue
192 vapier 1.103 # setup the env in case the pkg does something crazy
193     # in their ACLOCAL_AMFLAGS. like run a shell script
194 vapier 1.107 # which turns around and runs autotools. #365401
195     # or split across multiple lines. #383525
196 vapier 1.103 autotools_env_setup
197 vapier 1.107 aclocal_opts=$(sed -n \
198     "/^ACLOCAL_AMFLAGS[[:space:]]*=/{ \
199     # match the first line
200     s:[^=]*=::p; \
201     # then gobble up all escaped lines
202     : nextline /\\\\$/{ n; p; b nextline; } \
203     }" ${amflags_file})
204     eval aclocal_opts=\""${aclocal_opts}"\"
205 vapier 1.74 break
206     done
207    
208 vapier 1.107 echo ${aclocal_opts}
209     }
210    
211     # @FUNCTION: eaclocal
212     # @DESCRIPTION:
213     # These functions runs the autotools using autotools_run_tool with the
214     # specified parametes. The name of the tool run is the same of the function
215     # without e prefix.
216     # They also force installing the support files for safety.
217     # Respects AT_M4DIR for additional directories to search for macro's.
218     eaclocal() {
219 flameeyes 1.22 [[ ! -f aclocal.m4 || -n $(grep -e 'generated.*by aclocal' aclocal.m4) ]] && \
220 vapier 1.115 autotools_run_tool --at-m4flags aclocal "$@" $(eaclocal_amflags)
221 azarah 1.12 }
222    
223 vapier 1.76 # @FUNCTION: _elibtoolize
224     # @DESCRIPTION:
225 vapier 1.135 # Runs libtoolize. If --install is the first arg, automatically drop it if
226     # the active libtool version doesn't support it.
227     #
228     # Note the '_' prefix .. to not collide with elibtoolize() from libtool.eclass.
229 azarah 1.12 _elibtoolize() {
230 flameeyes 1.34 # Check if we should run libtoolize (AM_PROG_LIBTOOL is an older macro,
231     # check for both it and the current AC_PROG_LIBTOOL)
232 vapier 1.77 [[ -n $(autotools_check_macro AC_PROG_LIBTOOL AM_PROG_LIBTOOL LT_INIT) ]] || return 0
233 azarah 1.19
234 vapier 1.135 local LIBTOOLIZE=${LIBTOOLIZE:-libtoolize}
235     type -P glibtoolize && LIBTOOLIZE=glibtoolize
236    
237     [[ -f GNUmakefile.am || -f Makefile.am ]] && set -- "$@" --automake
238     if [[ $1 == "--install" ]] ; then
239     ${LIBTOOLIZE} -n --install >& /dev/null || shift
240     fi
241 swegener 1.20
242 vapier 1.135 autotools_run_tool ${LIBTOOLIZE} "$@" ${opts}
243 flameeyes 1.15
244 azarah 1.12 # Need to rerun aclocal
245     eaclocal
246 azarah 1.11 }
247 azarah 1.1
248 vapier 1.76 # @FUNCTION: eautoheader
249     # @DESCRIPTION:
250     # Runs autoheader.
251 azarah 1.11 eautoheader() {
252 azarah 1.12 # Check if we should run autoheader
253     [[ -n $(autotools_check_macro "AC_CONFIG_HEADERS") ]] || return 0
254 vapier 1.115 autotools_run_tool --at-no-fail --at-m4flags autoheader "$@"
255 azarah 1.11 }
256 azarah 1.1
257 vapier 1.76 # @FUNCTION: eautoconf
258     # @DESCRIPTION:
259     # Runs autoconf.
260 azarah 1.11 eautoconf() {
261 azarah 1.12 if [[ ! -f configure.ac && ! -f configure.in ]] ; then
262     echo
263 vapier 1.91 eerror "No configure.{ac,in} present in '${PWD}'!"
264 azarah 1.12 echo
265     die "No configure.{ac,in} present!"
266     fi
267    
268 vapier 1.115 autotools_run_tool --at-m4flags autoconf "$@"
269 azarah 1.11 }
270 azarah 1.1
271 vapier 1.76 # @FUNCTION: eautomake
272     # @DESCRIPTION:
273     # Runs automake.
274 azarah 1.11 eautomake() {
275 flameeyes 1.24 local extra_opts
276 flameeyes 1.70 local makefile_name
277 flameeyes 1.24
278 vapier 1.98 # Run automake if:
279     # - a Makefile.am type file exists
280 vapier 1.117 # - the configure script is using the AM_INIT_AUTOMAKE directive
281     for makefile_name in {GNUmakefile,{M,m}akefile}.am "" ; do
282 vapier 1.98 [[ -f ${makefile_name} ]] && break
283     done
284    
285 vapier 1.117 if [[ -z ${makefile_name} ]] ; then
286 vapier 1.138 [[ -n $(autotools_check_macro AM_INIT_AUTOMAKE) ]] || return 0
287 flameeyes 1.24
288 vapier 1.98 elif [[ -z ${FROM_EAUTORECONF} && -f ${makefile_name%.am}.in ]]; then
289 flameeyes 1.35 local used_automake
290     local installed_automake
291    
292 vapier 1.87 installed_automake=$(WANT_AUTOMAKE= automake --version | head -n 1 | \
293 flameeyes 1.35 sed -e 's:.*(GNU automake) ::')
294 vapier 1.98 used_automake=$(head -n 1 < ${makefile_name%.am}.in | \
295 flameeyes 1.35 sed -e 's:.*by automake \(.*\) from .*:\1:')
296    
297     if [[ ${installed_automake} != ${used_automake} ]]; then
298     einfo "Automake used for the package (${used_automake}) differs from"
299     einfo "the installed version (${installed_automake})."
300     eautoreconf
301 flameeyes 1.36 return 0
302 flameeyes 1.35 fi
303     fi
304    
305 vapier 1.109 [[ -f INSTALL && -f AUTHORS && -f ChangeLog && -f NEWS && -f README ]] \
306 flameeyes 1.24 || extra_opts="${extra_opts} --foreign"
307    
308 flameeyes 1.14 # --force-missing seems not to be recognized by some flavours of automake
309 flameeyes 1.24 autotools_run_tool automake --add-missing --copy ${extra_opts} "$@"
310 azarah 1.1 }
311    
312 vapier 1.90 # @FUNCTION: eautopoint
313     # @DESCRIPTION:
314     # Runs autopoint (from the gettext package).
315     eautopoint() {
316     autotools_run_tool autopoint "$@"
317     }
318    
319 vapier 1.118 # @FUNCTION: config_rpath_update
320     # @USAGE: [destination]
321     # @DESCRIPTION:
322     # Some packages utilize the config.rpath helper script, but don't
323     # use gettext directly. So we have to copy it in manually since
324     # we can't let `autopoint` do it for us.
325     config_rpath_update() {
326     local dst src=$(type -P gettext | sed 's:bin/gettext:share/gettext/config.rpath:')
327    
328     [[ $# -eq 0 ]] && set -- $(find -name config.rpath)
329     [[ $# -eq 0 ]] && return 0
330    
331     einfo "Updating all config.rpath files"
332     for dst in "$@" ; do
333     einfo " ${dst}"
334     cp "${src}" "${dst}" || die
335     done
336     }
337    
338 vapier 1.137 # @FUNCTION: autotools_env_setup
339     # @INTERNAL
340     # @DESCRIPTION:
341     # Process the WANT_AUTO{CONF,MAKE} flags.
342 vapier 1.103 autotools_env_setup() {
343 vapier 1.120 # We do the "latest" → version switch here because it solves
344 flameeyes 1.86 # possible order problems, see bug #270010 as an example.
345 flameeyes 1.96 if [[ ${WANT_AUTOMAKE} == "latest" ]]; then
346 vapier 1.128 local pv
347     for pv in ${_LATEST_AUTOMAKE[@]/#*:} ; do
348     # has_version respects ROOT, but in this case, we don't want it to,
349     # thus "ROOT=/" prefix:
350     ROOT=/ has_version "=sys-devel/automake-${pv}*" && export WANT_AUTOMAKE="${pv}"
351     done
352 flameeyes 1.96 [[ ${WANT_AUTOMAKE} == "latest" ]] && \
353     die "Cannot find the latest automake! Tried ${_LATEST_AUTOMAKE}"
354     fi
355 flameeyes 1.86 [[ ${WANT_AUTOCONF} == "latest" ]] && export WANT_AUTOCONF=2.5
356 vapier 1.103 }
357 vapier 1.137
358     # @FUNCTION: autotools_run_tool
359     # @USAGE: [--at-no-fail] [--at-m4flags] <autotool> [tool-specific flags]
360     # @INTERNAL
361     # @DESCRIPTION:
362     # Run the specified autotool helper, but do logging and error checking
363     # around it in the process.
364 vapier 1.103 autotools_run_tool() {
365 vapier 1.115 # Process our own internal flags first
366     local autofail=true m4flags=false
367     while [[ -n $1 ]] ; do
368     case $1 in
369     --at-no-fail) autofail=false;;
370     --at-m4flags) m4flags=true;;
371     # whatever is left goes to the actual tool
372     *) break;;
373     esac
374     shift
375     done
376    
377 vapier 1.116 if [[ ${EBUILD_PHASE} != "unpack" && ${EBUILD_PHASE} != "prepare" ]]; then
378     ewarn "QA Warning: running $1 in ${EBUILD_PHASE} phase"
379     fi
380    
381 vapier 1.103 autotools_env_setup
382 flameeyes 1.86
383 vapier 1.85 local STDERR_TARGET="${T}/$1.out"
384     # most of the time, there will only be one run, but if there are
385     # more, make sure we get unique log filenames
386     if [[ -e ${STDERR_TARGET} ]] ; then
387 vapier 1.104 local i=1
388     while :; do
389     STDERR_TARGET="${T}/$1-${i}.out"
390     [[ -e ${STDERR_TARGET} ]] || break
391     : $(( i++ ))
392     done
393 vapier 1.85 fi
394 azarah 1.17
395 vapier 1.115 if ${m4flags} ; then
396 vapier 1.116 set -- "${1}" $(autotools_m4dir_include) "${@:2}" $(autotools_m4sysdir_include)
397 vapier 1.115 fi
398    
399 vapier 1.85 printf "***** $1 *****\n***** PWD: ${PWD}\n***** $*\n\n" > "${STDERR_TARGET}"
400 azarah 1.17
401 azarah 1.27 ebegin "Running $@"
402 vapier 1.85 "$@" >> "${STDERR_TARGET}" 2>&1
403 vapier 1.115 if ! eend $? && ${autofail} ; then
404 azarah 1.17 echo
405     eerror "Failed Running $1 !"
406     eerror
407     eerror "Include in your bugreport the contents of:"
408     eerror
409 vapier 1.85 eerror " ${STDERR_TARGET}"
410 azarah 1.17 echo
411     die "Failed Running $1 !"
412     fi
413     }
414    
415     # Internal function to check for support
416 vapier 1.137
417     # Keep a list of all the macros we might use so that we only
418     # have to run the trace code once. Order doesn't matter.
419     ALL_AUTOTOOLS_MACROS=(
420     AC_PROG_LIBTOOL AM_PROG_LIBTOOL LT_INIT
421     AC_CONFIG_HEADERS
422     AC_CONFIG_SUBDIRS
423     AC_CONFIG_AUX_DIR AC_CONFIG_MACRO_DIR
424     AM_INIT_AUTOMAKE
425     )
426 azarah 1.17 autotools_check_macro() {
427 vapier 1.77 [[ -f configure.ac || -f configure.in ]] || return 0
428 vapier 1.137
429     # We can run in multiple dirs, so we have to cache the trace
430     # data in $PWD rather than an env var.
431     local trace_file=".__autoconf_trace_data"
432     if [[ ! -e ${trace_file} ]] || [[ aclocal.m4 -nt ${trace_file} ]] ; then
433     WANT_AUTOCONF="2.5" autoconf \
434     $(autotools_m4dir_include) \
435     ${ALL_AUTOTOOLS_MACROS[@]/#/--trace=} > ${trace_file} 2>/dev/null
436     fi
437    
438     local macro args=()
439 vapier 1.77 for macro ; do
440 vapier 1.137 has ${macro} ${ALL_AUTOTOOLS_MACROS[@]} || die "internal error: add ${macro} to ALL_AUTOTOOLS_MACROS"
441     args+=( -e ":${macro}:" )
442 vapier 1.77 done
443 vapier 1.137 grep "${args[@]}" ${trace_file}
444 azarah 1.17 }
445    
446 vapier 1.136 # @FUNCTION: autotools_check_macro_val
447     # @USAGE: <macro> [macros]
448     # @INTERNAL
449     # @DESCRIPTION:
450     # Look for a macro and extract its value.
451 vapier 1.112 autotools_check_macro_val() {
452 vapier 1.136 local macro scan_out
453 vapier 1.112
454 vapier 1.136 for macro ; do
455     autotools_check_macro "${macro}" | \
456     gawk -v macro="${macro}" \
457     '($0 !~ /^[[:space:]]*(#|dnl)/) {
458     if (match($0, macro ":(.*)$", res))
459     print res[1]
460     }' | uniq
461     done
462 azarah 1.16
463 azarah 1.17 return 0
464 azarah 1.11 }
465 azarah 1.17
466 vapier 1.115 _autotools_m4dir_include() {
467 vapier 1.113 local x include_opts
468 flameeyes 1.102
469 vapier 1.115 for x in "$@" ; do
470     case ${x} in
471     # We handle it below
472     -I) ;;
473 flameeyes 1.102 *)
474     [[ ! -d ${x} ]] && ewarn "autotools.eclass: '${x}' does not exist"
475 vapier 1.113 include_opts+=" -I ${x}"
476 flameeyes 1.102 ;;
477     esac
478     done
479    
480 vapier 1.113 echo ${include_opts}
481 flameeyes 1.102 }
482 vapier 1.115 autotools_m4dir_include() { _autotools_m4dir_include ${AT_M4DIR} ; }
483     autotools_m4sysdir_include() { _autotools_m4dir_include $(eval echo ${AT_SYS_M4DIR}) ; }
484 vapier 1.111
485     fi

  ViewVC Help
Powered by ViewVC 1.1.20