/[gentoo-x86]/eclass/autotools.eclass
Gentoo

Diff of /eclass/autotools.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.4 Revision 1.139
1# Copyright 1999-2002 Gentoo Technologies, Inc. 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License, v2 or later 2# Distributed under the terms of the GNU General Public License v2
3# Author: Martin Schlemmer <azarah@gentoo.org>
4# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.4 2002/07/26 21:50:14 danarmak Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.139 2012/05/21 17:40:44 vapier Exp $
5# The autotools eclass enables building of the apps that needs the latest autconf/automake. 4
5# @ECLASS: autotools.eclass
6# @MAINTAINER:
7# base-system@gentoo.org
8# @BLURB: Regenerates auto* build scripts
9# @DESCRIPTION:
10# This eclass is for safely handling autotooled software packages that need to
11# regenerate their build scripts. All functions will abort in case of errors.
12
13# Note: We require GNU m4, as does autoconf. So feel free to use any features
14# from the GNU version of m4 without worrying about other variants (i.e. BSD).
15
16if [[ ${___ECLASS_ONCE_AUTOTOOLS} != "recur -_+^+_- spank" ]] ; then
17___ECLASS_ONCE_AUTOTOOLS="recur -_+^+_- spank"
18
19inherit libtool
20
21# @ECLASS-VARIABLE: WANT_AUTOCONF
22# @DESCRIPTION:
23# The major version of autoconf your package needs
24: ${WANT_AUTOCONF:=latest}
25
26# @ECLASS-VARIABLE: WANT_AUTOMAKE
27# @DESCRIPTION:
28# The major version of automake your package needs
29: ${WANT_AUTOMAKE:=latest}
30
31# @ECLASS-VARIABLE: WANT_LIBTOOL
32# @DESCRIPTION:
33# Do you want libtool? Valid values here are "latest" and "none".
34: ${WANT_LIBTOOL:=latest}
35
36# @ECLASS-VARIABLE: _LATEST_AUTOMAKE
37# @INTERNAL
38# @DESCRIPTION:
39# CONSTANT!
40# The latest major version/slot of automake available on each arch. #312315
41# If a newer slot is stable on any arch, and is NOT reflected in this list,
42# then circular dependencies may arise during emerge @system bootstraps.
43# Do NOT change this variable in your ebuilds!
44# If you want to force a newer minor version, you can specify the correct
45# WANT value by using a colon: <PV>[:<WANT_AUTOMAKE>]
46_LATEST_AUTOMAKE=( 1.11.1:1.11 )
47
48_automake_atom="sys-devel/automake"
49_autoconf_atom="sys-devel/autoconf"
50if [[ -n ${WANT_AUTOMAKE} ]]; then
51 case ${WANT_AUTOMAKE} in
52 # Even if the package doesn't use automake, we still need to depend
53 # on it because we run aclocal to process m4 macros. This matches
54 # the autoreconf tool, so this requirement is correct. #401605
55 none) ;;
56 latest)
57 # Use SLOT deps if we can. For EAPI=0, we get pretty close.
58 if [[ ${EAPI:-0} != 0 ]] ; then
59 _automake_atom="|| ( `printf '>=sys-devel/automake-%s:%s ' ${_LATEST_AUTOMAKE[@]/:/ }` )"
60 else
61 _automake_atom="|| ( `printf '>=sys-devel/automake-%s ' ${_LATEST_AUTOMAKE[@]/%:*}` )"
62 fi
63 ;;
64 *) _automake_atom="=sys-devel/automake-${WANT_AUTOMAKE}*" ;;
65 esac
66 export WANT_AUTOMAKE
67fi
68
69if [[ -n ${WANT_AUTOCONF} ]] ; then
70 case ${WANT_AUTOCONF} in
71 none) _autoconf_atom="" ;; # some packages don't require autoconf at all
72 2.1) _autoconf_atom="=sys-devel/autoconf-${WANT_AUTOCONF}*" ;;
73 # if you change the "latest" version here, change also autotools_env_setup
74 latest|2.5) _autoconf_atom=">=sys-devel/autoconf-2.68" ;;
75 *) die "Invalid WANT_AUTOCONF value '${WANT_AUTOCONF}'" ;;
76 esac
77 export WANT_AUTOCONF
78fi
79
80_libtool_atom="sys-devel/libtool"
81if [[ -n ${WANT_LIBTOOL} ]] ; then
82 case ${WANT_LIBTOOL} in
83 none) _libtool_atom="" ;;
84 latest) ;;
85 *) die "Invalid WANT_LIBTOOL value '${WANT_LIBTOOL}'" ;;
86 esac
87 export WANT_LIBTOOL
88fi
89
90AUTOTOOLS_DEPEND="${_automake_atom} ${_autoconf_atom} ${_libtool_atom}"
91RDEPEND=""
92
93# @ECLASS-VARIABLE: AUTOTOOLS_AUTO_DEPEND
94# @DESCRIPTION:
95# Set to 'no' to disable automatically adding to DEPEND. This lets
96# ebuilds former conditional depends by using ${AUTOTOOLS_DEPEND} in
97# their own DEPEND string.
98: ${AUTOTOOLS_AUTO_DEPEND:=yes}
99if [[ ${AUTOTOOLS_AUTO_DEPEND} != "no" ]] ; then
100 DEPEND=${AUTOTOOLS_DEPEND}
101fi
102
103unset _automake_atom _autoconf_atom
104
105# @ECLASS-VARIABLE: AM_OPTS
106# @DEFAULT_UNSET
107# @DESCRIPTION:
108# Additional options to pass to automake during
109# eautoreconf call.
110
111# @ECLASS-VARIABLE: AT_NOEAUTOMAKE
112# @DEFAULT_UNSET
113# @DESCRIPTION:
114# Don't run eautomake command if set to 'yes'; only used to workaround
115# broken packages. Generally you should, instead, fix the package to
116# not call AM_INIT_AUTOMAKE if it doesn't actually use automake.
117
118# @ECLASS-VARIABLE: AT_NOELIBTOOLIZE
119# @DEFAULT_UNSET
120# @DESCRIPTION:
121# Don't run elibtoolize command if set to 'yes',
122# useful when elibtoolize needs to be ran with
123# particular options
124
125# @ECLASS-VARIABLE: AT_M4DIR
126# @DESCRIPTION:
127# Additional director(y|ies) aclocal should search
128: ${AT_M4DIR:=}
129
130# @ECLASS-VARIABLE: AT_SYS_M4DIR
131# @INTERNAL
132# @DESCRIPTION:
133# For system integrators, a list of additional aclocal search paths.
134# This variable gets eval-ed, so you can use variables in the definition
135# that may not be valid until eautoreconf & friends are run.
136: ${AT_SYS_M4DIR:=}
137
138# @FUNCTION: eautoreconf
139# @DESCRIPTION:
140# This function mimes the behavior of autoreconf, but uses the different
141# eauto* functions to run the tools. It doesn't accept parameters, but
142# the directory with include files can be specified with AT_M4DIR variable.
6# 143#
7# NOTES: 144# Should do a full autoreconf - normally what most people will be interested in.
145# Also should handle additional directories specified by AC_CONFIG_SUBDIRS.
146eautoreconf() {
147 local x g
148
149 if [[ -z ${AT_NO_RECURSIVE} ]]; then
150 # Take care of subdirs
151 for x in $(autotools_check_macro_val AC_CONFIG_SUBDIRS) ; do
152 if [[ -d ${x} ]] ; then
153 pushd "${x}" >/dev/null
154 AT_NOELIBTOOLIZE="yes" eautoreconf
155 popd >/dev/null
156 fi
157 done
158 fi
159
160 einfo "Running eautoreconf in '${PWD}' ..."
161
162 local m4dirs=$(autotools_check_macro_val AC_CONFIG_{AUX,MACRO}_DIR)
163 [[ -n ${m4dirs} ]] && mkdir -p ${m4dirs}
164
165 # Run all the tools before aclocal so we can gather the .m4 files.
166 local i tools=(
167 # <tool> <was run> <command>
168 gettext false "eautopoint --force"
169 libtool false "_elibtoolize --install --copy --force"
170 )
171 for (( i = 0; i < ${#tools[@]}; i += 3 )) ; do
172 if _at_uses_${tools[i]} ; then
173 tools[i+1]=true
174 ${tools[i+2]}
175 fi
176 done
177
178 # Generate aclocal.m4 with our up-to-date m4 files.
179 local rerun_aclocal=false
180 eaclocal
181
182 # Check to see if we had macros expanded by other macros or in other
183 # m4 files that we couldn't detect early. This is uncommon, but some
184 # packages do this, so we have to handle it correctly.
185 for (( i = 0; i < ${#tools[@]}; i += 3 )) ; do
186 if ! ${tools[i+1]} && _at_uses_${tools[i]} ; then
187 ${tools[i+2]}
188 rerun_aclocal=true
189 fi
190 done
191 ${rerun_aclocal} && eaclocal
192
193 eautoconf
194 eautoheader
195 [[ ${AT_NOEAUTOMAKE} != "yes" ]] && FROM_EAUTORECONF="yes" eautomake ${AM_OPTS}
196
197 [[ ${AT_NOELIBTOOLIZE} == "yes" ]] && return 0
198
199 # Call it here to prevent failures due to elibtoolize called _before_
200 # eautoreconf. We set $S because elibtoolize runs on that #265319
201 S=${PWD} elibtoolize --force
202
203 return 0
204}
205
206# @FUNCTION: _at_uses_pkg
207# @USAGE: <macros>
208# @INTERNAL
209# See if the specified macros are enabled.
210_at_uses_pkg() {
211 if [[ -e aclocal.m4 ]] ; then
212 # If aclocal.m4 exists, trust the trace data.
213 [[ -n $(autotools_check_macro "${@}") ]]
214 else
215 # If aclocal.m4 hasn't been generated yet, cheat, but be conservative.
216 local macro args=()
217 for macro ; do
218 args+=( -e "^[[:space:]]*${macro}\>" )
219 done
220 egrep -q "${args[@]}" configure.??
221 fi
222}
223_at_uses_gettext() { _at_uses_pkg AM_GNU_GETTEXT_VERSION; }
224_at_uses_autoheader() { _at_uses_pkg AC_CONFIG_HEADERS; }
225_at_uses_automake() { _at_uses_pkg AM_INIT_AUTOMAKE; }
226_at_uses_libtool() { _at_uses_pkg A{C,M}_PROG_LIBTOOL LT_INIT; }
227
228# @FUNCTION: eaclocal_amflags
229# @DESCRIPTION:
230# Extract the ACLOCAL_AMFLAGS value from the Makefile.am and try to handle
231# (most) of the crazy crap that people throw at us.
232eaclocal_amflags() {
233 local aclocal_opts amflags_file
234
235 for amflags_file in GNUmakefile.am Makefile.am GNUmakefile.in Makefile.in ; do
236 [[ -e ${amflags_file} ]] || continue
237 # setup the env in case the pkg does something crazy
238 # in their ACLOCAL_AMFLAGS. like run a shell script
239 # which turns around and runs autotools. #365401
240 # or split across multiple lines. #383525
241 autotools_env_setup
242 aclocal_opts=$(sed -n \
243 "/^ACLOCAL_AMFLAGS[[:space:]]*=/{ \
244 # match the first line
245 s:[^=]*=::p; \
246 # then gobble up all escaped lines
247 : nextline /\\\\$/{ n; p; b nextline; } \
248 }" ${amflags_file})
249 eval aclocal_opts=\""${aclocal_opts}"\"
250 break
251 done
252
253 echo ${aclocal_opts}
254}
255
256# @FUNCTION: eaclocal
257# @DESCRIPTION:
258# These functions runs the autotools using autotools_run_tool with the
259# specified parametes. The name of the tool run is the same of the function
260# without e prefix.
261# They also force installing the support files for safety.
262# Respects AT_M4DIR for additional directories to search for macro's.
263eaclocal() {
264 [[ ! -f aclocal.m4 || -n $(grep -e 'generated.*by aclocal' aclocal.m4) ]] && \
265 autotools_run_tool --at-m4flags aclocal "$@" $(eaclocal_amflags)
266}
267
268# @FUNCTION: _elibtoolize
269# @DESCRIPTION:
270# Runs libtoolize. If --install is the first arg, automatically drop it if
271# the active libtool version doesn't support it.
8# 272#
9# This eclass was made to bridge the incompadibility problem of autoconf-2.13, 273# Note the '_' prefix .. to not collide with elibtoolize() from libtool.eclass.
10# autoconf-2.5x and automake-1.4x, automake-1.5x. Most packages needs 274_elibtoolize() {
11# autoconf-2.13 and automake-1.4x, but cannot work with the latest versions 275 local LIBTOOLIZE=${LIBTOOLIZE:-libtoolize}
12# of these packages due to incompadibility, thus when we have a package that 276 type -P glibtoolize && LIBTOOLIZE=glibtoolize
13# needs the latest versions of automake and autoconf, it begins to get a
14# problem.
15#
16#
17# Commented Example:
18#
19# The following is a commented template for how to use this eclass:
20#
21# #<cut here>
22# # Copyright 1999-2002 Gentoo Technologies, Inc.
23# # Distributed under the terms of the GNU General Public License, v2 or later
24# # Maintainer: John Doe <john@foo.com>
25# # $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.4 2002/07/26 21:50:14 danarmak Exp $
26#
27# # If you need to set the versions different from in here, it *must*
28# # be done before inherit.eclass is sourced
29# #ACONFVER=2.52f
30# #AMAKEVER=1.5b
31#
32# # Source inherit.eclass and inherit AutoTools
33# . /usr/portage/eclass/inherit.eclass
34# inherit autotools
35#
36# # This is pretty standard.
37# S=${WORKDIR}/${P}
38# DESCRIPTION="My Application"
39#
40# # Here you *NEED* to have $SRC_URI as a source url to include the automake
41# # and autoconf source tarballs
42# SRC_URI="${SRC_URI}
43# http://download.foo.com/files/${P}.tar.gz"
44#
45# HOMEPAGE="http://www.foo.com/"
46#
47# # Here you *NEED* to have "$DEPEND" as an depend to include the dependancies
48# # of automake and autoconf.
49# DEPEND="${DEPEND}
50# foo-libs/libfoo"
51#
52# src_compile() {
53#
54# # This will install automake and autoconf in a tempory directory and
55# # setup the environment. Do not forget!!!!!!!
56# install_autotools
57#
58# # Now like normal
59# ./configure --host=${CHOST} \
60# --prefix=/usr || die
61# emake || die
62# }
63#
64# src_install() {
65#
66# # Still pretty standard to how you would normally do it
67# make DESTDIR=${D} install || die
68# dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
69# }
70# #<cut here>
71#
72 277
278 [[ -f GNUmakefile.am || -f Makefile.am ]] && set -- "$@" --automake
279 if [[ $1 == "--install" ]] ; then
280 ${LIBTOOLIZE} -n --install >& /dev/null || shift
281 fi
73 282
74ECLASS=autotools 283 autotools_run_tool ${LIBTOOLIZE} "$@" ${opts}
75INHERITED="$INHERITED $ECLASS" 284}
76 285
77#[ -z "$ACONFVER" ] && ACONFVER=2.52f 286# @FUNCTION: eautoheader
78#[ -z "$AMAKEVER" ] && AMAKEVER=1.5b 287# @DESCRIPTION:
79[ -z "$ACONFVER" ] && die "!!! You need to set \$ACONFVER *before* inheriting the eclass !!!" 288# Runs autoheader.
80[ -z "$AMAKEVER" ] && die "!!! You need to set \$AMAKEVER *before* inheriting the eclass !!!" 289eautoheader() {
290 _at_uses_autoheader || return 0
291 autotools_run_tool --at-no-fail --at-m4flags autoheader "$@"
292}
81 293
82DESCRIPTION="Based on the $ECLASS eclass" 294# @FUNCTION: eautoconf
83#ASRC_URI="ftp://ftp.gnu.org/gnu/autoconf/autoconf-${ACONFVER}.tar.bz2 295# @DESCRIPTION:
84# ftp://alpha.gnu.org/gnu/autoconf/autoconf-${ACONFVER}.tar.bz2 296# Runs autoconf.
85# ftp://ftp.gnu.org/gnu/automake/automake-${AMAKEVER}.tar.bz2 297eautoconf() {
86# ftp://alpha.gnu.org/gnu/automake/automake-${AMAKEVER}.tar.bz2" 298 if [[ ! -f configure.ac && ! -f configure.in ]] ; then
87SRC_URI="ftp://ftp.gnu.org/gnu/autoconf/autoconf-${ACONFVER}.tar.bz2
88 ftp://alpha.gnu.org/gnu/autoconf/autoconf-${ACONFVER}.tar.bz2
89 ftp://ftp.gnu.org/gnu/automake/automake-${AMAKEVER}.tar.bz2
90 ftp://alpha.gnu.org/gnu/automake/automake-${AMAKEVER}.tar.bz2"
91
92DEPEND="sys-devel/make
93 sys-devel/perl
94 >=sys-devel/m4-1.4o-r2"
95
96
97AUTO_S="${WORKDIR}"
98AUTO_D="${T}/autotools"
99
100fetch_autotools() {
101
102 local y
103 for y in ${ASRC_URI}
104 do
105 if [ ! -e ${DISTDIR}/${y##*/} ]
106 then
107 echo ">>> Fetching ${y##*/}..."
108 echo 299 echo
109 local x 300 eerror "No configure.{ac,in} present in '${PWD}'!"
110 local _SRC_URI
111 for x in ${GENTOO_MIRRORS}
112 do
113 _SRC_URI="${_SRC_URI} ${x}/distfiles/${y##*/}"
114 done
115 _SRC_URI="${_SRC_URI} `queryhost.sh "${SRC_URI}"`"
116 for x in ${_SRC_URI}
117 do
118 if [ ! -e ${DISTDIR}/${y##*/} ]
119 then
120 if [ "${y##*/}" = "${x##*/}" ]
121 then
122 echo ">>> Trying site ${x}..."
123 eval "${FETCHCOMMAND}"
124 fi
125 fi
126 done
127 if [ ! -e ${DISTDIR}/${y##*/} ]
128 then
129 echo '!!!'" Couldn't download ${y##*/} needed by autotools.eclass. Aborting."
130 exit 1
131 fi
132 echo 301 echo
133 fi 302 die "No configure.{ac,in} present!"
303 fi
304
305 autotools_run_tool --at-m4flags autoconf "$@"
306}
307
308# @FUNCTION: eautomake
309# @DESCRIPTION:
310# Runs automake.
311eautomake() {
312 local extra_opts
313 local makefile_name
314
315 # Run automake if:
316 # - a Makefile.am type file exists
317 # - the configure script is using the AM_INIT_AUTOMAKE directive
318 for makefile_name in {GNUmakefile,{M,m}akefile}.am "" ; do
319 [[ -f ${makefile_name} ]] && break
320 done
321
322 if [[ -z ${makefile_name} ]] ; then
323 _at_uses_automake || return 0
324
325 elif [[ -z ${FROM_EAUTORECONF} && -f ${makefile_name%.am}.in ]]; then
326 local used_automake
327 local installed_automake
328
329 installed_automake=$(WANT_AUTOMAKE= automake --version | head -n 1 | \
330 sed -e 's:.*(GNU automake) ::')
331 used_automake=$(head -n 1 < ${makefile_name%.am}.in | \
332 sed -e 's:.*by automake \(.*\) from .*:\1:')
333
334 if [[ ${installed_automake} != ${used_automake} ]]; then
335 einfo "Automake used for the package (${used_automake}) differs from"
336 einfo "the installed version (${installed_automake})."
337 eautoreconf
338 return 0
339 fi
340 fi
341
342 [[ -f INSTALL && -f AUTHORS && -f ChangeLog && -f NEWS && -f README ]] \
343 || extra_opts="${extra_opts} --foreign"
344
345 # --force-missing seems not to be recognized by some flavours of automake
346 autotools_run_tool automake --add-missing --copy ${extra_opts} "$@"
347}
348
349# @FUNCTION: eautopoint
350# @DESCRIPTION:
351# Runs autopoint (from the gettext package).
352eautopoint() {
353 autotools_run_tool autopoint "$@"
354}
355
356# @FUNCTION: config_rpath_update
357# @USAGE: [destination]
358# @DESCRIPTION:
359# Some packages utilize the config.rpath helper script, but don't
360# use gettext directly. So we have to copy it in manually since
361# we can't let `autopoint` do it for us.
362config_rpath_update() {
363 local dst src=$(type -P gettext | sed 's:bin/gettext:share/gettext/config.rpath:')
364
365 [[ $# -eq 0 ]] && set -- $(find -name config.rpath)
366 [[ $# -eq 0 ]] && return 0
367
368 einfo "Updating all config.rpath files"
369 for dst in "$@" ; do
370 einfo " ${dst}"
371 cp "${src}" "${dst}" || die
372 done
373}
374
375# @FUNCTION: autotools_env_setup
376# @INTERNAL
377# @DESCRIPTION:
378# Process the WANT_AUTO{CONF,MAKE} flags.
379autotools_env_setup() {
380 # We do the "latest" → version switch here because it solves
381 # possible order problems, see bug #270010 as an example.
382 if [[ ${WANT_AUTOMAKE} == "latest" ]]; then
383 local pv
384 for pv in ${_LATEST_AUTOMAKE[@]/#*:} ; do
385 # has_version respects ROOT, but in this case, we don't want it to,
386 # thus "ROOT=/" prefix:
387 ROOT=/ has_version "=sys-devel/automake-${pv}*" && export WANT_AUTOMAKE="${pv}"
134 done 388 done
389 [[ ${WANT_AUTOMAKE} == "latest" ]] && \
390 die "Cannot find the latest automake! Tried ${_LATEST_AUTOMAKE}"
391 fi
392 [[ ${WANT_AUTOCONF} == "latest" ]] && export WANT_AUTOCONF=2.5
135} 393}
136 394
137unpack_autotools() { 395# @FUNCTION: autotools_run_tool
138 396# @USAGE: [--at-no-fail] [--at-m4flags] <autotool> [tool-specific flags]
139 cd ${AUTO_S} 397# @INTERNAL
140 398# @DESCRIPTION:
141 local x 399# Run the specified autotool helper, but do logging and error checking
142 for x in ${ASRC_URI} 400# around it in the process.
401autotools_run_tool() {
402 # Process our own internal flags first
403 local autofail=true m4flags=false
404 while [[ -n $1 ]] ; do
405 case $1 in
406 --at-no-fail) autofail=false;;
407 --at-m4flags) m4flags=true;;
408 # whatever is left goes to the actual tool
409 *) break;;
410 esac
411 shift
143 do 412 done
144 unpack ${x##*/} || die "!!! Could not unpack ${x##*/} needed by autotools !!!" 413
414 if [[ ${EBUILD_PHASE} != "unpack" && ${EBUILD_PHASE} != "prepare" ]]; then
415 ewarn "QA Warning: running $1 in ${EBUILD_PHASE} phase"
416 fi
417
418 autotools_env_setup
419
420 local STDERR_TARGET="${T}/$1.out"
421 # most of the time, there will only be one run, but if there are
422 # more, make sure we get unique log filenames
423 if [[ -e ${STDERR_TARGET} ]] ; then
424 local i=1
425 while :; do
426 STDERR_TARGET="${T}/$1-${i}.out"
427 [[ -e ${STDERR_TARGET} ]] || break
428 : $(( i++ ))
145 done 429 done
146} 430 fi
147 431
148install_autoconf() { 432 if ${m4flags} ; then
433 set -- "${1}" $(autotools_m4dir_include) "${@:2}" $(autotools_m4sysdir_include)
434 fi
149 435
150 cd ${AUTO_S}/autoconf-${ACONFVER} || die "!!! Failed to build autoconf !!!" 436 printf "***** $1 *****\n***** PWD: ${PWD}\n***** $*\n\n" > "${STDERR_TARGET}"
151 437
152 ./configure --prefix=${AUTO_D} \ 438 ebegin "Running $@"
153 --infodir=${AUTO_D}/share/info \ 439 "$@" >> "${STDERR_TARGET}" 2>&1
154 --mandir=${AUTO_D}/share/man \ 440 if ! eend $? && ${autofail} ; then
155 --target=${CHOST} || die "!!! Failed to configure autoconf !!!" 441 echo
156 442 eerror "Failed Running $1 !"
157 emake || die "!!! Failed to build autoconf !!!" 443 eerror
158 444 eerror "Include in your bugreport the contents of:"
159 make install || die "!!! Failed to install autoconf !!!" 445 eerror
446 eerror " ${STDERR_TARGET}"
447 echo
448 die "Failed Running $1 !"
449 fi
160} 450}
161 451
162install_automake() { 452# Internal function to check for support
163 453
164 cd ${AUTO_S}/automake-${AMAKEVER} || die "!!! Failed to build automake !!!" 454# Keep a list of all the macros we might use so that we only
455# have to run the trace code once. Order doesn't matter.
456ALL_AUTOTOOLS_MACROS=(
457 AC_PROG_LIBTOOL AM_PROG_LIBTOOL LT_INIT
458 AC_CONFIG_HEADERS
459 AC_CONFIG_SUBDIRS
460 AC_CONFIG_AUX_DIR AC_CONFIG_MACRO_DIR
461 AM_INIT_AUTOMAKE
462 AM_GNU_GETTEXT_VERSION
463)
464autotools_check_macro() {
465 [[ -f configure.ac || -f configure.in ]] || return 0
165 466
166 ./configure --prefix=${AUTO_D} \ 467 # We can run in multiple dirs, so we have to cache the trace
167 --infodir=${AUTO_D}/share/info \ 468 # data in $PWD rather than an env var.
168 --mandir=${AUTO_D}/share/man \ 469 local trace_file=".__autoconf_trace_data"
169 --target=${CHOST} || die "!!! Failed to configure automake !!!" 470 if [[ ! -e ${trace_file} ]] || [[ aclocal.m4 -nt ${trace_file} ]] ; then
471 WANT_AUTOCONF="2.5" autoconf \
472 $(autotools_m4dir_include) \
473 ${ALL_AUTOTOOLS_MACROS[@]/#/--trace=} > ${trace_file} 2>/dev/null
474 fi
170 475
171 emake || die "!!! Failed to build automake !!!" 476 local macro args=()
172 477 for macro ; do
173 make install || die "!!! Failed to install automake !!!" 478 has ${macro} ${ALL_AUTOTOOLS_MACROS[@]} || die "internal error: add ${macro} to ALL_AUTOTOOLS_MACROS"
479 args+=( -e ":${macro}:" )
480 done
481 grep "${args[@]}" ${trace_file}
174} 482}
175 483
176install_autotools() { 484# @FUNCTION: autotools_check_macro_val
485# @USAGE: <macro> [macros]
486# @INTERNAL
487# @DESCRIPTION:
488# Look for a macro and extract its value.
489autotools_check_macro_val() {
490 local macro scan_out
177 491
178 if [ "${SRC_URI/autoconf/}" = "$SRC_URI" ] || [ "${SRC_URI/automake/}" = "$SRC_URI" ] 492 for macro ; do
179 then 493 autotools_check_macro "${macro}" | \
180 echo "!!! \$SRC_URI was not set properly !!! It needs to include \${SRC_URI}" 494 gawk -v macro="${macro}" \
181 exit 1 495 '($0 !~ /^[[:space:]]*(#|dnl)/) {
496 if (match($0, macro ":(.*)$", res))
497 print res[1]
498 }' | uniq
499 done
500
501 return 0
502}
503
504_autotools_m4dir_include() {
505 local x include_opts
506
507 for x in "$@" ; do
508 case ${x} in
509 # We handle it below
510 -I) ;;
511 *)
512 [[ ! -d ${x} ]] && ewarn "autotools.eclass: '${x}' does not exist"
513 include_opts+=" -I ${x}"
514 ;;
515 esac
516 done
517
518 echo ${include_opts}
519}
520autotools_m4dir_include() { _autotools_m4dir_include ${AT_M4DIR} ; }
521autotools_m4sysdir_include() { _autotools_m4dir_include $(eval echo ${AT_SYS_M4DIR}) ; }
522
182 fi 523fi
183
184 if [ "${DEPEND/make/}" = "$DEPEND" ] || [ "${DEPEND/perl/}" = "$DEPEND" ] || \
185 [ "${DEPEND/m4/}" = "$DEPEND" ]
186 then
187 echo "!!! \$DEPEND was not set properly !!! It needs to include \${DEPEND}"
188 exit 1
189 fi
190
191 mkdir -p ${AUTO_S}
192 mkdir -p ${AUTO_D}/{bin,etc,lib,include,share} \
193 || die "!!! Could not create needed directories for autotools !!!"
194
195# fetch_autotools
196# unpack_autotools
197 install_autoconf
198 install_automake
199
200 export PATH=${AUTO_D}/bin:${PATH}
201 cd ${S}
202 ln -sf ${AUTO_D}/share/automake/depcomp ${S}/depcomp
203}
204

Legend:
Removed from v.1.4  
changed lines
  Added in v.1.139

  ViewVC Help
Powered by ViewVC 1.1.20