/[gentoo-x86]/eclass/autotools.eclass
Gentoo

Diff of /eclass/autotools.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.46 Revision 1.61
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.46 2006/09/23 19:43:07 flameeyes Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.61 2007/01/04 14:56:46 flameeyes Exp $
4# 4#
5# Author: Diego Pettenò <flameeyes@gentoo.org> 5# Author: Diego Pettenò <flameeyes@gentoo.org>
6# Enhancements: Martin Schlemmer <azarah@gentoo.org> 6# Enhancements: Martin Schlemmer <azarah@gentoo.org>
7# 7#
8# This eclass is for handling autotooled software packages that 8# This eclass is for handling autotooled software packages that
10# 10#
11# NB: If you add anything, please comment it! 11# NB: If you add anything, please comment it!
12 12
13inherit eutils libtool 13inherit eutils libtool
14 14
15[[ ${WANT_AUTOMAKE} == "latest" ]] && export WANT_AUTOMAKE=1.9
16[[ ${WANT_AUTOCONF} == "latest" ]] && export WANT_AUTOCONF=2.5
17
18_automake_atom="sys-devel/automake" 15_automake_atom="sys-devel/automake"
19_autoconf_atom="sys-devel/autoconf" 16_autoconf_atom="sys-devel/autoconf"
17if [[ -n ${WANT_AUTOMAKE} ]]; then
18 case ${WANT_AUTOMAKE} in
19 # workaround while we have different versions of automake in arch and ~arch
20 latest) _automake_atom="|| ( =sys-devel/automake-1.10* =sys-devel/automake-1.9* )" ;;
20[[ -n ${WANT_AUTOMAKE} ]] && _automake_atom="=sys-devel/automake-${WANT_AUTOMAKE}*" 21 *) _automake_atom="=sys-devel/automake-${WANT_AUTOMAKE}*" ;;
22 esac
23fi
24
21if [[ -n ${WANT_AUTOCONF} ]] ; then 25if [[ -n ${WANT_AUTOCONF} ]] ; then
22 case ${WANT_AUTOCONF} in 26 case ${WANT_AUTOCONF} in
23 2.1) _autoconf_atom="=sys-devel/autoconf-${WANT_AUTOCONF}*" ;; 27 2.1) _autoconf_atom="=sys-devel/autoconf-${WANT_AUTOCONF}*" ;;
24 2.5) _autoconf_atom=">=sys-devel/autoconf-2.59" ;; 28 latest | 2.5) _autoconf_atom=">=sys-devel/autoconf-2.59" ;;
25 esac 29 esac
26fi 30fi
27DEPEND="${_automake_atom} 31DEPEND="${_automake_atom}
28 ${_autoconf_atom} 32 ${_autoconf_atom}
29 sys-devel/libtool" 33 sys-devel/libtool"
33# Variables: 37# Variables:
34# 38#
35# AT_M4DIR - Additional director(y|ies) aclocal should search 39# AT_M4DIR - Additional director(y|ies) aclocal should search
36# AM_OPTS - Additional options to pass to automake during 40# AM_OPTS - Additional options to pass to automake during
37# eautoreconf call. 41# eautoreconf call.
42# AT_NOELIBTOOLIZE - Don't run elibtoolize command if set to 'yes',
43# useful when elibtoolize needs to be ran with
44# particular options
38 45
39# Functions: 46# Functions:
40# 47#
41# eautoreconf() - Should do a full autoreconf - normally what most people 48# eautoreconf() - Should do a full autoreconf - normally what most people
42# will be interested in. Also should handle additional 49# will be interested in. Also should handle additional
110 ;; 117 ;;
111 esac 118 esac
112 done 119 done
113 fi 120 fi
114 121
122 autotools_set_versions
115 [[ ! -f aclocal.m4 || -n $(grep -e 'generated.*by aclocal' aclocal.m4) ]] && \ 123 [[ ! -f aclocal.m4 || -n $(grep -e 'generated.*by aclocal' aclocal.m4) ]] && \
116 autotools_run_tool aclocal "$@" ${aclocal_opts} 124 autotools_run_tool aclocal "$@" ${aclocal_opts}
117} 125}
118 126
119_elibtoolize() { 127_elibtoolize() {
135} 143}
136 144
137eautoheader() { 145eautoheader() {
138 # Check if we should run autoheader 146 # Check if we should run autoheader
139 [[ -n $(autotools_check_macro "AC_CONFIG_HEADERS") ]] || return 0 147 [[ -n $(autotools_check_macro "AC_CONFIG_HEADERS") ]] || return 0
148 autotools_set_versions
140 autotools_run_tool autoheader "$@" 149 NO_FAIL=1 autotools_run_tool autoheader "$@"
141} 150}
142 151
143eautoconf() { 152eautoconf() {
144 if [[ ! -f configure.ac && ! -f configure.in ]] ; then 153 if [[ ! -f configure.ac && ! -f configure.in ]] ; then
145 echo 154 echo
146 eerror "No configure.{ac,in} present in '$(pwd | sed -e 's:.*/::')'!" 155 eerror "No configure.{ac,in} present in '$(pwd | sed -e 's:.*/::')'!"
147 echo 156 echo
148 die "No configure.{ac,in} present!" 157 die "No configure.{ac,in} present!"
149 fi 158 fi
150 159
160 autotools_set_versions
151 autotools_run_tool autoconf "$@" 161 autotools_run_tool autoconf "$@"
152} 162}
153 163
154eautomake() { 164eautomake() {
155 local extra_opts 165 local extra_opts
156 166
157 [[ -f Makefile.am ]] || return 0 167 [[ -f Makefile.am ]] || return 0
158 168
159 if [[ -n ${WANT_AUTOMAKE} ]]; then 169 autotools_set_versions
160 export WANT_AUTOMAKE # let the automake wrapper pick it up
161 einfo "Required automake ${WANT_AUTOMAKE}. Using $(automake --version | head -n 1)."
162 fi
163
164 if [[ -z ${FROM_EAUTORECONF} && -f Makefile.in ]]; then 170 if [[ -z ${FROM_EAUTORECONF} && -f Makefile.in ]]; then
165 local used_automake 171 local used_automake
166 local installed_automake 172 local installed_automake
167 173
168 installed_automake=$(automake --version | head -n 1 | \ 174 installed_automake=$(automake --version | head -n 1 | \
183 189
184 # --force-missing seems not to be recognized by some flavours of automake 190 # --force-missing seems not to be recognized by some flavours of automake
185 autotools_run_tool automake --add-missing --copy ${extra_opts} "$@" 191 autotools_run_tool automake --add-missing --copy ${extra_opts} "$@"
186} 192}
187 193
194autotools_set_versions() {
195 [[ -n ${autotools_version_sets} ]] && return 0
188 196
197 if [[ -n ${WANT_AUTOCONF} ]]; then
198 [[ ${WANT_AUTOCONF} == "latest" ]] && WANT_AUTOCONF="2.5"
199 export WANT_AUTOCONF
200 einfo "Requested autoconf ${WANT_AUTOCONF}"
201 einfo "Using $(autoconf --version 2>/dev/null | head -n 1)"
202 einfo "Using $(autoheader --version 2>/dev/null | head -n 1)"
203 else
204 ewarn "QA Notice: \${WANT_AUTOCONF} variable unset. Please report on http://bugs.gentoo.org/"
205 fi
206
207 if [[ -n ${WANT_AUTOMAKE} ]]; then
208 local latest_automake
209 if [[ ${WANT_AUTOMAKE} == "latest" ]]; then
210 latest_automake="latest: "
211 for amver in 1.10 1.9 1.8 1.7 1.6; do
212 WANT_AUTOMAKE="${amver}"
213 ROOT=/ has_version =sys-devel/automake-${amver}* && break
214 done
215 fi
216 export WANT_AUTOMAKE
217 einfo "Requested automake ${latest_automake}${WANT_AUTOMAKE}"
218 einfo "Using $(automake --version 2>/dev/null | head -n 1)"
219 einfo "Using $(aclocal --version 2>/dev/null | head -n 1)"
220 else
221 ewarn "QA Notice: \${WANT_AUTOMAKE} variable unset. Please report on http://bugs.gentoo.org/"
222 fi
223
224 autotools_version_sets="yes"
225}
189 226
190# Internal function to run an autotools' tool 227# Internal function to run an autotools' tool
191autotools_run_tool() { 228autotools_run_tool() {
192 local STDERR_TARGET="${T}/$$.out" 229 local STDERR_TARGET="${T}/$$.out"
193 local PATCH_TARGET="${T}/$$.patch"
194 local ris 230 local ris
195 231
196 echo "***** $1 *****" > ${STDERR_TARGET%/*}/$1-${STDERR_TARGET##*/} 232 echo "***** $1 *****" > ${STDERR_TARGET%/*}/$1-${STDERR_TARGET##*/}
197 echo >> ${STDERR_TARGET%/*}/$1-${STDERR_TARGET##*/} 233 echo >> ${STDERR_TARGET%/*}/$1-${STDERR_TARGET##*/}
198 234
199 ebegin "Running $@" 235 ebegin "Running $@"
200 $@ >> ${STDERR_TARGET%/*}/$1-${STDERR_TARGET##*/} 2>&1 236 $@ >> ${STDERR_TARGET%/*}/$1-${STDERR_TARGET##*/} 2>&1
201 ris=$? 237 ris=$?
202 eend ${ris} 238 eend ${ris}
203 239
204 if [[ ${ris} != 0 ]]; then 240 if [[ ${ris} != 0 && ${NO_FAIL} != 1 ]]; then
205 echo 241 echo
206 eerror "Failed Running $1 !" 242 eerror "Failed Running $1 !"
207 eerror 243 eerror
208 eerror "Include in your bugreport the contents of:" 244 eerror "Include in your bugreport the contents of:"
209 eerror 245 eerror

Legend:
Removed from v.1.46  
changed lines
  Added in v.1.61

  ViewVC Help
Powered by ViewVC 1.1.20