/[gentoo-x86]/eclass/autotools.eclass
Gentoo

Diff of /eclass/autotools.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.61 Revision 1.65
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.61 2007/01/04 14:56:46 flameeyes Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.65 2007/03/04 21:03:59 vapier Exp $
4# 4#
5# Author: Diego Pettenò <flameeyes@gentoo.org> 5# Maintainer: base-system@gentoo.org
6# Enhancements: Martin Schlemmer <azarah@gentoo.org>
7# 6#
8# This eclass is for handling autotooled software packages that 7# This eclass is for handling autotooled software packages that
9# needs to regenerate their build scripts. 8# needs to regenerate their build scripts.
10# 9#
11# NB: If you add anything, please comment it! 10# NB: If you add anything, please comment it!
12 11
13inherit eutils libtool 12inherit eutils libtool
13
14[[ -z ${WANT_AUTOCONF} ]] && WANT_AUTOCONF="latest"
15[[ -z ${WANT_AUTOMAKE} ]] && WANT_AUTOMAKE="latest"
14 16
15_automake_atom="sys-devel/automake" 17_automake_atom="sys-devel/automake"
16_autoconf_atom="sys-devel/autoconf" 18_autoconf_atom="sys-devel/autoconf"
17if [[ -n ${WANT_AUTOMAKE} ]]; then 19if [[ -n ${WANT_AUTOMAKE} ]]; then
18 case ${WANT_AUTOMAKE} in 20 case ${WANT_AUTOMAKE} in
19 # workaround while we have different versions of automake in arch and ~arch 21 # workaround while we have different versions of automake in arch and ~arch
22 none) _automake_atom="" ;; # some packages don't require automake at all
20 latest) _automake_atom="|| ( =sys-devel/automake-1.10* =sys-devel/automake-1.9* )" ;; 23 latest) _automake_atom="=sys-devel/automake-1.10*" ;;
21 *) _automake_atom="=sys-devel/automake-${WANT_AUTOMAKE}*" ;; 24 *) _automake_atom="=sys-devel/automake-${WANT_AUTOMAKE}*" ;;
22 esac 25 esac
26 [[ ${WANT_AUTOMAKE} == "latest" ]] && WANT_AUTOMAKE="1.10"
27 export WANT_AUTOMAKE
23fi 28fi
24 29
25if [[ -n ${WANT_AUTOCONF} ]] ; then 30if [[ -n ${WANT_AUTOCONF} ]] ; then
26 case ${WANT_AUTOCONF} in 31 case ${WANT_AUTOCONF} in
27 2.1) _autoconf_atom="=sys-devel/autoconf-${WANT_AUTOCONF}*" ;; 32 2.1) _autoconf_atom="=sys-devel/autoconf-${WANT_AUTOCONF}*" ;;
28 latest | 2.5) _autoconf_atom=">=sys-devel/autoconf-2.59" ;; 33 latest | 2.5) _autoconf_atom=">=sys-devel/autoconf-2.59" ;;
29 esac 34 esac
35 [[ ${WANT_AUTOCONF} == "latest" ]] && WANT_AUTOCONF="2.5"
36 export WANT_AUTOCONF
30fi 37fi
31DEPEND="${_automake_atom} 38DEPEND="${_automake_atom}
32 ${_autoconf_atom} 39 ${_autoconf_atom}
33 sys-devel/libtool" 40 sys-devel/libtool"
34RDEPEND="" 41RDEPEND=""
117 ;; 124 ;;
118 esac 125 esac
119 done 126 done
120 fi 127 fi
121 128
122 autotools_set_versions
123 [[ ! -f aclocal.m4 || -n $(grep -e 'generated.*by aclocal' aclocal.m4) ]] && \ 129 [[ ! -f aclocal.m4 || -n $(grep -e 'generated.*by aclocal' aclocal.m4) ]] && \
124 autotools_run_tool aclocal "$@" ${aclocal_opts} 130 autotools_run_tool aclocal "$@" ${aclocal_opts}
125} 131}
126 132
127_elibtoolize() { 133_elibtoolize() {
143} 149}
144 150
145eautoheader() { 151eautoheader() {
146 # Check if we should run autoheader 152 # Check if we should run autoheader
147 [[ -n $(autotools_check_macro "AC_CONFIG_HEADERS") ]] || return 0 153 [[ -n $(autotools_check_macro "AC_CONFIG_HEADERS") ]] || return 0
148 autotools_set_versions
149 NO_FAIL=1 autotools_run_tool autoheader "$@" 154 NO_FAIL=1 autotools_run_tool autoheader "$@"
150} 155}
151 156
152eautoconf() { 157eautoconf() {
153 if [[ ! -f configure.ac && ! -f configure.in ]] ; then 158 if [[ ! -f configure.ac && ! -f configure.in ]] ; then
155 eerror "No configure.{ac,in} present in '$(pwd | sed -e 's:.*/::')'!" 160 eerror "No configure.{ac,in} present in '$(pwd | sed -e 's:.*/::')'!"
156 echo 161 echo
157 die "No configure.{ac,in} present!" 162 die "No configure.{ac,in} present!"
158 fi 163 fi
159 164
160 autotools_set_versions
161 autotools_run_tool autoconf "$@" 165 autotools_run_tool autoconf "$@"
162} 166}
163 167
164eautomake() { 168eautomake() {
165 local extra_opts 169 local extra_opts
166 170
167 [[ -f Makefile.am ]] || return 0 171 [[ -f Makefile.am ]] || return 0
168 172
169 autotools_set_versions
170 if [[ -z ${FROM_EAUTORECONF} && -f Makefile.in ]]; then 173 if [[ -z ${FROM_EAUTORECONF} && -f Makefile.in ]]; then
171 local used_automake 174 local used_automake
172 local installed_automake 175 local installed_automake
173 176
174 installed_automake=$(automake --version | head -n 1 | \ 177 installed_automake=$(automake --version | head -n 1 | \
189 192
190 # --force-missing seems not to be recognized by some flavours of automake 193 # --force-missing seems not to be recognized by some flavours of automake
191 autotools_run_tool automake --add-missing --copy ${extra_opts} "$@" 194 autotools_run_tool automake --add-missing --copy ${extra_opts} "$@"
192} 195}
193 196
194autotools_set_versions() {
195 [[ -n ${autotools_version_sets} ]] && return 0
196
197 if [[ -n ${WANT_AUTOCONF} ]]; then
198 [[ ${WANT_AUTOCONF} == "latest" ]] && WANT_AUTOCONF="2.5"
199 export WANT_AUTOCONF
200 einfo "Requested autoconf ${WANT_AUTOCONF}"
201 einfo "Using $(autoconf --version 2>/dev/null | head -n 1)"
202 einfo "Using $(autoheader --version 2>/dev/null | head -n 1)"
203 else
204 ewarn "QA Notice: \${WANT_AUTOCONF} variable unset. Please report on http://bugs.gentoo.org/"
205 fi
206
207 if [[ -n ${WANT_AUTOMAKE} ]]; then
208 local latest_automake
209 if [[ ${WANT_AUTOMAKE} == "latest" ]]; then
210 latest_automake="latest: "
211 for amver in 1.10 1.9 1.8 1.7 1.6; do
212 WANT_AUTOMAKE="${amver}"
213 ROOT=/ has_version =sys-devel/automake-${amver}* && break
214 done
215 fi
216 export WANT_AUTOMAKE
217 einfo "Requested automake ${latest_automake}${WANT_AUTOMAKE}"
218 einfo "Using $(automake --version 2>/dev/null | head -n 1)"
219 einfo "Using $(aclocal --version 2>/dev/null | head -n 1)"
220 else
221 ewarn "QA Notice: \${WANT_AUTOMAKE} variable unset. Please report on http://bugs.gentoo.org/"
222 fi
223
224 autotools_version_sets="yes"
225}
226
227# Internal function to run an autotools' tool 197# Internal function to run an autotools' tool
228autotools_run_tool() { 198autotools_run_tool() {
229 local STDERR_TARGET="${T}/$$.out" 199 local STDERR_TARGET="${T}/$$.out"
230 local ris 200 local ris
231 201

Legend:
Removed from v.1.61  
changed lines
  Added in v.1.65

  ViewVC Help
Powered by ViewVC 1.1.20