/[gentoo-x86]/eclass/depend.apache.eclass
Gentoo

Diff of /eclass/depend.apache.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.1 Revision 1.9
1# Copyright 1999-2004 Gentoo Foundation 1# Copyright 2004-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License, v2 or later
3# $Header: /var/cvsroot/gentoo-x86/eclass/depend.apache.eclass,v 1.1 2004/07/16 10:48:22 stuart Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/depend.apache.eclass,v 1.9 2005/01/21 07:52:12 vericgar Exp $
4ECLASS=depend.apache
5INHERITED="$INHERITED $ECLASS"
4 6
5ECLASS="depend.apache" 7######
6INHERITED="$INHERITED $ECLASS" 8## Apache Common Variables
7IUSE="apache apache2" 9##
10## These are internal variables used by this, and other apache-related eclasses,
11## and thus should not need to be used by the ebuilds themselves (the ebuilds
12## should know what version of Apache they are building against).
13######
8 14
9# call this function to work out which version of the apache web server 15####
10# your ebuild should be installing itself to use 16## APACHE_VERSION
17##
18## Stores the version of apache we are going to be ebuilding. This variable is
19## set by the need_apache{|1|2} functions.
20##
21## This needs to stay as '1' until apache2 is on by default -- although it
22## doesn't matter much as it's set by the need_apache functions.
23####
24APACHE_VERSION='1'
11 25
12detect_apache_useflags() { 26####
13 USE_APACHE1= 27## APXS1, APXS2
14 USE_APACHE2= 28##
15 USE_APACHE_MULTIPLE= 29## Paths to the apxs tools
30####
31APXS1="/usr/sbin/apxs"
32APXS2="/usr/sbin/apxs2"
16 33
17 useq apache2 && USE_APACHE2=1 34####
18 useq apache && USE_APACHE1=1 35## APACHECTL1, APACHECTL2
36##
37## Paths to the apachectl tools
38####
39APACHECTL1="/usr/sbin/apachectl"
40APACHECTL2="/usr/sbin/apache2ctl"
19 41
20 [ -n "$USE_APACHE1" ] && [ -n "$USE_APACHE2" ] && USE_APACHE_MULTIPLE=1 42####
43## APACHE1_BASEDIR, APACHE2_BASEDIR
44##
45## Paths to the server root directories
46####
47APACHE1_BASEDIR="/usr/lib/apache"
48APACHE2_BASEDIR="/usr/lib/apache2"
49
50####
51## APACHE1_CONFDIR, APACHE2_CONFDIR
52##
53## Paths to the configuration file directories (usually under
54## $APACHE?_BASEDIR/conf)
55####
56APACHE1_CONFDIR="/etc/apache"
57APACHE2_CONFDIR="/etc/apache2"
58
59####
60## APACHE1_MODULES_CONFDIR, APACHE2_MODULES_CONFDIR
61##
62## Paths where module configuration files are kept
63####
64APACHE1_MODULES_CONFDIR="${APACHE1_CONFDIR}/modules.d"
65APACHE2_MODULES_CONFDIR="${APACHE2_CONFDIR}/modules.d"
66
67####
68## APACHE1_MODULES_VHOSTDIR, APACHE2_MODULES_VHOSTDIR
69##
70## Paths where virtual host configuration files are kept
71####
72APACHE1_VHOSTDIR="${APACHE1_CONFDIR}/vhosts.d"
73APACHE2_VHOSTDIR="${APACHE2_CONFDIR}/vhosts.d"
74
75####
76## APACHE1_MODULESDIR, APACHE2_MODULESDIR
77##
78## Paths where we install modules
79####
80APACHE1_MODULESDIR="${APACHE1_BASEDIR}/modules"
81APACHE2_MODULESDIR="${APACHE2_BASEDIR}/modules"
82
83####
84## APACHE1_DEPEND, APACHE2_DEPEND
85##
86## Dependencies for apache 1.x and apache 2.x
87## - apache2 must be at least version 2.0.52-r3, this is lowest version
88## containing our new overall changes -- trapni (Jan 21 2005)
89## - apache1 must be at least version 1.3.33-r1, but how to
90## define the DEPEND here? (FIXME) -- trapni (Jan 21 2005)
91## - currently not possible - bug #4315 -- vericgar (Jan 21 2005)
92####
93APACHE1_DEPEND="=net-www/apache-1*"
94APACHE2_DEPEND=">=net-www/apache-2.0.52-r3"
95
96
97####
98## APACHE_DEPEND
99##
100## Dependency magic based on useflags to use the right DEPEND
101####
102
103APACHE_DEPEND="apache2? ( ${APACHE2_DEPEND} ) !apache2? ( ${APACHE1_DEPEND} )"
104
105####
106## need_apache1
107##
108## An ebuild calls this to get the dependency information
109## for apache-1.x. An ebuild should use this in order for
110## future changes to the build infrastructure to happen
111## seamlessly. All an ebuild needs to do is include the
112## line need_apache1 somewhere.
113####
114need_apache1() {
115 debug-print-function need_apache1
116
117 DEPEND="${DEPEND} ${APACHE1_DEPEND}"
118 APACHE_VERSION='1'
21} 119}
22 120
23detect_apache_installed() { 121####
24 HAS_APACHE1= 122## need_apache2
25 HAS_APACHE2= 123##
26 HAS_APACHE_MULTIPLE= 124## An ebuild calls this to get the dependency information
27 HAS_APACHE_ANY= 125## for apache-2.x. An ebuild should use this in order for
126## future changes to the build infrastructure to happen
127## seamlessly. All an ebuild needs to do is include the
128## line need_apache1 somewhere.
129####
130need_apache2() {
131 debug-print-function need_apache2
28 132
29 has_version '=net-www/apache-1*' && HAS_APACHE1=1 && HAS_APACHE_ANY=1 133 DEPEND="${DEPEND} ${APACHE2_DEPEND}"
30 has_version '=net-www/apache-2*' && HAS_APACHE2=1 && HAS_APACHE_ANY=1 134 APACHE_VERSION='2'
31
32 [ -n "${HAVE_APACHE1}" ] && [ -n "${HAVE_APACHE2}" && HAVE_APACHE_MULTIPLE=1
33} 135}
34 136
35# call this function from your pkg_setup
36 137
138####
139## DO NOT CHANGE THIS FUNCTION UNLESS YOU UNDERSTAND THE CONSEQUENCES IT
140## WILL HAVE ON THE CACHE! There MUST be a apache2? () block in DEPEND for
141## things to work correct in the dependency calculation stage.
142####
37depend_apache() { 143need_apache() {
38 detect_apache_installed 144 debug-print-function need_apache
39 detect_apache_useflags
40 145
41 # deal with the multiple cases first - much easier 146 IUSE="${IUSE} apache2"
42 if [ -n "$USE_APACHE_MULTIPLE" ]; then 147 DEPEND="${DEPEND} ${APACHE_DEPEND}"
43 echo 148 if useq apache2; then
44 eerror "You have both the apache and apache2 USE flags set" 149 APACHE_VERSION='2'
45 eerror
46 eerror "Please set only ONE of these USE flags, and try again"
47 echo
48 die "Multiple Apache USE flags set - you can only have one set at a time"
49 fi
50
51 if [ -n "$USE_APACHE2" ] ; then
52 if [ -z "$HAS_APACHE2" -a -n "$HAS_APACHE_ANY" ] ; then
53 echo
54 eerror "You have the 'apache2' USE flag set, but only have Apache v1 installed"
55 eerror "If you really meant to upgrade to Apache v2, please install Apache v2"
56 eerror "before installing $CATEGORY/${PN}-${PVR}"
57 echo
58 die "Automatic upgrade of Apache would be forced; avoiding"
59 else 150 else
60 einfo "Apache 2 support enabled" 151 APACHE_VERSION='1'
61 DETECT_APACHE=2
62 return
63 fi
64 fi
65
66 if [ -n "$USE_APACHE1" ]; then
67 if [ -z "$HAS_APACHE1" -a -n "$HAS_APACHE_ANY" ]; then
68 echo
69 eerror "You have the 'apache' USE flag set, but only have a later version of"
70 eerror "Apache installed on your computer. Please use the 'apache2' USE flag"
71 eerror "or downgrade to Apache v1 before installing $CATEGORY/${PN}-${PVR}"
72 echo
73 die "Avoiding installing older version of Apache"
74 else
75 einfo "Apache 1 support enabled"
76 DETECT_APACHE=1
77 return
78 fi
79 fi 152 fi
80} 153}
81

Legend:
Removed from v.1.1  
changed lines
  Added in v.1.9

  ViewVC Help
Powered by ViewVC 1.1.20