/[gentoo-x86]/eclass/depend.apache.eclass
Gentoo

Diff of /eclass/depend.apache.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.15 Revision 1.18
1# Copyright 2004-2005 Gentoo Foundation 1# Copyright 2004-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License, v2 or later 2# Distributed under the terms of the GNU General Public License, v2 or later
3# $Header: /var/cvsroot/gentoo-x86/eclass/depend.apache.eclass,v 1.15 2005/06/07 22:11:26 vericgar Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/depend.apache.eclass,v 1.18 2005/07/11 15:08:06 swegener Exp $
4ECLASS=depend.apache
5INHERITED="$INHERITED $ECLASS"
6 4
7###### 5######
8## Apache Common Variables 6## Apache Common Variables
9## 7##
10## These are internal variables used by this, and other apache-related eclasses, 8## These are internal variables used by this, and other apache-related eclasses,
84## APACHE1_DEPEND, APACHE2_DEPEND 82## APACHE1_DEPEND, APACHE2_DEPEND
85## 83##
86## Dependencies for apache 1.x and apache 2.x 84## Dependencies for apache 1.x and apache 2.x
87## - apache2 must be at least version 2.0.52-r3, this is lowest version 85## - apache2 must be at least version 2.0.52-r3, this is lowest version
88## containing our new overall changes -- trapni (Jan 21 2005) 86## containing our new overall changes -- trapni (Jan 21 2005)
89## - apache1 must be at least version 1.3.33-r1, but how to 87## - apache1 must be at least version 1.3.33-r1, but how to
90## define the DEPEND here? (FIXME) -- trapni (Jan 21 2005) 88## define the DEPEND here? (FIXME) -- trapni (Jan 21 2005)
91## - currently not possible - bug #4315 -- vericgar (Jan 21 2005) 89## - currently not possible - bug #4315 -- vericgar (Jan 21 2005)
92#### 90####
93APACHE1_DEPEND="=net-www/apache-1*" 91APACHE1_DEPEND="=net-www/apache-1*"
94APACHE2_DEPEND=">=net-www/apache-2.0.54-r10" 92APACHE2_DEPEND=">=net-www/apache-2.0.54-r10"
135 RDEPEND="${RDEPEND} ${APACHE2_DEPEND}" 133 RDEPEND="${RDEPEND} ${APACHE2_DEPEND}"
136 APACHE_VERSION='2' 134 APACHE_VERSION='2'
137} 135}
138 136
139#### 137####
140## DO NOT CHANGE THIS FUNCTION UNLESS YOU UNDERSTAND THE CONSEQUENCES IT 138## DO NOT CHANGE THIS FUNCTION UNLESS YOU UNDERSTAND THE CONSEQUENCES IT
141## WILL HAVE ON THE CACHE! There MUST be a apache2? () block in DEPEND for 139## WILL HAVE ON THE CACHE! There MUST be a apache2? () block in DEPEND for
142## things to work correct in the dependency calculation stage. 140## things to work correct in the dependency calculation stage.
143#### 141####
144need_apache() { 142need_apache() {
145 debug-print-function need_apache 143 debug-print-function need_apache

Legend:
Removed from v.1.15  
changed lines
  Added in v.1.18

  ViewVC Help
Powered by ViewVC 1.1.20