/[gentoo-x86]/eclass/depend.apache.eclass
Gentoo

Diff of /eclass/depend.apache.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.17 Revision 1.19
1# Copyright 2004-2005 Gentoo Foundation 1# Copyright 2004-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License, v2 or later 2# Distributed under the terms of the GNU General Public License, v2 or later
3# $Header: /var/cvsroot/gentoo-x86/eclass/depend.apache.eclass,v 1.17 2005/07/06 20:23:20 agriffis Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/depend.apache.eclass,v 1.19 2005/08/02 23:26:14 vericgar Exp $
4 4
5###### 5######
6## Apache Common Variables 6## Apache Common Variables
7## 7##
8## These are internal variables used by this, and other apache-related eclasses, 8## These are internal variables used by this, and other apache-related eclasses,
61#### 61####
62APACHE1_MODULES_CONFDIR="${APACHE1_CONFDIR}/modules.d" 62APACHE1_MODULES_CONFDIR="${APACHE1_CONFDIR}/modules.d"
63APACHE2_MODULES_CONFDIR="${APACHE2_CONFDIR}/modules.d" 63APACHE2_MODULES_CONFDIR="${APACHE2_CONFDIR}/modules.d"
64 64
65#### 65####
66## APACHE1_MODULES_VHOSTDIR, APACHE2_MODULES_VHOSTDIR 66## APACHE1_VHOSTDIR, APACHE2_VHOSTDIR
67## 67##
68## Paths where virtual host configuration files are kept 68## Paths where virtual host configuration files are kept
69#### 69####
70APACHE1_VHOSTDIR="${APACHE1_CONFDIR}/vhosts.d" 70APACHE1_VHOSTDIR="${APACHE1_CONFDIR}/vhosts.d"
71APACHE2_VHOSTDIR="${APACHE2_CONFDIR}/vhosts.d" 71APACHE2_VHOSTDIR="${APACHE2_CONFDIR}/vhosts.d"
82## APACHE1_DEPEND, APACHE2_DEPEND 82## APACHE1_DEPEND, APACHE2_DEPEND
83## 83##
84## Dependencies for apache 1.x and apache 2.x 84## Dependencies for apache 1.x and apache 2.x
85## - apache2 must be at least version 2.0.52-r3, this is lowest version 85## - apache2 must be at least version 2.0.52-r3, this is lowest version
86## containing our new overall changes -- trapni (Jan 21 2005) 86## containing our new overall changes -- trapni (Jan 21 2005)
87## - apache1 must be at least version 1.3.33-r1, but how to 87## - apache1 must be at least version 1.3.33-r1, but how to
88## define the DEPEND here? (FIXME) -- trapni (Jan 21 2005) 88## define the DEPEND here? (FIXME) -- trapni (Jan 21 2005)
89## - currently not possible - bug #4315 -- vericgar (Jan 21 2005) 89## - currently not possible - bug #4315 -- vericgar (Jan 21 2005)
90#### 90####
91APACHE1_DEPEND="=net-www/apache-1*" 91APACHE1_DEPEND="=net-www/apache-1*"
92APACHE2_DEPEND=">=net-www/apache-2.0.54-r10" 92APACHE2_DEPEND=">=net-www/apache-2.0.54-r10"
133 RDEPEND="${RDEPEND} ${APACHE2_DEPEND}" 133 RDEPEND="${RDEPEND} ${APACHE2_DEPEND}"
134 APACHE_VERSION='2' 134 APACHE_VERSION='2'
135} 135}
136 136
137#### 137####
138## DO NOT CHANGE THIS FUNCTION UNLESS YOU UNDERSTAND THE CONSEQUENCES IT 138## DO NOT CHANGE THIS FUNCTION UNLESS YOU UNDERSTAND THE CONSEQUENCES IT
139## WILL HAVE ON THE CACHE! There MUST be a apache2? () block in DEPEND for 139## WILL HAVE ON THE CACHE! There MUST be a apache2? () block in DEPEND for
140## things to work correct in the dependency calculation stage. 140## things to work correct in the dependency calculation stage.
141#### 141####
142need_apache() { 142need_apache() {
143 debug-print-function need_apache 143 debug-print-function need_apache

Legend:
Removed from v.1.17  
changed lines
  Added in v.1.19

  ViewVC Help
Powered by ViewVC 1.1.20