/[gentoo-x86]/eclass/depend.apache.eclass
Gentoo

Diff of /eclass/depend.apache.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.20 Revision 1.21
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/depend.apache.eclass,v 1.20 2005/09/04 10:54:53 stuart Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/depend.apache.eclass,v 1.21 2005/09/10 20:21:51 vericgar Exp $
4 4
5###### 5######
6## Apache Common Variables 6## Apache Common Variables
7## 7##
8## These are internal variables used by this, and other apache-related eclasses, 8## These are internal variables used by this, and other apache-related eclasses,
61#### 61####
62APACHE1_MODULES_CONFDIR="${APACHE1_CONFDIR}/modules.d" 62APACHE1_MODULES_CONFDIR="${APACHE1_CONFDIR}/modules.d"
63APACHE2_MODULES_CONFDIR="${APACHE2_CONFDIR}/modules.d" 63APACHE2_MODULES_CONFDIR="${APACHE2_CONFDIR}/modules.d"
64 64
65#### 65####
66## APACHE1_MODULES_VHOSTDIR, APACHE2_MODULES_VHOSTDIR 66## APACHE1_VHOSTDIR, APACHE2_VHOSTDIR
67## 67##
68## Paths where virtual host configuration files are kept 68## Paths where virtual host configuration files are kept
69#### 69####
70APACHE1_VHOSTDIR="${APACHE1_CONFDIR}/vhosts.d" 70APACHE1_VHOSTDIR="${APACHE1_CONFDIR}/vhosts.d"
71APACHE2_VHOSTDIR="${APACHE2_CONFDIR}/vhosts.d" 71APACHE2_VHOSTDIR="${APACHE2_CONFDIR}/vhosts.d"
80 80
81#### 81####
82## APACHE1_DEPEND, APACHE2_DEPEND 82## APACHE1_DEPEND, APACHE2_DEPEND
83## 83##
84## Dependencies for apache 1.x and apache 2.x 84## Dependencies for apache 1.x and apache 2.x
85## - apache2 must be at least version 2.0.52-r3, this is lowest version 85## - apache2 must be at least version 2.0.54-r30, this is lowest version
86## containing our new overall changes -- trapni (Jan 21 2005) 86## containing our new overall changes -- trapni (Jan 21 2005)
87## - apache1 must be at least version 1.3.33-r1, but how to 87## - apache1 must be at least version 1.3.33-r10, but how to
88## define the DEPEND here? (FIXME) -- trapni (Jan 21 2005) 88## define the DEPEND here? (FIXME) -- trapni (Jan 21 2005)
89## - currently not possible - bug #4315 -- vericgar (Jan 21 2005) 89## - currently not possible - bug #4315 -- vericgar (Jan 21 2005)
90#### 90####
91APACHE1_DEPEND="=net-www/apache-1*" 91APACHE1_DEPEND="=net-www/apache-1*"
92APACHE2_DEPEND=">=net-www/apache-2.0.54-r10" 92APACHE2_DEPEND=">=net-www/apache-2.0.54-r30"
93 93
94#### 94####
95## APACHE_DEPEND 95## APACHE_DEPEND
96## 96##
97## Dependency magic based on useflags to use the right DEPEND 97## Dependency magic based on useflags to use the right DEPEND

Legend:
Removed from v.1.20  
changed lines
  Added in v.1.21

  ViewVC Help
Powered by ViewVC 1.1.20