/[gentoo-x86]/eclass/depend.apache.eclass
Gentoo

Diff of /eclass/depend.apache.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.34 Revision 1.35
1# Copyright 1999-2007 Gentoo Foundation 1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/depend.apache.eclass,v 1.34 2007/09/08 14:06:12 hollow Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/depend.apache.eclass,v 1.35 2007/11/25 14:27:52 hollow Exp $
4 4
5inherit multilib 5# @ECLASS: depend.apache.eclass
6 6# @MAINTAINER: apache-devs@gentoo.org
7# @BLURB: Functions to allow ebuilds to depend on apache
8# @DESCRIPTION:
7# This eclass handles depending on apache in a sane way and providing 9# This eclass handles depending on apache in a sane way and providing
8# information about where certain interfaces are located. 10# information about where certain interfaces are located.
9 11#
10# NOTE: If you use this, be sure you use the need_* call after you have 12# @NOTE: If you use this, be sure you use the need_* call after you have defined
11# defined DEPEND and RDEPEND. Also note that you can not rely on the 13# DEPEND and RDEPEND. Also note that you can not rely on the automatic
12# automatic RDEPEND=DEPEND that portage does if you use this eclass. 14# RDEPEND=DEPEND that portage does if you use this eclass.
15#
13# See bug 107127 for more information. 16# See bug 107127 for more information.
14 17
15###### 18inherit multilib
16## Apache Common Variables
17##
18## These are internal variables used by this, and other apache-related eclasses,
19## and thus should not need to be used by the ebuilds themselves (the ebuilds
20## should know what version of Apache they are building against).
21######
22 19
23#### 20# ==============================================================================
24## APACHE_VERSION 21# INTERNAL VARIABLES
25## 22# ==============================================================================
23
24# @ECLASS-VARIABLE: APACHE_VERSION
25# @DESCRIPTION:
26## Stores the version of apache we are going to be ebuilding. This variable is 26# Stores the version of apache we are going to be ebuilding. This variable is
27## set by the need_apache{|1|2} functions. 27# set by the need_apache functions.
28##
29####
30#APACHE_VERSION="2" 28#APACHE_VERSION="2"
31 29
32#### 30# @ECLASS-VARIABLE: APXS2
33## APXS1, APXS2 31# @DESCRIPTION:
34##
35## Paths to the apxs tools 32# Paths to the apxs tool
36####
37APXS1="/usr/sbin/apxs"
38APXS2="/usr/sbin/apxs2" 33APXS2="/usr/sbin/apxs2"
39 34
40#### 35# @ECLASS-VARIABLE: APACHECTL2
41## APACHECTL1, APACHECTL2 36# @DESCRIPTION:
42##
43## Paths to the apachectl tools 37# Path to the apachectl tool
44####
45APACHECTL1="/usr/sbin/apachectl"
46APACHECTL2="/usr/sbin/apache2ctl" 38APACHECTL2="/usr/sbin/apache2ctl"
47 39
48#### 40# @ECLASS-VARIABLE: APACHE2_BASEDIR
49## APACHE1_BASEDIR, APACHE2_BASEDIR 41# @DESCRIPTION:
50##
51## Paths to the server root directories 42# Path to the server root directory
52####
53APACHE1_BASEDIR="/usr/$(get_libdir)/apache"
54APACHE2_BASEDIR="/usr/$(get_libdir)/apache2" 43APACHE2_BASEDIR="/usr/$(get_libdir)/apache2"
55 44
56#### 45# @ECLASS-VARIABLE: APACHE2_CONFDIR
57## APACHE1_CONFDIR, APACHE2_CONFDIR 46# @DESCRIPTION:
58##
59## Paths to the configuration file directories 47# Path to the configuration file directory
60####
61APACHE1_CONFDIR="/etc/apache"
62APACHE2_CONFDIR="/etc/apache2" 48APACHE2_CONFDIR="/etc/apache2"
63 49
64#### 50# @ECLASS-VARIABLE: APACHE2_MODULES_CONFDIR
65## APACHE1_MODULES_CONFDIR, APACHE2_MODULES_CONFDIR 51# @DESCRIPTION:
66##
67## Paths where module configuration files are kept 52# Path where module configuration files are kept
68####
69APACHE1_MODULES_CONFDIR="${APACHE1_CONFDIR}/modules.d"
70APACHE2_MODULES_CONFDIR="${APACHE2_CONFDIR}/modules.d" 53APACHE2_MODULES_CONFDIR="${APACHE2_CONFDIR}/modules.d"
71 54
72#### 55# @ECLASS-VARIABLE: APACHE2_VHOSTDIR
73## APACHE1_VHOSTDIR, APACHE2_VHOSTDIR 56# @DESCRIPTION:
74##
75## Paths where virtual host configuration files are kept 57# Path where virtual host configuration files are kept
76####
77APACHE1_VHOSTDIR="${APACHE1_CONFDIR}/vhosts.d"
78APACHE2_VHOSTDIR="${APACHE2_CONFDIR}/vhosts.d" 58APACHE2_VHOSTDIR="${APACHE2_CONFDIR}/vhosts.d"
79 59
80#### 60# @ECLASS-VARIABLE: APACHE2_MODULESDIR
81## APACHE1_MODULESDIR, APACHE2_MODULESDIR 61# @DESCRIPTION:
82##
83## Paths where we install modules 62# Path where we install modules
84####
85APACHE1_MODULESDIR="${APACHE1_BASEDIR}/modules"
86APACHE2_MODULESDIR="${APACHE2_BASEDIR}/modules" 63APACHE2_MODULESDIR="${APACHE2_BASEDIR}/modules"
87 64
88#### 65# @ECLASS-VARIABLE: APACHE2_DEPEND
89## APACHE1_DEPEND, APACHE2_DEPEND 66# @DESCRIPTION:
90## APACHE2_0_DEPEND, APACHE2_2_DEPEND
91##
92## Dependencies for Apache 1.x and Apache 2.x 67# Dependencies for Apache 2.x
93####
94APACHE1_DEPEND="=www-servers/apache-1*"
95APACHE2_DEPEND="=www-servers/apache-2*" 68APACHE2_DEPEND="=www-servers/apache-2*"
69
70# @ECLASS-VARIABLE: APACHE2_0_DEPEND
71# @DESCRIPTION:
72# Dependencies for Apache 2.0.x
96APACHE2_0_DEPEND="=www-servers/apache-2.0*" 73APACHE2_0_DEPEND="=www-servers/apache-2.0*"
74
75# @ECLASS-VARIABLE: APACHE2_2_DEPEND
76# @DESCRIPTION:
77# Dependencies for Apache 2.2.x
97APACHE2_2_DEPEND="=www-servers/apache-2.2*" 78APACHE2_2_DEPEND="=www-servers/apache-2.2*"
98 79
99#### 80# @ECLASS-VARIABLE: WANT_APACHE_DEPEND
100## NEED_APACHE_DEPEND 81# @DESCRIPTION:
101##
102## Dependency magic based on useflags to use the right DEPEND 82# Dependency magic based on useflag to use the right DEPEND
103## If you change this, please check the DEPENDS in need_apache()
104####
105
106NEED_APACHE_DEPEND="${APACHE2_DEPEND}"
107WANT_APACHE_DEPEND="apache2? ( ${APACHE2_DEPEND} )" 83WANT_APACHE_DEPEND="apache2? ( ${APACHE2_DEPEND} )"
108 84
109#### 85# ==============================================================================
110## apr_config/apu_config 86# INTERNAL FUNCTIONS
111## 87# ==============================================================================
112## Version magic to get the correct apr-config/apu-config
113## based on the (probably) installed version of apache.
114## This is needed to get modules to link to the same apr/apu
115## as apache (i.e. link 0.9 for 2.0, 1.x for 2.2)
116####
117apr_config() {
118 local default="${1:-1}"
119 if [[ "${USE_APACHE}" == "2" ]]; then
120 if has_version ${APACHE2_0_DEPEND}; then
121 echo apr-config
122 else
123 echo apr-1-config
124 fi
125 else
126 if [[ "${default}" == "0" ]]; then
127 echo apr-config
128 elif [[ "${default}" == "1" ]]; then
129 echo apr-1-config
130 else
131 die "Unknown version specifier: ${default}"
132 fi
133 fi
134}
135 88
136apu_config() { 89# @FUNCTION: uses_apache2
137 local default="${1:-1}" 90# @DESCRIPTION:
138 if [[ "${USE_APACHE}" == "2" ]]; then
139 if has_version ${APACHE2_0_DEPEND}; then
140 echo apu-config
141 else
142 echo apu-1-config
143 fi
144 else
145 if [[ "${default}" == "0" ]]; then
146 echo apu-config
147 elif [[ "${default}" == "1" ]]; then
148 echo apu-1-config
149 else
150 die "Unknown version specifier: ${default}"
151 fi
152 fi
153}
154
155####
156# uses_apache1() - !!! DEPRECATED !!!
157####
158
159uses_apache1() {
160 debug-print-function $FUNCNAME $*
161 # WARNING: Do not use these variables with anything that is put
162 # into the dependency cache (DEPEND/RDEPEND/etc)
163 APACHE_VERSION="1"
164 APXS="${APXS1}"
165 USE_APACHE="1"
166 APACHECTL="${APACHECTL1}"
167 APACHE_BASEDIR="${APACHE1_BASEDIR}"
168 APACHE_CONFDIR="${APACHE1_CONFDIR}"
169 APACHE_MODULES_CONFDIR="${APACHE1_MODULES_CONFDIR}"
170 APACHE_VHOSTSDIR="${APACHE1_VHOSTSDIR}"
171 APACHE_MODULESDIR="${APACHE1_MODULESDIR}"
172}
173
174####
175# uses_apache2()
176#
177# sets up all of the environment variables required by an apache2 module 91# sets up all of the environment variables required for an apache2 module
178####
179
180uses_apache2() { 92uses_apache2() {
181 debug-print-function $FUNCNAME $* 93 debug-print-function $FUNCNAME $*
94
182 # WARNING: Do not use these variables with anything that is put 95 # WARNING: Do not use these variables with anything that is put
183 # into the dependency cache (DEPEND/RDEPEND/etc) 96 # into the dependency cache (DEPEND/RDEPEND/etc)
184 APACHE_VERSION="2" 97 APACHE_VERSION="2"
185 USE_APACHE="2" 98 USE_APACHE="2"
186 APXS="${APXS2}" 99 APXS="${APXS2}"
190 APACHE_MODULES_CONFDIR="${APACHE2_MODULES_CONFDIR}" 103 APACHE_MODULES_CONFDIR="${APACHE2_MODULES_CONFDIR}"
191 APACHE_VHOSTSDIR="${APACHE2_VHOSTSDIR}" 104 APACHE_VHOSTSDIR="${APACHE2_VHOSTSDIR}"
192 APACHE_MODULESDIR="${APACHE2_MODULESDIR}" 105 APACHE_MODULESDIR="${APACHE2_MODULESDIR}"
193} 106}
194 107
108# @FUNCTION: doesnt_use_apache
109# @DESCRIPTION:
110# sets up all of the environment variables required for optional apache usage
195doesnt_use_apache() { 111doesnt_use_apache() {
196 debug-print-function $FUNCNAME $* 112 debug-print-function $FUNCNAME $*
113
197 APACHE_VERSION="0" 114 APACHE_VERSION="0"
198 USE_APACHE="0" 115 USE_APACHE="0"
199} 116}
200 117
201#### 118# ==============================================================================
202## need_apache1 - !!! DEPRECATED !!! 119# PUBLIC FUNCTIONS
203#### 120# ==============================================================================
204need_apache1() {
205 debug-print-function $FUNCNAME $*
206 121
207 DEPEND="${DEPEND} ${APACHE1_DEPEND}" 122# @FUNCTION: want_apache
208 RDEPEND="${RDEPEND} ${APACHE1_DEPEND}" 123# @DESCRIPTION:
209 APACHE_VERSION="1"
210}
211
212####
213## need_apache2
214##
215## An ebuild calls this to get the dependency information 124# An ebuild calls this to get the dependency information for optional apache-2.x
216## for apache-2.x. An ebuild should use this in order for 125# support.
217## future changes to the build infrastructure to happen
218## seamlessly. All an ebuild needs to do is include the
219## line need_apache2 somewhere.
220####
221need_apache2() {
222 debug-print-function $FUNCNAME $*
223
224 DEPEND="${DEPEND} ${APACHE2_DEPEND}"
225 RDEPEND="${RDEPEND} ${APACHE2_DEPEND}"
226 APACHE_VERSION="2"
227}
228
229####
230## need_apache2_0
231##
232## Works like need_apache2 above, but its used by modules
233## that only support apache 2.0 and do not work with
234## higher versions.
235##
236####
237need_apache2_0() {
238 debug-print-function $FUNCNAME $*
239
240 DEPEND="${DEPEND} ${APACHE2_0_DEPEND}"
241 RDEPEND="${RDEPEND} ${APACHE2_0_DEPEND}"
242 APACHE_VERSION="2"
243}
244
245####
246## need_apache2_2
247##
248## Works like need_apache2 above, but its used by modules
249## that only support apache 2.2 and do not work with
250## lower versions.
251##
252####
253need_apache2_2() {
254 debug-print-function $FUNCNAME $*
255
256 DEPEND="${DEPEND} ${APACHE2_2_DEPEND}"
257 RDEPEND="${RDEPEND} ${APACHE2_2_DEPEND}"
258 APACHE_VERSION="2"
259}
260
261####
262## DO NOT CHANGE THIS FUNCTION UNLESS YOU UNDERSTAND THE CONSEQUENCES IT
263## WILL HAVE ON THE CACHE!
264##
265## This function can take a variable amount of arguments specifying the
266## versions of apache the ebuild supports
267##
268## If no arguments are specified, then all versions are assumed to be supported
269##
270## Currently supported versions: 2.0 2.2 2.x
271####
272need_apache() {
273 debug-print-function $FUNCNAME $*
274
275 local supports2x supports20 supports22
276
277 if [[ $# -eq 0 ]] ; then
278 supports2x="yes"
279 else
280 while [[ $# -gt 0 ]] ; do
281 case "$1" in
282 2.0) supports20="yes"; shift;;
283 2.2) supports22="yes"; shift;;
284 2.x) supports2x="yes"; shift;;
285 *) die "Unknown version specifier: $1";;
286 esac
287 done
288 fi
289
290 if [[ "${supports20}" == "yes" ]] && [[ "${supports22}" == "yes" ]] ; then
291 supports2x="yes"
292 fi
293
294 debug-print "supports20: ${supports20}"
295 debug-print "supports22: ${supports22}"
296 debug-print "supports2x: ${supports2x}"
297
298 if [[ "${supports2x}" == "yes" ]] ; then
299 need_apache2
300 elif [[ "${supports20}" == "yes" ]] ; then
301 need_apache2_0
302 elif [[ "${supports22}" == "yes" ]] ; then
303 need_apache2_2
304 fi
305
306 uses_apache2
307}
308
309want_apache() { 126want_apache() {
310 debug-print-function $FUNCNAME $* 127 debug-print-function $FUNCNAME $*
311 128
312 IUSE="${IUSE} apache2" 129 IUSE="${IUSE} apache2"
313 DEPEND="${DEPEND} ${WANT_APACHE_DEPEND}" 130 DEPEND="${DEPEND} ${WANT_APACHE_DEPEND}"
314 RDEPEND="${RDEPEND} ${WANT_APACHE_DEPEND}" 131 RDEPEND="${RDEPEND} ${WANT_APACHE_DEPEND}"
132
315 if use apache2 ; then 133 if use apache2 ; then
316 uses_apache2 134 uses_apache2
317 else 135 else
318 doesnt_use_apache 136 doesnt_use_apache
319 fi 137 fi
320} 138}
139
140# @FUNCTION: need_apache2
141# @DESCRIPTION:
142# An ebuild calls this to get the dependency information for apache-2.x. An
143# ebuild should use this in order for future changes to the build infrastructure
144# to happen seamlessly. All an ebuild needs to do is include the line
145# need_apache2 somewhere.
146need_apache2() {
147 debug-print-function $FUNCNAME $*
148
149 DEPEND="${DEPEND} ${APACHE2_DEPEND}"
150 RDEPEND="${RDEPEND} ${APACHE2_DEPEND}"
151 uses_apache2
152}
153
154# @FUNCTION: need_apache2_0
155# @DESCRIPTION:
156# Works like need_apache2 above, but its used by modules that only support
157# apache 2.0 and do not work with higher versions.
158need_apache2_0() {
159 debug-print-function $FUNCNAME $*
160
161 DEPEND="${DEPEND} ${APACHE2_0_DEPEND}"
162 RDEPEND="${RDEPEND} ${APACHE2_0_DEPEND}"
163 uses_apache2
164}
165
166# @FUNCTION: need_apache2_2
167# @DESCRIPTION:
168# Works like need_apache2 above, but its used by modules that only support
169# apache 2.2 and do not work with lower versions.
170need_apache2_2() {
171 debug-print-function $FUNCNAME $*
172
173 DEPEND="${DEPEND} ${APACHE2_2_DEPEND}"
174 RDEPEND="${RDEPEND} ${APACHE2_2_DEPEND}"
175 uses_apache2
176}
177
178# @FUNCTION: need_apache
179# @DESCRIPTION:
180# Legacy alias for need_apache2
181need_apache() {
182 need_apache2
183}
184
185# @FUNCTION: apr_config
186# @DESCRIPTION:
187# Version magic to get the correct apr-config binary based on the (probably)
188# installed version of apache. This is needed to get modules to link to the
189# same apr/apu as apache (i.e. link 0.9 for 2.0, 1.x for 2.2)
190apr_config() {
191 debug-print-function $FUNCNAME $*
192
193 local default="${1:-1}"
194 if [[ "${USE_APACHE}" == "2" ]]; then
195 if has_version ${APACHE2_0_DEPEND}; then
196 echo apr-config
197 else
198 echo apr-1-config
199 fi
200 else
201 if [[ "${default}" == "0" ]]; then
202 echo apr-config
203 elif [[ "${default}" == "1" ]]; then
204 echo apr-1-config
205 else
206 die "Unknown version specifier: ${default}"
207 fi
208 fi
209}
210
211# @FUNCTION: apu_config
212# @DESCRIPTION:
213# Version magic to get the correct apu-config binary based on the (probably)
214# installed version of apache. This is needed to get modules to link to the
215# same apr/apu as apache (i.e. link 0.9 for 2.0, 1.x for 2.2)
216apu_config() {
217 debug-print-function $FUNCNAME $*
218
219 local default="${1:-1}"
220 if [[ "${USE_APACHE}" == "2" ]]; then
221 if has_version ${APACHE2_0_DEPEND}; then
222 echo apu-config
223 else
224 echo apu-1-config
225 fi
226 else
227 if [[ "${default}" == "0" ]]; then
228 echo apu-config
229 elif [[ "${default}" == "1" ]]; then
230 echo apu-1-config
231 else
232 die "Unknown version specifier: ${default}"
233 fi
234 fi
235}

Legend:
Removed from v.1.34  
changed lines
  Added in v.1.35

  ViewVC Help
Powered by ViewVC 1.1.20