/[gentoo-x86]/eclass/depend.php.eclass
Gentoo

Diff of /eclass/depend.php.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.2 Revision 1.26
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/depend.php.eclass,v 1.2 2005/09/04 15:15:37 swegener Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/depend.php.eclass,v 1.26 2010/07/13 23:48:46 mabi Exp $
4# 4
5# ======================================================================== 5# Author: Stuart Herbert <stuart@gentoo.org>
6# 6# Author: Luca Longinotti <chtekk@gentoo.org>
7# Author: Jakub Moc <jakub@gentoo.org> (documentation)
8
7# depend.php.eclass 9# @ECLASS: depend.php.eclass
8# functions to allow ebuilds to depend on php4 and/or php5 10# @MAINTAINER:
9# 11# Gentoo PHP team <php-bugs@gentoo.org>
10# Author: Stuart Herbert 12# @BLURB: Functions to allow ebuilds to depend on php5 and check for specific features.
11# (stuart@gentoo.org) 13# @DESCRIPTION:
12# 14# This eclass provides functions that allow ebuilds to depend on php5 and check
13# ======================================================================== 15# for specific PHP features, SAPIs etc. Also provides dodoc-php wrapper to install
16# documentation for PHP packages to php-specific location.
14 17
15inherit eutils
16 18
17need_php4_cli() 19inherit eutils phpconfutils
18{
19 DEPEND="${DEPEND} =virtual/php-4*"
20 RDEPEND="${RDEPEND} =virtual/php-4*"
21 PHP_VERSION=4
22}
23 20
24need_php4_httpd() 21# PHP5-only depend functions
25{
26 DEPEND="${DEPEND} =virtual/httpd-php-4*"
27 RDEPEND="${RDEPEND} =virtual/httpd-php-4*"
28 PHP_VERSION=4
29}
30 22
31need_php4() 23# @FUNCTION: need_php5_cli
32{ 24# @DESCRIPTION:
33 DEPEND="${DEPEND} =dev-lang/php-4*" 25# Set this after setting DEPEND/RDEPEND in your ebuild if the ebuild requires PHP5
34 RDEPEND="${RDEPEND} =dev-lang/php-4*" 26# with cli SAPI.
35 PHP_VERSION=4
36 PHP_SHARED_CAT="php4"
37}
38
39# common settings go in here
40uses_php4()
41{
42 # cache this
43 libdir=$(get_libdir)
44
45 PHPIZE="/usr/${libdir}/php4/bin/phpize"
46 PHPCONFIG="/usr/${libdir}/php4/bin/php-config"
47 PHPCLI="/usr/${libdir}/php4/bin/php"
48 PHPCGI="/usr/${libdir}/php4/bin/php-cgi"
49 PHP_PKG="`best_version =dev-lang/php-4*`"
50 PHPPREFIX="/usr/${libdir}/php4"
51
52 einfo
53 einfo "Using ${PHP_PKG}"
54 einfo
55}
56
57need_php5_cli() 27need_php5_cli() {
58{
59 DEPEND="${DEPEND} =virtual/php-5*" 28 DEPEND="${DEPEND} =virtual/php-5*"
60 RDEPEND="${RDEPEND} =virtual/php-5*" 29 RDEPEND="${RDEPEND} =virtual/php-5*"
61 PHP_VERSION=5 30 PHP_VERSION="5"
62} 31}
63 32
33# @FUNCTION: need_php5_httpd
34# @DESCRIPTION:
35# Set this after setting DEPEND/RDEPEND in your ebuild if the ebuild requires PHP5
36# with either cgi or apache2 SAPI.
64need_php5_httpd() 37need_php5_httpd() {
65{
66 DEPEND="${DEPEND} =virtual/httpd-php-5*" 38 DEPEND="${DEPEND} =virtual/httpd-php-5*"
67 RDEPEND="${RDEPEND} =virtual/httpd-php-5*" 39 RDEPEND="${RDEPEND} =virtual/httpd-php-5*"
68 PHP_VERSION=5 40 PHP_VERSION="5"
69} 41}
70 42
43# @FUNCTION: need_php5
44# @DESCRIPTION:
45# Set this after setting DEPEND/RDEPEND in your ebuild if the ebuild requires PHP5
46# (with any SAPI).
71need_php5() 47need_php5() {
72{
73 DEPEND="${DEPEND} =dev-lang/php-5*" 48 DEPEND="${DEPEND} =dev-lang/php-5*"
74 RDEPEND="${RDEPEND} =dev-lang/php-5*" 49 RDEPEND="${RDEPEND} =dev-lang/php-5*"
75 PHP_VERSION=5 50 PHP_VERSION="5"
76 PHP_SHARED_CAT="php5" 51 PHP_SHARED_CAT="php5"
77} 52}
78 53
79# common settings go in here 54# common settings go in here
80uses_php5() 55uses_php5() {
81{
82 # cache this 56 # cache this
83 libdir=$(get_libdir) 57 libdir=$(get_libdir)
84 58
85 PHPIZE="/usr/${libdir}/php5/bin/phpize" 59 PHPIZE="/usr/${libdir}/php5/bin/phpize"
86 PHPCONFIG="/usr/${libdir}/php5/bin/php-config" 60 PHPCONFIG="/usr/${libdir}/php5/bin/php-config"
87 PHPCLI="/usr/${libdir}/php5/bin/php" 61 PHPCLI="/usr/${libdir}/php5/bin/php"
88 PHPCGI="/usr/${libdir}/php5/bin/php-cgi" 62 PHPCGI="/usr/${libdir}/php5/bin/php-cgi"
89 PHP_PKG="`best_version =dev-lang/php-5*`" 63 PHP_PKG="$(best_version =dev-lang/php-5*)"
90 PHPPREFIX="/usr/${libdir}/php5" 64 PHPPREFIX="/usr/${libdir}/php5"
65 EXT_DIR="$(${PHPCONFIG} --extension-dir 2>/dev/null)"
91 66
92 einfo 67 einfo
93 einfo "Using ${PHP_PKG}" 68 einfo "Using ${PHP_PKG}"
94 einfo 69 einfo
95} 70}
96 71
72# general PHP depend functions
73
74# @FUNCTION: need_php_cli
75# @DESCRIPTION:
76# Set this after setting DEPEND/RDEPEND in your ebuild if the ebuild requires PHP
77# (any version) with cli SAPI.
78need_php_cli() {
79 DEPEND="${DEPEND} virtual/php"
80 RDEPEND="${RDEPEND} virtual/php"
81}
82
83# @FUNCTION: need_php_httpd
84# @DESCRIPTION:
85# Set this after setting DEPEND/RDEPEND in your ebuild if the ebuild requires PHP
86# (any version) with either cgi or apache2 SAPI.
87need_php_httpd() {
88 DEPEND="${DEPEND} virtual/httpd-php"
89 RDEPEND="${RDEPEND} virtual/httpd-php"
90}
91
92# @FUNCTION: need_php
93# @DESCRIPTION:
94# Set this after setting DEPEND/RDEPEND in your ebuild if the ebuild requires PHP
95# (any version with any SAPI).
97need_php() 96need_php() {
98{
99 DEPEND="${DEPEND} dev-lang/php" 97 DEPEND="${DEPEND} dev-lang/php"
100 RDEPEND="${RDEPEND} dev-lang/php" 98 RDEPEND="${RDEPEND} dev-lang/php"
101 PHP_SHARED_CAT="php" 99 PHP_SHARED_CAT="php"
102} 100}
103 101
102# @FUNCTION: need_php_by_category
103# @DESCRIPTION:
104# Set this after setting DEPEND/RDEPEND in your ebuild to depend on PHP version
105# determined by ${CATEGORY} - any PHP version or PHP5 for dev-php or
106# dev-php5, respectively.
104need_php_by_category() 107need_php_by_category() {
105{
106 case "${CATEGORY}" in 108 case "${CATEGORY}" in
107 dev-php) need_php ;; 109 dev-php) need_php ;;
108 dev-php4) need_php4 ;;
109 dev-php5) need_php5 ;; 110 dev-php5) need_php5 ;;
110 *) die "I don't know which version of PHP packages in ${CATEGORY} require" 111 *) die "Version of PHP required by packages in category ${CATEGORY} unknown"
111 esac 112 esac
112} 113}
113 114
115
116# @FUNCTION: has_php
117# @DESCRIPTION:
118# Call this function from your pkg_setup, src_compile, src_install etc. if you
119# need to know which PHP version is being used and where the PHP binaries/data
120# are installed.
121has_php() {
122 # Detect which PHP version we have installed
123 if has_version '=dev-lang/php-5*' ; then
124 PHP_VERSION="5"
125 else
126 die "Unable to find an installed dev-lang/php package"
127 fi
128
129 # If we get here, then PHP_VERSION tells us which version of PHP we
130 # want to use
131 uses_php${PHP_VERSION}
132}
133
134# @FUNCTION: require_php_sapi_from
135# @USAGE: <list of SAPIs>
136# @DESCRIPTION:
114# call this function from pkg_setup if your PHP extension only works with 137# Call this function from pkg_setup if your package only works with
115# specific SAPIs 138# specific SAPI(s) and specify a list of PHP SAPI USE flags that are
139# required (one or more from cli, cgi, apache2) as arguments.
140# Returns if any of the listed SAPIs have been installed, dies if none
141# of them is available.
116# 142#
117# this function will disappear when USE-based deps are supported by 143# Unfortunately, if you want to be really sure that the required SAPI is
118# Portage 144# provided by PHP, you will have to use this function or similar ones (like
119# 145# require_php_cli or require_php_cgi) in pkg_setup until we are able to
120# $1 ... a list of SAPI USE flags (eg cli, cgi, apache2) 146# depend on USE flags being enabled. The above described need_php[45]_cli
121# 147# and need_php[45]_httpd functions cannot guarantee these requirements.
122# returns if any one of the listed SAPIs has been installed 148# See Bug 2272 for details.
123# dies if none of the listed SAPIs has been installed
124
125require_php_sapi_from() { 149require_php_sapi_from() {
126 has_php 150 has_php
127 151
128 local has_sapi=0 152 local has_sapi="0"
129 local x 153 local x
130 154
131 einfo "Checking for compatible SAPI(s)" 155 einfo "Checking for compatible SAPI(s)"
132 156
133 for x in $@ ; do 157 for x in $@ ; do
134 if built_with_use =${PHP_PKG} ${x} ; then 158 if built_with_use =${PHP_PKG} ${x} || phpconfutils_built_with_use =${PHP_PKG} ${x} ; then
135 einfo " Discovered compatible SAPI ${x}" 159 einfo " Discovered compatible SAPI ${x}"
136 has_sapi=1 160 has_sapi="1"
137 fi 161 fi
138 done 162 done
139 163
140 if [[ ${has_sapi} == 1 ]]; then 164 if [[ "${has_sapi}" == "1" ]] ; then
141 return 165 return
142 fi 166 fi
143 167
144 eerror 168 eerror
145 eerror "${PHP_PKG} needs to be re-installed with one of the following" 169 eerror "${PHP_PKG} needs to be re-installed with one of the following"
146 eerror "USE flags enabled:" 170 eerror "USE flags enabled:"
147 eerror 171 eerror
148 eerror " $@" 172 eerror " $@"
149 eerror 173 eerror
150 die "Re-install ${PHP_PKG}" 174 die "No compatible PHP SAPIs found"
151} 175}
152 176
177# @FUNCTION: require_php_with_use
178# @USAGE: <list of USE flags>
179# @DESCRIPTION:
153# call this function from pkg_setup if your package requires PHP compiled 180# Call this function from pkg_setup if your package requires PHP compiled
154# with specific USE flags 181# with specific USE flags. Returns if all of the listed USE flags are enabled.
182# Dies if any of the listed USE flags are disabled.
183
184# @VARIABLE: PHPCHECKNODIE
185# @DESCRIPTION:
186# You can set PHPCHECKNODIE to non-empty value in your ebuild to chain multiple
187# require_php_with_(any)_use checks without making the ebuild die on every failure.
188# This is useful in cases when certain PHP features are only required if specific
189# USE flag(s) are enabled for that ebuild.
190# @CODE
191# Example:
155# 192#
156# this function will disappear when USE-based deps are supported by 193# local flags="pcre session snmp sockets wddx"
157# Portage 194# use mysql && flags="${flags} mysql"
158# 195# use postgres && flags="${flags} postgres"
159# $1 ... a list of USE flags 196# if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} \
160# 197# || ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
161# returns if all of the listed USE flags are set 198# die "Re-install ${PHP_PKG} with ${flags} and either gd or gd-external"
162# dies if any of the listed USE flags are not set 199# fi
163 200# @CODE
164require_php_with_use() { 201require_php_with_use() {
165 has_php 202 has_php
166 203
167 local missing_use= 204 local missing_use=""
168 local x 205 local x
169 206
170 einfo "Checking for required PHP feature(s):" 207 einfo "Checking for required PHP feature(s) ..."
171 208
172 for x in $@ ; do 209 for x in $@ ; do
173 if ! built_with_use =${PHP_PKG} ${x} ; then 210 if ! built_with_use =${PHP_PKG} ${x} && ! phpconfutils_built_with_use =${PHP_PKG} ${x} ; then
174 einfo " Discovered missing USE flag ${x}" 211 einfo " Discovered missing USE flag: ${x}"
175 missing_use="${missing_use} ${x}" 212 missing_use="${missing_use} ${x}"
176 fi 213 fi
177 done 214 done
178 215
179 if [[ -z ${missing_use} ]]; then 216 if [[ -z "${missing_use}" ]] ; then
217 if [[ -z "${PHPCHECKNODIE}" ]] ; then
180 return 218 return
181 fi
182
183 eerror
184 eerror "${PHP_PKG} needs to be re-installed with all of the following"
185 eerror "USE flags enabled:"
186 eerror
187 eerror " $@"
188 eerror
189 die "Re-install ${PHP_PKG}"
190}
191
192# call this function from your src_compile & src_install methods
193# if you need to know where the PHP binaries are installed
194
195has_php()
196{
197 # if PHP_PKG is set, then we have remembered our PHP settings
198 # from last time
199 if [[ -n ${PHP_PKG} ]]; then
200 return
201 fi
202
203 if [[ -z ${PHP_VERSION} ]]; then
204 # detect which PHP version installed
205 if has_version '=dev-lang/php-5*' ; then
206 PHP_VERSION=5
207 elif has_version '=dev-lang/php-4*' ; then
208 PHP_VERSION=4
209 else 219 else
210 die "Unable to find an installed dev-lang/php package" 220 return 0
211 fi
212 fi 221 fi
222 fi
213 223
214 # if we get here, then PHP_VERSION tells us which version of PHP we 224 if [[ -z "${PHPCHECKNODIE}" ]] ; then
215 # want to use 225 eerror
226 eerror "${PHP_PKG} needs to be re-installed with all of the following"
227 eerror "USE flags enabled:"
228 eerror
229 eerror " $@"
230 eerror
231 die "Missing PHP USE flags found"
232 else
233 return 1
234 fi
235}
216 236
217 uses_php${PHP_VERSION} 237# @FUNCTION: require_php_with_any_use
238# @USAGE: <list of USE flags>
239# @DESCRIPTION:
240# Call this function from pkg_setup if your package requires PHP compiled with
241# any of specified USE flags. Returns if any of the listed USE flags are enabled.
242# Dies if all of the listed USE flags are disabled.
243require_php_with_any_use() {
244 has_php
245
246 local missing_use=""
247 local x
248
249 einfo "Checking for required PHP feature(s) ..."
250
251 for x in $@ ; do
252 if built_with_use =${PHP_PKG} ${x} || phpconfutils_built_with_use =${PHP_PKG} ${x} ; then
253 einfo " USE flag ${x} is enabled, ok ..."
254 return
255 else
256 missing_use="${missing_use} ${x}"
257 fi
258 done
259
260 if [[ -z "${missing_use}" ]] ; then
261 if [[ -z "${PHPCHECKNODIE}" ]] ; then
262 return
263 else
264 return 0
265 fi
266 fi
267
268 if [[ -z "${PHPCHECKNODIE}" ]] ; then
269 eerror
270 eerror "${PHP_PKG} needs to be re-installed with any of the following"
271 eerror "USE flags enabled:"
272 eerror
273 eerror " $@"
274 eerror
275 die "Missing PHP USE flags found"
276 else
277 return 1
278 fi
218} 279}
219 280
220# ======================================================================== 281# ========================================================================
221# has_*() functions 282# has_*() functions
222# 283#
223# these functions return 0 if the condition is satisfied, or 1 otherwise 284# These functions return 0 if the condition is satisfied, 1 otherwise
224# ======================================================================== 285# ========================================================================
225 286
287# @FUNCTION: has_zts
288# @DESCRIPTION:
289# Check if our PHP was compiled with ZTS (Zend Thread Safety) enabled.
290# @RETURN: 0 if true, 1 otherwise
226has_zts() 291has_zts() {
227{
228 has_php 292 has_php
229 293
230 if built_with_use =${PHP_PKG} apache2 threads ; then 294 if built_with_use =${PHP_PKG} apache2 threads || phpconfutils_built_with_use =${PHP_PKG} apache2 threads ; then
295 return 0
296 fi
297
298 return 1
299}
300
301# @FUNCTION: has_debug
302# @DESCRIPTION:
303# Check if our PHP was built with debug support enabled.
304# @RETURN: 0 if true, 1 otherwise
305has_debug() {
306 has_php
307
308 if built_with_use =${PHP_PKG} debug || phpconfutils_built_with_use =${PHP_PKG} debug ; then
309 return 0
310 fi
311
312 return 1
313}
314
315# @FUNCTION: has_concurrentmodphp
316# @DESCRIPTION:
317# Check if our PHP was built with the concurrentmodphp support enabled.
318# @RETURN: 0 if true, 1 otherwise
319has_concurrentmodphp() {
320 has_php
321
322 if built_with_use =${PHP_PKG} apache2 concurrentmodphp || phpconfutils_built_with_use =${PHP_PKG} apache2 concurrentmodphp ; then
231 return 0 323 return 0
232 fi 324 fi
233 325
234 return 1 326 return 1
235} 327}
236 328
237# ======================================================================== 329# ========================================================================
238# require_*() functions 330# require_*() functions
239# 331#
240# These functions die() if PHP was built without the required USE flag(s) 332# These functions die() if PHP was built without the required features
241# ======================================================================== 333# ========================================================================
242 334
335# @FUNCTION: require_pdo
336# @DESCRIPTION:
337# Require a PHP built with PDO support (PHP5 only).
338# This function is now redundant and DEPRECATED since
339# pdo-external use flag and pecl-pdo-* ebuilds were removed.
340# You should use require_php_with_use pdo instead now.
341# @RETURN: die if feature is missing
243require_pdo() 342require_pdo() {
244{
245 has_php 343 has_php
246 344
247 # do we have php5.1 installed? 345 # Was PHP5 compiled with internal PDO support?
248 346 if built_with_use =${PHP_PKG} pdo || phpconfutils_built_with_use =${PHP_PKG} pdo ; then
249 if [[ ${PHP_VERSION} == 4 ]] ; then
250 eerror
251 eerror "This package requires PDO. PDO is only available for PHP 5."
252 eerror "Please install dev-lang/php-5*"
253 eerror
254 die "PHP 5 not installed"
255 fi
256
257 # was php5 compiled w/ pdo support?
258
259 if built_with_use =${PHP_PKG} pdo ; then
260 return 347 return
261 fi 348 else
262
263 # ok, maybe PDO was built as an external extension?
264
265 if built_with_use =${PHP_PKG} pdo-external && has_version dev-php5/pecl-pdo ; then
266 return
267 fi
268
269 # it suffices that pecl-pdo was installed to have PDO support
270
271 if has_version dev-php5/pecl-pdo ; then
272 return
273 fi
274
275 # if we get here, then we have no PDO support :(
276
277 eerror 349 eerror
278 eerror "No PDO extension for PHP found." 350 eerror "No PDO extension for PHP found."
279 eerror "Please note that PDO only exists for PHP 5." 351 eerror "Please note that PDO only exists for PHP 5."
280 eerror "Please install a PDO extension for PHP 5," 352 eerror "Please install a PDO extension for PHP 5."
281 eerror "you must install dev-lang/php-5.0* with" 353 eerror "You must install >=dev-lang/php-5.1 with USE=\"pdo\"."
282 eerror "the 'pdo-external' USE flag or you must"
283 eerror "install dev-lang/php-5.1* with either"
284 eerror "the 'pdo' or the 'pdo-external' USE flags"
285 eerror "turned on."
286 eerror 354 eerror
287 die "No PDO extension found for PHP" 355 die "No PDO extension for PHP 5 found"
356 fi
288} 357}
289 358
359# @FUNCTION: require_php_cli
360# @DESCRIPTION:
290# determines which installed PHP version has the CLI sapi 361# Determines which installed PHP version has the CLI SAPI enabled.
291# useful for PEAR eclass, or anything which needs to run PHP 362# Useful for PEAR stuff, or anything which needs to run PHP script
292# scripts 363# depending on the CLI SAPI.
293 364# @RETURN: die if feature is missing
294require_php_cli() 365require_php_cli() {
295{
296 # if PHP_PKG is set, then we have remembered our PHP settings 366 # If PHP_PKG is set, then we have remembered our PHP settings
297 # from last time 367 # from last time
298 if [[ -n ${PHP_PKG} ]]; then 368 if [[ -n ${PHP_PKG} ]] ; then
299 return 369 return
300 fi 370 fi
301 371
302 # detect which PHP version installed 372 local PHP_PACKAGE_FOUND=""
373
303 if has_version '=dev-lang/php-5*' ; then 374 if has_version '=dev-lang/php-5*' ; then
375 PHP_PACKAGE_FOUND="1"
304 pkg="`best_version '=dev-lang/php-5*'`" 376 pkg="$(best_version '=dev-lang/php-5*')"
305 if built_with_use =${pkg} cli ; then 377 if built_with_use =${pkg} cli || phpconfutils_built_with_use =${pkg} cli ; then
306 PHP_VERSION=5 378 PHP_VERSION="5"
379 fi
307 fi 380 fi
308 elif has_version '=dev-lang/php-4*' ; then 381
309 pkg="`best_version '=dev-lang/php-4*'`" 382 if [[ -z ${PHP_PACKAGE_FOUND} ]] ; then
310 if built_with_use =${pkg} cli ; then
311 PHP_VERSION=4
312 fi
313 else
314 die "Unable to find an installed dev-lang/php package" 383 die "Unable to find an installed dev-lang/php package"
315 fi 384 fi
316 385
317 if [[ -z ${PHP_VERSION} ]]; then 386 if [[ -z ${PHP_VERSION} ]] ; then
318 die "No PHP CLI installed" 387 die "No PHP CLI installed. Re-emerge dev-lang/php with USE=cli."
319 fi 388 fi
320 389
321 # if we get here, then PHP_VERSION tells us which version of PHP we 390 # If we get here, then PHP_VERSION tells us which version of PHP we
322 # want to use 391 # want to use
323 uses_php${PHP_VERSION} 392 uses_php${PHP_VERSION}
324} 393}
325 394
326# require a PHP built with sqlite support 395# @FUNCTION: require_php_cgi
327 396# @DESCRIPTION:
328require_sqlite() 397# Determines which installed PHP version has the CGI SAPI enabled.
329{ 398# Useful for anything which needs to run PHP scripts depending on the CGI SAPI.
330 has_php 399# @RETURN: die if feature is missing
331 400require_php_cgi() {
332 # has our PHP been built w/ sqlite? 401 # If PHP_PKG is set, then we have remembered our PHP settings
333 if built_with_use =${PHP_PKG} sqlite ; then 402 # from last time
334 return 403 if [[ -n ${PHP_PKG} ]] ; then
335 fi
336
337 # do we have pecl-sqlite installed for PHP4?
338 if [[ ${PHP_VERSION} == 4 ]] ; then
339 if has_version dev-php4/pecl-sqlite ; then
340 return 404 return
341 fi 405 fi
406
407 local PHP_PACKAGE_FOUND=""
408
409 if has_version '=dev-lang/php-5*' ; then
410 PHP_PACKAGE_FOUND="1"
411 pkg="$(best_version '=dev-lang/php-5*')"
412 if built_with_use =${pkg} cgi || phpconfutils_built_with_use =${pkg} cgi ; then
413 PHP_VERSION="5"
342 fi 414 fi
415 fi
343 416
417 if [[ -z ${PHP_PACKAGE_FOUND} ]] ; then
418 die "Unable to find an installed dev-lang/php package"
419 fi
420
421 if [[ -z ${PHP_VERSION} ]] ; then
422 die "No PHP CGI installed. Re-emerge dev-lang/php with USE=cgi."
423 fi
424
425 # If we get here, then PHP_VERSION tells us which version of PHP we
426 # want to use
427 uses_php${PHP_VERSION}
428}
429
430# @FUNCTION: require_sqlite
431# @DESCRIPTION:
432# Require a PHP built with SQLite support
433# @RETURN: die if feature is missing
434require_sqlite() {
435 has_php
436
437 # Has our PHP been built with SQLite support?
438 if built_with_use =${PHP_PKG} sqlite || phpconfutils_built_with_use =${PHP_PKG} sqlite ; then
439 return
440 fi
441
344 # if we get here, then we don't have any php/sqlite support installed 442 # If we get here, then we don't have any SQLite support for PHP installed
345 eerror 443 eerror
346 eerror "No sqlite extension for PHP found." 444 eerror "No SQLite extension for PHP found."
347 eerror "Please install an sqlite extension for PHP," 445 eerror "Please install an SQLite extension for PHP,"
348 eerror "this is done best by simply adding the" 446 eerror "this is done best by simply adding the"
349 eerror "'sqlite' USE flag when emerging dev-lang/php." 447 eerror "'sqlite' USE flag when emerging dev-lang/php."
350 eerror 448 eerror
351 die "No sqlite extension for PHP found" 449 die "No SQLite extension for PHP found"
352} 450}
451
452# @FUNCTION: require_gd
453# @DESCRIPTION:
454# Require a PHP built with GD support
455# @RETURN: die if feature is missing
456require_gd() {
457 has_php
458
459 # Do we have the internal GD support installed?
460 if built_with_use =${PHP_PKG} gd || phpconfutils_built_with_use =${PHP_PKG} gd ; then
461 return
462 fi
463
464 # Ok, maybe GD was built using the external library support?
465 if built_with_use =${PHP_PKG} gd-external || phpconfutils_built_with_use =${PHP_PKG} gd-external ; then
466 return
467 fi
468
469 # If we get here, then we have no GD support
470 eerror
471 eerror "No GD support for PHP found."
472 eerror "Please install the GD support for PHP,"
473 eerror "you must install dev-lang/php with either"
474 eerror "the 'gd' or the 'gd-external' USE flags"
475 eerror "turned on."
476 eerror
477 die "No GD support found for PHP"
478}
479
480# ========================================================================
481# Misc functions
482#
483# These functions provide miscellaneous checks and functionality.
484# ========================================================================
485
486# @FUNCTION: php_binary_extension
487# @DESCRIPTION:
488# Executes some checks needed when installing a binary PHP extension.
489php_binary_extension() {
490 has_php
491
492 local PUSE_ENABLED=""
493
494 # Binary extensions do not support the change of PHP
495 # API version, so they can't be installed when USE flags
496 # are enabled which change the PHP API version, they also
497 # don't provide correctly versioned symbols for our use
498
499 if has_debug ; then
500 eerror
501 eerror "You cannot install binary PHP extensions"
502 eerror "when the 'debug' USE flag is enabled!"
503 eerror "Please reemerge dev-lang/php with the"
504 eerror "'debug' USE flag turned off."
505 eerror
506 PUSE_ENABLED="1"
507 fi
508
509 if has_concurrentmodphp ; then
510 eerror
511 eerror "You cannot install binary PHP extensions when"
512 eerror "the 'concurrentmodphp' USE flag is enabled!"
513 eerror "Please reemerge dev-lang/php with the"
514 eerror "'concurrentmodphp' USE flag turned off."
515 eerror
516 PUSE_ENABLED="1"
517 fi
518
519 if [[ -n ${PUSE_ENABLED} ]] ; then
520 die "'debug' and/or 'concurrentmodphp' USE flags turned on!"
521 fi
522}
523
524# @FUNCTION: dodoc-php
525# @USAGE: <list of docs>
526# @DESCRIPTION:
527# Alternative to dodoc function for use in our PHP eclasses and ebuilds.
528# Stored here because depend.php gets always sourced everywhere in the PHP
529# ebuilds and eclasses. It simply is dodoc with a changed path to the docs.
530# NOTE: No support for docinto is provided!
531dodoc-php() {
532if [[ $# -lt 1 ]] ; then
533 echo "$0: at least one argument needed" 1>&2
534 exit 1
535fi
536
537phpdocdir="/usr/share/doc/${CATEGORY}/${PF}/"
538
539for x in $@ ; do
540 if [[ -s "${x}" ]] ; then
541 insinto "${phpdocdir}"
542 doins "${x}"
543 gzip -f -9 "${D}/${phpdocdir}/${x##*/}"
544 elif [[ ! -e "${x}" ]] ; then
545 echo "dodoc-php: ${x} does not exist" 1>&2
546 fi
547done
548}
549
550# @FUNCTION: dohtml-php
551# @USAGE: <list of html docs>
552# @DESCRIPTION:
553# Alternative to dohtml function for use in our PHP eclasses and ebuilds.
554# Stored here because depend.php gets always sourced everywhere in the PHP
555# ebuilds and eclasses. It simply is dohtml with a changed path to the docs.
556# NOTE: No support for [-a|-A|-p|-x] options is provided!
557dohtml-php() {
558if [[ $# -lt 1 ]] ; then
559 echo "$0: at least one argument needed" 1>&2
560 exit 1
561fi
562
563phphtmldir="/usr/share/doc/${CATEGORY}/${PF}/html"
564
565for x in $@ ; do
566 if [[ -s "${x}" ]] ; then
567 insinto "${phphtmldir}"
568 doins "${x}"
569 elif [[ ! -e "${x}" ]] ; then
570 echo "dohtml-php: ${x} does not exist" 1>&2
571 fi
572done
573}

Legend:
Removed from v.1.2  
changed lines
  Added in v.1.26

  ViewVC Help
Powered by ViewVC 1.1.20