/[gentoo-x86]/eclass/depend.php.eclass
Gentoo

Diff of /eclass/depend.php.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.20 Revision 1.27
1# Copyright 1999-2007 Gentoo Foundation 1# Copyright 1999-2007 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/depend.php.eclass,v 1.20 2007/08/16 22:11:00 hoffie Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/depend.php.eclass,v 1.27 2010/10/02 15:23:57 olemarkus Exp $
4 4
5# ======================================================================== 5# Author: Stuart Herbert <stuart@gentoo.org>
6# 6# Author: Luca Longinotti <chtekk@gentoo.org>
7# Author: Jakub Moc <jakub@gentoo.org> (documentation)
8
7# depend.php.eclass 9# @ECLASS: depend.php.eclass
8# Functions to allow ebuilds to depend on php4 and/or php5 10# @MAINTAINER:
9#
10# Author: Stuart Herbert
11# <stuart@gentoo.org>
12#
13# Author: Luca Longinotti
14# <chtekk@gentoo.org>
15#
16# Maintained by the PHP Team <php-bugs@gentoo.org> 11# Gentoo PHP team <php-bugs@gentoo.org>
17# 12# @BLURB: Functions to allow ebuilds to depend on php5 and check for specific features.
18# ======================================================================== 13# @DESCRIPTION:
14# This eclass provides functions that allow ebuilds to depend on php5 and check
15# for specific PHP features, SAPIs etc. Also provides dodoc-php wrapper to install
16# documentation for PHP packages to php-specific location.
17
19 18
20inherit eutils phpconfutils 19inherit eutils phpconfutils
21 20
22# PHP4-only depend functions
23need_php4_cli() {
24 DEPEND="${DEPEND} =virtual/php-4*"
25 RDEPEND="${RDEPEND} =virtual/php-4*"
26 PHP_VERSION="4"
27}
28
29need_php4_httpd() {
30 DEPEND="${DEPEND} =virtual/httpd-php-4*"
31 RDEPEND="${RDEPEND} =virtual/httpd-php-4*"
32 PHP_VERSION="4"
33}
34
35need_php4() {
36 DEPEND="${DEPEND} =dev-lang/php-4*"
37 RDEPEND="${RDEPEND} =dev-lang/php-4*"
38 PHP_VERSION="4"
39 PHP_SHARED_CAT="php4"
40}
41
42# common settings go in here
43uses_php4() {
44 # cache this
45 libdir=$(get_libdir)
46
47 PHPIZE="/usr/${libdir}/php4/bin/phpize"
48 PHPCONFIG="/usr/${libdir}/php4/bin/php-config"
49 PHPCLI="/usr/${libdir}/php4/bin/php"
50 PHPCGI="/usr/${libdir}/php4/bin/php-cgi"
51 PHP_PKG="`best_version =dev-lang/php-4*`"
52 PHPPREFIX="/usr/${libdir}/php4"
53 EXT_DIR="`${PHPCONFIG} --extension-dir 2>/dev/null`"
54
55 einfo
56 einfo "Using ${PHP_PKG}"
57 einfo
58}
59
60# PHP5-only depend functions 21# PHP5-only depend functions
22
23# @FUNCTION: need_php5_cli
24# @DESCRIPTION:
25# Set this after setting DEPEND/RDEPEND in your ebuild if the ebuild requires PHP5
26# with cli SAPI.
61need_php5_cli() { 27need_php5_cli() {
62 DEPEND="${DEPEND} =virtual/php-5*" 28 DEPEND="${DEPEND} =virtual/php-5*"
63 RDEPEND="${RDEPEND} =virtual/php-5*" 29 RDEPEND="${RDEPEND} =virtual/php-5*"
64 PHP_VERSION="5" 30 PHP_VERSION="5"
65} 31}
66 32
33# @FUNCTION: need_php5_httpd
34# @DESCRIPTION:
35# Set this after setting DEPEND/RDEPEND in your ebuild if the ebuild requires PHP5
36# with either cgi or apache2 SAPI.
67need_php5_httpd() { 37need_php5_httpd() {
68 DEPEND="${DEPEND} =virtual/httpd-php-5*" 38 DEPEND="${DEPEND} =virtual/httpd-php-5*"
69 RDEPEND="${RDEPEND} =virtual/httpd-php-5*" 39 RDEPEND="${RDEPEND} =virtual/httpd-php-5*"
70 PHP_VERSION="5" 40 PHP_VERSION="5"
71} 41}
72 42
43# @FUNCTION: need_php5
44# @DESCRIPTION:
45# Set this after setting DEPEND/RDEPEND in your ebuild if the ebuild requires PHP5
46# (with any SAPI).
73need_php5() { 47need_php5() {
74 DEPEND="${DEPEND} =dev-lang/php-5*" 48 DEPEND="${DEPEND} =dev-lang/php-5*"
75 RDEPEND="${RDEPEND} =dev-lang/php-5*" 49 RDEPEND="${RDEPEND} =dev-lang/php-5*"
76 PHP_VERSION="5" 50 PHP_VERSION="5"
77 PHP_SHARED_CAT="php5" 51 PHP_SHARED_CAT="php5"
84 58
85 PHPIZE="/usr/${libdir}/php5/bin/phpize" 59 PHPIZE="/usr/${libdir}/php5/bin/phpize"
86 PHPCONFIG="/usr/${libdir}/php5/bin/php-config" 60 PHPCONFIG="/usr/${libdir}/php5/bin/php-config"
87 PHPCLI="/usr/${libdir}/php5/bin/php" 61 PHPCLI="/usr/${libdir}/php5/bin/php"
88 PHPCGI="/usr/${libdir}/php5/bin/php-cgi" 62 PHPCGI="/usr/${libdir}/php5/bin/php-cgi"
89 PHP_PKG="`best_version =dev-lang/php-5*`" 63 PHP_PKG="$(best_version =dev-lang/php-5*)"
90 PHPPREFIX="/usr/${libdir}/php5" 64 PHPPREFIX="/usr/${libdir}/php5"
91 EXT_DIR="`${PHPCONFIG} --extension-dir 2>/dev/null`" 65 EXT_DIR="$(${PHPCONFIG} --extension-dir 2>/dev/null)"
92 66
93 einfo 67 einfo
94 einfo "Using ${PHP_PKG}" 68 einfo "Using ${PHP_PKG}"
95 einfo 69 einfo
96} 70}
97 71
98# general PHP depend functions 72# general PHP depend functions
73
74# @FUNCTION: need_php_cli
75# @DESCRIPTION:
76# Set this after setting DEPEND/RDEPEND in your ebuild if the ebuild requires PHP
77# (any version) with cli SAPI.
99need_php_cli() { 78need_php_cli() {
100 DEPEND="${DEPEND} virtual/php" 79 DEPEND="${DEPEND} virtual/php"
101 RDEPEND="${RDEPEND} virtual/php" 80 RDEPEND="${RDEPEND} virtual/php"
102} 81}
103 82
83# @FUNCTION: need_php_httpd
84# @DESCRIPTION:
85# Set this after setting DEPEND/RDEPEND in your ebuild if the ebuild requires PHP
86# (any version) with either cgi or apache2 SAPI.
104need_php_httpd() { 87need_php_httpd() {
105 DEPEND="${DEPEND} virtual/httpd-php" 88 DEPEND="${DEPEND} virtual/httpd-php"
106 RDEPEND="${RDEPEND} virtual/httpd-php" 89 RDEPEND="${RDEPEND} virtual/httpd-php"
107} 90}
108 91
92# @FUNCTION: need_php
93# @DESCRIPTION:
94# Set this after setting DEPEND/RDEPEND in your ebuild if the ebuild requires PHP
95# (any version with any SAPI).
109need_php() { 96need_php() {
110 DEPEND="${DEPEND} dev-lang/php" 97 DEPEND="${DEPEND} dev-lang/php"
111 RDEPEND="${RDEPEND} dev-lang/php" 98 RDEPEND="${RDEPEND} dev-lang/php"
112 PHP_SHARED_CAT="php" 99 PHP_SHARED_CAT="php"
113} 100}
114 101
102# @FUNCTION: need_php_by_category
103# @DESCRIPTION:
104# Set this after setting DEPEND/RDEPEND in your ebuild to depend on PHP version
105# determined by ${CATEGORY} - any PHP version or PHP5 for dev-php or
106# dev-php5, respectively.
115need_php_by_category() { 107need_php_by_category() {
116 case "${CATEGORY}" in 108 case "${CATEGORY}" in
117 dev-php) need_php ;; 109 dev-php) need_php ;;
118 dev-php4) need_php4 ;;
119 dev-php5) need_php5 ;; 110 dev-php5) need_php5 ;;
120 *) die "Version of PHP required by packages in category ${CATEGORY} unknown" 111 *) die "Version of PHP required by packages in category ${CATEGORY} unknown"
121 esac 112 esac
122} 113}
123 114
115
116# @FUNCTION: has_php
117# @DESCRIPTION:
124# Call this function from your pkg_setup, src_compile and src_install methods 118# Call this function from your pkg_setup, src_compile, src_install etc. if you
125# if you need to know where the PHP binaries are installed and their data 119# need to know which PHP version is being used and where the PHP binaries/data
126 120# are installed.
127has_php() { 121has_php() {
128 # If PHP_PKG is already set, then we have remembered our PHP settings
129 # from last time
130 if [[ -n ${PHP_PKG} ]] ; then
131 return
132 fi
133
134 if [[ -z ${PHP_VERSION} ]] ; then
135 # Detect which PHP version we have installed 122 # Detect which PHP version we have installed
136 if has_version '=dev-lang/php-5*' ; then 123 if has_version '=dev-lang/php-5*' ; then
137 PHP_VERSION="5" 124 PHP_VERSION="5"
138 elif has_version '=dev-lang/php-4*' ; then
139 PHP_VERSION="4"
140 else 125 else
141 die "Unable to find an installed dev-lang/php package" 126 die "Unable to find an installed dev-lang/php package"
142 fi
143 fi 127 fi
144 128
145 # If we get here, then PHP_VERSION tells us which version of PHP we 129 # If we get here, then PHP_VERSION tells us which version of PHP we
146 # want to use 130 # want to use
147 uses_php${PHP_VERSION} 131 uses_php${PHP_VERSION}
148} 132}
149 133
134# @FUNCTION: require_php_sapi_from
135# @USAGE: <list of SAPIs>
136# @DESCRIPTION:
150# Call this function from pkg_setup if your package only works with 137# Call this function from pkg_setup if your package only works with
151# specific SAPIs 138# specific SAPI(s) and specify a list of PHP SAPI USE flags that are
139# required (one or more from cli, cgi, apache2) as arguments.
140# Returns if any of the listed SAPIs have been installed, dies if none
141# of them is available.
152# 142#
153# $1 ... a list of PHP SAPI USE flags (cli, cgi, apache2) 143# Unfortunately, if you want to be really sure that the required SAPI is
154# 144# provided by PHP, you will have to use this function or similar ones (like
155# Returns if any one of the listed SAPIs have been installed 145# require_php_cli or require_php_cgi) in pkg_setup until we are able to
156# Dies if none of the listed SAPIs have been installed 146# depend on USE flags being enabled. The above described need_php[45]_cli
157 147# and need_php[45]_httpd functions cannot guarantee these requirements.
148# See Bug 2272 for details.
158require_php_sapi_from() { 149require_php_sapi_from() {
159 has_php 150 has_php
160 151
161 local has_sapi="0" 152 local has_sapi="0"
162 local x 153 local x
181 eerror " $@" 172 eerror " $@"
182 eerror 173 eerror
183 die "No compatible PHP SAPIs found" 174 die "No compatible PHP SAPIs found"
184} 175}
185 176
177# @FUNCTION: require_php_with_use
178# @USAGE: <list of USE flags>
179# @DESCRIPTION:
186# Call this function from pkg_setup if your package requires PHP compiled 180# Call this function from pkg_setup if your package requires PHP compiled
187# with specific USE flags 181# with specific USE flags. Returns if all of the listed USE flags are enabled.
182# Dies if any of the listed USE flags are disabled.
183
184# @VARIABLE: PHPCHECKNODIE
185# @DESCRIPTION:
186# You can set PHPCHECKNODIE to non-empty value in your ebuild to chain multiple
187# require_php_with_(any)_use checks without making the ebuild die on every failure.
188# This is useful in cases when certain PHP features are only required if specific
189# USE flag(s) are enabled for that ebuild.
190# @CODE
191# Example:
188# 192#
189# $1 ... a list of USE flags 193# local flags="pcre session snmp sockets wddx"
190# 194# use mysql && flags="${flags} mysql"
191# Returns if all of the listed USE flags are enabled 195# use postgres && flags="${flags} postgres"
192# Dies if any of the listed USE flags are disabled 196# if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} \
193 197# || ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
198# die "Re-install ${PHP_PKG} with ${flags} and either gd or gd-external"
199# fi
200# @CODE
194require_php_with_use() { 201require_php_with_use() {
195 has_php 202 has_php
196 203
197 local missing_use="" 204 local missing_use=""
198 local x 205 local x
199 206
200 einfo "Checking for required PHP feature(s) ..." 207 einfo "Checking for required PHP feature(s) ..."
201 208
202 for x in $@ ; do 209 for x in $@ ; do
210 case $x in
211 pcre|spl|reflection)
212 eqawarn "require_php_with_use MUST NOT check for the pcre, spl or reflection USE flag."
213 eqawarn "These USE flags are removed from >=dev-lang/php-5.3 and your ebuild will break"
214 eqawarn "if you check the USE flags against PHP 5.3 ebuilds."
215 eqawarn "Please use USE dependencies from EAPI 2 instead"
216 ;;
217 esac
218
203 if ! built_with_use =${PHP_PKG} ${x} && ! phpconfutils_built_with_use =${PHP_PKG} ${x} ; then 219 if ! built_with_use =${PHP_PKG} ${x} && ! phpconfutils_built_with_use =${PHP_PKG} ${x} ; then
204 einfo " Discovered missing USE flag: ${x}" 220 einfo " Discovered missing USE flag: ${x}"
205 missing_use="${missing_use} ${x}" 221 missing_use="${missing_use} ${x}"
206 fi 222 fi
207 done 223 done
225 else 241 else
226 return 1 242 return 1
227 fi 243 fi
228} 244}
229 245
246# @FUNCTION: require_php_with_any_use
247# @USAGE: <list of USE flags>
248# @DESCRIPTION:
230# Call this function from pkg_setup if your package requires PHP compiled 249# Call this function from pkg_setup if your package requires PHP compiled with
231# with any of specified USE flags
232#
233# $1 ... a list of USE flags
234#
235# Returns if any of the listed USE flags are enabled 250# any of specified USE flags. Returns if any of the listed USE flags are enabled.
236# Dies if all of the listed USE flags are disabled 251# Dies if all of the listed USE flags are disabled.
237
238require_php_with_any_use() { 252require_php_with_any_use() {
239 has_php 253 has_php
240 254
241 local missing_use="" 255 local missing_use=""
242 local x 256 local x
277# has_*() functions 291# has_*() functions
278# 292#
279# These functions return 0 if the condition is satisfied, 1 otherwise 293# These functions return 0 if the condition is satisfied, 1 otherwise
280# ======================================================================== 294# ========================================================================
281 295
296# @FUNCTION: has_zts
297# @DESCRIPTION:
282# Check if our PHP was compiled with ZTS (Zend Thread Safety) enabled 298# Check if our PHP was compiled with ZTS (Zend Thread Safety) enabled.
283 299# @RETURN: 0 if true, 1 otherwise
284has_zts() { 300has_zts() {
285 has_php 301 has_php
286 302
287 if built_with_use =${PHP_PKG} apache2 threads || phpconfutils_built_with_use =${PHP_PKG} apache2 threads ; then 303 if built_with_use =${PHP_PKG} apache2 threads || phpconfutils_built_with_use =${PHP_PKG} apache2 threads ; then
288 return 0 304 return 0
289 fi 305 fi
290 306
291 return 1 307 return 1
292} 308}
293 309
310# @FUNCTION: has_debug
311# @DESCRIPTION:
294# Check if our PHP was built with debug support enabled 312# Check if our PHP was built with debug support enabled.
295 313# @RETURN: 0 if true, 1 otherwise
296has_debug() { 314has_debug() {
297 has_php 315 has_php
298 316
299 if built_with_use =${PHP_PKG} debug || phpconfutils_built_with_use =${PHP_PKG} debug ; then 317 if built_with_use =${PHP_PKG} debug || phpconfutils_built_with_use =${PHP_PKG} debug ; then
300 return 0 318 return 0
301 fi 319 fi
302 320
303 return 1 321 return 1
304} 322}
305 323
324# @FUNCTION: has_concurrentmodphp
325# @DESCRIPTION:
306# Check if our PHP was built with the concurrentmodphp support enabled 326# Check if our PHP was built with the concurrentmodphp support enabled.
307 327# @RETURN: 0 if true, 1 otherwise
308has_concurrentmodphp() { 328has_concurrentmodphp() {
309 has_php 329 has_php
310 330
311 if built_with_use =${PHP_PKG} apache2 concurrentmodphp || phpconfutils_built_with_use =${PHP_PKG} apache2 concurrentmodphp ; then 331 if built_with_use =${PHP_PKG} apache2 concurrentmodphp || phpconfutils_built_with_use =${PHP_PKG} apache2 concurrentmodphp ; then
312 return 0 332 return 0
319# require_*() functions 339# require_*() functions
320# 340#
321# These functions die() if PHP was built without the required features 341# These functions die() if PHP was built without the required features
322# ======================================================================== 342# ========================================================================
323 343
344# @FUNCTION: require_pdo
345# @DESCRIPTION:
324# Require a PHP built with PDO support (PHP5 only) 346# Require a PHP built with PDO support (PHP5 only).
325 347# This function is now redundant and DEPRECATED since
348# pdo-external use flag and pecl-pdo-* ebuilds were removed.
349# You should use require_php_with_use pdo instead now.
350# @RETURN: die if feature is missing
326require_pdo() { 351require_pdo() {
327 has_php 352 has_php
328
329 # Do we have PHP5 installed?
330 if [[ "${PHP_VERSION}" == "4" ]] ; then
331 eerror
332 eerror "This package requires PDO."
333 eerror "PDO is only available for PHP 5."
334 eerror "You must install >=dev-lang/php-5.1 with"
335 eerror "either the 'pdo' or the 'pdo-external'"
336 eerror "USE flags turned on."
337 eerror
338 die "PHP 5 not installed"
339 fi
340 353
341 # Was PHP5 compiled with internal PDO support? 354 # Was PHP5 compiled with internal PDO support?
342 if built_with_use =${PHP_PKG} pdo || phpconfutils_built_with_use =${PHP_PKG} pdo ; then 355 if built_with_use =${PHP_PKG} pdo || phpconfutils_built_with_use =${PHP_PKG} pdo ; then
343 return 356 return
344 fi 357 else
345
346 # Ok, maybe PDO was built as an external extension?
347 if ( built_with_use =${PHP_PKG} pdo-external || phpconfutils_built_with_use =${PHP_PKG} pdo-external ) && has_version 'dev-php5/pecl-pdo' ; then
348 return
349 fi
350
351 # Ok, as last resort, it suffices that pecl-pdo was installed to have PDO support
352 if has_version 'dev-php5/pecl-pdo' ; then
353 return
354 fi
355
356 # If we get here, then we don't have PDO support
357 eerror 358 eerror
358 eerror "No PDO extension for PHP found." 359 eerror "No PDO extension for PHP found."
359 eerror "Please note that PDO only exists for PHP 5." 360 eerror "Please note that PDO only exists for PHP 5."
360 eerror "Please install a PDO extension for PHP 5," 361 eerror "Please install a PDO extension for PHP 5."
361 eerror "you must install >=dev-lang/php-5.1 with" 362 eerror "You must install >=dev-lang/php-5.1 with USE=\"pdo\"."
362 eerror "either the 'pdo' or the 'pdo-external'"
363 eerror "USE flags turned on."
364 eerror 363 eerror
365 die "No PDO extension for PHP 5 found" 364 die "No PDO extension for PHP 5 found"
365 fi
366} 366}
367 367
368# @FUNCTION: require_php_cli
369# @DESCRIPTION:
368# Determines which installed PHP version has the CLI SAPI enabled, 370# Determines which installed PHP version has the CLI SAPI enabled.
369# useful for PEAR stuff, or anything which needs to run PHP 371# Useful for PEAR stuff, or anything which needs to run PHP script
370# scripts depending on the CLI SAPI 372# depending on the CLI SAPI.
371 373# @RETURN: die if feature is missing
372require_php_cli() { 374require_php_cli() {
373 # If PHP_PKG is set, then we have remembered our PHP settings 375 # If PHP_PKG is set, then we have remembered our PHP settings
374 # from last time 376 # from last time
375 if [[ -n ${PHP_PKG} ]] ; then 377 if [[ -n ${PHP_PKG} ]] ; then
376 return 378 return
377 fi 379 fi
378 380
379 local PHP_PACKAGE_FOUND="" 381 local PHP_PACKAGE_FOUND=""
380 382
381 # Detect which PHP version we have installed
382 if has_version '=dev-lang/php-4*' ; then
383 PHP_PACKAGE_FOUND="1"
384 pkg="`best_version '=dev-lang/php-4*'`"
385 if built_with_use =${pkg} cli || phpconfutils_built_with_use =${pkg} cli ; then
386 PHP_VERSION="4"
387 fi
388 fi
389
390 if has_version '=dev-lang/php-5*' ; then 383 if has_version '=dev-lang/php-5*' ; then
391 PHP_PACKAGE_FOUND="1" 384 PHP_PACKAGE_FOUND="1"
392 pkg="`best_version '=dev-lang/php-5*'`" 385 pkg="$(best_version '=dev-lang/php-5*')"
393 if built_with_use =${pkg} cli || phpconfutils_built_with_use =${pkg} cli ; then 386 if built_with_use =${pkg} cli || phpconfutils_built_with_use =${pkg} cli ; then
394 PHP_VERSION="5" 387 PHP_VERSION="5"
395 fi 388 fi
396 fi 389 fi
397 390
406 # If we get here, then PHP_VERSION tells us which version of PHP we 399 # If we get here, then PHP_VERSION tells us which version of PHP we
407 # want to use 400 # want to use
408 uses_php${PHP_VERSION} 401 uses_php${PHP_VERSION}
409} 402}
410 403
404# @FUNCTION: require_php_cgi
405# @DESCRIPTION:
411# Determines which installed PHP version has the CGI SAPI enabled, 406# Determines which installed PHP version has the CGI SAPI enabled.
412# useful for anything which needs to run PHP scripts 407# Useful for anything which needs to run PHP scripts depending on the CGI SAPI.
413# depending on the CGI SAPI 408# @RETURN: die if feature is missing
414
415require_php_cgi() { 409require_php_cgi() {
416 # If PHP_PKG is set, then we have remembered our PHP settings 410 # If PHP_PKG is set, then we have remembered our PHP settings
417 # from last time 411 # from last time
418 if [[ -n ${PHP_PKG} ]] ; then 412 if [[ -n ${PHP_PKG} ]] ; then
419 return 413 return
420 fi 414 fi
421 415
422 local PHP_PACKAGE_FOUND="" 416 local PHP_PACKAGE_FOUND=""
423 417
424 # Detect which PHP version we have installed
425 if has_version '=dev-lang/php-4*' ; then
426 PHP_PACKAGE_FOUND="1"
427 pkg="`best_version '=dev-lang/php-4*'`"
428 if built_with_use =${pkg} cgi || phpconfutils_built_with_use =${pkg} cgi ; then
429 PHP_VERSION="4"
430 fi
431 fi
432
433 if has_version '=dev-lang/php-5*' ; then 418 if has_version '=dev-lang/php-5*' ; then
434 PHP_PACKAGE_FOUND="1" 419 PHP_PACKAGE_FOUND="1"
435 pkg="`best_version '=dev-lang/php-5*'`" 420 pkg="$(best_version '=dev-lang/php-5*')"
436 if built_with_use =${pkg} cgi || phpconfutils_built_with_use =${pkg} cgi ; then 421 if built_with_use =${pkg} cgi || phpconfutils_built_with_use =${pkg} cgi ; then
437 PHP_VERSION="5" 422 PHP_VERSION="5"
438 fi 423 fi
439 fi 424 fi
440 425
449 # If we get here, then PHP_VERSION tells us which version of PHP we 434 # If we get here, then PHP_VERSION tells us which version of PHP we
450 # want to use 435 # want to use
451 uses_php${PHP_VERSION} 436 uses_php${PHP_VERSION}
452} 437}
453 438
439# @FUNCTION: require_sqlite
440# @DESCRIPTION:
454# Require a PHP built with SQLite support 441# Require a PHP built with SQLite support
455 442# @RETURN: die if feature is missing
456require_sqlite() { 443require_sqlite() {
457 has_php 444 has_php
458 445
459 # Has our PHP been built with SQLite support? 446 # Has our PHP been built with SQLite support?
460 if built_with_use =${PHP_PKG} sqlite || phpconfutils_built_with_use =${PHP_PKG} sqlite ; then 447 if built_with_use =${PHP_PKG} sqlite || phpconfutils_built_with_use =${PHP_PKG} sqlite ; then
461 return 448 return
462 fi
463
464 # Do we have pecl-sqlite installed for PHP4?
465 if [[ "${PHP_VERSION}" == "4" ]] ; then
466 if has_version 'dev-php4/pecl-sqlite' ; then
467 return
468 fi
469 fi 449 fi
470 450
471 # If we get here, then we don't have any SQLite support for PHP installed 451 # If we get here, then we don't have any SQLite support for PHP installed
472 eerror 452 eerror
473 eerror "No SQLite extension for PHP found." 453 eerror "No SQLite extension for PHP found."
476 eerror "'sqlite' USE flag when emerging dev-lang/php." 456 eerror "'sqlite' USE flag when emerging dev-lang/php."
477 eerror 457 eerror
478 die "No SQLite extension for PHP found" 458 die "No SQLite extension for PHP found"
479} 459}
480 460
461# @FUNCTION: require_gd
462# @DESCRIPTION:
481# Require a PHP built with GD support 463# Require a PHP built with GD support
482 464# @RETURN: die if feature is missing
483require_gd() { 465require_gd() {
484 has_php 466 has_php
485 467
486 # Do we have the internal GD support installed? 468 # Do we have the internal GD support installed?
487 if built_with_use =${PHP_PKG} gd || phpconfutils_built_with_use =${PHP_PKG} gd ; then 469 if built_with_use =${PHP_PKG} gd || phpconfutils_built_with_use =${PHP_PKG} gd ; then
508# Misc functions 490# Misc functions
509# 491#
510# These functions provide miscellaneous checks and functionality. 492# These functions provide miscellaneous checks and functionality.
511# ======================================================================== 493# ========================================================================
512 494
495# @FUNCTION: php_binary_extension
496# @DESCRIPTION:
513# Executes some checks needed when installing a binary PHP extension 497# Executes some checks needed when installing a binary PHP extension.
514
515php_binary_extension() { 498php_binary_extension() {
516 has_php 499 has_php
517 500
518 local PUSE_ENABLED="" 501 local PUSE_ENABLED=""
519 502
545 if [[ -n ${PUSE_ENABLED} ]] ; then 528 if [[ -n ${PUSE_ENABLED} ]] ; then
546 die "'debug' and/or 'concurrentmodphp' USE flags turned on!" 529 die "'debug' and/or 'concurrentmodphp' USE flags turned on!"
547 fi 530 fi
548} 531}
549 532
533# @FUNCTION: dodoc-php
534# @USAGE: <list of docs>
535# @DESCRIPTION:
550# Alternative to dodoc function for use in our PHP eclasses and 536# Alternative to dodoc function for use in our PHP eclasses and ebuilds.
551# ebuilds.
552# Stored here because depend.php gets always sourced everywhere 537# Stored here because depend.php gets always sourced everywhere in the PHP
553# in the PHP ebuilds and eclasses.
554# It simply is dodoc with a changed path to the docs. 538# ebuilds and eclasses. It simply is dodoc with a changed path to the docs.
555# NOTE: no support for docinto is given! 539# NOTE: No support for docinto is provided!
556
557dodoc-php() { 540dodoc-php() {
558if [[ $# -lt 1 ]] ; then 541if [[ $# -lt 1 ]] ; then
559 echo "$0: at least one argument needed" 1>&2 542 echo "$0: at least one argument needed" 1>&2
560 exit 1 543 exit 1
561fi 544fi
562 545
563phpdocdir="${D}/usr/share/doc/${CATEGORY}/${PF}/" 546phpdocdir="/usr/share/doc/${CATEGORY}/${PF}/"
564
565if [[ ! -d "${phpdocdir}" ]] ; then
566 install -d "${phpdocdir}"
567fi
568 547
569for x in $@ ; do 548for x in $@ ; do
570 if [[ -s "${x}" ]] ; then 549 if [[ -s "${x}" ]] ; then
571 install -m0644 "${x}" "${phpdocdir}" 550 insinto "${phpdocdir}"
551 doins "${x}"
572 gzip -f -9 "${phpdocdir}/${x##*/}" 552 gzip -f -9 "${D}/${phpdocdir}/${x##*/}"
573 elif [[ ! -e "${x}" ]] ; then 553 elif [[ ! -e "${x}" ]] ; then
574 echo "dodoc-php: ${x} does not exist" 1>&2 554 echo "dodoc-php: ${x} does not exist" 1>&2
575 fi 555 fi
576done 556done
577} 557}
558
559# @FUNCTION: dohtml-php
560# @USAGE: <list of html docs>
561# @DESCRIPTION:
562# Alternative to dohtml function for use in our PHP eclasses and ebuilds.
563# Stored here because depend.php gets always sourced everywhere in the PHP
564# ebuilds and eclasses. It simply is dohtml with a changed path to the docs.
565# NOTE: No support for [-a|-A|-p|-x] options is provided!
566dohtml-php() {
567if [[ $# -lt 1 ]] ; then
568 echo "$0: at least one argument needed" 1>&2
569 exit 1
570fi
571
572phphtmldir="/usr/share/doc/${CATEGORY}/${PF}/html"
573
574for x in $@ ; do
575 if [[ -s "${x}" ]] ; then
576 insinto "${phphtmldir}"
577 doins "${x}"
578 elif [[ ! -e "${x}" ]] ; then
579 echo "dohtml-php: ${x} does not exist" 1>&2
580 fi
581done
582}

Legend:
Removed from v.1.20  
changed lines
  Added in v.1.27

  ViewVC Help
Powered by ViewVC 1.1.20