/[gentoo-x86]/eclass/distutils.eclass
Gentoo

Diff of /eclass/distutils.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.1.1.1 Revision 1.33
1# Copyright 1999-2004 Gentoo Foundation 1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.1.1.1 2005/11/30 09:59:34 chriswhite Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.33 2006/08/14 21:01:01 liquidx Exp $
4# 4#
5# Author: Jon Nelson <jnelson@gentoo.org> 5# Author: Jon Nelson <jnelson@gentoo.org>
6# Current Maintainer: Alastair Tse <liquidx@gentoo.org> 6# Current Maintainer: Alastair Tse <liquidx@gentoo.org>
7# 7#
8# The distutils eclass is designed to allow easier installation of 8# The distutils eclass is designed to allow easier installation of
21 21
22inherit python eutils 22inherit python eutils
23 23
24# This helps make it possible to add extensions to python slots. 24# This helps make it possible to add extensions to python slots.
25# Normally only a -py21- ebuild would set PYTHON_SLOT_VERSION. 25# Normally only a -py21- ebuild would set PYTHON_SLOT_VERSION.
26if [ "${PYTHON_SLOT_VERSION}" = 2.1 ] ; then 26if [ "${PYTHON_SLOT_VERSION}" = "2.1" ] ; then
27 DEPEND="=dev-lang/python-2.1*" 27 DEPEND="=dev-lang/python-2.1*"
28 python="python2.1" 28 python="python2.1"
29elif [ "${PYTHON_SLOT_VERSION}" = "2.3" ] ; then
30 DEPEND="=dev-lang/python-2.3*"
31 python="python2.3"
29else 32else
30 DEPEND="virtual/python" 33 DEPEND="virtual/python"
31 python="python" 34 python="python"
32fi 35fi
33 36
34distutils_src_compile() { 37distutils_src_compile() {
35 ${python} setup.py build "$@" || die "compilation failed" 38 ${python} setup.py build "$@" || die "compilation failed"
36} 39}
37 40
38distutils_src_install() { 41distutils_src_install() {
42
43 # need this for python-2.5 + setuptools in cases where
44 # a package uses distutils but does not install anything
45 # in site-packages. (eg. dev-java/java-config-2.x)
46 # - liquidx (14/08/2006)
47 pylibdir="$(${python} -c 'from distutils.sysconfig import get_python_lib; print get_python_lib()')"
48 [ -n "${pylibdir}" ] && dodir "${pylibdir}"
49
39 if has_version ">=dev-lang/python-2.3"; then 50 if has_version ">=dev-lang/python-2.3"; then
40 ${python} setup.py install --root=${D} --no-compile "$@" || die 51 ${python} setup.py install --root=${D} --no-compile "$@" || die
41 else 52 else
42 ${python} setup.py install --root=${D} "$@" || die 53 ${python} setup.py install --root=${D} "$@" || die
43 fi 54 fi
82distutils_pkg_postinst() { 93distutils_pkg_postinst() {
83 PYTHON_MODNAME=${PYTHON_MODNAME:-${PN}} 94 PYTHON_MODNAME=${PYTHON_MODNAME:-${PN}}
84 95
85 if has_version ">=dev-lang/python-2.3"; then 96 if has_version ">=dev-lang/python-2.3"; then
86 python_version 97 python_version
87 for pymod in "${PYTHON_MODNAME}"; do 98 for pymod in ${PYTHON_MODNAME}; do
88 if [ -d "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/${pymod}" ]; then 99 if [ -d "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/${pymod}" ]; then
89 python_mod_optimize ${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/${pymod} 100 python_mod_optimize ${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/${pymod}
90 fi 101 fi
91 done 102 done
92 fi 103 fi
106 117
107# checks for if tkinter support is compiled into python 118# checks for if tkinter support is compiled into python
108distutils_python_tkinter() { 119distutils_python_tkinter() {
109 if ! python -c "import Tkinter" >/dev/null 2>&1; then 120 if ! python -c "import Tkinter" >/dev/null 2>&1; then
110 eerror "You need to recompile python with Tkinter support." 121 eerror "You need to recompile python with Tkinter support."
111 eerror "That means: USE='tcltk' emerge python" 122 eerror "Try adding 'dev-lang/python X tk' to:"
123 eerror "/etc/portage/package.use"
112 echo 124 echo
113 die "missing tkinter support with installed python" 125 die "missing tkinter support with installed python"
114 fi 126 fi
115} 127}
116 128

Legend:
Removed from v.1.1.1.1  
changed lines
  Added in v.1.33

  ViewVC Help
Powered by ViewVC 1.1.20