/[gentoo-x86]/eclass/distutils.eclass
Gentoo

Diff of /eclass/distutils.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.31 Revision 1.45
1# Copyright 1999-2004 Gentoo Foundation 1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.31 2006/06/03 17:56:35 radek Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.45 2008/01/23 22:19:04 hawking Exp $
4# 4#
5# Author: Jon Nelson <jnelson@gentoo.org> 5# Author: Jon Nelson <jnelson@gentoo.org>
6# Current Maintainer: Alastair Tse <liquidx@gentoo.org> 6# Current Maintainer: Alastair Tse <liquidx@gentoo.org>
7# 7#
8# The distutils eclass is designed to allow easier installation of 8# The distutils eclass is designed to allow easier installation of
17# 17#
18# - Variables: 18# - Variables:
19# PYTHON_SLOT_VERSION - for Zope support 19# PYTHON_SLOT_VERSION - for Zope support
20# DOCS - additional DOCS 20# DOCS - additional DOCS
21 21
22inherit python eutils 22inherit python multilib eutils
23 23
24# This helps make it possible to add extensions to python slots. 24# This helps make it possible to add extensions to python slots.
25# Normally only a -py21- ebuild would set PYTHON_SLOT_VERSION. 25# Normally only a -py21- ebuild would set PYTHON_SLOT_VERSION.
26if [ "${PYTHON_SLOT_VERSION}" = "2.1" ] ; then 26if [ "${PYTHON_SLOT_VERSION}" = "2.1" ] ; then
27 DEPEND="=dev-lang/python-2.1*" 27 DEPEND="=dev-lang/python-2.1*"
32else 32else
33 DEPEND="virtual/python" 33 DEPEND="virtual/python"
34 python="python" 34 python="python"
35fi 35fi
36 36
37distutils_src_unpack() {
38 unpack ${A}
39 cd "${S}"
40
41 # remove ez_setup stuff to prevent packages
42 # from installing setuptools on their own
43 rm -rf ez_setup*
44 echo "def use_setuptools(*args, **kwargs): pass" > ez_setup.py
45}
46
37distutils_src_compile() { 47distutils_src_compile() {
38 ${python} setup.py build "$@" || die "compilation failed" 48 ${python} setup.py build "$@" || die "compilation failed"
39} 49}
40 50
41distutils_src_install() { 51distutils_src_install() {
52
53 # need this for python-2.5 + setuptools in cases where
54 # a package uses distutils but does not install anything
55 # in site-packages. (eg. dev-java/java-config-2.x)
56 # - liquidx (14/08/2006)
57 pylibdir="$(${python} -c 'from distutils.sysconfig import get_python_lib; print get_python_lib()')"
58 [ -n "${pylibdir}" ] && dodir "${pylibdir}"
59
42 if has_version ">=dev-lang/python-2.3"; then 60 if has_version ">=dev-lang/python-2.3"; then
43 ${python} setup.py install --root=${D} --no-compile "$@" || die 61 ${python} setup.py install --root=${D} --no-compile "$@" || die
44 else 62 else
45 ${python} setup.py install --root=${D} "$@" || die 63 ${python} setup.py install --root=${D} "$@" || die
46 fi 64 fi
47 65
48 DDOCS="CHANGELOG COPYRIGHT KNOWN_BUGS MAINTAINERS PKG-INFO" 66 DDOCS="CHANGELOG KNOWN_BUGS MAINTAINERS PKG-INFO CONTRIBUTORS TODO NEWS"
49 DDOCS="${DDOCS} CONTRIBUTORS TODO"
50 DDOCS="${DDOCS} Change* MANIFEST* README*" 67 DDOCS="${DDOCS} Change* MANIFEST* README* AUTHORS"
51 68
52 for doc in ${DDOCS}; do 69 for doc in ${DDOCS}; do
53 [ -s "$doc" ] && dodoc $doc 70 [ -s "$doc" ] && dodoc $doc
54 done 71 done
55 72
56 [ -n "${DOCS}" ] && dodoc ${DOCS} 73 [ -n "${DOCS}" ] && dodoc ${DOCS}
57
58 # deprecated! please use DOCS instead.
59 [ -n "${mydoc}" ] && dodoc ${mydoc}
60} 74}
61 75
62# generic pyc/pyo cleanup script. 76# generic pyc/pyo cleanup script.
63 77
64distutils_pkg_postrm() { 78distutils_pkg_postrm() {
83# installs things in another directory 97# installs things in another directory
84 98
85distutils_pkg_postinst() { 99distutils_pkg_postinst() {
86 PYTHON_MODNAME=${PYTHON_MODNAME:-${PN}} 100 PYTHON_MODNAME=${PYTHON_MODNAME:-${PN}}
87 101
102 # strip trailing slash
103 myroot="${ROOT%/}"
104
88 if has_version ">=dev-lang/python-2.3"; then 105 if has_version ">=dev-lang/python-2.3"; then
89 python_version 106 python_version
90 for pymod in ${PYTHON_MODNAME}; do 107 for pymod in ${PYTHON_MODNAME}; do
91 if [ -d "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/${pymod}" ]; then 108 if [ -d "${myroot}/usr/$(get_libdir)/python${PYVER}/site-packages/${pymod}" ]; then
92 python_mod_optimize ${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/${pymod} 109 python_mod_optimize ${myroot}/usr/$(get_libdir)/python${PYVER}/site-packages/${pymod}
93 fi 110 fi
94 done 111 done
95 fi 112 fi
96} 113}
97 114
98# e.g. insinto ${ROOT}/usr/include/python${PYVER} 115# e.g. insinto ${ROOT}/usr/include/python${PYVER}
99 116
100distutils_python_version() { 117distutils_python_version() {
101 local tmpstr="$(${python} -V 2>&1 )" 118 python_version
102 export PYVER_ALL="${tmpstr#Python }"
103
104 export PYVER_MAJOR=$(echo ${PYVER_ALL} | cut -d. -f1)
105 export PYVER_MINOR=$(echo ${PYVER_ALL} | cut -d. -f2)
106 export PYVER_MICRO=$(echo ${PYVER_ALL} | cut -d. -f3-)
107 export PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
108} 119}
109 120
110# checks for if tkinter support is compiled into python 121# checks for if tkinter support is compiled into python
111distutils_python_tkinter() { 122distutils_python_tkinter() {
112 if ! python -c "import Tkinter" >/dev/null 2>&1; then 123 python_tkinter_exists
113 eerror "You need to recompile python with Tkinter support."
114 eerror "That means: USE='tcltk' emerge python"
115 echo
116 die "missing tkinter support with installed python"
117 fi
118} 124}
119 125
120EXPORT_FUNCTIONS src_compile src_install pkg_postinst pkg_postrm 126EXPORT_FUNCTIONS src_unpack src_compile src_install pkg_postinst pkg_postrm

Legend:
Removed from v.1.31  
changed lines
  Added in v.1.45

  ViewVC Help
Powered by ViewVC 1.1.20