/[gentoo-x86]/eclass/distutils.eclass
Gentoo

Contents of /eclass/distutils.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.34 - (show annotations) (download)
Wed Aug 16 16:24:20 2006 UTC (8 years, 2 months ago) by liquidx
Branch: MAIN
Changes since 1.33: +2 -8 lines
fix python version parsing to deal with beta versions.

1 # Copyright 1999-2004 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/eclass/distutils.eclass,v 1.33 2006/08/14 21:01:01 liquidx Exp $
4 #
5 # Author: Jon Nelson <jnelson@gentoo.org>
6 # Current Maintainer: Alastair Tse <liquidx@gentoo.org>
7 #
8 # The distutils eclass is designed to allow easier installation of
9 # distutils-based python modules and their incorporation into
10 # the Gentoo Linux system.
11 #
12 # - Features:
13 # distutils_src_compile() - does python setup.py build
14 # distutils_src_install() - does python setup.py install and install docs
15 # distutils_python_version() - sets PYVER/PYVER_MAJOR/PYVER_MINOR
16 # distutils_python_tkinter() - checks for tkinter support in python
17 #
18 # - Variables:
19 # PYTHON_SLOT_VERSION - for Zope support
20 # DOCS - additional DOCS
21
22 inherit python eutils
23
24 # This helps make it possible to add extensions to python slots.
25 # Normally only a -py21- ebuild would set PYTHON_SLOT_VERSION.
26 if [ "${PYTHON_SLOT_VERSION}" = "2.1" ] ; then
27 DEPEND="=dev-lang/python-2.1*"
28 python="python2.1"
29 elif [ "${PYTHON_SLOT_VERSION}" = "2.3" ] ; then
30 DEPEND="=dev-lang/python-2.3*"
31 python="python2.3"
32 else
33 DEPEND="virtual/python"
34 python="python"
35 fi
36
37 distutils_src_compile() {
38 ${python} setup.py build "$@" || die "compilation failed"
39 }
40
41 distutils_src_install() {
42
43 # need this for python-2.5 + setuptools in cases where
44 # a package uses distutils but does not install anything
45 # in site-packages. (eg. dev-java/java-config-2.x)
46 # - liquidx (14/08/2006)
47 pylibdir="$(${python} -c 'from distutils.sysconfig import get_python_lib; print get_python_lib()')"
48 [ -n "${pylibdir}" ] && dodir "${pylibdir}"
49
50 if has_version ">=dev-lang/python-2.3"; then
51 ${python} setup.py install --root=${D} --no-compile "$@" || die
52 else
53 ${python} setup.py install --root=${D} "$@" || die
54 fi
55
56 DDOCS="CHANGELOG COPYRIGHT KNOWN_BUGS MAINTAINERS PKG-INFO"
57 DDOCS="${DDOCS} CONTRIBUTORS TODO"
58 DDOCS="${DDOCS} Change* MANIFEST* README*"
59
60 for doc in ${DDOCS}; do
61 [ -s "$doc" ] && dodoc $doc
62 done
63
64 [ -n "${DOCS}" ] && dodoc ${DOCS}
65
66 # deprecated! please use DOCS instead.
67 [ -n "${mydoc}" ] && dodoc ${mydoc}
68 }
69
70 # generic pyc/pyo cleanup script.
71
72 distutils_pkg_postrm() {
73 PYTHON_MODNAME=${PYTHON_MODNAME:-${PN}}
74
75 if has_version ">=dev-lang/python-2.3"; then
76 ebegin "Performing Python Module Cleanup .."
77 if [ -n "${PYTHON_MODNAME}" ]; then
78 for pymod in ${PYTHON_MODNAME}; do
79 for moddir in "`ls -d --color=none -1 ${ROOT}usr/$(get_libdir)/python*/site-packages/${pymod} 2> /dev/null`"; do
80 python_mod_cleanup ${moddir}
81 done
82 done
83 else
84 python_mod_cleanup
85 fi
86 eend 0
87 fi
88 }
89
90 # this is a generic optimization, you should override it if your package
91 # installs things in another directory
92
93 distutils_pkg_postinst() {
94 PYTHON_MODNAME=${PYTHON_MODNAME:-${PN}}
95
96 if has_version ">=dev-lang/python-2.3"; then
97 python_version
98 for pymod in ${PYTHON_MODNAME}; do
99 if [ -d "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/${pymod}" ]; then
100 python_mod_optimize ${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/${pymod}
101 fi
102 done
103 fi
104 }
105
106 # e.g. insinto ${ROOT}/usr/include/python${PYVER}
107
108 distutils_python_version() {
109 python_version
110 }
111
112 # checks for if tkinter support is compiled into python
113 distutils_python_tkinter() {
114 if ! python -c "import Tkinter" >/dev/null 2>&1; then
115 eerror "You need to recompile python with Tkinter support."
116 eerror "Try adding 'dev-lang/python X tk' to:"
117 eerror "/etc/portage/package.use"
118 echo
119 die "missing tkinter support with installed python"
120 fi
121 }
122
123 EXPORT_FUNCTIONS src_compile src_install pkg_postinst pkg_postrm

  ViewVC Help
Powered by ViewVC 1.1.20