/[gentoo-x86]/eclass/elisp.eclass
Gentoo

Contents of /eclass/elisp.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.25 - (hide annotations) (download)
Tue Dec 4 13:11:15 2007 UTC (6 years, 10 months ago) by ulm
Branch: MAIN
Changes since 1.24: +7 -6 lines
Move handling of SIMPLE_ELISP into elisp_pkg_setup, otherwise it fails
with portage-2.1.4_rc7.
Die in elisp_src_unpack if mv fails.

1 opfer 1.17 # Copyright 1999-2007 Gentoo Foundation
2 mkennedy 1.1 # Distributed under the terms of the GNU General Public License v2
3 ulm 1.25 # $Header: /var/cvsroot/gentoo-x86/eclass/elisp.eclass,v 1.24 2007/10/14 22:12:30 ulm Exp $
4 vapier 1.4 #
5 opfer 1.17 # Copyright 2007 Christian Faulhammer <opfer@gentoo.org>
6 ulm 1.20 # Copyright 2002-2003 Matthew Kennedy <mkennedy@gentoo.org>
7 mkennedy 1.9 # Copyright 2003 Jeremy Maitin-Shepard <jbms@attbi.com>
8 opfer 1.19 # Copyright 2007 Ulrich Mueller <ulm@gentoo.org>
9 vapier 1.4 #
10 ulm 1.21 # @ECLASS: elisp.eclass
11     # @MAINTAINER:
12 ulm 1.24 # Feel free to contact the Emacs team through <emacs@gentoo.org> if you
13     # have problems, suggestions or questions.
14 ulm 1.21 # @BLURB: Eclass for Emacs Lisp packages
15     # @DESCRIPTION:
16     #
17     # This eclass sets the site-lisp directory for Emacs-related packages.
18 opfer 1.17 #
19 opfer 1.18 # Emacs support for other than pure elisp packages is handled by
20 ulm 1.20 # elisp-common.eclass where you won't have a dependency on Emacs itself.
21     # All elisp-* functions are documented there.
22 ulm 1.23
23     # @ECLASS-VARIABLE: SIMPLE_ELISP
24     # @DESCRIPTION:
25 opfer 1.18 # Setting SIMPLE_ELISP=t in an ebuild means, that the package's source
26 opfer 1.19 # is a single (in whatever way) compressed elisp file with the file name
27 ulm 1.21 # ${PN}-${PV}. This eclass will then redefine ${S}, and move
28     # ${PN}-${PV}.el to ${PN}.el in src_unpack().
29 ulm 1.23
30     # @ECLASS-VARIABLE: DOCS
31     # @DESCRIPTION:
32 opfer 1.19 # DOCS="blah.txt ChangeLog" is automatically used to install the given
33     # files by dodoc in src_install().
34 ulm 1.23
35     # @ECLASS-VARIABLE: NEED_EMACS
36     # @DESCRIPTION:
37 opfer 1.19 # If you need anything different from Emacs 21, use the NEED_EMACS
38     # variable before inheriting elisp.eclass. Set it to the major version
39     # your package uses and the dependency will be adjusted.
40    
41     inherit elisp-common versionator
42    
43     VERSION=${NEED_EMACS:-21}
44     DEPEND=">=virtual/emacs-${VERSION}"
45 ulm 1.20 RDEPEND=">=virtual/emacs-${VERSION}"
46 opfer 1.19 IUSE=""
47 opfer 1.18
48 opfer 1.19 elisp_pkg_setup() {
49     local emacs_version="$(elisp-emacs-version)"
50     if ! version_is_at_least "${VERSION}" "${emacs_version}"; then
51     eerror "This package needs at least Emacs ${VERSION}."
52     eerror "Use \"eselect emacs\" to select the active version."
53     die "Emacs version ${emacs_version} is too low."
54     fi
55 ulm 1.25
56     if [ "${SIMPLE_ELISP}" = 't' ]; then
57     S="${WORKDIR}"
58     fi
59 opfer 1.19 }
60 mkennedy 1.1
61 opfer 1.18 elisp_src_unpack() {
62     unpack ${A}
63 opfer 1.19 if [ "${SIMPLE_ELISP}" = 't' ]; then
64 ulm 1.25 cd "${S}" && mv ${P}.el ${PN}.el \
65     || die "mv ${P}.el ${PN}.el failed"
66 opfer 1.18 fi
67 mkennedy 1.5 }
68    
69 opfer 1.18 elisp_src_compile() {
70 opfer 1.19 elisp-compile *.el || die "elisp-compile failed"
71 mkennedy 1.5 }
72    
73 opfer 1.18 elisp_src_install() {
74 ulm 1.23 elisp-install ${PN} *.el *.elc || die "elisp-install failed"
75     elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
76     || die "elisp-site-file-install failed"
77 opfer 1.19 if [ -n "${DOCS}" ]; then
78     dodoc ${DOCS} || die "dodoc failed"
79     fi
80 mkennedy 1.5 }
81    
82 opfer 1.18 elisp_pkg_postinst() {
83     elisp-site-regen
84 mkennedy 1.5 }
85    
86 opfer 1.18 elisp_pkg_postrm() {
87     elisp-site-regen
88 mkennedy 1.5 }
89 mkennedy 1.9
90 opfer 1.19 EXPORT_FUNCTIONS src_unpack src_compile src_install
91     EXPORT_FUNCTIONS pkg_setup pkg_postinst pkg_postrm

  ViewVC Help
Powered by ViewVC 1.1.20