/[gentoo-x86]/eclass/elisp.eclass
Gentoo

Contents of /eclass/elisp.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.34 - (hide annotations) (download)
Fri Sep 19 08:12:48 2008 UTC (5 years, 9 months ago) by ulm
Branch: MAIN
Changes since 1.33: +1 -2 lines
Partial sync from Emacs overlay.
Output a deprecation warning in elisp-comp().

1 ulm 1.29 # Copyright 1999-2008 Gentoo Foundation
2 mkennedy 1.1 # Distributed under the terms of the GNU General Public License v2
3 ulm 1.34 # $Header: /var/cvsroot/gentoo-x86/eclass/elisp.eclass,v 1.33 2008/08/28 09:55:01 ulm Exp $
4 vapier 1.4 #
5 ulm 1.20 # Copyright 2002-2003 Matthew Kennedy <mkennedy@gentoo.org>
6 ulm 1.29 # Copyright 2003 Jeremy Maitin-Shepard <jbms@attbi.com>
7 opfer 1.32 # Copyright 2007-2008 Christian Faulhammer <opfer@gentoo.org>
8 ulm 1.29 # Copyright 2007-2008 Ulrich Müller <ulm@gentoo.org>
9 vapier 1.4 #
10 ulm 1.21 # @ECLASS: elisp.eclass
11     # @MAINTAINER:
12 ulm 1.24 # Feel free to contact the Emacs team through <emacs@gentoo.org> if you
13     # have problems, suggestions or questions.
14 ulm 1.21 # @BLURB: Eclass for Emacs Lisp packages
15     # @DESCRIPTION:
16     #
17     # This eclass sets the site-lisp directory for Emacs-related packages.
18 opfer 1.17 #
19 opfer 1.18 # Emacs support for other than pure elisp packages is handled by
20 ulm 1.20 # elisp-common.eclass where you won't have a dependency on Emacs itself.
21     # All elisp-* functions are documented there.
22 ulm 1.30 #
23     # If the package's source is a single (in whatever way) compressed elisp
24     # file with the file name ${P}.el, then this eclass will move ${P}.el to
25     # ${PN}.el in src_unpack().
26 ulm 1.23
27     # @ECLASS-VARIABLE: DOCS
28     # @DESCRIPTION:
29 opfer 1.19 # DOCS="blah.txt ChangeLog" is automatically used to install the given
30     # files by dodoc in src_install().
31 ulm 1.23
32     # @ECLASS-VARIABLE: NEED_EMACS
33     # @DESCRIPTION:
34 opfer 1.19 # If you need anything different from Emacs 21, use the NEED_EMACS
35     # variable before inheriting elisp.eclass. Set it to the major version
36     # your package uses and the dependency will be adjusted.
37    
38     inherit elisp-common versionator
39    
40 ulm 1.33 DEPEND=">=virtual/emacs-${NEED_EMACS:-21}"
41     RDEPEND=">=virtual/emacs-${NEED_EMACS:-21}"
42 opfer 1.19 IUSE=""
43 opfer 1.18
44 opfer 1.19 elisp_pkg_setup() {
45 ulm 1.33 local need_emacs=${NEED_EMACS:-21}
46     local have_emacs=$(elisp-emacs-version)
47     if ! version_is_at_least "${need_emacs}" "${have_emacs}"; then
48     eerror "This package needs at least Emacs ${need_emacs}."
49 opfer 1.19 eerror "Use \"eselect emacs\" to select the active version."
50 ulm 1.33 die "Emacs version ${have_emacs} is too low."
51 opfer 1.19 fi
52     }
53 mkennedy 1.1
54 opfer 1.18 elisp_src_unpack() {
55 ulm 1.33 [ -n "${A}" ] && unpack ${A}
56 ulm 1.30 if [ -f ${P}.el ]; then
57 ulm 1.27 mv ${P}.el ${PN}.el || die "mv ${P}.el ${PN}.el failed"
58 opfer 1.18 fi
59 mkennedy 1.5 }
60    
61 opfer 1.18 elisp_src_compile() {
62 opfer 1.19 elisp-compile *.el || die "elisp-compile failed"
63 mkennedy 1.5 }
64    
65 opfer 1.18 elisp_src_install() {
66 ulm 1.23 elisp-install ${PN} *.el *.elc || die "elisp-install failed"
67     elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
68     || die "elisp-site-file-install failed"
69 opfer 1.19 if [ -n "${DOCS}" ]; then
70     dodoc ${DOCS} || die "dodoc failed"
71     fi
72 mkennedy 1.5 }
73    
74 opfer 1.18 elisp_pkg_postinst() {
75     elisp-site-regen
76 mkennedy 1.5 }
77    
78 opfer 1.18 elisp_pkg_postrm() {
79     elisp-site-regen
80 mkennedy 1.5 }
81 mkennedy 1.9
82 ulm 1.29 EXPORT_FUNCTIONS \
83     src_unpack src_compile src_install \
84     pkg_setup pkg_postinst pkg_postrm

  ViewVC Help
Powered by ViewVC 1.1.20