/[gentoo-x86]/eclass/elisp.eclass
Gentoo

Diff of /eclass/elisp.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.22 Revision 1.38
1# Copyright 1999-2007 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/elisp.eclass,v 1.22 2007/08/27 19:41:03 ulm Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/elisp.eclass,v 1.38 2009/03/12 12:08:47 ulm Exp $
4# 4#
5# Copyright 2007 Christian Faulhammer <opfer@gentoo.org>
6# Copyright 2002-2003 Matthew Kennedy <mkennedy@gentoo.org> 5# Copyright 2002-2003 Matthew Kennedy <mkennedy@gentoo.org>
7# Copyright 2003 Jeremy Maitin-Shepard <jbms@attbi.com> 6# Copyright 2003 Jeremy Maitin-Shepard <jbms@attbi.com>
7# Copyright 2007-2009 Christian Faulhammer <fauli@gentoo.org>
8# Copyright 2007 Ulrich Mueller <ulm@gentoo.org> 8# Copyright 2007-2009 Ulrich MΓΌller <ulm@gentoo.org>
9# 9#
10# @ECLASS: elisp.eclass 10# @ECLASS: elisp.eclass
11# @MAINTAINER: 11# @MAINTAINER:
12# emacs@gentoo.org 12# Feel free to contact the Emacs team through <emacs@gentoo.org> if you
13# have problems, suggestions or questions.
13# @BLURB: Eclass for Emacs Lisp packages 14# @BLURB: Eclass for Emacs Lisp packages
14# @DESCRIPTION: 15# @DESCRIPTION:
15# 16#
16# This eclass sets the site-lisp directory for Emacs-related packages. 17# This eclass is designed to install elisp files of Emacs related
18# packages into the site-lisp directory. The majority of elisp packages
19# will only need to define the standard ebuild variables (like SRC_URI)
20# and optionally SITEFILE for successful installation.
17# 21#
18# Emacs support for other than pure elisp packages is handled by 22# Emacs support for other than pure elisp packages is handled by
19# elisp-common.eclass where you won't have a dependency on Emacs itself. 23# elisp-common.eclass where you won't have a dependency on Emacs itself.
20# All elisp-* functions are documented there. 24# All elisp-* functions are documented there.
21# 25#
22# Setting SIMPLE_ELISP=t in an ebuild means, that the package's source 26# If the package's source is a single (in whatever way) compressed elisp
23# is a single (in whatever way) compressed elisp file with the file name 27# file with the file name ${P}.el, then this eclass will move ${P}.el to
24# ${PN}-${PV}. This eclass will then redefine ${S}, and move
25# ${PN}-${PV}.el to ${PN}.el in src_unpack(). 28# ${PN}.el in src_unpack().
26# 29
27# DOCS="blah.txt ChangeLog" is automatically used to install the given 30# @ECLASS-VARIABLE: NEED_EMACS
28# files by dodoc in src_install(). 31# @DESCRIPTION:
29#
30# If you need anything different from Emacs 21, use the NEED_EMACS 32# If you need anything different from Emacs 21, use the NEED_EMACS
31# variable before inheriting elisp.eclass. Set it to the major version 33# variable before inheriting elisp.eclass. Set it to the major version
32# your package uses and the dependency will be adjusted. 34# your package uses and the dependency will be adjusted.
33 35
36# @ECLASS-VARIABLE: DOCS
37# @DESCRIPTION:
38# DOCS="blah.txt ChangeLog" is automatically used to install the given
39# files by dodoc in src_install().
40
41# @ECLASS-VARIABLE: SITEFILE
42# @DESCRIPTION:
43# Name of package's site-init file. The filename must match the shell
44# pattern "[1-8][0-9]*-gentoo.el"; numbers below 10 and above 89 are
45# reserved for internal use. "50${PN}-gentoo.el" is a reasonable choice
46# in most cases.
47
34inherit elisp-common versionator 48inherit elisp-common versionator
35 49
36VERSION=${NEED_EMACS:-21} 50EXPORT_FUNCTIONS \
51 src_unpack src_compile src_install \
52 pkg_setup pkg_postinst pkg_postrm
53
37DEPEND=">=virtual/emacs-${VERSION}" 54DEPEND=">=virtual/emacs-${NEED_EMACS:-21}"
38RDEPEND=">=virtual/emacs-${VERSION}" 55RDEPEND=">=virtual/emacs-${NEED_EMACS:-21}"
39IUSE="" 56IUSE=""
40 57
41if [ "${SIMPLE_ELISP}" = 't' ]; then
42 S="${WORKDIR}"
43fi
44
45elisp_pkg_setup() { 58elisp_pkg_setup() {
59 local need_emacs=${NEED_EMACS:-21}
46 local emacs_version="$(elisp-emacs-version)" 60 local have_emacs=$(elisp-emacs-version)
47 if ! version_is_at_least "${VERSION}" "${emacs_version}"; then 61 if ! version_is_at_least "${need_emacs}" "${have_emacs}"; then
48 eerror "This package needs at least Emacs ${VERSION}." 62 eerror "This package needs at least Emacs ${need_emacs}."
49 eerror "Use \"eselect emacs\" to select the active version." 63 eerror "Use \"eselect emacs\" to select the active version."
50 die "Emacs version ${emacs_version} is too low." 64 die "Emacs version ${have_emacs} is too low."
51 fi 65 fi
66 einfo "Emacs version: ${have_emacs}"
52} 67}
53 68
54elisp_src_unpack() { 69elisp_src_unpack() {
55 unpack ${A} 70 [ -n "${A}" ] && unpack ${A}
56 if [ "${SIMPLE_ELISP}" = 't' ]; then 71 if [ -f ${P}.el ]; then
57 cd "${S}" && mv ${P}.el ${PN}.el 72 mv ${P}.el ${PN}.el || die
58 fi 73 fi
59} 74}
60 75
61elisp_src_compile() { 76elisp_src_compile() {
62 elisp-compile *.el || die "elisp-compile failed" 77 elisp-compile *.el || die
63} 78}
64 79
65elisp_src_install() { 80elisp_src_install() {
66 elisp-install ${PN} *.el *.elc 81 elisp-install ${PN} *.el *.elc || die
82 if [ -n "${SITEFILE}" ]; then
67 elisp-site-file-install "${FILESDIR}/${SITEFILE}" 83 elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
84 fi
68 if [ -n "${DOCS}" ]; then 85 if [ -n "${DOCS}" ]; then
69 dodoc ${DOCS} || die "dodoc failed" 86 dodoc ${DOCS} || die
70 fi 87 fi
71} 88}
72 89
73elisp_pkg_postinst() { 90elisp_pkg_postinst() {
74 elisp-site-regen 91 elisp-site-regen
75} 92}
76 93
77elisp_pkg_postrm() { 94elisp_pkg_postrm() {
78 elisp-site-regen 95 elisp-site-regen
79} 96}
80
81EXPORT_FUNCTIONS src_unpack src_compile src_install
82EXPORT_FUNCTIONS pkg_setup pkg_postinst pkg_postrm

Legend:
Removed from v.1.22  
changed lines
  Added in v.1.38

  ViewVC Help
Powered by ViewVC 1.1.20