/[gentoo-x86]/eclass/elisp.eclass
Gentoo

Diff of /eclass/elisp.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.32 Revision 1.34
1# Copyright 1999-2008 Gentoo Foundation 1# Copyright 1999-2008 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/elisp.eclass,v 1.32 2008/06/23 21:38:42 opfer Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/elisp.eclass,v 1.34 2008/09/19 08:12:48 ulm Exp $
4# 4#
5# Copyright 2002-2003 Matthew Kennedy <mkennedy@gentoo.org> 5# Copyright 2002-2003 Matthew Kennedy <mkennedy@gentoo.org>
6# Copyright 2003 Jeremy Maitin-Shepard <jbms@attbi.com> 6# Copyright 2003 Jeremy Maitin-Shepard <jbms@attbi.com>
7# Copyright 2007-2008 Christian Faulhammer <opfer@gentoo.org> 7# Copyright 2007-2008 Christian Faulhammer <opfer@gentoo.org>
8# Copyright 2007-2008 Ulrich Müller <ulm@gentoo.org> 8# Copyright 2007-2008 Ulrich Müller <ulm@gentoo.org>
35# variable before inheriting elisp.eclass. Set it to the major version 35# variable before inheriting elisp.eclass. Set it to the major version
36# your package uses and the dependency will be adjusted. 36# your package uses and the dependency will be adjusted.
37 37
38inherit elisp-common versionator 38inherit elisp-common versionator
39 39
40VERSION=${NEED_EMACS:-21}
41DEPEND=">=virtual/emacs-${VERSION}" 40DEPEND=">=virtual/emacs-${NEED_EMACS:-21}"
42RDEPEND=">=virtual/emacs-${VERSION}" 41RDEPEND=">=virtual/emacs-${NEED_EMACS:-21}"
43IUSE="" 42IUSE=""
44 43
45elisp_pkg_setup() { 44elisp_pkg_setup() {
45 local need_emacs=${NEED_EMACS:-21}
46 local emacs_version="$(elisp-emacs-version)" 46 local have_emacs=$(elisp-emacs-version)
47 if ! version_is_at_least "${VERSION}" "${emacs_version}"; then 47 if ! version_is_at_least "${need_emacs}" "${have_emacs}"; then
48 eerror "This package needs at least Emacs ${VERSION}." 48 eerror "This package needs at least Emacs ${need_emacs}."
49 eerror "Use \"eselect emacs\" to select the active version." 49 eerror "Use \"eselect emacs\" to select the active version."
50 die "Emacs version ${emacs_version} is too low." 50 die "Emacs version ${have_emacs} is too low."
51 fi 51 fi
52 einfo "Currently selected GNU Emacs version: ${emacs_version}"
53} 52}
54 53
55elisp_src_unpack() { 54elisp_src_unpack() {
56 unpack ${A} 55 [ -n "${A}" ] && unpack ${A}
57 if [ -f ${P}.el ]; then 56 if [ -f ${P}.el ]; then
58 mv ${P}.el ${PN}.el || die "mv ${P}.el ${PN}.el failed" 57 mv ${P}.el ${PN}.el || die "mv ${P}.el ${PN}.el failed"
59 fi 58 fi
60} 59}
61 60

Legend:
Removed from v.1.32  
changed lines
  Added in v.1.34

  ViewVC Help
Powered by ViewVC 1.1.20