/[gentoo-x86]/eclass/elisp.eclass
Gentoo

Diff of /eclass/elisp.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.34 Revision 1.39
1# Copyright 1999-2008 Gentoo Foundation 1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/elisp.eclass,v 1.34 2008/09/19 08:12:48 ulm Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/elisp.eclass,v 1.39 2009/03/26 14:14:22 ulm Exp $
4# 4#
5# Copyright 2002-2003 Matthew Kennedy <mkennedy@gentoo.org> 5# Copyright 2002-2003 Matthew Kennedy <mkennedy@gentoo.org>
6# Copyright 2003 Jeremy Maitin-Shepard <jbms@attbi.com> 6# Copyright 2003 Jeremy Maitin-Shepard <jbms@attbi.com>
7# Copyright 2007-2008 Christian Faulhammer <opfer@gentoo.org> 7# Copyright 2007-2009 Christian Faulhammer <fauli@gentoo.org>
8# Copyright 2007-2008 Ulrich Müller <ulm@gentoo.org> 8# Copyright 2007-2009 Ulrich Müller <ulm@gentoo.org>
9# 9#
10# @ECLASS: elisp.eclass 10# @ECLASS: elisp.eclass
11# @MAINTAINER: 11# @MAINTAINER:
12# Feel free to contact the Emacs team through <emacs@gentoo.org> if you 12# Feel free to contact the Emacs team through <emacs@gentoo.org> if you
13# have problems, suggestions or questions. 13# have problems, suggestions or questions.
14# @BLURB: Eclass for Emacs Lisp packages 14# @BLURB: Eclass for Emacs Lisp packages
15# @DESCRIPTION: 15# @DESCRIPTION:
16# 16#
17# This eclass sets the site-lisp directory for Emacs-related packages. 17# This eclass is designed to install elisp files of Emacs related
18# packages into the site-lisp directory. The majority of elisp packages
19# will only need to define the standard ebuild variables (like SRC_URI)
20# and optionally SITEFILE for successful installation.
18# 21#
19# Emacs support for other than pure elisp packages is handled by 22# Emacs support for other than pure elisp packages is handled by
20# elisp-common.eclass where you won't have a dependency on Emacs itself. 23# elisp-common.eclass where you won't have a dependency on Emacs itself.
21# All elisp-* functions are documented there. 24# All elisp-* functions are documented there.
22# 25#
23# If the package's source is a single (in whatever way) compressed elisp 26# If the package's source is a single (in whatever way) compressed elisp
24# file with the file name ${P}.el, then this eclass will move ${P}.el to 27# file with the file name ${P}.el, then this eclass will move ${P}.el to
25# ${PN}.el in src_unpack(). 28# ${PN}.el in src_unpack().
26 29
27# @ECLASS-VARIABLE: DOCS
28# @DESCRIPTION:
29# DOCS="blah.txt ChangeLog" is automatically used to install the given
30# files by dodoc in src_install().
31
32# @ECLASS-VARIABLE: NEED_EMACS 30# @ECLASS-VARIABLE: NEED_EMACS
33# @DESCRIPTION: 31# @DESCRIPTION:
34# If you need anything different from Emacs 21, use the NEED_EMACS 32# If you need anything different from Emacs 21, use the NEED_EMACS
35# variable before inheriting elisp.eclass. Set it to the major version 33# variable before inheriting elisp.eclass. Set it to the major version
36# your package uses and the dependency will be adjusted. 34# your package uses and the dependency will be adjusted.
37 35
36# @ECLASS-VARIABLE: DOCS
37# @DESCRIPTION:
38# DOCS="blah.txt ChangeLog" is automatically used to install the given
39# files by dodoc in src_install().
40
41# @ECLASS-VARIABLE: SITEFILE
42# @DESCRIPTION:
43# Name of package's site-init file. The filename must match the shell
44# pattern "[1-8][0-9]*-gentoo.el"; numbers below 10 and above 89 are
45# reserved for internal use. "50${PN}-gentoo.el" is a reasonable choice
46# in most cases.
47
38inherit elisp-common versionator 48inherit elisp-common versionator
49
50EXPORT_FUNCTIONS \
51 src_unpack src_compile src_install \
52 pkg_setup pkg_postinst pkg_postrm
39 53
40DEPEND=">=virtual/emacs-${NEED_EMACS:-21}" 54DEPEND=">=virtual/emacs-${NEED_EMACS:-21}"
41RDEPEND=">=virtual/emacs-${NEED_EMACS:-21}" 55RDEPEND=">=virtual/emacs-${NEED_EMACS:-21}"
42IUSE="" 56IUSE=""
43 57
47 if ! version_is_at_least "${need_emacs}" "${have_emacs}"; then 61 if ! version_is_at_least "${need_emacs}" "${have_emacs}"; then
48 eerror "This package needs at least Emacs ${need_emacs}." 62 eerror "This package needs at least Emacs ${need_emacs}."
49 eerror "Use \"eselect emacs\" to select the active version." 63 eerror "Use \"eselect emacs\" to select the active version."
50 die "Emacs version ${have_emacs} is too low." 64 die "Emacs version ${have_emacs} is too low."
51 fi 65 fi
66 einfo "Emacs version: ${have_emacs}"
52} 67}
53 68
54elisp_src_unpack() { 69elisp_src_unpack() {
55 [ -n "${A}" ] && unpack ${A} 70 [ -n "${A}" ] && unpack ${A}
56 if [ -f ${P}.el ]; then 71 if [ -f ${P}.el ]; then
57 mv ${P}.el ${PN}.el || die "mv ${P}.el ${PN}.el failed" 72 # the "simple elisp" case with a single *.el file in WORKDIR
73 mv ${P}.el ${PN}.el || die
74 [ -d "${S}" ] || S=${WORKDIR}
58 fi 75 fi
59} 76}
60 77
61elisp_src_compile() { 78elisp_src_compile() {
62 elisp-compile *.el || die "elisp-compile failed" 79 elisp-compile *.el || die
63} 80}
64 81
65elisp_src_install() { 82elisp_src_install() {
66 elisp-install ${PN} *.el *.elc || die "elisp-install failed" 83 elisp-install ${PN} *.el *.elc || die
84 if [ -n "${SITEFILE}" ]; then
67 elisp-site-file-install "${FILESDIR}/${SITEFILE}" \ 85 elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
68 || die "elisp-site-file-install failed" 86 fi
69 if [ -n "${DOCS}" ]; then 87 if [ -n "${DOCS}" ]; then
70 dodoc ${DOCS} || die "dodoc failed" 88 dodoc ${DOCS} || die
71 fi 89 fi
72} 90}
73 91
74elisp_pkg_postinst() { 92elisp_pkg_postinst() {
75 elisp-site-regen 93 elisp-site-regen
76} 94}
77 95
78elisp_pkg_postrm() { 96elisp_pkg_postrm() {
79 elisp-site-regen 97 elisp-site-regen
80} 98}
81
82EXPORT_FUNCTIONS \
83 src_unpack src_compile src_install \
84 pkg_setup pkg_postinst pkg_postrm

Legend:
Removed from v.1.34  
changed lines
  Added in v.1.39

  ViewVC Help
Powered by ViewVC 1.1.20