/[gentoo-x86]/eclass/elisp.eclass
Gentoo

Diff of /eclass/elisp.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.35 Revision 1.36
1# Copyright 1999-2008 Gentoo Foundation 1# Copyright 1999-2008 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/elisp.eclass,v 1.35 2008/10/16 09:28:58 ulm Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/elisp.eclass,v 1.36 2008/11/16 10:23:42 ulm Exp $
4# 4#
5# Copyright 2002-2003 Matthew Kennedy <mkennedy@gentoo.org> 5# Copyright 2002-2003 Matthew Kennedy <mkennedy@gentoo.org>
6# Copyright 2003 Jeremy Maitin-Shepard <jbms@attbi.com> 6# Copyright 2003 Jeremy Maitin-Shepard <jbms@attbi.com>
7# Copyright 2007-2008 Christian Faulhammer <opfer@gentoo.org> 7# Copyright 2007-2008 Christian Faulhammer <opfer@gentoo.org>
8# Copyright 2007-2008 Ulrich Müller <ulm@gentoo.org> 8# Copyright 2007-2008 Ulrich Müller <ulm@gentoo.org>
54 if ! version_is_at_least "${need_emacs}" "${have_emacs}"; then 54 if ! version_is_at_least "${need_emacs}" "${have_emacs}"; then
55 eerror "This package needs at least Emacs ${need_emacs}." 55 eerror "This package needs at least Emacs ${need_emacs}."
56 eerror "Use \"eselect emacs\" to select the active version." 56 eerror "Use \"eselect emacs\" to select the active version."
57 die "Emacs version ${have_emacs} is too low." 57 die "Emacs version ${have_emacs} is too low."
58 fi 58 fi
59 einfo "Emacs version: ${have_emacs}"
59} 60}
60 61
61elisp_src_unpack() { 62elisp_src_unpack() {
62 [ -n "${A}" ] && unpack ${A} 63 [ -n "${A}" ] && unpack ${A}
63 if [ -f ${P}.el ]; then 64 if [ -f ${P}.el ]; then

Legend:
Removed from v.1.35  
changed lines
  Added in v.1.36

  ViewVC Help
Powered by ViewVC 1.1.20