/[gentoo-x86]/eclass/elisp.eclass
Gentoo

Contents of /eclass/elisp.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.40 - (show annotations) (download)
Sun Mar 29 19:49:45 2009 UTC (5 years, 7 months ago) by ulm
Branch: MAIN
Changes since 1.39: +33 -6 lines
Sync elisp.eclass from Emacs overlay (revision 1355):

Inherit eutils. Call EXPORT_FUNCTIONS with EAPI dependent arguments.
Assign RDEPEND from DEPEND, avoiding unnecessary code duplication.
New function elisp_src_prepare, applies patches from ELISP_PATCHES.
New function elisp_src_configure, does nothing.

1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/eclass/elisp.eclass,v 1.39 2009/03/26 14:14:22 ulm Exp $
4 #
5 # Copyright 2002-2003 Matthew Kennedy <mkennedy@gentoo.org>
6 # Copyright 2003 Jeremy Maitin-Shepard <jbms@attbi.com>
7 # Copyright 2007-2009 Christian Faulhammer <fauli@gentoo.org>
8 # Copyright 2007-2009 Ulrich Müller <ulm@gentoo.org>
9 #
10 # @ECLASS: elisp.eclass
11 # @MAINTAINER:
12 # Feel free to contact the Emacs team through <emacs@gentoo.org> if you
13 # have problems, suggestions or questions.
14 # @BLURB: Eclass for Emacs Lisp packages
15 # @DESCRIPTION:
16 #
17 # This eclass is designed to install elisp files of Emacs related
18 # packages into the site-lisp directory. The majority of elisp packages
19 # will only need to define the standard ebuild variables (like SRC_URI)
20 # and optionally SITEFILE for successful installation.
21 #
22 # Emacs support for other than pure elisp packages is handled by
23 # elisp-common.eclass where you won't have a dependency on Emacs itself.
24 # All elisp-* functions are documented there.
25 #
26 # If the package's source is a single (in whatever way) compressed elisp
27 # file with the file name ${P}.el, then this eclass will move ${P}.el to
28 # ${PN}.el in src_unpack().
29
30 # @ECLASS-VARIABLE: NEED_EMACS
31 # @DESCRIPTION:
32 # If you need anything different from Emacs 21, use the NEED_EMACS
33 # variable before inheriting elisp.eclass. Set it to the major version
34 # your package uses and the dependency will be adjusted.
35
36 # @ECLASS-VARIABLE: DOCS
37 # @DESCRIPTION:
38 # DOCS="blah.txt ChangeLog" is automatically used to install the given
39 # files by dodoc in src_install().
40
41 # @ECLASS-VARIABLE: ELISP_PATCHES
42 # @DESCRIPTION:
43 # Any patches to apply after unpacking the sources. Patches are searched
44 # both in ${PWD} and ${FILESDIR}.
45
46 # @ECLASS-VARIABLE: SITEFILE
47 # @DESCRIPTION:
48 # Name of package's site-init file. The filename must match the shell
49 # pattern "[1-8][0-9]*-gentoo.el"; numbers below 10 and above 89 are
50 # reserved for internal use. "50${PN}-gentoo.el" is a reasonable choice
51 # in most cases.
52
53 inherit elisp-common eutils versionator
54
55 case "${EAPI:-0}" in
56 0|1) EXPORT_FUNCTIONS src_{unpack,compile,install} \
57 pkg_{setup,postinst,postrm} ;;
58 *) EXPORT_FUNCTIONS src_{unpack,prepare,configure,compile,install} \
59 pkg_{setup,postinst,postrm} ;;
60 esac
61
62 DEPEND=">=virtual/emacs-${NEED_EMACS:-21}"
63 RDEPEND="${DEPEND}"
64 IUSE=""
65
66 elisp_pkg_setup() {
67 local need_emacs=${NEED_EMACS:-21}
68 local have_emacs=$(elisp-emacs-version)
69 if ! version_is_at_least "${need_emacs}" "${have_emacs}"; then
70 eerror "This package needs at least Emacs ${need_emacs}."
71 eerror "Use \"eselect emacs\" to select the active version."
72 die "Emacs version ${have_emacs} is too low."
73 fi
74 einfo "Emacs version: ${have_emacs}"
75 }
76
77 elisp_src_unpack() {
78 [ -n "${A}" ] && unpack ${A}
79 if [ -f ${P}.el ]; then
80 # the "simple elisp" case with a single *.el file in WORKDIR
81 mv ${P}.el ${PN}.el || die
82 [ -d "${S}" ] || S=${WORKDIR}
83 fi
84
85 case "${EAPI:-0}" in
86 0|1) elisp_src_prepare ;;
87 esac
88 }
89
90 elisp_src_prepare() {
91 local patch
92 for patch in ${ELISP_PATCHES}; do
93 if [ -f "${patch}" ]; then
94 epatch "${patch}"
95 elif [ -f "${FILESDIR}/${patch}" ]; then
96 epatch "${FILESDIR}/${patch}"
97 else
98 die "Cannot find ${patch}"
99 fi
100 done
101 }
102
103 elisp_src_configure() { :; }
104
105 elisp_src_compile() {
106 elisp-compile *.el || die
107 }
108
109 elisp_src_install() {
110 elisp-install ${PN} *.el *.elc || die
111 if [ -n "${SITEFILE}" ]; then
112 elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
113 fi
114 if [ -n "${DOCS}" ]; then
115 dodoc ${DOCS} || die
116 fi
117 }
118
119 elisp_pkg_postinst() {
120 elisp-site-regen
121 }
122
123 elisp_pkg_postrm() {
124 elisp-site-regen
125 }

  ViewVC Help
Powered by ViewVC 1.1.20