/[gentoo-x86]/eclass/fortran-2.eclass
Gentoo

Diff of /eclass/fortran-2.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.6 Revision 1.11
1# Copyright 1999-2012 Gentoo Foundation 1# Copyright 1999-2012 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/fortran-2.eclass,v 1.6 2012/09/27 16:35:41 axs Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/fortran-2.eclass,v 1.11 2012/10/07 14:53:43 jlec Exp $
4 4
5# @ECLASS: fortran-2.eclass 5# @ECLASS: fortran-2.eclass
6# @MAINTAINER: 6# @MAINTAINER:
7# jlec@gentoo.org 7# jlec@gentoo.org
8# sci@gentoo.org 8# sci@gentoo.org
31# Generally not needed as default is sufficient. 31# Generally not needed as default is sufficient.
32# 32#
33# Valid settings are any combination of: 77 90 95 2003 33# Valid settings are any combination of: 77 90 95 2003
34: ${FORTRAN_STANDARD:=77} 34: ${FORTRAN_STANDARD:=77}
35 35
36inherit toolchain-funcs 36inherit eutils toolchain-funcs
37 37
38# @FUNCTION: _write_testsuite 38# @FUNCTION: _write_testsuite
39# @INTERNAL 39# @INTERNAL
40# @DESCRIPTION: 40# @DESCRIPTION:
41# writes fortran test code 41# writes fortran test code
144 if [[ ${FORTRAN_NEED_OPENMP} == 1 ]]; then 144 if [[ ${FORTRAN_NEED_OPENMP} == 1 ]]; then
145 _fortran-has-openmp || \ 145 _fortran-has-openmp || \
146 die "Please install current gcc with USE=openmp or set the FC variable to a compiler that supports OpenMP" 146 die "Please install current gcc with USE=openmp or set the FC variable to a compiler that supports OpenMP"
147 fi 147 fi
148 tc-export F77 FC 148 tc-export F77 FC
149 einfo "Using following Fortran compiler"
150 einfo " F77: ${F77}"
151 einfo " FC: ${FC}"
149} 152}
150 153
151case ${EAPI:-0} in 154case ${EAPI:-0} in
152 0|1|2|3|4|5) EXPORT_FUNCTIONS pkg_setup ;; 155 0|1|2|3|4|5) EXPORT_FUNCTIONS pkg_setup ;;
153 *) die "EAPI=${EAPI} is not supported" ;; 156 *) die "EAPI=${EAPI} is not supported" ;;
154esac 157esac
158
159#if in_iuse fortran; then
160# DEPEND="fortran? ( virtual/fortran )"
161#else
162# DEPEND="virtual/fortran"
163#fi
164
165#RDEPEND="${DEPEND}"

Legend:
Removed from v.1.6  
changed lines
  Added in v.1.11

  ViewVC Help
Powered by ViewVC 1.1.20