/[gentoo-x86]/eclass/gems.eclass
Gentoo

Diff of /eclass/gems.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.18 Revision 1.19
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/Attic/gems.eclass,v 1.18 2007/09/17 04:59:29 nichoj Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/Attic/gems.eclass,v 1.19 2008/01/11 00:22:03 rbrown Exp $
4# 4#
5# Author: Rob Cakebread <pythonhead@gentoo.org> 5# Author: Rob Cakebread <pythonhead@gentoo.org>
6# Current Maintainer: Ruby Herd <ruby@gentoo.org> 6# Current Maintainer: Ruby Herd <ruby@gentoo.org>
7# 7#
8# The gems eclass is designed to allow easier installation of 8# The gems eclass is designed to allow easier installation of
17# 17#
18# NOTE: 18# NOTE:
19# See http://dev.gentoo.org/~pythonhead/ruby/gems.html for notes on using gems with portage 19# See http://dev.gentoo.org/~pythonhead/ruby/gems.html for notes on using gems with portage
20 20
21 21
22inherit ruby eutils 22inherit eutils ruby versionator
23 23
24SRC_URI="http://gems.rubyforge.org/gems/${P}.gem" 24SRC_URI="http://gems.rubyforge.org/gems/${P}.gem"
25 25
26IUSE="doc" 26IUSE="doc"
27 27
59 else 59 else
60 myconf="--no-rdoc" 60 myconf="--no-rdoc"
61 fi 61 fi
62 62
63 # RI documentation installation: bug #145222 63 # RI documentation installation: bug #145222
64 if gem --version|grep -q ^0.9; then 64 if version_is_at_least "0.9" $(gem --version); then
65 if use doc; then 65 if use doc; then
66 myconf="--ri ${myconf}" 66 myconf="--ri ${myconf}"
67 else 67 else
68 myconf="--no-ri ${myconf}" 68 myconf="--no-ri ${myconf}"
69 fi 69 fi
70 fi 70 fi
71
72 71
73 dodir ${GEMSDIR} 72 dodir ${GEMSDIR}
74 gem install ${GEM_SRC} -v ${PV} ${myconf} -l -i ${D}/${GEMSDIR} || die "gem install failed: gem-$(gem --version) install ${GEM_SRC} -v ${PV} ${myconf} -l -i ${D}/${GEMSDIR}" 73 gem install ${GEM_SRC} -v ${PV} ${myconf} -l -i ${D}/${GEMSDIR} || die "gem install failed: gem-$(gem --version) install ${GEM_SRC} -v ${PV} ${myconf} -l -i ${D}/${GEMSDIR}"
75 74
76 # This is a workaround for <=rubygems-0.9.0.8 because it's exitstatus equals 0 75 # This is a workaround for <=rubygems-0.9.0.8 because it's exitstatus equals 0

Legend:
Removed from v.1.18  
changed lines
  Added in v.1.19

  ViewVC Help
Powered by ViewVC 1.1.20