/[gentoo-x86]/eclass/ghc-package.eclass
Gentoo

Contents of /eclass/ghc-package.eclass

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1.32 - (hide annotations) (download)
Thu Nov 24 00:04:13 2011 UTC (2 years, 7 months ago) by vapier
Branch: MAIN
Changes since 1.31: +2 -2 lines
fix up copy & paste errors (same func/var name)

1 slyfox 1.29 # Copyright 1999-2011 Gentoo Foundation
2 kosmikus 1.1 # Distributed under the terms of the GNU General Public License v2
3 vapier 1.32 # $Header: /var/cvsroot/gentoo-x86/eclass/ghc-package.eclass,v 1.31 2011/08/22 04:46:31 vapier Exp $
4 vapier 1.31
5 slyfox 1.29 # @ECLASS: ghc-package.eclass
6     # @MAINTAINER:
7     # "Gentoo's Haskell Language team" <haskell@gentoo.org>
8 vapier 1.31 # @AUTHOR:
9 slyfox 1.29 # Original Author: Andres Loeh <kosmikus@gentoo.org>
10     # @BLURB: This eclass helps with the Glasgow Haskell Compiler's package configuration utility.
11     # @DESCRIPTION:
12     # Helper eclass to handle ghc installation/upgrade/deinstallation process.
13 kosmikus 1.1
14 kosmikus 1.6 inherit versionator
15    
16 slyfox 1.29 # @FUNCTION: ghc-getghc
17     # @DESCRIPTION:
18 kosmikus 1.1 # returns the name of the ghc executable
19     ghc-getghc() {
20 kosmikus 1.22 type -P ghc
21 kosmikus 1.1 }
22    
23 slyfox 1.29 # @FUNCTION: ghc-getghcpkg
24     # @DESCRIPTION:
25     # Internal function determines returns the name of the ghc-pkg executable
26 kosmikus 1.1 ghc-getghcpkg() {
27 kosmikus 1.22 type -P ghc-pkg
28 kosmikus 1.1 }
29    
30 slyfox 1.29 # @FUNCTION: ghc-getghcpkgbin
31     # @DESCRIPTION:
32 kosmikus 1.1 # returns the name of the ghc-pkg binary (ghc-pkg
33     # itself usually is a shell script, and we have to
34 kosmikus 1.6 # bypass the script under certain circumstances);
35 kosmikus 1.15 # for Cabal, we add an empty global package config file,
36     # because for some reason the global package file
37     # must be specified
38 kosmikus 1.1 ghc-getghcpkgbin() {
39 kolmodin 1.27 if version_is_at_least "6.10" "$(ghc-version)"; then
40     # the ghc-pkg executable changed name in ghc 6.10, as it no longer needs
41     # the wrapper script with the static flags
42     echo '[]' > "${T}/empty.conf"
43     echo "$(ghc-libdir)/ghc-pkg" "--global-conf=${T}/empty.conf"
44     elif ghc-cabal; then
45 kosmikus 1.15 echo '[]' > "${T}/empty.conf"
46     echo "$(ghc-libdir)/ghc-pkg.bin" "--global-conf=${T}/empty.conf"
47 kosmikus 1.6 else
48 kosmikus 1.15 echo "$(ghc-libdir)/ghc-pkg.bin"
49 kosmikus 1.6 fi
50 kosmikus 1.1 }
51    
52 slyfox 1.29 # @FUNCTION: ghc-version
53     # @DESCRIPTION:
54 kosmikus 1.1 # returns the version of ghc
55 kosmikus 1.6 _GHC_VERSION_CACHE=""
56 kosmikus 1.1 ghc-version() {
57 kosmikus 1.6 if [[ -z "${_GHC_VERSION_CACHE}" ]]; then
58 dcoutts 1.16 _GHC_VERSION_CACHE="$($(ghc-getghc) --numeric-version)"
59 kosmikus 1.6 fi
60     echo "${_GHC_VERSION_CACHE}"
61     }
62    
63 slyfox 1.29 # @FUNCTION: ghc-cabal
64     # @DESCRIPTION:
65 kosmikus 1.15 # this function can be used to determine if ghc itself
66     # uses the Cabal package format; it has nothing to do
67     # with the Cabal libraries ... ghc uses the Cabal package
68     # format since version 6.4
69 kosmikus 1.6 ghc-cabal() {
70     version_is_at_least "6.4" "$(ghc-version)"
71 kosmikus 1.1 }
72    
73 slyfox 1.29 # @FUNCTION: ghc-bestcabalversion
74     # @DESCRIPTION:
75 kosmikus 1.15 # return the best version of the Cabal library that is available
76     ghc-bestcabalversion() {
77     local cabalversion
78     if ghc-cabal; then
79 dcoutts 1.19 # We ask portage, not ghc, so that we only pick up
80     # portage-installed cabal versions.
81 dcoutts 1.23 cabalversion="$(ghc-extractportageversion dev-haskell/cabal)"
82 kosmikus 1.15 echo "Cabal-${cabalversion}"
83     else
84     # older ghc's don't support package versioning
85     echo Cabal
86     fi
87     }
88    
89 slyfox 1.29 # @FUNCTION: ghc-sanecabal
90     # @DESCRIPTION:
91 kosmikus 1.15 # check if a standalone Cabal version is available for the
92     # currently used ghc; takes minimal version of Cabal as
93     # an optional argument
94     ghc-sanecabal() {
95     local f
96     local version
97     if [[ -z "$1" ]]; then version="1.0.1"; else version="$1"; fi
98     for f in $(ghc-confdir)/cabal-*; do
99     [[ -f "${f}" ]] && version_is_at_least "${version}" "${f#*cabal-}" && return
100     done
101     return 1
102     }
103    
104 slyfox 1.29 # @FUNCTION: ghc-saneghc
105     # @DESCRIPTION:
106 dcoutts 1.23 # checks if ghc and ghc-bin are installed in the same version
107 swegener 1.26 # (if they're both installed); if this is not the case, we
108 dcoutts 1.23 # unfortunately cannot trust portage's dependency resolution
109     ghc-saneghc() {
110     local ghcversion
111     local ghcbinversion
112     if [[ "${PN}" == "ghc" || "${PN}" == "ghc-bin" ]]; then
113     return
114     fi
115     if has_version dev-lang/ghc && has_version dev-lang/ghc-bin; then
116     ghcversion="$(ghc-extractportageversion dev-lang/ghc)"
117     ghcbinversion="$(ghc-extractportageversion dev-lang/ghc-bin)"
118     if [[ "${ghcversion}" != "${ghcbinversion}" ]]; then
119     return 1
120     fi
121     fi
122     return
123     }
124    
125 slyfox 1.30 # @FUNCTION: ghc-supports-shared-libraries
126     # @DESCRIPTION:
127     # checks if ghc is built with support for building
128     # shared libraries (aka '-dynamic' option)
129     ghc-supports-shared-libraries() {
130     $(ghc-getghc) --info | grep "RTS ways" | grep -q "dyn"
131     }
132    
133 slyfox 1.29 # @FUNCTION: ghc-extractportageversion
134     # @DESCRIPTION:
135 dcoutts 1.23 # extract the version of a portage-installed package
136     ghc-extractportageversion() {
137     local pkg
138     local version
139     pkg="$(best_version $1)"
140     version="${pkg#$1-}"
141     version="${version%-r*}"
142     version="${version%_pre*}"
143     echo "${version}"
144     }
145    
146 slyfox 1.29 # @FUNCTION: ghc-libdir
147     # @DESCRIPTION:
148 kosmikus 1.1 # returns the library directory
149 kosmikus 1.6 _GHC_LIBDIR_CACHE=""
150 kosmikus 1.1 ghc-libdir() {
151 kosmikus 1.6 if [[ -z "${_GHC_LIBDIR_CACHE}" ]]; then
152     _GHC_LIBDIR_CACHE="$($(ghc-getghc) --print-libdir)"
153     fi
154     echo "${_GHC_LIBDIR_CACHE}"
155 kosmikus 1.1 }
156    
157 slyfox 1.29 # @FUNCTION: ghc-confdir
158     # @DESCRIPTION:
159 kosmikus 1.1 # returns the (Gentoo) library configuration directory
160     ghc-confdir() {
161 kosmikus 1.15 echo "$(ghc-libdir)/gentoo"
162 kosmikus 1.1 }
163    
164 slyfox 1.29 # @FUNCTION: ghc-localpkgconf
165     # @DESCRIPTION:
166 kosmikus 1.1 # returns the name of the local (package-specific)
167     # package configuration file
168     ghc-localpkgconf() {
169     echo "${PF}.conf"
170     }
171    
172 slyfox 1.29 # @FUNCTION: ghc-makeghcilib
173     # @DESCRIPTION:
174 kosmikus 1.3 # make a ghci foo.o file from a libfoo.a file
175     ghc-makeghcilib() {
176     local outfile
177     outfile="$(dirname $1)/$(basename $1 | sed 's:^lib\?\(.*\)\.a$:\1.o:')"
178 kosmikus 1.15 ld --relocatable --discard-all --output="${outfile}" --whole-archive "$1"
179     }
180    
181 vapier 1.32 # @FUNCTION: ghc-package-exists
182 slyfox 1.29 # @DESCRIPTION:
183 kosmikus 1.15 # tests if a ghc package exists
184     ghc-package-exists() {
185 kolmodin 1.27 local describe_flag
186     if version_is_at_least "6.4" "$(ghc-version)"; then
187     describe_flag="describe"
188     else
189     describe_flag="--show-package"
190     fi
191    
192     $(ghc-getghcpkg) "${describe_flag}" "$1" > /dev/null 2>&1
193 kosmikus 1.3 }
194    
195 slyfox 1.29 # @FUNCTION: ghc-setup-pkg
196     # @DESCRIPTION:
197 kosmikus 1.3 # creates a local (package-specific) package
198     # configuration file; the arguments should be
199     # uninstalled package description files, each
200     # containing a single package description; if
201     # no arguments are given, the resulting file is
202     # empty
203 kosmikus 1.1 ghc-setup-pkg() {
204 kosmikus 1.3 local localpkgconf
205     localpkgconf="${S}/$(ghc-localpkgconf)"
206 kosmikus 1.15 echo '[]' > "${localpkgconf}"
207 kolmodin 1.27 local update_flag
208     if version_is_at_least "6.4" "$(ghc-version)"; then
209     update_flag="update -"
210     else
211     update_flag="--update-package"
212     fi
213 dcoutts 1.10 for pkg in $*; do
214 kolmodin 1.27 $(ghc-getghcpkgbin) -f "${localpkgconf}" ${update_flag} --force \
215 kosmikus 1.15 < "${pkg}" || die "failed to register ${pkg}"
216 kosmikus 1.3 done
217 kosmikus 1.1 }
218    
219 slyfox 1.29 # @FUNCTION: ghc-fixlibpath
220     # @DESCRIPTION:
221 araujo 1.9 # fixes the library and import directories path
222     # of the package configuration file
223     ghc-fixlibpath() {
224 kosmikus 1.15 sed -i "s|$1|$(ghc-libdir)|g" "${S}/$(ghc-localpkgconf)"
225 araujo 1.9 if [[ -n "$2" ]]; then
226 kosmikus 1.15 sed -i "s|$2|$(ghc-libdir)/imports|g" "${S}/$(ghc-localpkgconf)"
227 araujo 1.9 fi
228     }
229    
230 slyfox 1.29 # @FUNCTION: ghc-install-pkg
231     # @DESCRIPTION:
232 kosmikus 1.1 # moves the local (package-specific) package configuration
233     # file to its final destination
234     ghc-install-pkg() {
235 kosmikus 1.15 mkdir -p "${D}/$(ghc-confdir)"
236     cat "${S}/$(ghc-localpkgconf)" | sed "s|${D}||g" \
237     > "${D}/$(ghc-confdir)/$(ghc-localpkgconf)"
238 kosmikus 1.1 }
239    
240 slyfox 1.29 # @FUNCTION: ghc-register-pkg
241     # @DESCRIPTION:
242 kosmikus 1.1 # registers all packages in the local (package-specific)
243     # package configuration file
244     ghc-register-pkg() {
245     local localpkgconf
246 kosmikus 1.3 localpkgconf="$(ghc-confdir)/$1"
247 kolmodin 1.27 local update_flag
248     local describe_flag
249     if version_is_at_least "6.4" "$(ghc-version)"; then
250     update_flag="update -"
251     describe_flag="describe"
252     else
253     update_flag="--update-package"
254     describe_flag="--show-package"
255     fi
256 kosmikus 1.15 if [[ -f "${localpkgconf}" ]]; then
257     for pkg in $(ghc-listpkg "${localpkgconf}"); do
258 kosmikus 1.8 ebegin "Registering ${pkg} "
259 kolmodin 1.27 $(ghc-getghcpkgbin) -f "${localpkgconf}" "${describe_flag}" "${pkg}" \
260     | $(ghc-getghcpkg) ${update_flag} --force > /dev/null
261 kosmikus 1.8 eend $?
262 kosmikus 1.7 done
263     fi
264 kosmikus 1.1 }
265    
266 slyfox 1.29 # @FUNCTION: ghc-reregister
267     # @DESCRIPTION:
268 kosmikus 1.1 # re-adds all available .conf files to the global
269     # package conf file, to be used on a ghc reinstallation
270     ghc-reregister() {
271 slyfox 1.29 has "${EAPI:-0}" 0 1 2 && ! use prefix && EPREFIX=
272 kosmikus 1.15 einfo "Re-adding packages (may cause several harmless warnings) ..."
273 slyfox 1.29 PATH="${EPREFIX}/usr/bin:${PATH}" CONFDIR="$(ghc-confdir)"
274 kolmodin 1.27 if [ -d "${CONFDIR}" ]; then
275     pushd "${CONFDIR}" > /dev/null
276 kosmikus 1.5 for conf in *.conf; do
277 slyfox 1.29 PATH="${EPREFIX}/usr/bin:${PATH}" ghc-register-pkg "${conf}"
278 kosmikus 1.5 done
279 kosmikus 1.8 popd > /dev/null
280 kosmikus 1.5 fi
281 kosmikus 1.1 }
282    
283 slyfox 1.29 # @FUNCTION: ghc-unregister-pkg
284     # @DESCRIPTION:
285 kosmikus 1.15 # unregisters a package configuration file
286     # protected are all packages that are still contained in
287     # another package configuration file
288 kosmikus 1.1 ghc-unregister-pkg() {
289     local localpkgconf
290 kosmikus 1.15 local i
291     local pkg
292 kolmodin 1.27 local unregister_flag
293 kosmikus 1.3 localpkgconf="$(ghc-confdir)/$1"
294 kosmikus 1.15
295 kolmodin 1.27 if version_is_at_least "6.4" "$(ghc-version)"; then
296     unregister_flag="unregister"
297     else
298     unregister_flag="--remove-package"
299     fi
300    
301 kosmikus 1.15 if [[ -f "${localpkgconf}" ]]; then
302 kosmikus 1.7 for pkg in $(ghc-reverse "$(ghc-listpkg ${localpkgconf})"); do
303 slyfox 1.30 if ! ghc-package-exists "${pkg}"; then
304     einfo "Package ${pkg} is not installed for ghc-$(ghc-version)."
305     else
306     ebegin "Unregistering ${pkg} "
307     $(ghc-getghcpkg) "${unregister_flag}" "${pkg}" --force > /dev/null
308     eend $?
309     fi
310 kosmikus 1.7 done
311     fi
312 kosmikus 1.1 }
313    
314 slyfox 1.29 # @FUNCTION: ghc-reverse
315     # @DESCRIPTION:
316 kosmikus 1.1 # help-function: reverse a list
317     ghc-reverse() {
318     local result
319 kosmikus 1.15 local i
320 kosmikus 1.1 for i in $1; do
321     result="${i} ${result}"
322     done
323 kosmikus 1.15 echo "${result}"
324     }
325    
326 slyfox 1.29 # @FUNCTION: ghc-elem
327     # @DESCRIPTION:
328 kosmikus 1.15 # help-function: element-check
329     ghc-elem() {
330     local i
331     for i in $2; do
332     [[ "$1" == "${i}" ]] && return 0
333     done
334     return 1
335 kosmikus 1.1 }
336    
337 slyfox 1.29 # @FUNCTION: ghc-listpkg
338     # @DESCRIPTION:
339 kosmikus 1.1 # show the packages in a package configuration file
340     ghc-listpkg() {
341 kosmikus 1.6 local ghcpkgcall
342 kosmikus 1.15 local i
343 kolmodin 1.28 local extra_flags
344     if version_is_at_least '6.12.3' "$(ghc-version)"; then
345     extra_flags="${extra_flags} -v0"
346     fi
347 kosmikus 1.15 for i in $*; do
348     if ghc-cabal; then
349 kolmodin 1.28 echo $($(ghc-getghcpkg) list ${extra_flags} -f "${i}") \
350 kosmikus 1.15 | sed \
351     -e "s|^.*${i}:\([^:]*\).*$|\1|" \
352     -e "s|/.*$||" \
353 dcoutts 1.25 -e "s|,| |g" -e "s|[(){}]||g"
354 kosmikus 1.15 else
355     echo $($(ghc-getghcpkgbin) -l -f "${i}") \
356     | cut -f2 -d':' \
357     | sed 's:,: :g'
358     fi
359     done
360 kosmikus 1.1 }
361    
362 slyfox 1.29 # @FUNCTION: ghc-package_pkg_setup
363     # @DESCRIPTION:
364 kolmodin 1.21 # exported function: check if we have a consistent ghc installation
365     ghc-package_pkg_setup() {
366 dcoutts 1.23 if ! ghc-saneghc; then
367     eerror "You have inconsistent versions of dev-lang/ghc and dev-lang/ghc-bin"
368     eerror "installed. Portage currently cannot work correctly with this setup."
369     eerror "There are several possibilities to work around this problem:"
370     eerror "(1) Up/downgrade ghc-bin to the same version as ghc."
371     eerror "(2) Unmerge ghc-bin."
372     eerror "(3) Unmerge ghc."
373     eerror "You probably want option 1 or 2."
374     die "Inconsistent versions of ghc and ghc-bin."
375     fi
376 kolmodin 1.21 }
377    
378 slyfox 1.29 # @FUNCTION: ghc-package_pkg_postinst
379     # @DESCRIPTION:
380 kosmikus 1.1 # exported function: registers the package-specific package
381     # configuration file
382     ghc-package_pkg_postinst() {
383 kosmikus 1.15 ghc-register-pkg "$(ghc-localpkgconf)"
384 kosmikus 1.1 }
385    
386 slyfox 1.29 # @FUNCTION: ghc-package_pkg_prerm
387     # @DESCRIPTION:
388 kosmikus 1.15 # exported function: unregisters the package-specific package
389     # configuration file; a package contained therein is unregistered
390     # only if it the same package is not also contained in another
391     # package configuration file ...
392 kosmikus 1.1 ghc-package_pkg_prerm() {
393 kosmikus 1.15 ghc-unregister-pkg "$(ghc-localpkgconf)"
394 kosmikus 1.1 }
395    
396 kolmodin 1.21 EXPORT_FUNCTIONS pkg_setup pkg_postinst pkg_prerm

  ViewVC Help
Powered by ViewVC 1.1.20