/[gentoo-x86]/eclass/ghc-package.eclass
Gentoo

Diff of /eclass/ghc-package.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.18 Revision 1.20
1# Copyright 1999-2004 Gentoo Foundation 1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/ghc-package.eclass,v 1.18 2006/08/02 19:49:03 dcoutts Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/ghc-package.eclass,v 1.20 2006/10/04 17:45:35 kosmikus Exp $
4# 4#
5# Author: Andres Loeh <kosmikus@gentoo.org> 5# Author: Andres Loeh <kosmikus@gentoo.org>
6# Maintained by: Haskell herd <haskell@gentoo.org> 6# Maintained by: Haskell herd <haskell@gentoo.org>
7# 7#
8# This eclass helps with the Glasgow Haskell Compiler's package 8# This eclass helps with the Glasgow Haskell Compiler's package
59# return the best version of the Cabal library that is available 59# return the best version of the Cabal library that is available
60ghc-bestcabalversion() { 60ghc-bestcabalversion() {
61 local cabalpackage 61 local cabalpackage
62 local cabalversion 62 local cabalversion
63 if ghc-cabal; then 63 if ghc-cabal; then
64 # Try if ghc-pkg can determine the latest version. 64 # We ask portage, not ghc, so that we only pick up
65 # If not, use portage. 65 # portage-installed cabal versions.
66 cabalpackage="$($(ghc-getghcpkg) latest Cabal 2> /dev/null)"
67 if [[ $? -eq 0 ]]; then
68 cabalversion="${cabalpackage#Cabal-}"
69 else
70 cabalpackage="$(best_version cabal)" 66 cabalpackage="$(best_version dev-haskell/cabal)"
71 cabalversion="${cabalpackage#dev-haskell/cabal-}" 67 cabalversion="${cabalpackage#dev-haskell/cabal-}"
72 cabalversion="${cabalversion%-r*}" 68 cabalversion="${cabalversion%-r*}"
73 cabalversion="${cabalversion%_pre*}" 69 cabalversion="${cabalversion%_pre*}"
74 fi
75 echo "Cabal-${cabalversion}" 70 echo "Cabal-${cabalversion}"
76 else 71 else
77 # older ghc's don't support package versioning 72 # older ghc's don't support package versioning
78 echo Cabal 73 echo Cabal
79 fi 74 fi

Legend:
Removed from v.1.18  
changed lines
  Added in v.1.20

  ViewVC Help
Powered by ViewVC 1.1.20