/[gentoo-x86]/eclass/ghc-package.eclass
Gentoo

Diff of /eclass/ghc-package.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.1.1.1 Revision 1.28
1# Copyright 1999-2004 Gentoo Foundation 1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/ghc-package.eclass,v 1.1.1.1 2005/11/30 09:59:38 chriswhite Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/ghc-package.eclass,v 1.28 2010/06/24 13:50:10 kolmodin Exp $
4# 4#
5# Author: Andres Loeh <kosmikus@gentoo.org> 5# Author: Andres Loeh <kosmikus@gentoo.org>
6# Maintained by: Haskell herd <haskell@gentoo.org>
6# 7#
7# This eclass helps with the Glasgow Haskell Compiler's package 8# This eclass helps with the Glasgow Haskell Compiler's package
8# configuration utility. 9# configuration utility.
9 10
10inherit versionator 11inherit versionator
13PATH="/usr/bin:/opt/ghc/bin:${PATH}" 14PATH="/usr/bin:/opt/ghc/bin:${PATH}"
14 15
15# for later configuration using environment variables/ 16# for later configuration using environment variables/
16# returns the name of the ghc executable 17# returns the name of the ghc executable
17ghc-getghc() { 18ghc-getghc() {
18 echo "ghc" 19 type -P ghc
19} 20}
20 21
21# returns the name of the ghc-pkg executable 22# returns the name of the ghc-pkg executable
22ghc-getghcpkg() { 23ghc-getghcpkg() {
23 echo "ghc-pkg" 24 type -P ghc-pkg
24} 25}
25 26
26# returns the name of the ghc-pkg binary (ghc-pkg 27# returns the name of the ghc-pkg binary (ghc-pkg
27# itself usually is a shell script, and we have to 28# itself usually is a shell script, and we have to
28# bypass the script under certain circumstances); 29# bypass the script under certain circumstances);
29# for Cabal, we add an empty global package config file, 30# for Cabal, we add an empty global package config file,
30# because for some reason the global package file 31# because for some reason the global package file
31# must be specified 32# must be specified
32ghc-getghcpkgbin() { 33ghc-getghcpkgbin() {
34 if version_is_at_least "6.10" "$(ghc-version)"; then
35 # the ghc-pkg executable changed name in ghc 6.10, as it no longer needs
36 # the wrapper script with the static flags
37 echo '[]' > "${T}/empty.conf"
38 echo "$(ghc-libdir)/ghc-pkg" "--global-conf=${T}/empty.conf"
33 if ghc-cabal; then 39 elif ghc-cabal; then
34 echo '[]' > "${T}/empty.conf" 40 echo '[]' > "${T}/empty.conf"
35 echo "$(ghc-libdir)/ghc-pkg.bin" "--global-conf=${T}/empty.conf" 41 echo "$(ghc-libdir)/ghc-pkg.bin" "--global-conf=${T}/empty.conf"
36 else 42 else
37 echo "$(ghc-libdir)/ghc-pkg.bin" 43 echo "$(ghc-libdir)/ghc-pkg.bin"
38 fi 44 fi
40 46
41# returns the version of ghc 47# returns the version of ghc
42_GHC_VERSION_CACHE="" 48_GHC_VERSION_CACHE=""
43ghc-version() { 49ghc-version() {
44 if [[ -z "${_GHC_VERSION_CACHE}" ]]; then 50 if [[ -z "${_GHC_VERSION_CACHE}" ]]; then
45 _GHC_VERSION_CACHE="$($(ghc-getghc) --version | sed 's:^.*version ::')" 51 _GHC_VERSION_CACHE="$($(ghc-getghc) --numeric-version)"
46 fi 52 fi
47 echo "${_GHC_VERSION_CACHE}" 53 echo "${_GHC_VERSION_CACHE}"
48} 54}
49 55
50# this function can be used to determine if ghc itself 56# this function can be used to determine if ghc itself
55 version_is_at_least "6.4" "$(ghc-version)" 61 version_is_at_least "6.4" "$(ghc-version)"
56} 62}
57 63
58# return the best version of the Cabal library that is available 64# return the best version of the Cabal library that is available
59ghc-bestcabalversion() { 65ghc-bestcabalversion() {
60 local cabalpackage
61 local cabalversion 66 local cabalversion
62 if ghc-cabal; then 67 if ghc-cabal; then
63 # Try if ghc-pkg can determine the latest version. 68 # We ask portage, not ghc, so that we only pick up
64 # If not, use portage. 69 # portage-installed cabal versions.
65 cabalpackage="$($(ghc-getghcpkg) latest Cabal 2> /dev/null)" 70 cabalversion="$(ghc-extractportageversion dev-haskell/cabal)"
66 if [[ $? -eq 0 ]]; then
67 cabalversion="${cabalpackage#Cabal-}"
68 else
69 cabalpackage="$(best_version cabal)"
70 cabalversion="${cabalpackage#dev-haskell/cabal-}"
71 cabalversion="${cabalversion%-r*}"
72 cabalversion="${cabalversion%_pre*}"
73 fi
74 echo "Cabal-${cabalversion}" 71 echo "Cabal-${cabalversion}"
75 else 72 else
76 # older ghc's don't support package versioning 73 # older ghc's don't support package versioning
77 echo Cabal 74 echo Cabal
78 fi 75 fi
89 [[ -f "${f}" ]] && version_is_at_least "${version}" "${f#*cabal-}" && return 86 [[ -f "${f}" ]] && version_is_at_least "${version}" "${f#*cabal-}" && return
90 done 87 done
91 return 1 88 return 1
92} 89}
93 90
91# checks if ghc and ghc-bin are installed in the same version
92# (if they're both installed); if this is not the case, we
93# unfortunately cannot trust portage's dependency resolution
94ghc-saneghc() {
95 local ghcversion
96 local ghcbinversion
97 if [[ "${PN}" == "ghc" || "${PN}" == "ghc-bin" ]]; then
98 return
99 fi
100 if has_version dev-lang/ghc && has_version dev-lang/ghc-bin; then
101 ghcversion="$(ghc-extractportageversion dev-lang/ghc)"
102 ghcbinversion="$(ghc-extractportageversion dev-lang/ghc-bin)"
103 if [[ "${ghcversion}" != "${ghcbinversion}" ]]; then
104 return 1
105 fi
106 fi
107 return
108}
109
110# extract the version of a portage-installed package
111ghc-extractportageversion() {
112 local pkg
113 local version
114 pkg="$(best_version $1)"
115 version="${pkg#$1-}"
116 version="${version%-r*}"
117 version="${version%_pre*}"
118 echo "${version}"
119}
120
94# returns the library directory 121# returns the library directory
95_GHC_LIBDIR_CACHE="" 122_GHC_LIBDIR_CACHE=""
96ghc-libdir() { 123ghc-libdir() {
97 if [[ -z "${_GHC_LIBDIR_CACHE}" ]]; then 124 if [[ -z "${_GHC_LIBDIR_CACHE}" ]]; then
98 _GHC_LIBDIR_CACHE="$($(ghc-getghc) --print-libdir)" 125 _GHC_LIBDIR_CACHE="$($(ghc-getghc) --print-libdir)"
118 ld --relocatable --discard-all --output="${outfile}" --whole-archive "$1" 145 ld --relocatable --discard-all --output="${outfile}" --whole-archive "$1"
119} 146}
120 147
121# tests if a ghc package exists 148# tests if a ghc package exists
122ghc-package-exists() { 149ghc-package-exists() {
150 local describe_flag
151 if version_is_at_least "6.4" "$(ghc-version)"; then
152 describe_flag="describe"
153 else
154 describe_flag="--show-package"
155 fi
156
123 $(ghc-getghcpkg) -s "$1" > /dev/null 2>&1 157 $(ghc-getghcpkg) "${describe_flag}" "$1" > /dev/null 2>&1
124} 158}
125 159
126# creates a local (package-specific) package 160# creates a local (package-specific) package
127# configuration file; the arguments should be 161# configuration file; the arguments should be
128# uninstalled package description files, each 162# uninstalled package description files, each
131# empty 165# empty
132ghc-setup-pkg() { 166ghc-setup-pkg() {
133 local localpkgconf 167 local localpkgconf
134 localpkgconf="${S}/$(ghc-localpkgconf)" 168 localpkgconf="${S}/$(ghc-localpkgconf)"
135 echo '[]' > "${localpkgconf}" 169 echo '[]' > "${localpkgconf}"
170 local update_flag
171 if version_is_at_least "6.4" "$(ghc-version)"; then
172 update_flag="update -"
173 else
174 update_flag="--update-package"
175 fi
136 for pkg in $*; do 176 for pkg in $*; do
137 $(ghc-getghcpkgbin) -f "${localpkgconf}" -u --force \ 177 $(ghc-getghcpkgbin) -f "${localpkgconf}" ${update_flag} --force \
138 < "${pkg}" || die "failed to register ${pkg}" 178 < "${pkg}" || die "failed to register ${pkg}"
139 done 179 done
140} 180}
141 181
142# fixes the library and import directories path 182# fixes the library and import directories path
159# registers all packages in the local (package-specific) 199# registers all packages in the local (package-specific)
160# package configuration file 200# package configuration file
161ghc-register-pkg() { 201ghc-register-pkg() {
162 local localpkgconf 202 local localpkgconf
163 localpkgconf="$(ghc-confdir)/$1" 203 localpkgconf="$(ghc-confdir)/$1"
204 local update_flag
205 local describe_flag
206 if version_is_at_least "6.4" "$(ghc-version)"; then
207 update_flag="update -"
208 describe_flag="describe"
209 else
210 update_flag="--update-package"
211 describe_flag="--show-package"
212 fi
164 if [[ -f "${localpkgconf}" ]]; then 213 if [[ -f "${localpkgconf}" ]]; then
165 for pkg in $(ghc-listpkg "${localpkgconf}"); do 214 for pkg in $(ghc-listpkg "${localpkgconf}"); do
166 ebegin "Registering ${pkg} " 215 ebegin "Registering ${pkg} "
167 $(ghc-getghcpkgbin) -f "${localpkgconf}" -s "${pkg}" \ 216 $(ghc-getghcpkgbin) -f "${localpkgconf}" "${describe_flag}" "${pkg}" \
168 | $(ghc-getghcpkg) -u --force > /dev/null 217 | $(ghc-getghcpkg) ${update_flag} --force > /dev/null
169 eend $? 218 eend $?
170 done 219 done
171 fi 220 fi
172} 221}
173 222
174# re-adds all available .conf files to the global 223# re-adds all available .conf files to the global
175# package conf file, to be used on a ghc reinstallation 224# package conf file, to be used on a ghc reinstallation
176ghc-reregister() { 225ghc-reregister() {
177 einfo "Re-adding packages (may cause several harmless warnings) ..." 226 einfo "Re-adding packages (may cause several harmless warnings) ..."
178 if [ -d "$(ghc-confdir)" ]; then 227 PATH="/usr/bin:${PATH}" CONFDIR="$(ghc-confdir)"
179 pushd "$(ghc-confdir)" > /dev/null 228 if [ -d "${CONFDIR}" ]; then
229 pushd "${CONFDIR}" > /dev/null
180 for conf in *.conf; do 230 for conf in *.conf; do
181# einfo "Processing ${conf} ..." 231 PATH="/usr/bin:${PATH}" ghc-register-pkg "${conf}"
182 ghc-register-pkg "${conf}"
183 done 232 done
184 popd > /dev/null 233 popd > /dev/null
185 fi 234 fi
186} 235}
187 236
191ghc-unregister-pkg() { 240ghc-unregister-pkg() {
192 local localpkgconf 241 local localpkgconf
193 local i 242 local i
194 local pkg 243 local pkg
195 local protected 244 local protected
245 local unregister_flag
196 localpkgconf="$(ghc-confdir)/$1" 246 localpkgconf="$(ghc-confdir)/$1"
247
248 if version_is_at_least "6.4" "$(ghc-version)"; then
249 unregister_flag="unregister"
250 else
251 unregister_flag="--remove-package"
252 fi
197 253
198 for i in $(ghc-confdir)/*.conf; do 254 for i in $(ghc-confdir)/*.conf; do
199 [[ "${i}" != "${localpkgconf}" ]] && protected="${protected} $(ghc-listpkg ${i})" 255 [[ "${i}" != "${localpkgconf}" ]] && protected="${protected} $(ghc-listpkg ${i})"
200 done 256 done
201 # protected now contains the packages that cannot be unregistered yet 257 # protected now contains the packages that cannot be unregistered yet
207 elif ! ghc-package-exists "${pkg}"; then 263 elif ! ghc-package-exists "${pkg}"; then
208 : 264 :
209 # einfo "Package ${pkg} is not installed for ghc-$(ghc-version)." 265 # einfo "Package ${pkg} is not installed for ghc-$(ghc-version)."
210 else 266 else
211 ebegin "Unregistering ${pkg} " 267 ebegin "Unregistering ${pkg} "
212 $(ghc-getghcpkg) -r "${pkg}" --force > /dev/null 268 $(ghc-getghcpkg) "${unregister_flag}" "${pkg}" --force > /dev/null
213 eend $? 269 eend $?
214 fi 270 fi
215 done 271 done
216 fi 272 fi
217} 273}
237 293
238# show the packages in a package configuration file 294# show the packages in a package configuration file
239ghc-listpkg() { 295ghc-listpkg() {
240 local ghcpkgcall 296 local ghcpkgcall
241 local i 297 local i
298 local extra_flags
299 if version_is_at_least '6.12.3' "$(ghc-version)"; then
300 extra_flags="${extra_flags} -v0"
301 fi
242 for i in $*; do 302 for i in $*; do
243 if ghc-cabal; then 303 if ghc-cabal; then
244 echo $($(ghc-getghcpkg) list -f "${i}") \ 304 echo $($(ghc-getghcpkg) list ${extra_flags} -f "${i}") \
245 | sed \ 305 | sed \
246 -e "s|^.*${i}:\([^:]*\).*$|\1|" \ 306 -e "s|^.*${i}:\([^:]*\).*$|\1|" \
247 -e "s|/.*$||" \ 307 -e "s|/.*$||" \
248 -e "s|,| |g" -e "s|[()]||g" 308 -e "s|,| |g" -e "s|[(){}]||g"
249 else 309 else
250 echo $($(ghc-getghcpkgbin) -l -f "${i}") \ 310 echo $($(ghc-getghcpkgbin) -l -f "${i}") \
251 | cut -f2 -d':' \ 311 | cut -f2 -d':' \
252 | sed 's:,: :g' 312 | sed 's:,: :g'
253 fi 313 fi
254 done 314 done
315}
316
317# exported function: check if we have a consistent ghc installation
318ghc-package_pkg_setup() {
319 if ! ghc-saneghc; then
320 eerror "You have inconsistent versions of dev-lang/ghc and dev-lang/ghc-bin"
321 eerror "installed. Portage currently cannot work correctly with this setup."
322 eerror "There are several possibilities to work around this problem:"
323 eerror "(1) Up/downgrade ghc-bin to the same version as ghc."
324 eerror "(2) Unmerge ghc-bin."
325 eerror "(3) Unmerge ghc."
326 eerror "You probably want option 1 or 2."
327 die "Inconsistent versions of ghc and ghc-bin."
328 fi
255} 329}
256 330
257# exported function: registers the package-specific package 331# exported function: registers the package-specific package
258# configuration file 332# configuration file
259ghc-package_pkg_postinst() { 333ghc-package_pkg_postinst() {
266# package configuration file ... 340# package configuration file ...
267ghc-package_pkg_prerm() { 341ghc-package_pkg_prerm() {
268 ghc-unregister-pkg "$(ghc-localpkgconf)" 342 ghc-unregister-pkg "$(ghc-localpkgconf)"
269} 343}
270 344
271EXPORT_FUNCTIONS pkg_postinst pkg_prerm 345EXPORT_FUNCTIONS pkg_setup pkg_postinst pkg_prerm

Legend:
Removed from v.1.1.1.1  
changed lines
  Added in v.1.28

  ViewVC Help
Powered by ViewVC 1.1.20