/[gentoo-x86]/eclass/gst-plugins-ugly.eclass
Gentoo

Diff of /eclass/gst-plugins-ugly.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.19 Revision 1.20
1# Copyright 1999-2004 Gentoo Foundation 1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/gst-plugins-ugly.eclass,v 1.19 2010/07/28 06:24:44 leio Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/gst-plugins-ugly.eclass,v 1.20 2010/12/26 04:38:12 leio Exp $
4 4
5# Author : foser <foser@gentoo.org> 5# Author : foser <foser@gentoo.org>
6 6
7# gst-plugins-ugly eclass 7# gst-plugins-ugly eclass
8# 8#
43if [ "${PN}" != "${MY_PN}" ]; then 43if [ "${PN}" != "${MY_PN}" ]; then
44RDEPEND="=media-libs/gst-plugins-base-0.10*" 44RDEPEND="=media-libs/gst-plugins-base-0.10*"
45DEPEND="${RDEPEND} 45DEPEND="${RDEPEND}
46 >=sys-apps/sed-4 46 >=sys-apps/sed-4
47 dev-util/pkgconfig" 47 dev-util/pkgconfig"
48
49# -ugly-0.10.16 uses orc optionally instead of liboil unconditionally.
50# While <0.10.16 configure always checks for liboil, it is linked to only by a52dec,
51# so we only builddep for all packages, and have a RDEPEND in old gst-plugins-a52dec
52if ! version_is_at_least "0.10.16"; then
53DEPEND="${DEPEND} >=dev-libs/liboil-0.3.8"
54fi
55
48RESTRICT=test 56RESTRICT=test
49fi 57fi
50 58
51### 59###
52# public functions 60# public functions

Legend:
Removed from v.1.19  
changed lines
  Added in v.1.20

  ViewVC Help
Powered by ViewVC 1.1.20