/[gentoo-x86]/eclass/gtk-sharp-module.eclass
Gentoo

Diff of /eclass/gtk-sharp-module.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.9 Revision 1.31
1# Copyright 1999-2008 Gentoo Foundation 1# Copyright 1999-2008 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/gtk-sharp-module.eclass,v 1.9 2009/01/05 20:49:10 loki_val Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/gtk-sharp-module.eclass,v 1.31 2011/07/29 13:57:29 darkside Exp $
4 4
5# Author : Peter Johanson <latexer@gentoo.org>, butchered by ikelos, then loki_val. 5# @ECLASS: gtk-sharp-module.eclass
6# Based off of original work in gst-plugins.eclass by <foser@gentoo.org> 6# @MAINTAINER:
7# dotnet@gentoo.org
8# @BLURB: Manages the modules of the gtk-, gnome-, and gnome-desktop-sharp tarballs
9# @DESCRIPTION:
10# This eclass provides phase functions and helper functions for the modules
11# of the gtk-sharp, gnome-sharp and gnome-desktop-sharp tarballs.
12# PLEASE TAKE NOTE: ONLY FOR EAPI-2 EBUILDS
7 13
8# Note that this breaks compatibility with the original gtk-sharp-component 14WANT_AUTOMAKE=none
9# eclass. 15WANT_AUTOCONF=none
10 16
11inherit eutils mono multilib autotools base versionator 17inherit eutils mono multilib libtool autotools base versionator
12 18
13# Get the name of the component to build and the build dir; by default, 19case ${EAPI:-0} in
14# extract it from the ebuild's name. 20 2|3|4) ;;
21 *) die "Unknown EAPI." ;;
22esac
23
24# @ECLASS-VARIABLE: GTK_SHARP_MODULE
25# @DESCRIPTION:
26# The name of the Gtk# module.
27# Default value: ${PN/-sharp/}
15GTK_SHARP_MODULE=${GTK_SHARP_MODULE:=${PN/-sharp/}} 28GTK_SHARP_MODULE=${GTK_SHARP_MODULE:=${PN/-sharp/}}
29
30# @ECLASS-VARIABLE: GTK_SHARP_MODULE_DIR
31# @DESCRIPTION:
32# The subdirectory of S in which GTK_SHARP_MODULE is installed.
33# Default value: ${PN/-sharp/}
16GTK_SHARP_MODULE_DIR=${GTK_SHARP_MODULE_DIR:=${PN/-sharp/}} 34GTK_SHARP_MODULE_DIR=${GTK_SHARP_MODULE_DIR:=${PN/-sharp/}}
17 35
18# Allow ebuilds to set a value for the required GtkSharp version. 36# @ECLASS-VARIABLE: GTK_SHARP_REQUIRED_VERSION
37# @DESCRIPTION:
38# The version of the gtk-sharp tarball this package requires.
39# Optional.
19GTK_SHARP_REQUIRED_VERSION=${GTK_SHARP_REQUIRED_VERSION} 40GTK_SHARP_REQUIRED_VERSION="${GTK_SHARP_REQUIRED_VERSION}"
20 41
21# Version number used to differentiate between unversioned 1.0 series and the 42# @ECLASS-VARIABLE: gapi_users_list
22# versioned 2.0 series (2.0 series has 2 or 2.0 appended to various paths and 43# @DESCRIPTION:
23# scripts). Default to ${SLOT}. 44# List of modules that use one of gapi2-codegen, gapi2-fixup or gapi2-parser
24GTK_SHARP_SLOT="${GTK_SHARP_SLOT:=${SLOT}}" 45# No ebuild-serviceable parts inside.
25GTK_SHARP_SLOT_DEC="${GTK_SHARP_SLOT_DEC:=-${GTK_SHARP_SLOT}.0}" 46gapi_users_list="art gnome gnomevfs ${gnome_desktop_sharp_module_list} atk gtk gdk glade pango"
26 47
27#Handy little var 48# @ECLASS-VARIABLE: PV_MAJOR
49# @DESCRIPTION:
50# The first two components of the PV variable.
28PV_MAJOR=$(get_version_component_range 1-2) 51PV_MAJOR=$(get_version_component_range 1-2)
29 52
30# Set some defaults. 53# @FUNCTION: add_bdepend
31DESCRIPTION="GtkSharp's ${GTK_SHARP_MODULE} module" 54# @USAGE: <package atom>
32HOMEPAGE="http://www.mono-project.com/GtkSharp" 55# @DESCRIPTION:
33 56# Adds to the DEPEND variable
34LICENSE="LGPL-2.1"
35DEPEND="
36 >=dev-lang/mono-2.0.1
37 >=sys-apps/sed-4
38 >=dev-util/pkgconfig-0.23
39 "
40RDEPEND="
41 >=dev-lang/mono-2.0.1
42 "
43
44IUSE="debug"
45
46
47# The GtkSharp modules are currently divided into three seperate tarball
48# distributions. Figure out which of these our component belongs to.
49
50gtk_sharp_module_list="glib glade gtk gdk atk pango gtk-dotnet gtk-gapi"
51gnome_sharp_module_list="art gnome gnomevfs gconf"
52gnome_desktop_sharp_module_list="gnome-desktop gnome-print gnome-panel gtkhtml gtksourceview nautilusburn rsvg vte wnck"
53
54has "${GTK_SHARP_MODULE}" ${gtk_sharp_module_list} && GTK_SHARP_REQUIRED_VERSION=${PV}
55
56
57add_bdepend() { 57add_bdepend() {
58 [[ ${#@} -eq 1 ]] || die "${FUNCNAME} needs ONE (1) argument"
58 DEPEND="${DEPEND} $@" 59 DEPEND="${DEPEND} $@"
59} 60}
60 61
62# @FUNCTION: add_rdepend
63# @USAGE: <package atom>
64# @DESCRIPTION:
65# Adds to the RDEPEND variable
61add_rdepend() { 66add_rdepend() {
67 [[ ${#@} -eq 1 ]] || die "${FUNCNAME} needs ONE (1) argument"
62 RDEPEND="${RDEPEND} $@" 68 RDEPEND="${RDEPEND} $@"
63} 69}
64 70
71# @FUNCTION: add_depend
72# @USAGE: <package atom>
73# @DESCRIPTION:
74# Adds to the DEPEND and RDEPEND variables
65add_depend() { 75add_depend() {
76 [[ ${#@} -eq 1 ]] || die "${FUNCNAME} needs ONE (1) argument"
66 DEPEND="${DEPEND} $@" 77 DEPEND="${DEPEND} $@"
67 RDEPEND="${RDEPEND} $@" 78 RDEPEND="${RDEPEND} $@"
68} 79}
69 80
70gsm_get_tarball() { 81# @ECLASS-VARIABLE: TARBALL
71 has "${GTK_SHARP_MODULE}" ${gtk_sharp_module_list} \ 82# @DESCRIPTION:
72 && echo "gtk-sharp" && return 0 83# The GtkSharp modules are currently divided into three seperate tarball
73 has "${GTK_SHARP_MODULE}" ${gnome_sharp_module_list} \ 84# distributions. The TARBALL variable holds the name of the tarball
74 && echo "gnome-sharp" && return 0 85# to which GTK_SHARP_MODULE belongs.
75 has "${GTK_SHARP_MODULE}" ${gnome_desktop_sharp_module_list} \ 86case ${GTK_SHARP_MODULE} in
76 && echo "gnome-desktop-sharp" && return 0 87 glib|glade|gtk|gdk|atk|pango|gtk-dotnet|gtk-gapi|gtk-docs)
77 die "unknown GtkSharp module: ${GTK_SHARP_MODULE}" 88 TARBALL="gtk-sharp"
78} 89 case ${PVR} in
79 90 2.12.*)
80[[ "${PN}" != "gtk-sharp-gapi" ]] && add_bdepend "=dev-dotnet/gtk-sharp-gapi-${GTK_SHARP_REQUIRED_VERSION}*" 91 SRC_URI="mirror://gentoo/${TARBALL}-2.12.7.patch.bz2"
81has "${GTK_SHARP_MODULE}" ${gnome_sharp_module_list} ${gnome_desktop_sharp_module_list} gtk-dotnet glade \ 92 #Upstream: https://bugzilla.novell.com/show_bug.cgi?id=$bugno
93 #Upstream bug #470390 for the gtk-sharp-2.12.7.patch
94 PATCHES=(
95 "${WORKDIR}/${TARBALL}-2.12.7.patch"
96 )
97 EAUTORECONF="YES"
98 add_bdepend "=sys-devel/automake-1.10*"
99 add_bdepend ">=sys-devel/autoconf-2.61"
100 ;;
101 esac
102 ;;
103 art|gnome|gnomevfs|gconf)
104 TARBALL="gnome-sharp"
82 && add_depend "=dev-dotnet/gtk-sharp-${GTK_SHARP_REQUIRED_VERSION}*" 105 add_depend "=dev-dotnet/gtk-sharp-${GTK_SHARP_REQUIRED_VERSION}*"
83has "${GTK_SHARP_MODULE}" gtk gdk atk pango gtk-dotnet parser \ 106 has "${GTK_SHARP_MODULE}" "${gapi_users_list}" && \
107 add_bdepend "=dev-dotnet/gtk-sharp-gapi-${GTK_SHARP_REQUIRED_VERSION}*"
108 case ${PVR} in
109 2.24.1*)
110 SRC_URI="mirror://gentoo/${TARBALL}-2.24.1.patch.bz2"
111 # Upstream bug: https://bugzilla.novell.com/show_bug.cgi?id=483251
112 PATCHES=(
113 "${WORKDIR}/${TARBALL}-2.24.1.patch"
114 )
115 EAUTORECONF="YES"
116 add_bdepend "=sys-devel/automake-1.10*"
117 add_bdepend ">=sys-devel/autoconf-2.61"
118 ;;
119 2.24.2*)
120 add_depend ">=dev-lang/mono-2.7"
121 ;;
122 esac
123 ;;
124 gnome-desktop|gnome-print|gnome-panel|gtkhtml|gtksourceview|nautilusburn|rsvg|vte|wnck)
125 TARBALL="gnome-desktop-sharp"
84 && add_depend "=dev-dotnet/glib-sharp-${GTK_SHARP_REQUIRED_VERSION}*" 126 add_depend "=dev-dotnet/gtk-sharp-${GTK_SHARP_REQUIRED_VERSION}*"
85has "${GTK_SHARP_MODULE}" ${gnome_desktop_sharp_module_list} \
86 && add_depend ">=dev-dotnet/gnome-sharp-${PV_MAJOR}" 127 add_depend "=dev-dotnet/gnome-sharp-2.24*"
128 add_bdepend "=dev-dotnet/gtk-sharp-gapi-${GTK_SHARP_REQUIRED_VERSION}*"
129 ;;
130 *)
131 eerror "Huh? Sonny boy, looks like your GTK_SHARP_MODULE is not on the approved list. BAILING!"
132 die "How did we get here!!?"
133 ;;
134esac
87 135
88case ${PF} in 136case ${PF} in
89 #gtk-sharp tarball 137 #gtk-sharp tarball
138 gtk-sharp-docs*)
139 add_depend ">=virtual/monodoc-2.0"
140 ;;
90 gtk-sharp-gapi*) 141 gtk-sharp-gapi*)
142 add_rdepend "!<=dev-dotnet/gtk-sharp-2.12.7:2"
91 add_depend "dev-perl/XML-LibXML" 143 add_depend "dev-perl/XML-LibXML"
92 ;; 144 ;;
93 gtk-sharp-*) 145 gtk-sharp-*)
146 add_bdepend "~dev-dotnet/gtk-sharp-gapi-${PV}"
147 add_depend "~dev-dotnet/glib-sharp-${PV}"
94 add_depend "~dev-dotnet/atk-sharp-${PV}" 148 add_depend "~dev-dotnet/atk-sharp-${PV}"
95 add_depend "~dev-dotnet/gdk-sharp-${PV}" 149 add_depend "~dev-dotnet/gdk-sharp-${PV}"
96 add_depend "~dev-dotnet/pango-sharp-${PV}" 150 add_depend "~dev-dotnet/pango-sharp-${PV}"
97 ;; 151 ;;
98 gdk-sharp-*) 152 gdk-sharp-*)
99 add_rdepend "!<=dev-dotnet/gtk-sharp-2.12.7:2" 153 add_bdepend "~dev-dotnet/gtk-sharp-gapi-${PV}"
154 add_depend "~dev-dotnet/glib-sharp-${PV}"
100 add_depend "x11-libs/gtk+:2" 155 add_depend "x11-libs/gtk+:2"
101 add_depend "~dev-dotnet/pango-sharp-${PV}" 156 add_depend "~dev-dotnet/pango-sharp-${PV}"
157 add_rdepend "!<=dev-dotnet/gtk-sharp-2.12.7:2"
102 ;; 158 ;;
103 atk-sharp-*) 159 atk-sharp-*)
160 add_bdepend "~dev-dotnet/gtk-sharp-gapi-${PV}"
161 add_depend "~dev-dotnet/glib-sharp-${PV}"
162 add_depend "dev-libs/atk"
104 add_rdepend "!<=dev-dotnet/gtk-sharp-2.12.7:2" 163 add_rdepend "!<=dev-dotnet/gtk-sharp-2.12.7:2"
105 add_depend "dev-libs/atk"
106 ;; 164 ;;
107 glib-sharp-*) 165 glib-sharp-*)
108 add_rdepend "!<=dev-dotnet/gtk-sharp-2.12.7:2" 166 add_rdepend "!<=dev-dotnet/gtk-sharp-2.12.7:2"
109 add_depend "dev-libs/glib:2" 167 add_depend "dev-libs/glib:2"
110 ;; 168 ;;
111 pango-sharp-*) 169 pango-sharp-*)
170 add_bdepend "~dev-dotnet/gtk-sharp-gapi-${PV}"
171 add_depend "~dev-dotnet/glib-sharp-${PV}"
172 add_depend "x11-libs/pango"
112 add_rdepend "!<=dev-dotnet/gtk-sharp-2.12.7:2" 173 add_rdepend "!<=dev-dotnet/gtk-sharp-2.12.7:2"
113 add_depend "x11-libs/pango"
114 ;; 174 ;;
115 gtk-dotnet-*) 175 gtk-dotnet-*)
116 add_rdepend "!<=dev-dotnet/gtk-sharp-2.12.7:2" 176 add_depend "~dev-dotnet/glib-sharp-${PV}"
117 add_depend "~dev-dotnet/gdk-sharp-${PV}" 177 add_depend "~dev-dotnet/gdk-sharp-${PV}"
118 add_depend "~dev-dotnet/pango-sharp-${PV}" 178 add_depend "~dev-dotnet/pango-sharp-${PV}"
179 add_depend "~dev-dotnet/gtk-sharp-${PV}"
119 add_depend "!dev-lang/mono[minimal]" 180 add_depend "dev-lang/mono[-minimal]"
181 add_rdepend "!<=dev-dotnet/gtk-sharp-2.12.7:2"
120 ;; 182 ;;
121 glade-sharp-*) 183 glade-sharp-*)
184 add_bdepend "~dev-dotnet/gtk-sharp-gapi-${PV}"
185 add_depend "~dev-dotnet/glib-sharp-${PV}"
122 add_depend "~dev-dotnet/atk-sharp-${PV}" 186 add_depend "~dev-dotnet/atk-sharp-${PV}"
123 add_depend "~dev-dotnet/gdk-sharp-${PV}" 187 add_depend "~dev-dotnet/gdk-sharp-${PV}"
188 add_depend "~dev-dotnet/gtk-sharp-${PV}"
124 add_depend "~dev-dotnet/pango-sharp-${PV}" 189 add_depend "~dev-dotnet/pango-sharp-${PV}"
125 add_depend ">=gnome-base/libglade-2.3.6" 190 add_depend ">=gnome-base/libglade-2.3.6:2.0"
126 ;; 191 ;;
127 #gnome-sharp tarball 192 #gnome-sharp tarball
128 art-sharp-*) 193 art-sharp-*)
129 add_depend ">=media-libs/libart_lgpl-2.3.20" 194 add_depend ">=media-libs/libart_lgpl-2.3.20"
130 ;; 195 ;;
131 gnome-sharp-*) 196 gnome-sharp-*)
132 add_depend ">=gnome-base/libgnomeui-${PV_MAJOR}" 197 add_depend ">=gnome-base/libgnomeui-${PV_MAJOR}"
133 add_depend ">=gnome-base/gnome-panel-${PV_MAJOR}"
134 add_depend "~dev-dotnet/gnomevfs-sharp-${PV}" 198 add_depend "~dev-dotnet/gnomevfs-sharp-${PV}"
135 add_depend "~dev-dotnet/art-sharp-${PV}" 199 add_depend "~dev-dotnet/art-sharp-${PV}"
136 add_depend ">=gnome-base/libgnomecanvas-${GNOMECANVAS_REQUIRED_VERSION}" 200 add_depend ">=gnome-base/libgnomecanvas-${GNOMECANVAS_REQUIRED_VERSION}"
201 add_depend ">=x11-libs/gtk+-2.14.0:2"
137 ;; 202 ;;
138 gconf-sharp-*) 203 gconf-sharp-*)
139 add_depend ">=gnome-base/gconf-${PV_MAJOR}" 204 add_depend ">=gnome-base/gconf-${PV_MAJOR}:2"
140 add_depend ">=dev-dotnet/glade-sharp-${GTK_SHARP_REQUIRED_VERSION}" 205 add_depend "=dev-dotnet/glade-sharp-${GTK_SHARP_REQUIRED_VERSION}*"
141 add_depend "~dev-dotnet/gnome-sharp-${PV}" 206 add_depend "~dev-dotnet/gnome-sharp-${PV}"
142 add_depend "~dev-dotnet/art-sharp-${PV}" 207 add_depend "~dev-dotnet/art-sharp-${PV}"
143 ;; 208 ;;
144 gnomevfs-sharp-*) 209 gnomevfs-sharp-*)
145 add_depend ">=gnome-base/gnome-vfs-${PV_MAJOR}" 210 add_depend ">=gnome-base/gnome-vfs-${PV_MAJOR}:2"
146 ;; 211 ;;
147 #gnome-desktop-sharp tarball 212 #gnome-desktop-sharp tarball
148 gnome-desktop-sharp-*) 213 gnome-desktop-sharp-*)
214 # NOTE: libgnome-desktop-2.so has been known to make binary-
215 # incompatible changes, requiring .so bumps. gnome-desktop-sharp
216 # is locked to a specific .so.n version, so strict dependencies
217 # may be required in the future (as it has in the past).
149 add_depend "=gnome-base/gnome-desktop-${PV_MAJOR}*" 218 add_depend ">=gnome-base/gnome-desktop-${PV_MAJOR}:2"
150 ;; 219 ;;
151 gnome-panel-sharp-*) 220 gnome-panel-sharp-*)
152 add_depend "=gnome-base/gnome-panel-${PV_MAJOR}*" 221 add_depend ">=gnome-base/gnome-panel-${PV_MAJOR}"
153 ;; 222 ;;
154 gnome-print-sharp-*) 223 gnome-print-sharp-*)
155 add_depend ">=gnome-base/libgnomeprint-${API_VERSION}" 224 add_depend "gnome-base/libgnomeprint:2.2"
225 add_depend "gnome-base/libgnomeprintui:2.2"
156 ;; 226 ;;
157 gtkhtml-sharp-*) 227 gtkhtml-sharp-*)
158 #NOTE: gtkhtml dependency must follow gtkhtml-sharp version. 228 #NOTE: gtkhtml dependency must follow gtkhtml-sharp version.
159 #i.e. gtkhtml-sharp-2.24.0 >=gtkhtml-3.24 229 #i.e. gtkhtml-sharp-2.24.0 >=gtkhtml-3.24
160 # gtkhtml-sharp-2.16.0 >=gtkhtml-3.16 230 # gtkhtml-sharp-2.16.0 >=gtkhtml-3.16
161 # See bug 249540 for unpleasant side effects. 231 # See bug 249540 for unpleasant side effects.
162 add_depend ">=gnome-extra/gtkhtml-$(($(get_version_component_range 1) + 1 )).$(get_version_component_range 2)" 232 add_depend ">=gnome-extra/gtkhtml-$(($(get_version_component_range 1) + 1 )).$(get_version_component_range 2):3.14"
163 ;; 233 ;;
164 gtksourceview-sharp-*) 234 gtksourceview-sharp-*)
165 add_depend ">=x11-libs/gtksourceview-${GTKSOURCEVIEW_REQUIRED_VERSION}:2.0" 235 add_depend ">=x11-libs/gtksourceview-${GTKSOURCEVIEW_REQUIRED_VERSION}:2.0"
166 ;; 236 ;;
167 nautilusburn-sharp-*) 237 nautilusburn-sharp-*)
168 add_depend ">=gnome-extra/nautilus-cd-burner-${PV_MAJOR}" 238 add_depend ">=gnome-extra/nautilus-cd-burner-2.24.0"
169 ;; 239 ;;
170 rsvg-sharp-*) 240 rsvg-sharp-*)
171 add_depend ">=gnome-base/librsvg-${RSVG_REQUIRED_VERSION}" 241 add_depend ">=gnome-base/librsvg-${RSVG_REQUIRED_VERSION}:2"
172 ;; 242 ;;
173 vte-sharp-*) 243 vte-sharp-*)
174 add_depend ">=x11-libs/vte-${VTE_REQUIRED_VERSION}" 244 add_depend ">=x11-libs/vte-${VTE_REQUIRED_VERSION}:0"
175 ;; 245 ;;
176 wnck-sharp-*) 246 wnck-sharp-*)
177 add_depend ">=x11-libs/libwnck-${PV_MAJOR}" 247 add_depend ">=x11-libs/libwnck-${PV_MAJOR}:1"
178 ;; 248 ;;
179esac 249esac
180 250
251# @ECLASS-VARIABLE: DESCRIPTION
252# @DESCRIPTION:
253# Default value: GtkSharp's ${GTK_SHARP_MODULE} module of the ${TARBALL} tarball
254DESCRIPTION="GtkSharp's ${GTK_SHARP_MODULE} module of the ${TARBALL} tarball"
255# @ECLASS-VARIABLE: HOMEPAGE
256# @DESCRIPTION:
257# Default value: http://www.mono-project.com/GtkSharp
258HOMEPAGE="http://www.mono-project.com/GtkSharp"
259# @ECLASS-VARIABLE: DESCRIPTION
260# @DESCRIPTION:
261# Default value: LGPL-2.1
262LICENSE="LGPL-2.1"
181 263
264add_depend ">=dev-lang/mono-2.0.1"
265add_bdepend ">=sys-apps/sed-4"
266add_bdepend ">=dev-util/pkgconfig-0.23"
267add_bdepend ">=app-shells/bash-3.1"
182 268
183GSM_P=$(gsm_get_tarball)-${PV} 269IUSE="debug"
184S=${WORKDIR}/${GSM_P} 270# @ECLASS-VARIABLE: S
185SRC_URI="mirror://gnome/sources/$(gsm_get_tarball)/${PV%.*}/${GSM_P}.tar.bz2" 271# @DESCRIPTION:
186 272# Default value: ${WORKDIR}/${TARBALL}-${PV}
187if [[ "${GSM_P%.*}" = "gtk-sharp-2.12" ]] 273S="${WORKDIR}/${TARBALL}-${PV}"
188then 274# @ECLASS-VARIABLE: SRC_URI
275# @DESCRIPTION:
276# Default value: mirror://gnome/sources/${TARBALL}/${PV_MAJOR}/${TARBALL}-${PV}.tar.bz2
189 SRC_URI="${SRC_URI} 277SRC_URI="${SRC_URI}
190 mirror://gentoo/gtk-sharp-2.12.0-patches.tar.bz2" 278 mirror://gnome/sources/${TARBALL}/${PV_MAJOR}/${TARBALL}-${PV}.tar.bz2"
191 #Upstream: https://bugzilla.novell.com/show_bug.cgi?id=$bugno 279
192 #Upstream bug #421063 280# @FUNCTION: get_sharp_apis
193 PATCHES=( "${WORKDIR}/patches/$(gsm_get_tarball)-2.12.0-parallelmake.patch" 281# @USAGE: <type> <pkgconfig-package>
194 "${WORKDIR}/patches/$(gsm_get_tarball)-2.12.0-doc-parallelmake.patch" ) 282# @RETURN: .NET API files
195 EAUTORECONF="YES" 283# @DESCRIPTION:
284# Given a valid pkg-config package, will return a list of API xml files.
285# <type> can be either --prefixed or --bare. If prefixed, each API file
286# will be prefixed with -I:
287get_sharp_apis() {
288 [[ ${#@} -eq 2 ]] || die "${FUNCNAME} needs two arguments"
289 get_sharp_assemblies "$@"
290}
291
292# @FUNCTION: get_sharp_assemblies
293# @USAGE: <type> <pkgconfig-package>
294# @RETURN: .NET .dll assemblies
295# @DESCRIPTION:
296# Given a valid pkg-config package, will return a list of .dll assemblies.
297# <type> can be either --prefixed or --bare. If prefixed, each .dll file
298# will be prefixed with -r:
299get_sharp_assemblies() {
300 [[ ${#@} -eq 2 ]] || die "${FUNCNAME} needs two arguments"
301 local string config=libs prefix="-r:"
302 local -a rvalue
303 [[ "${FUNCNAME[1]}" = "get_sharp_apis" ]] && config=cflags && prefix="-I:"
304 for string in $(pkg-config --${config} ${2} 2> /dev/null)
305 do
306 rvalue+=( ${string#-?:} )
307 done
308
309 case $1 in
310 --bare)
311 :
312 ;;
313 --prefixed)
314 for (( i=0 ; i< ${#rvalue[@]} ; i++ ))
315 do
316 rvalue[$i]=${prefix}${rvalue[$i]}
317 done
318 ;;
319 *)
320 die "${FUNCNAME}: Unknown parameter"
321 ;;
322 esac
323 echo "${rvalue[@]}"
324}
325
326# @FUNCTION: phase_hook
327# @USAGE: <prefix>
328# Looks for functions named <prefix>_caller_suffix and executes them.
329# _caller_suffix is the calling function with the prefix
330# gtk-sharp-module removed.
331phase_hook() {
332 [[ ${#@} -eq 1 ]] || die "${FUNCNAME} needs one argument"
333 if [[ "$(type -t ${1}${FUNCNAME[1]#gtk-sharp-module})" = "function" ]]
334 then
335 ebegin "Phase-hook: Running ${1}${FUNCNAME[1]#gtk-sharp-module}"
336 ${1}${FUNCNAME[1]#gtk-sharp-module}
337 eend 0
196fi 338 fi
339}
197 340
341# @FUNCTION: ac_path_prog_override
342# @USAGE: <PROG> [path]
343# @DESCRIPTION:
344# Override AC_PATH_PROG() autoconf macros. Path will be set to " " if
345# not specified.
346ac_path_prog_override() {
347 if [[ ${#@} -lt 1 || ${#@} -gt 2 ]]
348 then
349 eerror "${FUNCNAME[0]} requires at least one parameter and takes at most two:"
350 eerror "AC_PATH_PROG(PARAM1, param2)"
351 die "${FUNCNAME[0]} requires at least one parameter and takes at most two:"
352 fi
353 export ac_cv_path_${1}="${2:- }"
354}
198 355
199### Public functions.
200 356
201gtk-sharp-module_fix_files() { 357# @FUNCTION: pkg_check_modules_override
202 # Change references like "/r:../art/art-sharp.dll" -> 358# @USAGE: <GROUP> [package1] [package2]
203 # "/r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/art-sharp.dll" and references like 359# @DESCRIPTION:
204 # "../glib/glib-sharp.xml" or "$(top_srcdir)/glib/glib-sharp.xml" -> 360# Will export the appropriate variables to override PKG_CHECK_MODULES autoconf
205 # "${gapi_dir}/glib-sharp.xml". 361# macros, with the string " " by default. If packages are specified, they will
206 # 362# be looked up with pkg-config and the appropriate LIBS and CFLAGS substituted.
207 # We also make sure to call the installed gapi-fixup and gapi-codegen and 363# LIBS and CFLAGS can also be specified per-package with the following syntax:
208 # not the ones that would be built locally. 364# @CODE
209 local gapi_dir="${ROOT}/usr/share/gapi${GTK_SHARP_SLOT_DEC}" 365# package=LIBS%CFLAGS
210 local GAPI_FIXUP="gapi2-fixup" 366# @CODE
211 local GAPI_CODEGEN="gapi2-codegen" 367# = and % have no effect unless both are specified.
368# Here is an example:
369# @CODE
370# pkg_check_modules_override GASH "gtk+-2.0=-jule%" gobject-2.0
371# @CODE
372# The above example will do:
373# export GASH_CFLAGS+=" -jule"
374# export GASH_LIBS+=" "
375# export GASH_CFLAGS+=" $(pkg-config --cflags gobject-2.0)"
376# export GASH_LIBS+=" $(pkg-config --libs gobject-2.0)"
377#
378# NOTE: If a package is not found, the string " " will be inserted in place of
379# <GROUP>_CFLAGS and <GROUP>_LIBS
380pkg_check_modules_override() {
381 local package
382 local group="${1}"
383 local packages="${*:2}"
384 export ${group}_CFLAGS=" "
385 export ${group}_LIBS=" "
212 386
213 local makefiles=( $(find "${S}" -name Makefile.in) ) 387 if [[ ${#@} -lt 1 ]]
388 then
389 eerror "${FUNCNAME[0]} requires at least one parameter: GROUP"
390 eerror "PKG_CHECK_MODULES(GROUP, package1 package2 etc)"
391 die "${FUNCNAME[0]} requires at least one parameter: GROUP"
392 fi
393
394 for package in $packages
395 do
396 if [[ ${package/=} != ${package} && ${package/\%} != ${package} ]]
397 then
398 package_cflag_libs=${package##*=}
399 export ${group}_CFLAGS+=" ${package_cflag_libs%%\%*}"
400 export ${group}_LIBS+=" ${package_cflag_libs##*\%}"
401 else
402 if pkg-config --exists $package
403 then
404 export ${group}_CFLAGS+=" $(pkg-config --cflags $package)"
405 export ${group}_LIBS+=" $(pkg-config --libs $package)"
406 else
407 export ${group}_CFLAGS+=" "
408 export ${group}_LIBS+=" "
409 fi
410 fi
411 done
412}
413
414# @FUNCTION: gtk-sharp-tarball-post_src_prepare
415# @DESCRIPTION:
416# Runs a M-m-m-monster sed on GTK_SHARP_MODULE_DIR to convert references to
417# local assemblies to the installed ones. Is only called by src_prepare when
418# $GTK_SHARP_MODULE is a member of $gtk_sharp_module_list.
419gtk-sharp-tarball-post_src_prepare() {
420 has "${EAPI:-0}" 2 && ! use prefix && EPREFIX=
421 cd "${S}/${GTK_SHARP_MODULE_DIR}"
214 sed -i \ 422 sed -i \
215 -e "s;\(\.\.\|\$(top_srcdir)\|\$(srcdir)/\.\.\)/[[:alpha:]]*/\([[:alpha:]]*\(-[[:alpha:]]*\)*\).xml;${gapi_dir}/\2.xml;g" \ 423 -e "s; \$(srcdir)/../glib/glib-api.xml; $(get_sharp_apis --bare glib-sharp-2.0);" \
424 -e "s; ../pango/pango-api.xml; $(get_sharp_apis --bare pango-sharp-2.0);" \
425 -e "s; ../atk/atk-api.xml; $(get_sharp_apis --bare atk-sharp-2.0);" \
426 -e "s; ../gdk/gdk-api.xml; $(get_sharp_apis --bare gdk-sharp-2.0);" \
427 -e "s; ../gtk/gtk-api.xml; $(get_sharp_apis --bare gtk-sharp-2.0);" \
216 -e "s; \.\./glib/glib-sharp.dll; $(get_sharp_lib glib-sharp-2.0);g" \ 428 -e "s; \.\./glib/glib-sharp.dll; $(get_sharp_assemblies --bare glib-sharp-2.0);g" \
217 -e "s; \.\./pango/pango-sharp.dll; $(get_sharp_lib pango-sharp-2.0);g" \ 429 -e "s; \.\./pango/pango-sharp.dll; $(get_sharp_assemblies --bare pango-sharp-2.0);g" \
218 -e "s; \.\./art/art-sharp.dll; $(get_sharp_lib art-sharp-2.0);g" \
219 -e "s; \.\./atk/atk-sharp.dll; $(get_sharp_lib atk-sharp-2.0);g" \ 430 -e "s; \.\./atk/atk-sharp.dll; $(get_sharp_assemblies --bare atk-sharp-2.0);g" \
220 -e "s; \.\./gdk/gdk-sharp.dll; $(get_sharp_lib gdk-sharp-2.0);g" \ 431 -e "s; \.\./gdk/gdk-sharp.dll; $(get_sharp_assemblies --bare gdk-sharp-2.0);g" \
221 -e "s; \.\./gtk/gtk-sharp.dll; $(get_sharp_lib gtk-sharp-2.0);g" \ 432 -e "s; \.\./gtk/gtk-sharp.dll; $(get_sharp_assemblies --bare gtk-sharp-2.0);g" \
222 -e "s;\.\./gnomevfs/gnome-vfs-sharp.dll;$(get_sharp_lib gnome-vfs-sharp-2.0);g" \
223 -e "s;\$(top_builddir)/art/art-sharp.dll;$(get_sharp_lib art-sharp-2.0);" \
224 -e "s;\$(top_builddir)/gnome/gnome-sharp.dll;$(get_sharp_lib gnome-sharp-2.0);" \
225 -e "s;\$(RUNTIME) \$(top_builddir)/parser/gapi-fixup.exe;${GAPI_FIXUP};" \ 433 -e "s;\$(RUNTIME) \$(top_builddir)/parser/gapi-fixup.exe;${EPREFIX}/usr/bin/gapi2-fixup;" \
226 -e "s;\$(RUNTIME) \$(top_builddir)/generator/gapi_codegen.exe;${GAPI_CODEGEN};" \ 434 -e "s;\$(RUNTIME) \$(top_builddir)/generator/gapi_codegen.exe;${EPREFIX}/usr/bin/gapi2-codegen;" \
227 -e "s:\$(SYMBOLS) \$(top_builddir)/parser/gapi-fixup.exe:\$(SYMBOLS):" \ 435 -e "s:\$(SYMBOLS) \$(top_builddir)/parser/gapi-fixup.exe:\$(SYMBOLS):" \
228 -e "s:\$(INCLUDE_API) \$(top_builddir)/generator/gapi_codegen.exe:\$(INCLUDE_API):" \ 436 -e "s:\$(INCLUDE_API) \$(top_builddir)/generator/gapi_codegen.exe:\$(INCLUDE_API):" \
229 "${makefiles[@]}" || die "failed to fix GtkSharp makefiles" 437 $(find . -name Makefile.in) || die "failed to fix ${TARBALL}-tarball makefiles"
230} 438}
231 439
232get_sharp_lib() { 440# @FUNCTION: gnome-sharp-tarball-post_src_prepare
233 S="$(pkg-config --libs ${1})" 441# @DESCRIPTION:
234 S=${S%% *} 442# Runs a M-m-m-monster sed on GTK_SHARP_MODULE_DIR to convert references to
235 printf ${S#-r:} 443# local assemblies to the installed ones. Is only called by src_prepare when
236} 444# $GTK_SHARP_MODULE is a member of $gnome_sharp_module_list.
237
238gtk-sharp_tarball_src_prepare() {
239 local package
240 sed -i -e '/SUBDIRS/s/ glib / /' \
241 -e '/SUBDIRS/s/ glade / /' \
242 -e '/SUBDIRS/s/ sample / /' \
243 -e '/SUBDIRS/s/ doc/ /' \
244 Makefile.am || die "failed sedding sense into gtk-sharp's Makefile.am"
245 for package in GLIB PANGO ATK GTK
246 do
247 sed -r -i -e "s:(PKG_CHECK_MODULES\(${package}.*)\):\1,[foo=bar],[bar=foo]):" \
248 configure.in || die "failed sedding sense into gnome-sharp's configure.in"
249 done
250 EAUTORECONF=YES
251}
252
253gnome-sharp_tarball_src_prepare() { 445gnome-sharp-tarball-post_src_prepare() {
254 if ! [[ "${PN}" = "gconf-sharp" ]] 446 cd "${S}/${GTK_SHARP_MODULE_DIR}"
255 then 447 sed -i \
256 sed -r -i -e "s:(PKG_CHECK_MODULES\(GLADESHARP.*)\):\1,[foo=bar],[bar=foo]):" \ 448 -e "s; ../gnomevfs/gnome-vfs-api.xml; $(get_sharp_apis --bare gnome-vfs-sharp-2.0);" \
257 configure.in || die "failed sedding sense into gnome-sharp's configure.in" 449 -e "s; ../art/art-api.xml; $(get_sharp_apis --bare art-sharp-2.0);" \
258 EAUTORECONF=YES 450 -e "s; \.\./art/art-sharp.dll; $(get_sharp_assemblies --bare art-sharp-2.0);g" \
259 fi 451 -e "s; \.\./gnomevfs/gnome-vfs-sharp.dll; $(get_sharp_assemblies --bare gnome-vfs-sharp-2.0);g" \
452 -e "s;/r:\$(top_builddir)/art/art-sharp.dll;$(get_sharp_assemblies --prefixed art-sharp-2.0);" \
453 -e "s;/r:\$(top_builddir)/gnome/gnome-sharp.dll;$(get_sharp_assemblies --prefixed gnome-sharp-2.0);" \
454 $(find . -name Makefile.in) || die "failed to fix ${TARBALL}-tarball makefiles"
260} 455}
261 456
457# @FUNCTION: gtk-sharp-module_src_prepare
458# @DESCRIPTION:
459# Runs autopatch from base.eclass, eautoreconf if EAUTORECONF is set to any
460# value.
461# Contains a phase_hook, runs very last.
462# phase_hook prefix trigger: ${TARBALL}-tarball-post
463# Is exported.
262gtk-sharp-module_src_prepare() { 464gtk-sharp-module_src_prepare() {
263 if [[ "$(type -t $(gsm_get_tarball)_tarball_src_prepare)" = "function" ]] 465 base_src_prepare
264 then 466# @ECLASS-VARIABLE: EAUTORECONF
265 ebegin "Running $(gsm_get_tarball)_tarball_src_prepare" 467# @DESCRIPTION:
266 $(gsm_get_tarball)_tarball_src_prepare 468# If set, EAUTORECONF will be run during src_prepare.
267 eend $?
268 fi
269 base_src_util autopatch
270
271 [[ ${EAUTORECONF} ]] && eautoreconf 469 [[ ${EAUTORECONF} ]] && eautoreconf
272 470 phase_hook ${TARBALL}-tarball-post
273 cd "${S}/${GTK_SHARP_MODULE_DIR}" 471 elibtoolize
274
275 gtk-sharp-module_fix_files &> /dev/null
276} 472}
277 473
474# @FUNCTION: gtk-sharp-tarball_src_configure
475# @DESCRIPTION:
476# Sets some environment variables that will allow us to make the dependencies
477# for each ebuild be only its own dependencies, without patching configure.
478# Is only called by gtk-sharp-module_src_configure when $GTK_SHARP_MODULE
479# is a member of $gtk_sharp_module_list.
480gtk-sharp-tarball_src_configure() {
481 pkg_check_modules_override GLIB gobject-2.0
482 pkg_check_modules_override GIO gio-2.0
483 pkg_check_modules_override PANGO pango
484 pkg_check_modules_override ATK atk
485 pkg_check_modules_override GTK gtk+-2.0
486 pkg_check_modules_override GLADE libglade-2.0
487}
488
489# @FUNCTION: gnome-sharp-tarball_src_configure
490# @DESCRIPTION:
491# Sets some environment variables that will allow us to make the dependencies
492# for each ebuild be only its own dependencies. Without patching configure.
493# Is only called by gtk-sharp-module_src_configure when $GTK_SHARP_MODULE
494# is a member of $gnome_sharp_module_list.
495gnome-sharp-tarball_src_configure() {
496 has "${EAPI:-0}" 2 && ! use prefix && EPREFIX=
497 pkg_check_modules_override GLADESHARP glade-sharp-2.0
498 pkg_check_modules_override GAPI gapi-2.0
499 ac_path_prog_override GAPI_PARSER "${EPREFIX}"/usr/bin/gapi2-parser
500 ac_path_prog_override GAPI_CODEGEN "${EPREFIX}"/usr/bin/gapi2-codegen
501 ac_path_prog_override GAPI_FIXUP "${EPREFIX}"/usr/bin/gapi2-fixup
502}
503
504# @FUNCTION: gtk-sharp-module_src_configure
505# @USAGE: [econf-arguments]
506# @DESCRIPTION:
507# Calls econf with some default values.
508# Contains a phase_hook, run before econf.
509# phase_hook prefix trigger: ${TARBALL}-tarball
510# Is exported.
278gtk-sharp-module_src_configure() { 511gtk-sharp-module_src_configure() {
512 phase_hook ${TARBALL}-tarball
279 econf --disable-static \ 513 econf --disable-static \
280 --disable-dependency-tracking \ 514 --disable-dependency-tracking \
281 --disable-maintainer-mode \ 515 --disable-maintainer-mode \
282 $(use debug &&echo "--enable-debug" ) \ 516 $(use debug &&echo "--enable-debug" ) \
283 ${gtk_sharp_conf} \
284 ${@} || die "econf failed" 517 ${@} || die "econf failed"
285} 518}
286 519
520# @FUNCTION: gtk-sharp-module_src_compile
521# @DESCRIPTION:
522# Calls emake in the subdir of the module.
523# Sets CSC=/usr/bin/gmcs. Deletes top_srcdir Makefiles to prevent recursing in
524# case we missed some dll references.
525# Is exported.
287gtk-sharp-module_src_compile() { 526gtk-sharp-module_src_compile() {
527 rm -f "${S}"/Makefile* &> /dev/null
288 cd "${S}/${GTK_SHARP_MODULE_DIR}" 528 cd "${S}/${GTK_SHARP_MODULE_DIR}"
289 emake || die "emake failed" 529 emake CSC=/usr/bin/gmcs || die "emake failed"
290} 530}
291 531
532# @FUNCTION: gtk-sharp-module_src_install
533# @DESCRIPTION:
534# Installs the module. Fixes up lib paths so they're multilib-safe.
535# Gets rid of .la files.
536# Is exported.
292gtk-sharp-module_src_install() { 537gtk-sharp-module_src_install() {
293
294 cd "${GTK_SHARP_MODULE_DIR}" 538 cd "${S}/${GTK_SHARP_MODULE_DIR}"
295 emake DESTDIR=${D} install || die "emake install failed" 539 emake DESTDIR="${D}" install || die "emake install failed"
296 mono_multilib_comply 540 mono_multilib_comply
297 find "${D}" -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed" 541 find "${D}" -type f -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
298 if has "${GTK_SHARP_MODULE}" gtk gdk atk pango 542 [[ $(find "${D}" -type f|wc -l) -lt 3 ]] && die "Too few files. This smells like a failed install."
299 then
300 find "${D}" -name '*.pc' -exec rm -rf '{}' '+' || die "la removal failed"
301 pkgconfig_filename="${PN}${GTK_SHARP_SLOT_DEC}"
302 pkgconfig_pkgname="${GTK_SHARP_MODULE}#"
303 pkgconfig_description=".NET/Mono bindings for ${GTK_SHARP_MODULE}"
304 pkgconfig_monodir="$(gsm_get_tarball)${GTK_SHARP_SLOT_DEC}"
305 case ${GTK_SHARP_MODULE} in
306 gtk)
307 pkgconfig_requires="glib-sharp${GTK_SHARP_SLOT_DEC} atk-sharp${GTK_SHARP_SLOT_DEC} gdk-sharp${GTK_SHARP_SLOT_DEC} pango-sharp${GTK_SHARP_SLOT_DEC}"
308 ;;
309 gdk)
310 pkgconfig_requires="glib-sharp${GTK_SHARP_SLOT_DEC} pango-sharp${GTK_SHARP_SLOT_DEC}"
311 ;;
312 atk)
313 pkgconfig_requires="glib-sharp${GTK_SHARP_SLOT_DEC}"
314 ;;
315 pango)
316 pkgconfig_requires="glib-sharp${GTK_SHARP_SLOT_DEC}"
317 ;;
318 *)
319 die "unhandled gtk_sharp_module"
320 ;;
321 esac
322 generate_pkgconfig
323 fi
324} 543}
325 544
326EXPORT_FUNCTIONS src_prepare src_configure src_compile src_install 545EXPORT_FUNCTIONS src_prepare src_configure src_compile src_install
327
328generate_pkgconfig() {
329 ebegin "Generating .pc file for ${P}"
330 local dll \
331 gfile \
332 pkgconfig_gapidir \
333 apifile \
334 LSTRING='Libs:' \
335 CSTRING='Cflags:' \
336 pkgconfig_filename="${1:-${pkgconfig_filename:-${PN}}}" \
337 pkgconfig_monodir="${2:-${pkgconfig_monodir:-${pkgconfig_filename}}}" \
338 pkgconfig_pkgname="${3:-${pkgconfig_pkgname:-${pkgconfig_filename}}}" \
339 pkgconfig_version="${4:-${pkgconfig_version:-${PV}}}" \
340 pkgconfig_description="${5:-${pkgconfig_description:-${DESCRIPTION}}}" \
341 pkgconfig_requires="${6:-${pkgconfig_requires}}" \
342
343 pushd "${D}/usr/" &> /dev/null
344 apifile=$(find share -name '*-api.xml' 2>/dev/null)
345 popd &> /dev/null
346
347 pkgconfig_gapidir=${apifile:+\$\{prefix\}/${apifile%/*}}
348
349 dodir "/usr/$(get_libdir)/pkgconfig"
350 cat <<- EOF -> "${D}/usr/$(get_libdir)/pkgconfig/${pkgconfig_filename}.pc"
351 prefix=\${pcfiledir}/../..
352 exec_prefix=\${prefix}
353 libdir=\${prefix}/$(get_libdir)
354 gapidir=${pkgconfig_gapidir}
355 Name: ${pkgconfig_pkgname}
356 Description: ${pkgconfig_description}
357 Version: ${pkgconfig_version}
358 EOF
359
360 for gfile in "${D}"/usr/${apifile%/*}/*-api.xml
361 do
362 CSTRING="${CSTRING} -I:"'${gapidir}'"/${gfile##*/}"
363 done
364 echo "${CSTRING}" >> "${D}/usr/$(get_libdir)/pkgconfig/${pkgconfig_filename}.pc"
365
366
367 for dll in "${D}"/usr/$(get_libdir)/mono/${pkgconfig_monodir}/*.dll
368 do
369 if ! [[ "${dll##*/}" == "policy."*".dll" ]]
370 then
371 LSTRING="${LSTRING} -r:"'${libdir}'"/mono/${pkgconfig_monodir}/${dll##*/}"
372 fi
373 done
374 echo "${LSTRING}" >> "${D}/usr/$(get_libdir)/pkgconfig/${pkgconfig_filename}.pc"
375
376 if [[ "${pkgconfig_requires}" ]]
377 then
378 printf "Requires: ${pkgconfig_requires}" >> "${D}/usr/$(get_libdir)/pkgconfig/${pkgconfig_filename}.pc"
379 fi
380 PKG_CONFIG_PATH="${D}/usr/$(get_libdir)/pkgconfig/" pkg-config --silence-errors --libs ${pkgconfig_filename} &> /dev/null
381 eend $?
382}
383

Legend:
Removed from v.1.9  
changed lines
  Added in v.1.31

  ViewVC Help
Powered by ViewVC 1.1.20