/[gentoo-x86]/eclass/haskell-cabal.eclass
Gentoo

Diff of /eclass/haskell-cabal.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.15 Revision 1.23
1# Copyright 1999-2006 Gentoo Foundation 1# Copyright 1999-2011 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/haskell-cabal.eclass,v 1.15 2009/07/27 19:03:20 kolmodin Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/haskell-cabal.eclass,v 1.23 2011/03/13 20:15:14 slyfox Exp $
4# 4#
5# Original authors: Andres Loeh <kosmikus@gentoo.org> 5# Original authors: Andres Loeh <kosmikus@gentoo.org>
6# Duncan Coutts <dcoutts@gentoo.org> 6# Duncan Coutts <dcoutts@gentoo.org>
7# Maintained by: Haskell herd <haskell@gentoo.org> 7# Maintained by: Haskell herd <haskell@gentoo.org>
8# 8#
16# reflect the tools and features that the package makes 16# reflect the tools and features that the package makes
17# use of. 17# use of.
18# 18#
19# Currently supported features: 19# Currently supported features:
20# haddock -- for documentation generation 20# haddock -- for documentation generation
21# hscolour -- generation of colourised sources
21# alex -- lexer/scanner generator 22# alex -- lexer/scanner generator
22# happy -- parser generator 23# happy -- parser generator
23# c2hs -- C interface generator 24# c2hs -- C interface generator
24# cpphs -- C preprocessor clone written in Haskell 25# cpphs -- C preprocessor clone written in Haskell
25# profile -- if package supports to build profiling-enabled libraries 26# profile -- if package supports to build profiling-enabled libraries
26# bootstrap -- only used for the cabal package itself 27# bootstrap -- only used for the cabal package itself
27# bin -- the package installs binaries 28# bin -- the package installs binaries
28# lib -- the package installs libraries 29# lib -- the package installs libraries
30# nocabaldep -- don't add dependency on cabal.
31# only used for packages that _must_ not pull the dependency
32# on cabal, but still use this eclass (e.g. haskell-updater).
29# 33#
30# Dependencies on other cabal packages have to be specified 34# Dependencies on other cabal packages have to be specified
31# correctly. 35# correctly.
32# 36#
33# Cabal libraries should usually be SLOTted with "${PV}". 37# Cabal libraries should usually be SLOTted with "${PV}".
40# Special flags to Cabal Configure can now be set by using 44# Special flags to Cabal Configure can now be set by using
41# CABAL_CONFIGURE_FLAGS 45# CABAL_CONFIGURE_FLAGS
42 46
43inherit ghc-package multilib 47inherit ghc-package multilib
44 48
49HASKELL_CABAL_EXPF="pkg_setup src_compile src_test src_install"
50
51case "${EAPI:-0}" in
52 2|3|4) HASKELL_CABAL_EXPF+=" src_configure" ;;
53 *) ;;
54esac
55
56EXPORT_FUNCTIONS ${HASKELL_CABAL_EXPF}
45 57
46for feature in ${CABAL_FEATURES}; do 58for feature in ${CABAL_FEATURES}; do
47 case ${feature} in 59 case ${feature} in
48 haddock) CABAL_USE_HADDOCK=yes;; 60 haddock) CABAL_USE_HADDOCK=yes;;
61 hscolour) CABAL_USE_HSCOLOUR=yes;;
49 alex) CABAL_USE_ALEX=yes;; 62 alex) CABAL_USE_ALEX=yes;;
50 happy) CABAL_USE_HAPPY=yes;; 63 happy) CABAL_USE_HAPPY=yes;;
51 c2hs) CABAL_USE_C2HS=yes;; 64 c2hs) CABAL_USE_C2HS=yes;;
52 cpphs) CABAL_USE_CPPHS=yes;; 65 cpphs) CABAL_USE_CPPHS=yes;;
53 profile) CABAL_USE_PROFILE=yes;; 66 profile) CABAL_USE_PROFILE=yes;;
54 bootstrap) CABAL_BOOTSTRAP=yes;; 67 bootstrap) CABAL_BOOTSTRAP=yes;;
55 bin) CABAL_HAS_BINARIES=yes;; 68 bin) CABAL_HAS_BINARIES=yes;;
56 lib) CABAL_HAS_LIBRARIES=yes;; 69 lib) CABAL_HAS_LIBRARIES=yes;;
70 nocabaldep) CABAL_FROM_GHC=yes;;
57 *) CABAL_UNKNOWN="${CABAL_UNKNOWN} ${feature}";; 71 *) CABAL_UNKNOWN="${CABAL_UNKNOWN} ${feature}";;
58 esac 72 esac
59done 73done
60 74
61if [[ -n "${CABAL_USE_HADDOCK}" ]]; then 75if [[ -n "${CABAL_USE_HADDOCK}" ]]; then
62 IUSE="${IUSE} doc" 76 IUSE="${IUSE} doc"
63 DEPEND="${DEPEND} doc? ( dev-haskell/haddock )" 77 DEPEND="${DEPEND} doc? ( dev-haskell/haddock )"
64fi 78fi
65 79
80if [[ -n "${CABAL_USE_HSCOLOUR}" ]]; then
81 IUSE="${IUSE} hscolour"
82 DEPEND="${DEPEND} hscolour? ( dev-haskell/hscolour )"
83fi
84
66if [[ -n "${CABAL_USE_ALEX}" ]]; then 85if [[ -n "${CABAL_USE_ALEX}" ]]; then
67 DEPEND="${DEPEND} dev-haskell/alex" 86 DEPEND="${DEPEND} dev-haskell/alex"
68 cabalconf="${cabalconf} --with-alex=/usr/bin/alex"
69fi 87fi
70 88
71if [[ -n "${CABAL_USE_HAPPY}" ]]; then 89if [[ -n "${CABAL_USE_HAPPY}" ]]; then
72 DEPEND="${DEPEND} dev-haskell/happy" 90 DEPEND="${DEPEND} dev-haskell/happy"
73 cabalconf="${cabalconf} --with-happy=/usr/bin/happy"
74fi 91fi
75 92
76if [[ -n "${CABAL_USE_C2HS}" ]]; then 93if [[ -n "${CABAL_USE_C2HS}" ]]; then
77 DEPEND="${DEPEND} dev-haskell/c2hs" 94 DEPEND="${DEPEND} dev-haskell/c2hs"
78 cabalconf="${cabalconf} --with-c2hs=/usr/bin/c2hs"
79fi 95fi
80 96
81if [[ -n "${CABAL_USE_CPPHS}" ]]; then 97if [[ -n "${CABAL_USE_CPPHS}" ]]; then
82 DEPEND="${DEPEND} dev-haskell/cpphs" 98 DEPEND="${DEPEND} dev-haskell/cpphs"
83 cabalconf="${cabalconf} --with-cpphs=/usr/bin/cpphs"
84fi 99fi
85 100
86if [[ -n "${CABAL_USE_PROFILE}" ]]; then 101if [[ -n "${CABAL_USE_PROFILE}" ]]; then
87 IUSE="${IUSE} profile" 102 IUSE="${IUSE} profile"
88fi 103fi
90# We always use a standalone version of Cabal, rather than the one that comes 105# We always use a standalone version of Cabal, rather than the one that comes
91# with GHC. But of course we can't depend on cabal when building cabal itself. 106# with GHC. But of course we can't depend on cabal when building cabal itself.
92if [[ -z ${CABAL_MIN_VERSION} ]]; then 107if [[ -z ${CABAL_MIN_VERSION} ]]; then
93 CABAL_MIN_VERSION=1.1.4 108 CABAL_MIN_VERSION=1.1.4
94fi 109fi
95if [[ -z "${CABAL_BOOTSTRAP}" ]]; then 110if [[ -z "${CABAL_BOOTSTRAP}" && -z "${CABAL_FROM_GHC}" ]]; then
96 DEPEND="${DEPEND} >=dev-haskell/cabal-${CABAL_MIN_VERSION}" 111 DEPEND="${DEPEND} >=dev-haskell/cabal-${CABAL_MIN_VERSION}"
97fi 112fi
98 113
99# Libraries require GHC to be installed. 114# Libraries require GHC to be installed.
100if [[ -n "${CABAL_HAS_LIBRARIES}" ]]; then 115if [[ -n "${CABAL_HAS_LIBRARIES}" ]]; then
107 if [[ -z "${_CABAL_VERSION_CACHE}" ]]; then 122 if [[ -z "${_CABAL_VERSION_CACHE}" ]]; then
108 if [[ "${CABAL_BOOTSTRAP}" ]]; then 123 if [[ "${CABAL_BOOTSTRAP}" ]]; then
109 # We're bootstrapping cabal, so the cabal version is the version 124 # We're bootstrapping cabal, so the cabal version is the version
110 # of this package itself. 125 # of this package itself.
111 _CABAL_VERSION_CACHE="${PV}" 126 _CABAL_VERSION_CACHE="${PV}"
127 elif [[ "${CABAL_FROM_GHC}" ]]; then
128 # We can't assume there's a version of Cabal installed by ebuild as
129 # this might be a first time install of GHC (for packages that
130 # use the shipped Cabal like haskell-updater).
131
132 # The user is likely to only have one version of Cabal, provided
133 # by GHC. Note that dev-haskell/cabal can be a dummy package, only
134 # using the version provided by GHC. If the user has another version
135 # of Cabal too (more recent than the one GHC provides through
136 # dev-haskell/cabal, or possibly older if he used an old
137 # Cabal package) the most recent is used (expected to be the last
138 # one in the ghc-pkg output).
139 _CABAL_VERSION_CACHE="$(ghc-pkg field Cabal version | tail -n 1)"
140
141 # Strip out the "version: " prefix
142 _CABAL_VERSION_CACHE="${_CABAL_VERSION_CACHE#"version: "}"
112 else 143 else
113 # We ask portage, not ghc, so that we only pick up 144 # We ask portage, not ghc, so that we only pick up
114 # portage-installed cabal versions. 145 # portage-installed cabal versions.
115 _CABAL_VERSION_CACHE="$(ghc-extractportageversion dev-haskell/cabal)" 146 _CABAL_VERSION_CACHE="$(ghc-extractportageversion dev-haskell/cabal)"
116 fi 147 fi
157 188
158 echo 'import Distribution.Simple; main = defaultMainWithHooks defaultUserHooks' \ 189 echo 'import Distribution.Simple; main = defaultMainWithHooks defaultUserHooks' \
159 > $setupdir/Setup.hs 190 > $setupdir/Setup.hs
160} 191}
161 192
193cabal-hscolour() {
194 ./setup hscolour || die "setup hscolour failed"
195}
196
162cabal-haddock() { 197cabal-haddock() {
163 ./setup haddock || die "setup haddock failed" 198 ./setup haddock || die "setup haddock failed"
164} 199}
165 200
201cabal-hscolour-haddock() {
202 # --hyperlink-source implies calling 'setup hscolour'
203 ./setup haddock --hyperlink-source || die "setup haddock failed"
204}
205
166cabal-configure() { 206cabal-configure() {
207 has "${EAPI:-0}" 0 1 2 && ! use prefix && EPREFIX=
208
167 if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then 209 if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then
168 cabalconf="${cabalconf} --with-haddock=/usr/bin/haddock" 210 cabalconf="${cabalconf} --with-haddock=${EPREFIX}/usr/bin/haddock"
169 fi 211 fi
170 if [[ -n "${CABAL_USE_PROFILE}" ]] && use profile; then 212 if [[ -n "${CABAL_USE_PROFILE}" ]] && use profile; then
171 cabalconf="${cabalconf} --enable-library-profiling" 213 cabalconf="${cabalconf} --enable-library-profiling"
172 fi 214 fi
215 if [[ -n "${CABAL_USE_ALEX}" ]]; then
216 cabalconf="${cabalconf} --with-alex=${EPREFIX}/usr/bin/alex"
217 fi
218
219 if [[ -n "${CABAL_USE_HAPPY}" ]]; then
220 cabalconf="${cabalconf} --with-happy=${EPREFIX}/usr/bin/happy"
221 fi
222
223 if [[ -n "${CABAL_USE_C2HS}" ]]; then
224 cabalconf="${cabalconf} --with-c2hs=${EPREFIX}/usr/bin/c2hs"
225 fi
226 if [[ -n "${CABAL_USE_CPPHS}" ]]; then
227 cabalconf="${cabalconf} --with-cpphs=${EPREFIX}/usr/bin/cpphs"
228 fi
229
173 # Building GHCi libs on ppc64 causes "TOC overflow". 230 # Building GHCi libs on ppc64 causes "TOC overflow".
174 if use ppc64; then 231 if use ppc64; then
175 cabalconf="${cabalconf} --disable-library-for-ghci" 232 cabalconf="${cabalconf} --disable-library-for-ghci"
176 fi 233 fi
177 234
235 if version_is_at_least "1.4" "$(cabal-version)"; then
236 # disable executable stripping for the executables, as portage will
237 # strip by itself, and pre-stripping gives a QA warning.
238 # cabal versions previous to 1.4 does not strip executables, and does
239 # not accept the flag.
240 # this fixes numerous bugs, amongst them;
241 # bug #251881, bug #251882, bug #251884, bug #251886, bug #299494
242 cabalconf="${cabalconf} --disable-executable-stripping"
243 fi
244
178 if version_is_at_least "1.2.0" "$(cabal-version)"; then 245 if version_is_at_least "1.2.0" "$(cabal-version)"; then
179 cabalconf="${cabalconf} --docdir=/usr/share/doc/${PF}" 246 cabalconf="${cabalconf} --docdir=${EPREFIX}/usr/share/doc/${PF}"
180 # As of Cabal 1.2, configure is quite quiet. For diagnostic purposes 247 # As of Cabal 1.2, configure is quite quiet. For diagnostic purposes
181 # it's better if the configure chatter is in the build logs: 248 # it's better if the configure chatter is in the build logs:
182 cabalconf="${cabalconf} --verbose" 249 cabalconf="${cabalconf} --verbose"
183 fi 250 fi
184 # Note: with Cabal-1.1.6.x we do not have enough control 251 # Note: with Cabal-1.1.6.x we do not have enough control
186 # into /usr/share/${P}/ghc-x.y/doc/ 253 # into /usr/share/${P}/ghc-x.y/doc/
187 # rather than /usr/share/doc/${PF}/ 254 # rather than /usr/share/doc/${PF}/
188 # Because we can only set the datadir, not the docdir. 255 # Because we can only set the datadir, not the docdir.
189 256
190 ./setup configure \ 257 ./setup configure \
191 --ghc --prefix=/usr \ 258 --ghc --prefix="${EPREFIX}"/usr \
192 --with-compiler="$(ghc-getghc)" \ 259 --with-compiler="$(ghc-getghc)" \
193 --with-hc-pkg="$(ghc-getghcpkg)" \ 260 --with-hc-pkg="$(ghc-getghcpkg)" \
194 --prefix=/usr \ 261 --prefix="${EPREFIX}"/usr \
195 --libdir=/usr/$(get_libdir) \ 262 --libdir="${EPREFIX}"/usr/$(get_libdir) \
196 --libsubdir=${P}/ghc-$(ghc-version) \ 263 --libsubdir=${P}/ghc-$(ghc-version) \
197 --datadir=/usr/share/ \ 264 --datadir="${EPREFIX}"/usr/share/ \
198 --datasubdir=${P}/ghc-$(ghc-version) \ 265 --datasubdir=${P}/ghc-$(ghc-version) \
199 ${cabalconf} \ 266 ${cabalconf} \
200 ${CABAL_CONFIGURE_FLAGS} \ 267 ${CABAL_CONFIGURE_FLAGS} \
201 "$@" || die "setup configure failed" 268 "$@" || die "setup configure failed"
202} 269}
206 ./setup build \ 273 ./setup build \
207 || die "setup build failed" 274 || die "setup build failed"
208} 275}
209 276
210cabal-copy() { 277cabal-copy() {
278 has "${EAPI:-0}" 0 1 2 && ! use prefix && ED=${D}
279
211 ./setup copy \ 280 ./setup copy \
212 --destdir="${D}" \ 281 --destdir="${D}" \
213 || die "setup copy failed" 282 || die "setup copy failed"
214 283
215 # cabal is a bit eager about creating dirs, 284 # cabal is a bit eager about creating dirs,
216 # so remove them if they are empty 285 # so remove them if they are empty
217 rmdir "${D}/usr/bin" 2> /dev/null 286 rmdir "${ED}/usr/bin" 2> /dev/null
218 287
219 # GHC 6.4 has a bug in get/setPermission and Cabal 1.1.1 has 288 # GHC 6.4 has a bug in get/setPermission and Cabal 1.1.1 has
220 # no workaround. 289 # no workaround.
221 # set the +x permission on executables 290 # set the +x permission on executables
222 if [[ -d "${D}/usr/bin" ]] ; then 291 if [[ -d "${ED}/usr/bin" ]] ; then
223 chmod +x "${D}/usr/bin/"* 292 chmod +x "${ED}/usr/bin/"*
224 fi 293 fi
225 # TODO: do we still need this? 294 # TODO: do we still need this?
226} 295}
227 296
228cabal-pkg() { 297cabal-pkg() {
271 340
272# exported function: check if cabal is correctly installed for 341# exported function: check if cabal is correctly installed for
273# the currently active ghc (we cannot guarantee this with portage) 342# the currently active ghc (we cannot guarantee this with portage)
274haskell-cabal_pkg_setup() { 343haskell-cabal_pkg_setup() {
275 ghc-package_pkg_setup 344 ghc-package_pkg_setup
276 if [[ -z "${CABAL_BOOTSTRAP}" ]] && ! ghc-sanecabal "${CABAL_MIN_VERSION}"; then 345 if [[ -z "${CABAL_BOOTSTRAP}" && -z "${CABAL_FROM_GHC}" ]] && ! ghc-sanecabal "${CABAL_MIN_VERSION}"; then
277 eerror "The package dev-haskell/cabal is not correctly installed for" 346 eerror "The package dev-haskell/cabal is not correctly installed for"
278 eerror "the currently active version of ghc ($(ghc-version)). Please" 347 eerror "the currently active version of ghc ($(ghc-version)). Please"
279 eerror "run ghc-updater or re-emerge dev-haskell/cabal." 348 eerror "run ghc-updater or haskell-updater or re-build dev-haskell/cabal."
280 die "cabal is not correctly installed" 349 die "cabal is not correctly installed"
281 fi 350 fi
282 if [[ -z "${CABAL_HAS_BINARIES}" ]] && [[ -z "${CABAL_HAS_LIBRARIES}" ]]; then 351 if [[ -z "${CABAL_HAS_BINARIES}" ]] && [[ -z "${CABAL_HAS_LIBRARIES}" ]]; then
283 eerror "QA: Neither bin nor lib are in CABAL_FEATURES." 352 eerror "QA: Neither bin nor lib are in CABAL_FEATURES."
284 fi 353 fi
286 ewarn "Unknown entry in CABAL_FEATURES: ${CABAL_UNKNOWN}" 355 ewarn "Unknown entry in CABAL_FEATURES: ${CABAL_UNKNOWN}"
287 fi 356 fi
288 if cabal-is-dummy-lib; then 357 if cabal-is-dummy-lib; then
289 einfo "${P} is included in ghc-${CABAL_CORE_LIB_GHC_PV}, nothing to install." 358 einfo "${P} is included in ghc-${CABAL_CORE_LIB_GHC_PV}, nothing to install."
290 fi 359 fi
360}
361
362haskell-cabal_src_configure() {
363 if ! cabal-is-dummy-lib; then
364 pushd "${S}" > /dev/null
365
366 cabal-bootstrap
367
368 ghc_flags=""
369 # currently cabal does not respect CFLAGS and LDFLAGS on it's own (bug #333217)
370 # so translate LDFLAGS to ghc parameters (without filtering)
371 for flag in $LDFLAGS; do ghc_flags="${ghc_flags} --ghc-option=-optl$flag"; done
372
373 cabal-configure $ghc_flags "$@"
374
375 popd > /dev/null
376 fi
377}
378
379# exported function: nice alias
380cabal_src_configure() {
381 haskell-cabal_src_configure "$@"
291} 382}
292 383
293# exported function: cabal-style bootstrap configure and compile 384# exported function: cabal-style bootstrap configure and compile
294cabal_src_compile() { 385cabal_src_compile() {
295 if ! cabal-is-dummy-lib; then 386 if ! cabal-is-dummy-lib; then
296 cabal-bootstrap 387 has src_configure ${HASKELL_CABAL_EXPF} || haskell-cabal_src_configure "$@"
297 cabal-configure
298 cabal-build 388 cabal-build
299 389
300 if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then 390 if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then
391 if [[ -n "${CABAL_USE_HSCOLOUR}" ]] && use hscolour; then
392 # hscolour and haddock
393 cabal-hscolour-haddock
394 else
395 # just haddock
301 cabal-haddock 396 cabal-haddock
397 fi
398 else
399 if [[ -n "${CABAL_USE_HSCOLOUR}" ]] && use hscolour; then
400 # just hscolour
401 cabal-hscolour
402 fi
302 fi 403 fi
303 fi 404 fi
304} 405}
406
305haskell-cabal_src_compile() { 407haskell-cabal_src_compile() {
408 pushd "${S}" > /dev/null
409
306 cabal_src_compile 410 cabal_src_compile "$@"
411
412 popd > /dev/null
413}
414
415haskell-cabal_src_test() {
416 pushd "${S}" > /dev/null
417
418 if cabal-is-dummy-lib; then
419 einfo ">>> No tests for dummy library: ${CATEGORY}/${PF}"
420 else
421 einfo ">>> Test phase [cabal test]: ${CATEGORY}/${PF}"
422 ./setup test || die "cabal test failed"
423 fi
424
425 popd > /dev/null
307} 426}
308 427
309# exported function: cabal-style copy and register 428# exported function: cabal-style copy and register
310cabal_src_install() { 429cabal_src_install() {
430 has "${EAPI:-0}" 0 1 2 && ! use prefix && EPREFIX=
431
311 if cabal-is-dummy-lib; then 432 if cabal-is-dummy-lib; then
312 # create a dummy local package conf file for the sake of ghc-updater 433 # create a dummy local package conf file for the sake of ghc-updater
313 dodir "$(ghc-confdir)" 434 local ghc_confdir_with_prefix="$(ghc-confdir)"
435 # remove EPREFIX
436 dodir ${ghc_confdir_with_prefix#${EPREFIX}}
314 echo '[]' > "${D}/$(ghc-confdir)/$(ghc-localpkgconf)" 437 echo '[]' > "${D}/$(ghc-confdir)/$(ghc-localpkgconf)"
315 else 438 else
316 cabal-copy 439 cabal-copy
317 cabal-pkg 440 cabal-pkg
318 441
321 dohtml -r dist/doc/html/* 444 dohtml -r dist/doc/html/*
322 fi 445 fi
323 fi 446 fi
324 fi 447 fi
325} 448}
449
326haskell-cabal_src_install() { 450haskell-cabal_src_install() {
451 pushd "${S}" > /dev/null
452
327 cabal_src_install 453 cabal_src_install
328}
329 454
330EXPORT_FUNCTIONS pkg_setup src_compile src_install 455 popd > /dev/null
456}
457
458# ebuild.sh:use_enable() taken as base
459#
460# Usage examples:
461#
462# CABAL_CONFIGURE_FLAGS=$(cabal_flag gui)
463# leads to "--flags=gui" or "--flags=-gui" (useflag 'gui')
464#
465# CABAL_CONFIGURE_FLAGS=$(cabal_flag gtk gui)
466# also leads to "--flags=gui" or " --flags=-gui" (useflag 'gtk')
467#
468cabal_flag() {
469 if [[ -z "$1" ]]; then
470 echo "!!! cabal_flag() called without a parameter." >&2
471 echo "!!! cabal_flag() <USEFLAG> [<cabal_flagname>]" >&2
472 return 1
473 fi
474
475 local UWORD=${2:-$1}
476
477 if use "$1"; then
478 echo "--flags=${UWORD}"
479 else
480 echo "--flags=-${UWORD}"
481 fi
482
483 return 0
484}

Legend:
Removed from v.1.15  
changed lines
  Added in v.1.23

  ViewVC Help
Powered by ViewVC 1.1.20