/[gentoo-x86]/eclass/haskell-cabal.eclass
Gentoo

Diff of /eclass/haskell-cabal.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.7 Revision 1.15
1# Copyright 1999-2006 Gentoo Foundation 1# Copyright 1999-2006 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/haskell-cabal.eclass,v 1.7 2006/08/02 19:49:03 dcoutts Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/haskell-cabal.eclass,v 1.15 2009/07/27 19:03:20 kolmodin Exp $
4# 4#
5# Original authors: Andres Loeh <kosmikus@gentoo.org> 5# Original authors: Andres Loeh <kosmikus@gentoo.org>
6# Duncan Coutts <dcoutts@gentoo.org> 6# Duncan Coutts <dcoutts@gentoo.org>
7# Maintained by: Haskell herd <haskell@gentoo.org> 7# Maintained by: Haskell herd <haskell@gentoo.org>
8# 8#
34# 34#
35# Many Cabal packages require S to be manually set. 35# Many Cabal packages require S to be manually set.
36# 36#
37# Conforming Cabal packages don't require any function definitions 37# Conforming Cabal packages don't require any function definitions
38# in the ebuild. 38# in the ebuild.
39#
40# Special flags to Cabal Configure can now be set by using
41# CABAL_CONFIGURE_FLAGS
39 42
40inherit ghc-package 43inherit ghc-package multilib
41 44
42 45
43for feature in ${CABAL_FEATURES}; do 46for feature in ${CABAL_FEATURES}; do
44 case ${feature} in 47 case ${feature} in
45 haddock) CABAL_USE_HADDOCK=yes;; 48 haddock) CABAL_USE_HADDOCK=yes;;
56done 59done
57 60
58if [[ -n "${CABAL_USE_HADDOCK}" ]]; then 61if [[ -n "${CABAL_USE_HADDOCK}" ]]; then
59 IUSE="${IUSE} doc" 62 IUSE="${IUSE} doc"
60 DEPEND="${DEPEND} doc? ( dev-haskell/haddock )" 63 DEPEND="${DEPEND} doc? ( dev-haskell/haddock )"
61 cabalconf="${cabalconf} --with-haddock=/usr/bin/haddock"
62fi 64fi
63 65
64if [[ -n "${CABAL_USE_ALEX}" ]]; then 66if [[ -n "${CABAL_USE_ALEX}" ]]; then
65 DEPEND="${DEPEND} dev-haskell/alex" 67 DEPEND="${DEPEND} dev-haskell/alex"
66 cabalconf="${cabalconf} --with-alex=/usr/bin/alex" 68 cabalconf="${cabalconf} --with-alex=/usr/bin/alex"
85 IUSE="${IUSE} profile" 87 IUSE="${IUSE} profile"
86fi 88fi
87 89
88# We always use a standalone version of Cabal, rather than the one that comes 90# We always use a standalone version of Cabal, rather than the one that comes
89# with GHC. But of course we can't depend on cabal when building cabal itself. 91# with GHC. But of course we can't depend on cabal when building cabal itself.
92if [[ -z ${CABAL_MIN_VERSION} ]]; then
93 CABAL_MIN_VERSION=1.1.4
94fi
90if [[ -z "${CABAL_BOOTSTRAP}" ]]; then 95if [[ -z "${CABAL_BOOTSTRAP}" ]]; then
91 DEPEND="${DEPEND} >=dev-haskell/cabal-1.1.3" 96 DEPEND="${DEPEND} >=dev-haskell/cabal-${CABAL_MIN_VERSION}"
92fi 97fi
93 98
94# Libraries require GHC to be installed. 99# Libraries require GHC to be installed.
95if [[ -n "${CABAL_HAS_LIBRARIES}" ]]; then 100if [[ -n "${CABAL_HAS_LIBRARIES}" ]]; then
96 RDEPEND="${RDEPEND} virtual/ghc" 101 RDEPEND="${RDEPEND} dev-lang/ghc"
102fi
103
104# returns the version of cabal currently in use
105_CABAL_VERSION_CACHE=""
106cabal-version() {
107 if [[ -z "${_CABAL_VERSION_CACHE}" ]]; then
108 if [[ "${CABAL_BOOTSTRAP}" ]]; then
109 # We're bootstrapping cabal, so the cabal version is the version
110 # of this package itself.
111 _CABAL_VERSION_CACHE="${PV}"
112 else
113 # We ask portage, not ghc, so that we only pick up
114 # portage-installed cabal versions.
115 _CABAL_VERSION_CACHE="$(ghc-extractportageversion dev-haskell/cabal)"
116 fi
97fi 117 fi
118 echo "${_CABAL_VERSION_CACHE}"
119}
98 120
99cabal-bootstrap() { 121cabal-bootstrap() {
100 local setupmodule 122 local setupmodule
101 local cabalversion 123 local cabalpackage
102 if [[ -f "${S}/Setup.lhs" ]]; then 124 if [[ -f "${S}/Setup.lhs" ]]; then
103 setupmodule="${S}/Setup.lhs" 125 setupmodule="${S}/Setup.lhs"
104 else 126 else
105 if [[ -f "${S}/Setup.hs" ]]; then 127 if [[ -f "${S}/Setup.hs" ]]; then
106 setupmodule="${S}/Setup.hs" 128 setupmodule="${S}/Setup.hs"
109 fi 131 fi
110 fi 132 fi
111 133
112 # We build the setup program using the latest version of 134 # We build the setup program using the latest version of
113 # cabal that we have installed 135 # cabal that we have installed
114 cabalversion=$(ghc-bestcabalversion) 136 if version_is_at_least "6.4" "$(ghc-version)"; then
137 cabalpackage=Cabal-$(cabal-version)
138 else
139 # older ghc's don't support package versioning
140 cabalpackage=Cabal
141 fi
115 einfo "Using ${cabalversion}." 142 einfo "Using cabal-$(cabal-version)."
116 $(ghc-getghc) -package "${cabalversion}" --make "${setupmodule}" -o setup \ 143 $(ghc-getghc) -package "${cabalpackage}" --make "${setupmodule}" -o setup \
117 || die "compiling ${setupmodule} failed" 144 || die "compiling ${setupmodule} failed"
145}
146
147cabal-mksetup() {
148 local setupdir
149
150 if [[ -n $1 ]]; then
151 setupdir=$1
152 else
153 setupdir=${S}
154 fi
155
156 rm -f "${setupdir}"/Setup.{lhs,hs}
157
158 echo 'import Distribution.Simple; main = defaultMainWithHooks defaultUserHooks' \
159 > $setupdir/Setup.hs
118} 160}
119 161
120cabal-haddock() { 162cabal-haddock() {
121 ./setup haddock || die "setup haddock failed" 163 ./setup haddock || die "setup haddock failed"
122} 164}
123 165
124cabal-configure() { 166cabal-configure() {
167 if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then
168 cabalconf="${cabalconf} --with-haddock=/usr/bin/haddock"
169 fi
125 if [[ -n "${CABAL_USE_PROFILE}" ]] && use profile; then 170 if [[ -n "${CABAL_USE_PROFILE}" ]] && use profile; then
126 cabalconf="${cabalconf} --enable-executable-profiling";
127 cabalconf="${cabalconf} --enable-library-profiling" 171 cabalconf="${cabalconf} --enable-library-profiling"
128 fi 172 fi
129 # Building GHCi libs on ppc64 causes "TOC overflow". 173 # Building GHCi libs on ppc64 causes "TOC overflow".
130 if use ppc64; then 174 if use ppc64; then
131 cabalconf="${cabalconf} --disable-library-for-ghci" 175 cabalconf="${cabalconf} --disable-library-for-ghci"
132 fi 176 fi
177
178 if version_is_at_least "1.2.0" "$(cabal-version)"; then
179 cabalconf="${cabalconf} --docdir=/usr/share/doc/${PF}"
180 # As of Cabal 1.2, configure is quite quiet. For diagnostic purposes
181 # it's better if the configure chatter is in the build logs:
182 cabalconf="${cabalconf} --verbose"
183 fi
184 # Note: with Cabal-1.1.6.x we do not have enough control
185 # to put the docs into the right place. They're currently going
186 # into /usr/share/${P}/ghc-x.y/doc/
187 # rather than /usr/share/doc/${PF}/
188 # Because we can only set the datadir, not the docdir.
133 189
134 ./setup configure \ 190 ./setup configure \
135 --ghc --prefix=/usr \ 191 --ghc --prefix=/usr \
136 --with-compiler="$(ghc-getghc)" \ 192 --with-compiler="$(ghc-getghc)" \
137 --with-hc-pkg="$(ghc-getghcpkg)" \ 193 --with-hc-pkg="$(ghc-getghcpkg)" \
194 --prefix=/usr \
195 --libdir=/usr/$(get_libdir) \
196 --libsubdir=${P}/ghc-$(ghc-version) \
197 --datadir=/usr/share/ \
198 --datasubdir=${P}/ghc-$(ghc-version) \
138 ${cabalconf} \ 199 ${cabalconf} \
200 ${CABAL_CONFIGURE_FLAGS} \
139 "$@" || die "setup configure failed" 201 "$@" || die "setup configure failed"
140} 202}
141 203
142cabal-build() { 204cabal-build() {
205 unset LANG LC_ALL LC_MESSAGES
143 ./setup build \ 206 ./setup build \
144 || die "setup build failed" 207 || die "setup build failed"
145} 208}
146 209
147cabal-copy() { 210cabal-copy() {
148 ./setup copy \ 211 ./setup copy \
149 --copy-prefix="${D}/usr" \ 212 --destdir="${D}" \
150 || die "setup copy failed" 213 || die "setup copy failed"
151 214
152 # cabal is a bit eager about creating dirs, 215 # cabal is a bit eager about creating dirs,
153 # so remove them if they are empty 216 # so remove them if they are empty
154 rmdir "${D}/usr/bin" 2> /dev/null 217 rmdir "${D}/usr/bin" 2> /dev/null
157 # no workaround. 220 # no workaround.
158 # set the +x permission on executables 221 # set the +x permission on executables
159 if [[ -d "${D}/usr/bin" ]] ; then 222 if [[ -d "${D}/usr/bin" ]] ; then
160 chmod +x "${D}/usr/bin/"* 223 chmod +x "${D}/usr/bin/"*
161 fi 224 fi
225 # TODO: do we still need this?
162} 226}
163 227
164cabal-pkg() { 228cabal-pkg() {
165 # This does not actually register since we're using /usr/bin/true instead 229 # This does not actually register since we're using true instead
166 # of ghc-pkg. So it just leaves the .installed-pkg-config and we can 230 # of ghc-pkg. So it just leaves the .installed-pkg-config and we can
167 # register that ourselves (if it exists). 231 # register that ourselves (if it exists).
168 local result 232 local result
169 local err 233 local err
170 234
171 if [[ -n ${CABAL_HAS_LIBRARIES} ]]; then 235 if [[ -n ${CABAL_HAS_LIBRARIES} ]]; then
172 sed -i "s|$(ghc-getghcpkg)|/usr/bin/true|" .setup-config 236 if version_is_at_least "1.2.0" "$(cabal-version)"; then
173 ./setup register || die "setup register failed" 237 # Newer cabal can generate a package conf for us:
174 if [[ -f .installed-pkg-config ]]; then 238 ./setup register --gen-pkg-config="${T}/${P}.conf"
175 ghc-setup-pkg .installed-pkg-config 239 ghc-setup-pkg "${T}/${P}.conf"
176 ghc-install-pkg 240 ghc-install-pkg
177 else 241 else
242 # With older cabal we have to hack it by replacing its ghc-pkg
243 # with true and then just picking up the .installed-pkg-config
244 # file and registering that ourselves (if it exists).
245 sed -i "s|$(ghc-getghcpkg)|$(type -P true)|" .setup-config
246 ./setup register || die "setup register failed"
247 if [[ -f .installed-pkg-config ]]; then
248 ghc-setup-pkg .installed-pkg-config
249 ghc-install-pkg
250 else
178 die "setup register has not generated a package configuration file" 251 die "setup register has not generated a package configuration file"
179 fi 252 fi
180 fi 253 fi
254 fi
255}
256
257# Some cabal libs are bundled along with some versions of ghc
258# eg filepath-1.0 comes with ghc-6.6.1
259# by putting CABAL_CORE_LIB_GHC_PV="6.6.1" in an ebuild we are declaring that
260# when building with this version of ghc, the ebuild is a dummy that is it will
261# install no files since the package is already included with ghc.
262# However portage still records the dependency and we can upgrade the package
263# to a later one that's not included with ghc.
264# You can also put a space separated list, eg CABAL_CORE_LIB_GHC_PV="6.6 6.6.1".
265cabal-is-dummy-lib() {
266 for version in ${CABAL_CORE_LIB_GHC_PV[*]}; do
267 [[ "$(ghc-version)" == "$version" ]] && return 0
268 done
269 return 1
181} 270}
182 271
183# exported function: check if cabal is correctly installed for 272# exported function: check if cabal is correctly installed for
184# the currently active ghc (we cannot guarantee this with portage) 273# the currently active ghc (we cannot guarantee this with portage)
185haskell-cabal_pkg_setup() { 274haskell-cabal_pkg_setup() {
275 ghc-package_pkg_setup
186 if [[ -z "${CABAL_BOOTSTRAP}" ]] && ! ghc-sanecabal "1.1.3"; then 276 if [[ -z "${CABAL_BOOTSTRAP}" ]] && ! ghc-sanecabal "${CABAL_MIN_VERSION}"; then
187 eerror "The package dev-haskell/cabal is not correctly installed for" 277 eerror "The package dev-haskell/cabal is not correctly installed for"
188 eerror "the currently active version of ghc ($(ghc-version)). Please" 278 eerror "the currently active version of ghc ($(ghc-version)). Please"
189 eerror "run ghc-updater or re-emerge dev-haskell/cabal." 279 eerror "run ghc-updater or re-emerge dev-haskell/cabal."
190 die "cabal is not correctly installed" 280 die "cabal is not correctly installed"
191 fi 281 fi
192 if [[ -z "${CABAL_HAS_BINARIES}" ]] && [[ -z "${CABAL_HAS_LIBRARIES}" ]]; then 282 if [[ -z "${CABAL_HAS_BINARIES}" ]] && [[ -z "${CABAL_HAS_LIBRARIES}" ]]; then
193 eerror "QA: Neither bin nor lib are in CABAL_FEATURES." 283 eerror "QA: Neither bin nor lib are in CABAL_FEATURES."
194 fi 284 fi
195 if [[ -n "${CABAL_UNKNOWN}" ]]; then 285 if [[ -n "${CABAL_UNKNOWN}" ]]; then
196 ewarn "Unknown entry in CABAL_FEATURES: ${CABAL_UNKNONW}" 286 ewarn "Unknown entry in CABAL_FEATURES: ${CABAL_UNKNOWN}"
287 fi
288 if cabal-is-dummy-lib; then
289 einfo "${P} is included in ghc-${CABAL_CORE_LIB_GHC_PV}, nothing to install."
197 fi 290 fi
198} 291}
199 292
200# exported function: cabal-style bootstrap configure and compile 293# exported function: cabal-style bootstrap configure and compile
201cabal_src_compile() { 294cabal_src_compile() {
295 if ! cabal-is-dummy-lib; then
202 cabal-bootstrap 296 cabal-bootstrap
203 cabal-configure 297 cabal-configure
204 cabal-build 298 cabal-build
205 299
206 if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then 300 if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then
207 cabal-haddock 301 cabal-haddock
302 fi
208 fi 303 fi
209} 304}
210haskell-cabal_src_compile() { 305haskell-cabal_src_compile() {
211 cabal_src_compile 306 cabal_src_compile
212} 307}
213 308
214# exported function: cabal-style copy and register 309# exported function: cabal-style copy and register
215cabal_src_install() { 310cabal_src_install() {
311 if cabal-is-dummy-lib; then
312 # create a dummy local package conf file for the sake of ghc-updater
313 dodir "$(ghc-confdir)"
314 echo '[]' > "${D}/$(ghc-confdir)/$(ghc-localpkgconf)"
315 else
216 cabal-copy 316 cabal-copy
217 cabal-pkg 317 cabal-pkg
218 318
219 if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then 319 if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then
320 if ! version_is_at_least "1.1.6" "$(cabal-version)"; then
220 dohtml dist/doc/html/* 321 dohtml -r dist/doc/html/*
322 fi
323 fi
221 fi 324 fi
222} 325}
223haskell-cabal_src_install() { 326haskell-cabal_src_install() {
224 cabal_src_install 327 cabal_src_install
225} 328}

Legend:
Removed from v.1.7  
changed lines
  Added in v.1.15

  ViewVC Help
Powered by ViewVC 1.1.20