/[gentoo-x86]/eclass/haskell-cabal.eclass
Gentoo

Diff of /eclass/haskell-cabal.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.2 Revision 1.18
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2006 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/haskell-cabal.eclass,v 1.2 2005/12/05 12:24:53 dcoutts Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/haskell-cabal.eclass,v 1.18 2010/01/26 20:50:40 kolmodin Exp $
4# 4#
5# Original authors: Andres Loeh <kosmikus@gentoo.org> 5# Original authors: Andres Loeh <kosmikus@gentoo.org>
6# Duncan Coutts <dcoutts@gentoo.org> 6# Duncan Coutts <dcoutts@gentoo.org>
7# Maintained by: Haskell herd <haskell@gentoo.org> 7# Maintained by: Haskell herd <haskell@gentoo.org>
8# 8#
22# happy -- parser generator 22# happy -- parser generator
23# c2hs -- C interface generator 23# c2hs -- C interface generator
24# cpphs -- C preprocessor clone written in Haskell 24# cpphs -- C preprocessor clone written in Haskell
25# profile -- if package supports to build profiling-enabled libraries 25# profile -- if package supports to build profiling-enabled libraries
26# bootstrap -- only used for the cabal package itself 26# bootstrap -- only used for the cabal package itself
27# bin -- the package installs binaries
28# lib -- the package installs libraries
29# nocabaldep -- don't add dependency on cabal.
30# only used for packages that _must_ not pull the dependency
31# on cabal, but still use this eclass (e.g. haskell-updater).
27# 32#
28# Dependencies on other cabal packages have to be specified 33# Dependencies on other cabal packages have to be specified
29# correctly. 34# correctly.
30# 35#
31# Cabal libraries should usually be SLOTted with "${PV}". 36# Cabal libraries should usually be SLOTted with "${PV}".
32# 37#
33# Many Cabal packages require S to be manually set. 38# Many Cabal packages require S to be manually set.
34# 39#
35# Conforming Cabal packages don't require any function definitions 40# Conforming Cabal packages don't require any function definitions
36# in the ebuild. 41# in the ebuild.
42#
43# Special flags to Cabal Configure can now be set by using
44# CABAL_CONFIGURE_FLAGS
37 45
38inherit ghc-package 46inherit ghc-package multilib
39 47
40 48
41for feature in ${CABAL_FEATURES}; do 49for feature in ${CABAL_FEATURES}; do
42 case ${feature} in 50 case ${feature} in
43 haddock) CABAL_USE_HADDOCK=yes;; 51 haddock) CABAL_USE_HADDOCK=yes;;
44 alex) CABAL_USE_ALEX=yes;; 52 alex) CABAL_USE_ALEX=yes;;
45 happy) CABAL_USE_HAPPY=yes;; 53 happy) CABAL_USE_HAPPY=yes;;
46 c2hs) CABAL_USE_C2HS=yes;; 54 c2hs) CABAL_USE_C2HS=yes;;
47 cpphs) CABAL_USE_CPPHS=yes;; 55 cpphs) CABAL_USE_CPPHS=yes;;
48 profile) CABAL_USE_PROFILE=yes;; 56 profile) CABAL_USE_PROFILE=yes;;
49 bootstrap) CABAL_BOOTSTRAP=yes;; 57 bootstrap) CABAL_BOOTSTRAP=yes;;
50 *) ewarn "Unknown entry in CABAL_FEATURES: ${feature}";; 58 bin) CABAL_HAS_BINARIES=yes;;
59 lib) CABAL_HAS_LIBRARIES=yes;;
60 nocabaldep) CABAL_FROM_GHC=yes;;
61 *) CABAL_UNKNOWN="${CABAL_UNKNOWN} ${feature}";;
51 esac 62 esac
52done 63done
53 64
54if [[ -n "${CABAL_USE_HADDOCK}" ]]; then 65if [[ -n "${CABAL_USE_HADDOCK}" ]]; then
55 IUSE="${IUSE} doc" 66 IUSE="${IUSE} doc"
56 DEPEND="${DEPEND} doc? ( dev-haskell/haddock )" 67 DEPEND="${DEPEND} doc? ( dev-haskell/haddock )"
57 cabalconf="${cabalconf} --with-haddock=/usr/bin/haddock"
58fi 68fi
59 69
60if [[ -n "${CABAL_USE_ALEX}" ]]; then 70if [[ -n "${CABAL_USE_ALEX}" ]]; then
61 DEPEND="${DEPEND} dev-haskell/alex" 71 DEPEND="${DEPEND} dev-haskell/alex"
62 cabalconf="${cabalconf} --with-alex=/usr/bin/alex" 72 cabalconf="${cabalconf} --with-alex=/usr/bin/alex"
81 IUSE="${IUSE} profile" 91 IUSE="${IUSE} profile"
82fi 92fi
83 93
84# We always use a standalone version of Cabal, rather than the one that comes 94# We always use a standalone version of Cabal, rather than the one that comes
85# with GHC. But of course we can't depend on cabal when building cabal itself. 95# with GHC. But of course we can't depend on cabal when building cabal itself.
96if [[ -z ${CABAL_MIN_VERSION} ]]; then
97 CABAL_MIN_VERSION=1.1.4
98fi
99if [[ -z "${CABAL_BOOTSTRAP}" && -z "${CABAL_FROM_GHC}" ]]; then
100 DEPEND="${DEPEND} >=dev-haskell/cabal-${CABAL_MIN_VERSION}"
101fi
102
103# Libraries require GHC to be installed.
104if [[ -n "${CABAL_HAS_LIBRARIES}" ]]; then
105 RDEPEND="${RDEPEND} dev-lang/ghc"
106fi
107
108# returns the version of cabal currently in use
109_CABAL_VERSION_CACHE=""
110cabal-version() {
111 if [[ -z "${_CABAL_VERSION_CACHE}" ]]; then
86if [[ -z "${CABAL_BOOTSTRAP}" ]]; then 112 if [[ "${CABAL_BOOTSTRAP}" ]]; then
87 DEPEND="${DEPEND} >=dev-haskell/cabal-1.1.3" 113 # We're bootstrapping cabal, so the cabal version is the version
114 # of this package itself.
115 _CABAL_VERSION_CACHE="${PV}"
116 elif [[ "${CABAL_FROM_GHC}" ]]; then
117 # We can't assume there's a version of Cabal installed by ebuild as
118 # this might be a first time install of GHC (for packages that
119 # use the shipped Cabal like haskell-updater).
120
121 # The user is likely to only have one version of Cabal, provided
122 # by GHC. Note that dev-haskell/cabal can be a dummy package, only
123 # using the version provided by GHC. If the user has another version
124 # of Cabal too (more recent than the one GHC provides through
125 # dev-haskell/cabal, or possibly older if he used an old
126 # Cabal package) the most recent is used (expected to be the last
127 # one in the ghc-pkg output).
128 _CABAL_VERSION_CACHE="$(ghc-pkg field Cabal version | tail -n 1)"
129
130 # Strip out the "version: " prefix
131 _CABAL_VERSION_CACHE="${_CABAL_VERSION_CACHE#"version: "}"
132 else
133 # We ask portage, not ghc, so that we only pick up
134 # portage-installed cabal versions.
135 _CABAL_VERSION_CACHE="$(ghc-extractportageversion dev-haskell/cabal)"
136 fi
88fi 137 fi
89 138 echo "${_CABAL_VERSION_CACHE}"
139}
90 140
91cabal-bootstrap() { 141cabal-bootstrap() {
92 local setupmodule 142 local setupmodule
93 local cabalversion 143 local cabalpackage
94 if [[ -f "${S}/Setup.lhs" ]]; then 144 if [[ -f "${S}/Setup.lhs" ]]; then
95 setupmodule="${S}/Setup.lhs" 145 setupmodule="${S}/Setup.lhs"
96 else 146 else
97 if [[ -f "${S}/Setup.hs" ]]; then 147 if [[ -f "${S}/Setup.hs" ]]; then
98 setupmodule="${S}/Setup.hs" 148 setupmodule="${S}/Setup.hs"
101 fi 151 fi
102 fi 152 fi
103 153
104 # We build the setup program using the latest version of 154 # We build the setup program using the latest version of
105 # cabal that we have installed 155 # cabal that we have installed
106 cabalversion=$(ghc-bestcabalversion) 156 if version_is_at_least "6.4" "$(ghc-version)"; then
157 cabalpackage=Cabal-$(cabal-version)
158 else
159 # older ghc's don't support package versioning
160 cabalpackage=Cabal
161 fi
107 einfo "Using ${cabalversion}." 162 einfo "Using cabal-$(cabal-version)."
108 $(ghc-getghc) -package "${cabalversion}" --make "${setupmodule}" -o setup \ 163 $(ghc-getghc) -package "${cabalpackage}" --make "${setupmodule}" -o setup \
109 || die "compiling ${setupmodule} failed" 164 || die "compiling ${setupmodule} failed"
165}
166
167cabal-mksetup() {
168 local setupdir
169
170 if [[ -n $1 ]]; then
171 setupdir=$1
172 else
173 setupdir=${S}
174 fi
175
176 rm -f "${setupdir}"/Setup.{lhs,hs}
177
178 echo 'import Distribution.Simple; main = defaultMainWithHooks defaultUserHooks' \
179 > $setupdir/Setup.hs
110} 180}
111 181
112cabal-haddock() { 182cabal-haddock() {
113 ./setup haddock || die "setup haddock failed" 183 ./setup haddock || die "setup haddock failed"
114} 184}
115 185
116cabal-configure() { 186cabal-configure() {
187 if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then
188 cabalconf="${cabalconf} --with-haddock=/usr/bin/haddock"
189 fi
117 if [[ -n "${CABAL_USE_PROFILE}" ]] && use profile; then 190 if [[ -n "${CABAL_USE_PROFILE}" ]] && use profile; then
118 cabalconf="${cabalconf} --enable-executable-profiling";
119 cabalconf="${cabalconf} --enable-library-profiling" 191 cabalconf="${cabalconf} --enable-library-profiling"
120 fi 192 fi
193 # Building GHCi libs on ppc64 causes "TOC overflow".
194 if use ppc64; then
195 cabalconf="${cabalconf} --disable-library-for-ghci"
196 fi
197
198 if version_is_at_least "1.4" "$(cabal-version)"; then
199 # disable executable stripping for the executables, as portage will
200 # strip by itself, and pre-stripping gives a QA warning.
201 # cabal versions previous to 1.4 does not strip executables, and does
202 # not accept the flag.
203 # this fixes numerous bugs, amongst them;
204 # bug #251881, bug #251882, bug #251884, bug #251886, bug #299494
205 cabalconf="${cabalconf} --disable-executable-stripping"
206 fi
207
208 if version_is_at_least "1.2.0" "$(cabal-version)"; then
209 cabalconf="${cabalconf} --docdir=/usr/share/doc/${PF}"
210 # As of Cabal 1.2, configure is quite quiet. For diagnostic purposes
211 # it's better if the configure chatter is in the build logs:
212 cabalconf="${cabalconf} --verbose"
213 fi
214 # Note: with Cabal-1.1.6.x we do not have enough control
215 # to put the docs into the right place. They're currently going
216 # into /usr/share/${P}/ghc-x.y/doc/
217 # rather than /usr/share/doc/${PF}/
218 # Because we can only set the datadir, not the docdir.
121 219
122 ./setup configure \ 220 ./setup configure \
123 --ghc --prefix=/usr \ 221 --ghc --prefix=/usr \
124 --with-compiler="$(ghc-getghc)" \ 222 --with-compiler="$(ghc-getghc)" \
125 --with-hc-pkg="$(ghc-getghcpkg)" \ 223 --with-hc-pkg="$(ghc-getghcpkg)" \
224 --prefix=/usr \
225 --libdir=/usr/$(get_libdir) \
226 --libsubdir=${P}/ghc-$(ghc-version) \
227 --datadir=/usr/share/ \
228 --datasubdir=${P}/ghc-$(ghc-version) \
126 ${cabalconf} \ 229 ${cabalconf} \
230 ${CABAL_CONFIGURE_FLAGS} \
127 "$@" || die "setup configure failed" 231 "$@" || die "setup configure failed"
128} 232}
129 233
130cabal-build() { 234cabal-build() {
235 unset LANG LC_ALL LC_MESSAGES
131 ./setup build \ 236 ./setup build \
132 || die "setup build failed" 237 || die "setup build failed"
133} 238}
134 239
135cabal-copy() { 240cabal-copy() {
136 ./setup copy \ 241 ./setup copy \
137 --copy-prefix="${D}/usr" \ 242 --destdir="${D}" \
138 || die "setup copy failed" 243 || die "setup copy failed"
139 244
140 # cabal is a bit eager about creating dirs, 245 # cabal is a bit eager about creating dirs,
141 # so remove them if they are empty 246 # so remove them if they are empty
142 rmdir "${D}/usr/bin" 2> /dev/null 247 rmdir "${D}/usr/bin" 2> /dev/null
145 # no workaround. 250 # no workaround.
146 # set the +x permission on executables 251 # set the +x permission on executables
147 if [[ -d "${D}/usr/bin" ]] ; then 252 if [[ -d "${D}/usr/bin" ]] ; then
148 chmod +x "${D}/usr/bin/"* 253 chmod +x "${D}/usr/bin/"*
149 fi 254 fi
255 # TODO: do we still need this?
150} 256}
151 257
152cabal-pkg() { 258cabal-pkg() {
153 # This does not actually register since we're using /usr/bin/true instead 259 # This does not actually register since we're using true instead
154 # of ghc-pkg. So it just leaves the .installed-pkg-config and we can 260 # of ghc-pkg. So it just leaves the .installed-pkg-config and we can
155 # register that ourselves (if it exists). 261 # register that ourselves (if it exists).
156 local result 262 local result
157 local err 263 local err
158 264
159 sed -i 's:ghc-pkg:/usr/bin/true:' .setup-config 265 if [[ -n ${CABAL_HAS_LIBRARIES} ]]; then
160 result="$(./setup register 2>&1)" 266 if version_is_at_least "1.2.0" "$(cabal-version)"; then
161 err="$?" 267 # Newer cabal can generate a package conf for us:
162 if ! echo ${result} | grep -q "no library to register"; then 268 ./setup register --gen-pkg-config="${T}/${P}.conf"
163 $(exit "${err}") || die "setup register failed" 269 ghc-setup-pkg "${T}/${P}.conf"
164 fi 270 ghc-install-pkg
271 else
272 # With older cabal we have to hack it by replacing its ghc-pkg
273 # with true and then just picking up the .installed-pkg-config
274 # file and registering that ourselves (if it exists).
275 sed -i "s|$(ghc-getghcpkg)|$(type -P true)|" .setup-config
276 ./setup register || die "setup register failed"
165 if [[ -f .installed-pkg-config ]]; then 277 if [[ -f .installed-pkg-config ]]; then
166 ghc-setup-pkg .installed-pkg-config 278 ghc-setup-pkg .installed-pkg-config
167 ghc-install-pkg 279 ghc-install-pkg
280 else
281 die "setup register has not generated a package configuration file"
282 fi
168 fi 283 fi
284 fi
285}
286
287# Some cabal libs are bundled along with some versions of ghc
288# eg filepath-1.0 comes with ghc-6.6.1
289# by putting CABAL_CORE_LIB_GHC_PV="6.6.1" in an ebuild we are declaring that
290# when building with this version of ghc, the ebuild is a dummy that is it will
291# install no files since the package is already included with ghc.
292# However portage still records the dependency and we can upgrade the package
293# to a later one that's not included with ghc.
294# You can also put a space separated list, eg CABAL_CORE_LIB_GHC_PV="6.6 6.6.1".
295cabal-is-dummy-lib() {
296 for version in ${CABAL_CORE_LIB_GHC_PV[*]}; do
297 [[ "$(ghc-version)" == "$version" ]] && return 0
298 done
299 return 1
169} 300}
170 301
171# exported function: check if cabal is correctly installed for 302# exported function: check if cabal is correctly installed for
172# the currently active ghc (we cannot guarantee this with portage) 303# the currently active ghc (we cannot guarantee this with portage)
173haskell-cabal_pkg_setup() { 304haskell-cabal_pkg_setup() {
174 if [[ -z "${CABAL_BOOTSTRAP}" ]] && ! ghc-sanecabal "1.1.3"; then 305 ghc-package_pkg_setup
306 if [[ -z "${CABAL_BOOTSTRAP}" && -z "${CABAL_FROM_GHC}" ]] && ! ghc-sanecabal "${CABAL_MIN_VERSION}"; then
175 eerror "The package dev-haskell/cabal is not correctly installed for" 307 eerror "The package dev-haskell/cabal is not correctly installed for"
176 eerror "the currently active version of ghc ($(ghc-version)). Please" 308 eerror "the currently active version of ghc ($(ghc-version)). Please"
177 eerror "run ghc-updater or re-emerge dev-haskell/cabal." 309 eerror "run ghc-updater or haskell-updater or re-build dev-haskell/cabal."
178 die "cabal is not correctly installed" 310 die "cabal is not correctly installed"
311 fi
312 if [[ -z "${CABAL_HAS_BINARIES}" ]] && [[ -z "${CABAL_HAS_LIBRARIES}" ]]; then
313 eerror "QA: Neither bin nor lib are in CABAL_FEATURES."
314 fi
315 if [[ -n "${CABAL_UNKNOWN}" ]]; then
316 ewarn "Unknown entry in CABAL_FEATURES: ${CABAL_UNKNOWN}"
317 fi
318 if cabal-is-dummy-lib; then
319 einfo "${P} is included in ghc-${CABAL_CORE_LIB_GHC_PV}, nothing to install."
179 fi 320 fi
180} 321}
181 322
182# exported function: cabal-style bootstrap configure and compile 323# exported function: cabal-style bootstrap configure and compile
183cabal_src_compile() { 324cabal_src_compile() {
325 if ! cabal-is-dummy-lib; then
184 cabal-bootstrap 326 cabal-bootstrap
185 cabal-configure 327 cabal-configure
186 cabal-build 328 cabal-build
187 329
188 if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then 330 if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then
189 cabal-haddock 331 cabal-haddock
190 fi 332 fi
333 fi
191} 334}
335
192haskell-cabal_src_compile() { 336haskell-cabal_src_compile() {
193 cabal_src_compile 337 cabal_src_compile
194} 338}
195 339
196# exported function: cabal-style copy and register 340# exported function: cabal-style copy and register
197cabal_src_install() { 341cabal_src_install() {
342 if cabal-is-dummy-lib; then
343 # create a dummy local package conf file for the sake of ghc-updater
344 dodir "$(ghc-confdir)"
345 echo '[]' > "${D}/$(ghc-confdir)/$(ghc-localpkgconf)"
346 else
198 cabal-copy 347 cabal-copy
199 cabal-pkg 348 cabal-pkg
200 349
201 if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then 350 if [[ -n "${CABAL_USE_HADDOCK}" ]] && use doc; then
351 if ! version_is_at_least "1.1.6" "$(cabal-version)"; then
202 dohtml dist/doc/html/* 352 dohtml -r dist/doc/html/*
353 fi
354 fi
203 fi 355 fi
204} 356}
205haskell-cabal_src_install() { 357haskell-cabal_src_install() {
206 cabal_src_install 358 cabal_src_install
207} 359}

Legend:
Removed from v.1.2  
changed lines
  Added in v.1.18

  ViewVC Help
Powered by ViewVC 1.1.20