/[gentoo-x86]/eclass/haskell-cabal.eclass
Gentoo

Diff of /eclass/haskell-cabal.eclass

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.3 Revision 1.4
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2006 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/eclass/haskell-cabal.eclass,v 1.3 2006/02/16 12:32:53 dcoutts Exp $ 3# $Header: /var/cvsroot/gentoo-x86/eclass/haskell-cabal.eclass,v 1.4 2006/02/16 14:10:51 dcoutts Exp $
4# 4#
5# Original authors: Andres Loeh <kosmikus@gentoo.org> 5# Original authors: Andres Loeh <kosmikus@gentoo.org>
6# Duncan Coutts <dcoutts@gentoo.org> 6# Duncan Coutts <dcoutts@gentoo.org>
7# Maintained by: Haskell herd <haskell@gentoo.org> 7# Maintained by: Haskell herd <haskell@gentoo.org>
8# 8#
162 # of ghc-pkg. So it just leaves the .installed-pkg-config and we can 162 # of ghc-pkg. So it just leaves the .installed-pkg-config and we can
163 # register that ourselves (if it exists). 163 # register that ourselves (if it exists).
164 local result 164 local result
165 local err 165 local err
166 166
167 if [[ -n ${CABAL_HAS_LIBRARIES} ]]; then
167 sed -i 's:ghc-pkg:/usr/bin/true:' .setup-config 168 sed -i 's:ghc-pkg:/usr/bin/true:' .setup-config
168 result="$(./setup register 2>&1)" 169 ./setup register || die "setup register failed"
169 err="$?"
170 if ! echo ${result} | grep -q "no library to register"; then
171 $(exit "${err}") || die "setup register failed"
172 fi
173 if [[ -f .installed-pkg-config ]]; then 170 if [[ -f .installed-pkg-config ]]; then
174 ghc-setup-pkg .installed-pkg-config 171 ghc-setup-pkg .installed-pkg-config
175 ghc-install-pkg 172 ghc-install-pkg
173 else
174 die "setup register has not generated a package configuration file"
175 fi
176 fi 176 fi
177} 177}
178 178
179# exported function: check if cabal is correctly installed for 179# exported function: check if cabal is correctly installed for
180# the currently active ghc (we cannot guarantee this with portage) 180# the currently active ghc (we cannot guarantee this with portage)
183 eerror "The package dev-haskell/cabal is not correctly installed for" 183 eerror "The package dev-haskell/cabal is not correctly installed for"
184 eerror "the currently active version of ghc ($(ghc-version)). Please" 184 eerror "the currently active version of ghc ($(ghc-version)). Please"
185 eerror "run ghc-updater or re-emerge dev-haskell/cabal." 185 eerror "run ghc-updater or re-emerge dev-haskell/cabal."
186 die "cabal is not correctly installed" 186 die "cabal is not correctly installed"
187 fi 187 fi
188 if [[ -z "${CABAL_HAS_BINARIES}" ]] && [[ -z "${CABAL_HAS_LIBRARIES}" ]]; then
189 eerror "QA: Neither bin nor lib are in CABAL_FEATURES."
190 fi
188 if [[ -n "${CABAL_UNKNOWN}" ]]; then 191 if [[ -n "${CABAL_UNKNOWN}" ]]; then
189 ewarn "Unknown entry in CABAL_FEATURES: ${CABAL_UNKNONW}" 192 ewarn "Unknown entry in CABAL_FEATURES: ${CABAL_UNKNONW}"
190 fi 193 fi
191} 194}
192 195

Legend:
Removed from v.1.3  
changed lines
  Added in v.1.4

  ViewVC Help
Powered by ViewVC 1.1.20